977c32266a
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/adcli.git#6e243e45b0e8acee9357297549ba61db87a462b8
61 lines
1.8 KiB
Diff
61 lines
1.8 KiB
Diff
From 0353d704879f20983184f8bded4f16538d72f7cc Mon Sep 17 00:00:00 2001
|
|
From: Sumit Bose <sbose@redhat.com>
|
|
Date: Wed, 10 Mar 2021 18:12:09 +0100
|
|
Subject: [PATCH] build: add --with-vendor-error-message configure option
|
|
|
|
With the new configure option --with-vendor-error-message a packager or
|
|
a distribution can add a message if adcli returns with an error.
|
|
|
|
Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1889386
|
|
---
|
|
configure.ac | 15 +++++++++++++++
|
|
tools/tools.c | 6 ++++++
|
|
2 files changed, 21 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index baa0d3b..7dfba97 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -123,6 +123,21 @@ if test "$sasl_invalid" = "yes"; then
|
|
AC_MSG_ERROR([Couldn't find Cyrus SASL headers])
|
|
fi
|
|
|
|
+# --------------------------------------------------------------------
|
|
+# Vendor error message
|
|
+
|
|
+AC_ARG_WITH([vendor-error-message],
|
|
+ [AS_HELP_STRING([--with-vendor-error-message=ARG],
|
|
+ [Add a vendor specific error message shown if a adcli command fails]
|
|
+ )],
|
|
+ [AS_IF([test "x$withval" != "x"],
|
|
+ [AC_DEFINE_UNQUOTED([VENDOR_MSG],
|
|
+ ["$withval"],
|
|
+ [Vendor specific error message])],
|
|
+ [AC_MSG_ERROR([--with-vendor-error-message requires an argument])]
|
|
+ )],
|
|
+ [])
|
|
+
|
|
# --------------------------------------------------------------------
|
|
# Documentation options
|
|
|
|
diff --git a/tools/tools.c b/tools/tools.c
|
|
index d0dcf98..84bbba9 100644
|
|
--- a/tools/tools.c
|
|
+++ b/tools/tools.c
|
|
@@ -538,6 +538,12 @@ main (int argc,
|
|
|
|
if (conn)
|
|
adcli_conn_unref (conn);
|
|
+#ifdef VENDOR_MSG
|
|
+ if (ret != 0) {
|
|
+ fprintf (stderr, VENDOR_MSG"\n");
|
|
+ }
|
|
+#endif
|
|
+
|
|
return ret;
|
|
}
|
|
|
|
--
|
|
2.30.2
|
|
|