adcli/SOURCES/0001-configure-update-some-...

85 lines
2.3 KiB
Diff

From a8492d71a6db8565544444eef11de8c733c95ef8 Mon Sep 17 00:00:00 2001
From: Sumit Bose <sbose@redhat.com>
Date: Tue, 6 Apr 2021 19:32:07 +0200
Subject: [PATCH] configure: update some macros for autoconf-2.71
---
configure.ac | 10 +++++-----
library/Makefile.am | 2 +-
tools/Makefile.am | 2 +-
3 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/configure.ac b/configure.ac
index 7dfba97..c6ff31d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-AC_PREREQ(2.61)
+AC_PREREQ([2.61])
AC_INIT([adcli],
[0.9.1],
@@ -33,7 +33,7 @@ LT_INIT([dlopen disable-static])
AC_PROG_CC
AC_PROG_CPP
AM_PROG_CC_C_O
-AM_PROG_LIBTOOL
+LT_INIT
# -------------------------------------------------------------------
# Kerberos
@@ -143,7 +143,7 @@ AC_ARG_WITH([vendor-error-message],
AC_MSG_CHECKING([whether to build documentation])
AC_ARG_ENABLE(doc,
- AC_HELP_STRING([--enable-doc],
+ AS_HELP_STRING([--enable-doc],
[Disable building documentation])
)
@@ -180,7 +180,7 @@ doc_status=$enable_doc
AC_MSG_CHECKING([for debug mode])
AC_ARG_ENABLE(debug,
- AC_HELP_STRING([--enable-debug=no/default/yes],
+ AS_HELP_STRING([--enable-debug=no/default/yes],
[Turn on or off debugging]))
if test "$enable_debug" != "no"; then
@@ -308,7 +308,7 @@ fi
AC_MSG_CHECKING([where is Samba's net utility])
AC_ARG_WITH([samba_data_tool],
- AC_HELP_STRING([--with-samba-data-tool=/path],
+ AS_HELP_STRING([--with-samba-data-tool=/path],
[Path to Samba's net utility]),
[],
[with_samba_data_tool=/usr/bin/net])
diff --git a/library/Makefile.am b/library/Makefile.am
index 4829555..e046606 100644
--- a/library/Makefile.am
+++ b/library/Makefile.am
@@ -1,6 +1,6 @@
include $(top_srcdir)/Makefile.decl
-INCLUDES = \
+AM_CPPFLAGS = \
-I$(top_srcdir) \
-DADCLI_UNSTABLE_API \
-DHOST_TRIPLET=\"$(host_triplet)\" \
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 1cdf451..71ec14d 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1,6 +1,6 @@
include $(top_srcdir)/Makefile.decl
-INCLUDES = \
+AM_CPPFLAGS = \
-I$(top_srcdir) \
-I$(top_srcdir)/library \
-DKRB5_CONFIG=\""$(sysconfdir)/krb5.conf"\" \
--
2.30.2