- latest upstream version
This commit is contained in:
parent
f4a9a935f2
commit
c1228e9735
@ -1 +1 @@
|
||||
acpid-2.0.2.tar.gz
|
||||
acpid-2.0.3.tar.gz
|
||||
|
@ -1,24 +0,0 @@
|
||||
diff -up acpid-2.0.2/acpid.c.headers acpid-2.0.2/acpid.c
|
||||
--- acpid-2.0.2/acpid.c.headers 2010-02-25 22:35:49.625058306 +0100
|
||||
+++ acpid-2.0.2/acpid.c 2010-02-25 22:37:40.512063316 +0100
|
||||
@@ -21,6 +21,8 @@
|
||||
*/
|
||||
|
||||
#include <unistd.h>
|
||||
+#include <sys/types.h>
|
||||
+#include <sys/stat.h>
|
||||
#include <fcntl.h>
|
||||
#include <signal.h>
|
||||
#include <string.h>
|
||||
diff -up acpid-2.0.2/sock.c.headers acpid-2.0.2/sock.c
|
||||
--- acpid-2.0.2/sock.c.headers 2010-02-25 22:35:55.644052326 +0100
|
||||
+++ acpid-2.0.2/sock.c 2010-02-25 22:37:29.592075611 +0100
|
||||
@@ -21,6 +21,8 @@
|
||||
*/
|
||||
|
||||
#include <unistd.h>
|
||||
+#include <sys/types.h>
|
||||
+#include <sys/stat.h>
|
||||
#include <fcntl.h>
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
@ -28,12 +28,3 @@ diff -up acpid-2.0.2/Makefile.makefile acpid-2.0.2/Makefile
|
||||
|
||||
install: $(PROGS) man install_docs
|
||||
mkdir -p $(DESTDIR)/$(SBINDIR)
|
||||
@@ -57,7 +58,7 @@ install: $(PROGS) man install_docs
|
||||
mkdir -p $(DESTDIR)/$(MANDIR)/man8
|
||||
install -m 0644 $(MAN8GZ) $(DESTDIR)/$(MANDIR)/man8
|
||||
# If DESTDIR is empty and mandb exists, run it
|
||||
- [ -z "$(DESTDIR)" ] && which mandb 1>/dev/null 2>&1 && mandb -q
|
||||
+ if test -z "$(DESTDIR)"; then which mandb 1>/dev/null 2>&1 && mandb -q; fi
|
||||
|
||||
DISTTMP=/tmp
|
||||
DISTNAME=acpid-$(VERSION)
|
||||
|
@ -1,11 +0,0 @@
|
||||
diff -up acpid-2.0.2/acpid.c.no_umask acpid-2.0.2/acpid.c
|
||||
--- acpid-2.0.2/acpid.c.no_umask 2010-02-25 22:19:13.273274011 +0100
|
||||
+++ acpid-2.0.2/acpid.c 2010-02-25 22:20:11.398023662 +0100
|
||||
@@ -370,7 +370,6 @@ daemonize(void)
|
||||
|
||||
/* disconnect */
|
||||
setsid();
|
||||
- umask(0);
|
||||
|
||||
/* get outta the way */
|
||||
if (chdir("/") < 0) {
|
@ -1,6 +1,6 @@
|
||||
Summary: ACPI Event Daemon
|
||||
Name: acpid
|
||||
Version: 2.0.2
|
||||
Version: 2.0.3
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Daemons
|
||||
@ -11,8 +11,6 @@ Source3: acpid.power.conf
|
||||
Source4: acpid.power.sh
|
||||
|
||||
Patch1: acpid-2.0.2-makefile.patch
|
||||
Patch2: acpid-2.0.2-no_umask.patch
|
||||
Patch3: acpid-2.0.2-headers.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
ExclusiveArch: ia64 x86_64 %{ix86}
|
||||
@ -30,8 +28,6 @@ acpid is a daemon that dispatches ACPI events to user-space programs.
|
||||
%setup -q
|
||||
|
||||
%patch1 -p1 -b .makefile
|
||||
%patch2 -p1 -b .no_umask
|
||||
%patch3 -p1 -b .headers
|
||||
|
||||
%build
|
||||
make %{?_smp_mflags}
|
||||
@ -88,6 +84,9 @@ if [ "$1" -ge "1" ]; then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Wed Mar 17 2010 Jiri Skala <jskala@redhat.com> - 2.0.3-1
|
||||
- latest upstream version
|
||||
|
||||
* Thu Feb 25 2010 Jiri Skala <jskala@redhat.com> - 2.0.2-1
|
||||
- latest upstream version
|
||||
- removed spare umask
|
||||
|
Loading…
Reference in New Issue
Block a user