New version
- Replaced RPM_BUILD_ROOT variables by {buildroot} macros - Updated URLs to project home page and source code - Dropped mk patch, handled better way in the spec
This commit is contained in:
parent
3d572e8852
commit
b3d1626d0f
@ -1,24 +0,0 @@
|
|||||||
diff -up acpid-2.0.15/Makefile.am.mk acpid-2.0.15/Makefile.am
|
|
||||||
--- acpid-2.0.15/Makefile.am.mk 2012-02-17 04:37:12.109907134 +0100
|
|
||||||
+++ acpid-2.0.15/Makefile.am 2012-03-16 11:27:15.127573044 +0100
|
|
||||||
@@ -20,7 +20,7 @@ acpi_listen_SOURCES = acpi_listen.c log.
|
|
||||||
|
|
||||||
dist_man8_MANS = acpid.8 acpi_listen.8
|
|
||||||
|
|
||||||
-dist_doc_DATA = COPYING Changelog README TESTPLAN TODO
|
|
||||||
+dist_doc_DATA =
|
|
||||||
|
|
||||||
# Just docs to add to the dist.
|
|
||||||
# One problem with this is that it includes all files in the samples dir
|
|
||||||
diff -up acpid-2.0.15/Makefile.in.mk acpid-2.0.15/Makefile.in
|
|
||||||
--- acpid-2.0.15/Makefile.in.mk 2012-03-16 11:28:53.568421905 +0100
|
|
||||||
+++ acpid-2.0.15/Makefile.in 2012-03-16 11:29:21.679378750 +0100
|
|
||||||
@@ -276,7 +276,7 @@ acpid_SOURCES = acpid.c acpi_ids.c conne
|
|
||||||
|
|
||||||
acpi_listen_SOURCES = acpi_listen.c log.c ud_socket.c
|
|
||||||
dist_man8_MANS = acpid.8 acpi_listen.8
|
|
||||||
-dist_doc_DATA = COPYING Changelog README TESTPLAN TODO
|
|
||||||
+dist_doc_DATA =
|
|
||||||
|
|
||||||
# Just docs to add to the dist.
|
|
||||||
# One problem with this is that it includes all files in the samples dir
|
|
52
acpid.spec
52
acpid.spec
@ -1,22 +1,19 @@
|
|||||||
Summary: ACPI Event Daemon
|
Summary: ACPI Event Daemon
|
||||||
Name: acpid
|
Name: acpid
|
||||||
Version: 2.0.17
|
Version: 2.0.18
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source: http://tedfelix.com/linux/acpid-%{version}.tar.xz
|
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.xz
|
||||||
Source1: acpid.init
|
Source1: acpid.init
|
||||||
Source2: acpid.video.conf
|
Source2: acpid.video.conf
|
||||||
Source3: acpid.power.conf
|
Source3: acpid.power.conf
|
||||||
Source4: acpid.power.sh
|
Source4: acpid.power.sh
|
||||||
Source5: acpid.service
|
Source5: acpid.service
|
||||||
Source6: acpid.sysconfig
|
Source6: acpid.sysconfig
|
||||||
|
|
||||||
Patch1: acpid-2.0.15-mk.patch
|
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
ExclusiveArch: ia64 x86_64 %{ix86}
|
ExclusiveArch: ia64 x86_64 %{ix86}
|
||||||
URL: http://tedfelix.com/linux/acpid-netlink.html
|
URL: http://sourceforge.net/projects/acpid2/
|
||||||
Requires(post): /sbin/chkconfig
|
Requires(post): /sbin/chkconfig
|
||||||
Requires(preun): /sbin/chkconfig
|
Requires(preun): /sbin/chkconfig
|
||||||
Requires: systemd-units
|
Requires: systemd-units
|
||||||
@ -37,7 +34,6 @@ The acpid-sysvinit contains SysV initscript.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch1 -p1 -b .mk
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
@ -45,33 +41,33 @@ make %{?_smp_mflags}
|
|||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf %{buildroot}
|
||||||
mkdir -p $RPM_BUILD_ROOT
|
mkdir -p %{buildroot}
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT
|
make install DESTDIR=%{buildroot} docdir=%{_docdir}/%{name}-%{version}
|
||||||
|
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/acpi/events
|
mkdir -p %{buildroot}%{_sysconfdir}/acpi/events
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/acpi/actions
|
mkdir -p %{buildroot}%{_sysconfdir}/acpi/actions
|
||||||
mkdir -p $RPM_BUILD_ROOT/lib/systemd/system
|
mkdir -p %{buildroot}/lib/systemd/system
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
|
mkdir -p %{buildroot}%{_sysconfdir}/sysconfig
|
||||||
|
|
||||||
chmod 755 $RPM_BUILD_ROOT%{_sysconfdir}/acpi/events
|
chmod 755 %{buildroot}%{_sysconfdir}/acpi/events
|
||||||
install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/acpi/events/videoconf
|
install -m 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/acpi/events/videoconf
|
||||||
install -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/acpi/events/powerconf
|
install -m 644 %{SOURCE3} %{buildroot}%{_sysconfdir}/acpi/events/powerconf
|
||||||
install -m 755 %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/acpi/actions/power.sh
|
install -m 755 %{SOURCE4} %{buildroot}%{_sysconfdir}/acpi/actions/power.sh
|
||||||
install -m 644 %{SOURCE5} $RPM_BUILD_ROOT/lib/systemd/system
|
install -m 644 %{SOURCE5} %{buildroot}/lib/systemd/system
|
||||||
install -m 644 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/acpid
|
install -m 644 %{SOURCE6} %{buildroot}%{_sysconfdir}/sysconfig/acpid
|
||||||
|
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
|
mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
|
||||||
install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/acpid
|
install -m 755 %{SOURCE1} %{buildroot}%{_sysconfdir}/rc.d/init.d/acpid
|
||||||
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf %{buildroot}
|
||||||
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%doc COPYING README Changelog TODO TESTPLAN
|
%doc %{_docdir}/%{name}-%{version}
|
||||||
/lib/systemd/system/%{name}.service
|
/lib/systemd/system/%{name}.service
|
||||||
%dir %{_sysconfdir}/acpi
|
%dir %{_sysconfdir}/acpi
|
||||||
%dir %{_sysconfdir}/acpi/events
|
%dir %{_sysconfdir}/acpi/events
|
||||||
@ -129,6 +125,12 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 15 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.0.18-1
|
||||||
|
- New version
|
||||||
|
- Replaced RPM_BUILD_ROOT variables by {buildroot} macros
|
||||||
|
- Updated URLs to project home page and source code
|
||||||
|
- Dropped mk patch, handled better way in the spec
|
||||||
|
|
||||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.17-2
|
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.17-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user