replaced makefile patch by new on, added kacpimon
This commit is contained in:
parent
2025c11fe5
commit
a0d0e3b083
24
acpid-2.0.15-mk.patch
Normal file
24
acpid-2.0.15-mk.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -up acpid-2.0.15/Makefile.am.mk acpid-2.0.15/Makefile.am
|
||||
--- acpid-2.0.15/Makefile.am.mk 2012-02-17 04:37:12.109907134 +0100
|
||||
+++ acpid-2.0.15/Makefile.am 2012-03-16 11:27:15.127573044 +0100
|
||||
@@ -20,7 +20,7 @@ acpi_listen_SOURCES = acpi_listen.c log.
|
||||
|
||||
dist_man8_MANS = acpid.8 acpi_listen.8
|
||||
|
||||
-dist_doc_DATA = COPYING Changelog README TESTPLAN TODO
|
||||
+dist_doc_DATA =
|
||||
|
||||
# Just docs to add to the dist.
|
||||
# One problem with this is that it includes all files in the samples dir
|
||||
diff -up acpid-2.0.15/Makefile.in.mk acpid-2.0.15/Makefile.in
|
||||
--- acpid-2.0.15/Makefile.in.mk 2012-03-16 11:28:53.568421905 +0100
|
||||
+++ acpid-2.0.15/Makefile.in 2012-03-16 11:29:21.679378750 +0100
|
||||
@@ -276,7 +276,7 @@ acpid_SOURCES = acpid.c acpi_ids.c conne
|
||||
|
||||
acpi_listen_SOURCES = acpi_listen.c log.c ud_socket.c
|
||||
dist_man8_MANS = acpid.8 acpi_listen.8
|
||||
-dist_doc_DATA = COPYING Changelog README TESTPLAN TODO
|
||||
+dist_doc_DATA =
|
||||
|
||||
# Just docs to add to the dist.
|
||||
# One problem with this is that it includes all files in the samples dir
|
@ -1,30 +0,0 @@
|
||||
diff -up acpid-2.0.2/Makefile.makefile acpid-2.0.2/Makefile
|
||||
diff -up acpid-2.0.2/Makefile.makefile acpid-2.0.2/Makefile
|
||||
diff -up acpid-2.0.2/Makefile.makefile acpid-2.0.2/Makefile
|
||||
diff -up acpid-2.0.2/Makefile.makefile acpid-2.0.2/Makefile
|
||||
diff -up acpid-2.0.2/Makefile.makefile acpid-2.0.2/Makefile
|
||||
--- acpid-2.0.2/Makefile.makefile 2010-01-27 00:36:23.000000000 +0100
|
||||
+++ acpid-2.0.2/Makefile 2010-02-25 16:01:39.641024017 +0100
|
||||
@@ -31,8 +31,9 @@ MAN8GZ = $(MAN8:.8=.8.gz)
|
||||
|
||||
DOCS = COPYING Changelog README TESTPLAN TODO
|
||||
|
||||
-CFLAGS = -W -Wall -Werror -Wundef -Wshadow -D_GNU_SOURCE $(OPT) \
|
||||
- -fno-strict-aliasing -g $(DEFS)
|
||||
+CFLAGS = -W -Wall -Werror -Wundef -Wshadow -D_GNU_SOURCE -O2 $(OPT) \
|
||||
+ -fno-strict-aliasing -g $(DEFS) $(RPM_OPT_FLAGS) -fPIE
|
||||
+LDFLAGS = -pie -Wl,-z,relro
|
||||
DEFS = -DVERSION="\"$(VERSION)\""
|
||||
|
||||
all: $(PROGS)
|
||||
@@ -46,8 +47,8 @@ man: $(MAN8)
|
||||
|
||||
install_docs:
|
||||
mkdir -p $(DESTDIR)/$(DOCDIR)
|
||||
- for a in $(DOCS); do install -m 0644 $$a $(DESTDIR)/$(DOCDIR) ; done
|
||||
- cp -a samples $(DESTDIR)/$(DOCDIR)
|
||||
+ #for a in $(DOCS); do install -m 0644 $$a $(DESTDIR)/$(DOCDIR) ; done
|
||||
+ #cp -a samples $(DESTDIR)/$(DOCDIR)
|
||||
|
||||
install: $(PROGS) man install_docs
|
||||
mkdir -p $(DESTDIR)/$(SBINDIR)
|
@ -4,7 +4,7 @@ Version: 2.0.15
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Daemons
|
||||
Source: http://tedfelix.com/linux/acpid-%{version}.tar.gz
|
||||
Source: http://tedfelix.com/linux/acpid-%{version}.tar.xz
|
||||
Source1: acpid.init
|
||||
Source2: acpid.video.conf
|
||||
Source3: acpid.power.conf
|
||||
@ -12,7 +12,7 @@ Source4: acpid.power.sh
|
||||
Source5: acpid.service
|
||||
Source6: acpid.sysconfig
|
||||
|
||||
Patch1: acpid-2.0.2-makefile.patch
|
||||
Patch1: acpid-2.0.15-mk.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
ExclusiveArch: ia64 x86_64 %{ix86}
|
||||
@ -37,9 +37,10 @@ The acpid-sysvinit contains SysV initscript.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch1 -p1 -b .makefile
|
||||
%patch1 -p1 -b .mk
|
||||
|
||||
%build
|
||||
%configure
|
||||
make %{?_smp_mflags}
|
||||
|
||||
|
||||
@ -81,8 +82,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/acpid
|
||||
%{_bindir}/acpi_listen
|
||||
%{_sbindir}/acpid
|
||||
%{_sbindir}/kacpimon
|
||||
%{_mandir}/man8/acpid.8.gz
|
||||
%{_mandir}/man8/acpi_listen.8.gz
|
||||
%{_mandir}/man8/kacpimon.8.gz
|
||||
|
||||
%files sysvinit
|
||||
%attr(0755,root,root) %{_sysconfdir}/rc.d/init.d/acpid
|
||||
|
Loading…
Reference in New Issue
Block a user