- latest upstream version

This commit is contained in:
Jiri Skala 2010-02-25 20:58:57 +00:00
parent 48c74c6313
commit 52da7a924d
5 changed files with 52 additions and 22 deletions

View File

@ -1 +1 @@
acpid-1.0.10.tar.gz acpid-2.0.2.tar.gz

View File

@ -1,13 +0,0 @@
diff -up acpid-1.0.8/Makefile.makefile acpid-1.0.8/Makefile
--- acpid-1.0.8/Makefile.makefile 2008-10-29 04:48:52.000000000 +0100
+++ acpid-1.0.8/Makefile 2008-11-11 15:19:21.000000000 +0100
@@ -23,7 +23,8 @@ all_SRCS = $(acpid_SRCS) $(acpi_listen_S
MAN8 = acpid.8 acpi_listen.8
MAN8GZ = $(MAN8:.8=.8.gz)
-CFLAGS = -W -Wall -Werror -Wundef -Wshadow -D_GNU_SOURCE -O2 -g $(DEFS)
+CFLAGS = -W -Wall -Werror -Wundef -Wshadow -D_GNU_SOURCE -O2 -g $(DEFS) $(RPM_OPT_FLAGS) -fPIE
+LDFLAGS = -pie -Wl,-z,relro
DEFS = -DVERSION="\"$(VERSION)\""
all: $(PROGS)

View File

@ -0,0 +1,39 @@
diff -up acpid-2.0.2/Makefile.makefile acpid-2.0.2/Makefile
diff -up acpid-2.0.2/Makefile.makefile acpid-2.0.2/Makefile
diff -up acpid-2.0.2/Makefile.makefile acpid-2.0.2/Makefile
diff -up acpid-2.0.2/Makefile.makefile acpid-2.0.2/Makefile
diff -up acpid-2.0.2/Makefile.makefile acpid-2.0.2/Makefile
--- acpid-2.0.2/Makefile.makefile 2010-01-27 00:36:23.000000000 +0100
+++ acpid-2.0.2/Makefile 2010-02-25 16:01:39.641024017 +0100
@@ -31,8 +31,9 @@ MAN8GZ = $(MAN8:.8=.8.gz)
DOCS = COPYING Changelog README TESTPLAN TODO
-CFLAGS = -W -Wall -Werror -Wundef -Wshadow -D_GNU_SOURCE $(OPT) \
- -fno-strict-aliasing -g $(DEFS)
+CFLAGS = -W -Wall -Werror -Wundef -Wshadow -D_GNU_SOURCE -O2 $(OPT) \
+ -fno-strict-aliasing -g $(DEFS) $(RPM_OPT_FLAGS) -fPIE
+LDFLAGS = -pie -Wl,-z,relro
DEFS = -DVERSION="\"$(VERSION)\""
all: $(PROGS)
@@ -46,8 +47,8 @@ man: $(MAN8)
install_docs:
mkdir -p $(DESTDIR)/$(DOCDIR)
- for a in $(DOCS); do install -m 0644 $$a $(DESTDIR)/$(DOCDIR) ; done
- cp -a samples $(DESTDIR)/$(DOCDIR)
+ #for a in $(DOCS); do install -m 0644 $$a $(DESTDIR)/$(DOCDIR) ; done
+ #cp -a samples $(DESTDIR)/$(DOCDIR)
install: $(PROGS) man install_docs
mkdir -p $(DESTDIR)/$(SBINDIR)
@@ -57,7 +58,7 @@ install: $(PROGS) man install_docs
mkdir -p $(DESTDIR)/$(MANDIR)/man8
install -m 0644 $(MAN8GZ) $(DESTDIR)/$(MANDIR)/man8
# If DESTDIR is empty and mandb exists, run it
- [ -z "$(DESTDIR)" ] && which mandb 1>/dev/null 2>&1 && mandb -q
+ if test -z "$(DESTDIR)"; then which mandb 1>/dev/null 2>&1 && mandb -q; fi
DISTTMP=/tmp
DISTNAME=acpid-$(VERSION)

View File

@ -1,18 +1,18 @@
Summary: ACPI Event Daemon Summary: ACPI Event Daemon
Name: acpid Name: acpid
Version: 1.0.10 Version: 2.0.2
Release: 2%{?dist} Release: 1%{?dist}
License: GPLv2+ License: GPLv2+
Group: System Environment/Daemons Group: System Environment/Daemons
Source: http://prdownloads.sourceforge.net/acpid/acpid-%{version}.tar.gz Source: http://tedfelix.com/linux/acpid-%{version}.tar.gz
Source1: acpid.init Source1: acpid.init
Source2: acpid.video.conf Source2: acpid.video.conf
Source3: acpid.power.conf Source3: acpid.power.conf
Source4: acpid.power.sh Source4: acpid.power.sh
Patch1: acpid-1.0.8-makefile.patch Patch1: acpid-2.0.2-makefile.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
ExclusiveArch: ia64 x86_64 %{ix86} ExclusiveArch: ia64 x86_64 %{ix86}
URL: http://acpid.sourceforge.net/ URL: http://tedfelix.com/linux/acpid-netlink.html
Requires(post): /sbin/chkconfig Requires(post): /sbin/chkconfig
Requires(preun): /sbin/chkconfig Requires(preun): /sbin/chkconfig
Requires(preun): /sbin/service Requires(preun): /sbin/service
@ -24,6 +24,7 @@ acpid is a daemon that dispatches ACPI events to user-space programs.
%prep %prep
%setup -q %setup -q
%patch1 -p1 -b .makefile %patch1 -p1 -b .makefile
%build %build
@ -33,7 +34,7 @@ make %{?_smp_mflags}
%install %install
rm -rf $RPM_BUILD_ROOT rm -rf $RPM_BUILD_ROOT
mkdir -p $RPM_BUILD_ROOT mkdir -p $RPM_BUILD_ROOT
make install INSTPREFIX=$RPM_BUILD_ROOT make install DESTDIR=$RPM_BUILD_ROOT
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/acpi/events mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/acpi/events
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/acpi/actions mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/acpi/actions
@ -52,7 +53,7 @@ rm -rf $RPM_BUILD_ROOT
%files %files
%defattr(-,root,root) %defattr(-,root,root)
%doc COPYING README Changelog TODO %doc COPYING README Changelog TODO TESTPLAN
%dir %{_sysconfdir}/acpi %dir %{_sysconfdir}/acpi
%dir %{_sysconfdir}/acpi/events %dir %{_sysconfdir}/acpi/events
%dir %{_sysconfdir}/acpi/actions %dir %{_sysconfdir}/acpi/actions
@ -81,6 +82,9 @@ if [ "$1" -ge "1" ]; then
fi fi
%changelog %changelog
* Thu Feb 25 2010 Jiri Skala <jskala@redhat.com> - 2.0.2-1
- latest upstream version
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.10-2 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.10-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild

View File

@ -1 +1 @@
61156ef32015c56dc0f2e3317f4ae09e acpid-1.0.10.tar.gz 02eddc52bbd95602ac1f25de56067af1 acpid-2.0.2.tar.gz