edb6c78416
This update also means a major update for all of the big-endian patching that has been done. The older mechanism was getting to unwieldy to keep maintained, and too sensitive to upstream changes. Hence, redid all of the old patches, and took the opportunity to make them more amenable to change over time. Ultimately, the goal is to have upstream accept these in some form. Signed-off-by: Al Stone <ahs3@redhat.com>
27 lines
805 B
Diff
27 lines
805 B
Diff
Index: acpica-unix2-20200925/generate/unix/Makefile.config
|
|
===================================================================
|
|
--- acpica-unix2-20200925.orig/generate/unix/Makefile.config
|
|
+++ acpica-unix2-20200925/generate/unix/Makefile.config
|
|
@@ -23,6 +23,9 @@
|
|
# OPT_CFLAGS can be overridden on the make command line by
|
|
# adding OPT_CFLAGS="..." to the invocation.
|
|
#
|
|
+# OPT_LDFLAGS can be overridden on the make command line by
|
|
+# adding OPT_LDFLAGS="..." to the invocation.
|
|
+#
|
|
# Notes:
|
|
# gcc should be version 4 or greater, otherwise some of the options
|
|
# used will not be recognized.
|
|
@@ -164,6 +167,11 @@ LDFLAGS +=-m32
|
|
endif
|
|
|
|
#
|
|
+# Common linker flags
|
|
+#
|
|
+OPT_LDFLAGS ?=
|
|
+
|
|
+#
|
|
# Optionally disable optimizations. Optimization causes problems on
|
|
# some compilers such as gcc 4.4
|
|
#
|