acpica-tools/aapits-linux.patch
2013-08-28 13:31:28 -06:00

531 lines
20 KiB
Diff

diff -urN acpica-unix2-20130626/tests/aapits/atexec.c acpica-unix2-20130626-aapits/tests/aapits/atexec.c
--- acpica-unix2-20130626/tests/aapits/atexec.c 2013-01-17 12:48:28.000000000 -0700
+++ acpica-unix2-20130626-aapits/tests/aapits/atexec.c 2013-07-25 13:44:23.023894441 -0600
@@ -530,6 +530,7 @@
}
+#if ACPI_MACHINE_WIDTH == 32
/*******************************************************************************
*
* FUNCTION: AtBuildLocalRSDT
@@ -648,8 +649,9 @@
LocalRSDT->Header.Checksum = (UINT8)~LocalRSDT->Header.Checksum;
}
}
+#endif
/*******************************************************************************
*
* FUNCTION: AtBuildLocalXSDT
@@ -1315,7 +1319,7 @@
ACPI_WARNING ((AE_INFO,
"Request on [%4.4s] is beyond region limit Req-%X+%X, Base=%X, Len-%X\n",
(RegionObject->Region.Node)->Name.Ascii, (UINT32) Address,
- ByteWidth, (UINT32) BufferAddress, Length));
+ ByteWidth, (UINT32) BufferAddress, (UINT32) Length));
return (AE_AML_REGION_LIMIT);
}
@@ -1683,7 +1687,9 @@
Path, Obj.Integer.Value, Value);
#else
printf ("API Error: Value of %s is 0x%llx instead of expected 0x%llx\n",
- Path, Obj.Integer.Value, Value);
+ Path,
+ (long long unsigned int) Obj.Integer.Value,
+ (long long unsigned int) Value);
#endif
Status = AE_ERROR;
}
@@ -1762,7 +1768,7 @@
{
TestErrors++;
printf ("Test Error: cannot allocate buffer of %d bytes\n",
- Results.Length);
+ (int) Results.Length);
return (AE_NO_MEMORY);
}
Results.Pointer = Object;
@@ -1843,7 +1849,8 @@
{
printf ("AtCheckBuffer: unexpected length %d of Buffer vs"
" calculated %d bytes\n",
- Results.Length, ACPI_ROUND_UP_TO_NATIVE_WORD(sizeof (ACPI_OBJECT) + Length));
+ (int)Results.Length,
+ (int)(ACPI_ROUND_UP_TO_NATIVE_WORD(sizeof (ACPI_OBJECT) + Length)));
}
/* Initialize the return buffer structure */
@@ -1852,7 +1859,7 @@
{
TestErrors++;
printf ("Test Error: cannot allocate buffer of %d bytes\n",
- Results.Length);
+ (int) Results.Length);
return (AE_NO_MEMORY);
}
Results.Pointer = Object;
diff -urN acpica-unix2-20130626/tests/aapits/atinit.c acpica-unix2-20130626-aapits/tests/aapits/atinit.c
--- acpica-unix2-20130626/tests/aapits/atinit.c 2013-01-17 12:48:28.000000000 -0700
+++ acpica-unix2-20130626-aapits/tests/aapits/atinit.c 2013-07-25 13:20:19.706705960 -0600
@@ -2915,7 +2915,7 @@
AapiErrors++;
printf ("API Error: AcpiGetSystemInfo() returned"
" Length %d, expected %d\n",
- OutBuffer.Length, sizeof (Info));
+ (int) OutBuffer.Length, (int) sizeof (Info));
return (AE_ERROR);
}
@@ -2937,7 +2937,7 @@
AapiErrors++;
printf ("API Error: AcpiGetSystemInfo() returned"
" Length %d, expected %d\n",
- OutBuffer.Length, sizeof (Info));
+ (int) OutBuffer.Length, (int) sizeof (Info));
return (AE_ERROR);
}
@@ -2957,7 +2957,7 @@
AapiErrors++;
printf ("API Error: AcpiGetSystemInfo() returned"
" Length %d, expected %d\n",
- OutBuffer.Length, sizeof (Info));
+ (int) OutBuffer.Length, (int) sizeof (Info));
return (AE_ERROR);
}
else if (OutBuffer.Pointer != &Info)
@@ -3040,7 +3040,7 @@
AapiErrors++;
printf ("API Error: AcpiGetSystemInfo() returned"
" Length %d, expected %d\n",
- OutBuffer.Length, sizeof (Info));
+ (int) OutBuffer.Length, (int) sizeof (Info));
return (AE_ERROR);
}
else if (OutBuffer.Pointer != &Info)
@@ -3105,7 +3105,7 @@
AapiErrors++;
printf ("API Error: AcpiGetSystemInfo() returned"
" Length %d, expected %d\n",
- OutBuffer.Length, sizeof (ACPI_SYSTEM_INFO));
+ (int) OutBuffer.Length, (int) sizeof (ACPI_SYSTEM_INFO));
return (AE_ERROR);
}
else
diff -urN acpica-unix2-20130626/tests/aapits/atmain.c acpica-unix2-20130626-aapits/tests/aapits/atmain.c
--- acpica-unix2-20130626/tests/aapits/atmain.c 2013-01-17 12:48:28.000000000 -0700
+++ acpica-unix2-20130626-aapits/tests/aapits/atmain.c 2013-07-25 13:18:22.083323948 -0600
@@ -206,7 +206,7 @@
{
printf ("ACPICA API TS err: test num %ld of test case %ld"
" is not implemented\n",
- test_num, test_case);
+ (long int) test_num, (long int) test_case);
return (AtRetNotImpl);
}
@@ -321,7 +323,7 @@
if (test_case < 1 || test_case > AT_TEST_CASE_NUM)
{
printf ("ACPICA API TS err: test case %ld is out of range 1 - %d\n",
- test_case, AT_TEST_CASE_NUM);
+ (long int) test_case, (int) AT_TEST_CASE_NUM);
return (AtRetBadParam);
}
@@ -329,7 +331,7 @@
if (test_num < 0 || test_num > AtTestCase[test_case].TestsNum)
{
printf ("ACPICA API TS err: test num %ld is out of range 0 - %d\n",
- test_num, AtTestCase[test_case].TestsNum);
+ (long int) test_num, AtTestCase[test_case].TestsNum);
return (AtRetBadParam);
}
diff -urN acpica-unix2-20130626/tests/aapits/atnamespace.c acpica-unix2-20130626-aapits/tests/aapits/atnamespace.c
--- acpica-unix2-20130626/tests/aapits/atnamespace.c 2013-01-17 12:48:28.000000000 -0700
+++ acpica-unix2-20130626-aapits/tests/aapits/atnamespace.c 2013-07-25 13:24:15.366466707 -0600
@@ -2426,7 +2426,8 @@
#else
printf ("API Error: Address of %s (0x%llX) != (0x%llX)\n",
PathNames[2 * i + 1],
- Info->Address, ExpectedInfo[i].Address);
+ (long long unsigned int) Info->Address,
+ (long long unsigned int) ExpectedInfo[i].Address);
#endif
#else
printf ("API Error: Address of %s (0x%X) != (0x%X)\n",
@@ -2799,7 +2800,8 @@
TestErrors++;
printf ("AtGetNextObjectTypeCommon: different numbers of entities"
"in TypesNames (%d) and LevelTypes0000 (%d)\n",
- TypesCount, sizeof (LevelTypes0000) / sizeof (ACPI_OBJECT_TYPE));
+ TypesCount,
+ (int) (sizeof (LevelTypes0000) / sizeof (ACPI_OBJECT_TYPE)));
return (AE_ERROR);
}
@@ -4083,7 +4085,9 @@
Pathname, Obj.Integer.Value, Value);
#else
printf ("API Error: Value of %s is 0x%llx instead of expected 0x%llx\n",
- Pathname, Obj.Integer.Value, Value);
+ Pathname,
+ (long long unsigned int) Obj.Integer.Value,
+ (long long unsigned int) Value);
#endif
Status = AE_ERROR;
}
@@ -5090,7 +5094,7 @@
{
AapiErrors++;
printf ("API Error: AcpiOsAllocate(%d) returned NULL\n",
- OutName.Length);
+ (int) OutName.Length);
return (AE_ERROR);
}
}
diff -urN acpica-unix2-20130626/tests/aapits/atosxfctrl.c acpica-unix2-20130626-aapits/tests/aapits/atosxfctrl.c
--- acpica-unix2-20130626/tests/aapits/atosxfctrl.c 2013-01-17 12:48:28.000000000 -0700
+++ acpica-unix2-20130626-aapits/tests/aapits/atosxfctrl.c 2013-07-25 13:30:00.375492751 -0600
@@ -622,13 +622,15 @@
#if ACPI_MACHINE_WIDTH == 64
#ifdef _MSC_VER
printf("OsxfCtrlFingReg: unexpected Width %d of Reg 0x%I64x\n",
+ Width, Address);
#else
printf("OsxfCtrlFingReg: unexpected Width %d of Reg 0x%llx\n",
+ Width, (long long unsigned int) Address);
#endif
#else
printf("OsxfCtrlFingReg: unexpected Width %d of Reg 0x%x\n",
-#endif
Width, Address);
+#endif
return (NULL);
}
@@ -649,15 +651,19 @@
#ifdef _MSC_VER
printf("OsxfCtrlFingReg: intersection Regs (0x%I64x: 0x%x)"
" and (0x%I64x: 0x%x)\n",
+ Reg->Address, Reg->Width, Address, Width);
#else
printf("OsxfCtrlFingReg: intersection Regs (0x%llx: 0x%x)"
" and (0x%llx: 0x%x)\n",
+ (long long unsigned int) Reg->Address,
+ Reg->Width,
+ (long long unsigned int) Address, Width);
#endif
#else
printf("OsxfCtrlFingReg: intersection Regs (0x%x: 0x%x)"
" and (0x%x: 0x%x)\n",
-#endif
Reg->Address, Reg->Width, Address, Width);
+#endif
return (NULL);
}
}
@@ -671,13 +677,15 @@
#if ACPI_MACHINE_WIDTH == 64
#ifdef _MSC_VER
printf("OsxfCtrlFingReg: no memory for Reg (0x%I64x: 0x%x)\n",
+ Reg->Address, Reg->Width);
#else
printf("OsxfCtrlFingReg: no memory for Reg (0x%llx: 0x%x)\n",
+ (long long unsigned int) Reg->Address, Reg->Width);
#endif
#else
printf("OsxfCtrlFingReg: no memory for Reg (0x%x: 0x%x)\n",
-#endif
Reg->Address, Reg->Width);
+#endif
return (NULL);
}
Reg->Type = Type;
@@ -817,14 +825,19 @@
#if ACPI_MACHINE_WIDTH == 64
#ifdef _MSC_VER
printf("%.2u (%s Address 0x%I64x: Width %.2u) r/w counts: %u/%u\n",
+ i, (Reg->Type == EMUL_REG_SYS)? "SYS": "IO",
+ Reg->Address, Reg->Width, Reg->ReadCount, Reg->WriteCount);
#else
printf("%.2u (%s Address 0x%llx: Width %.2u) r/w counts: %u/%u\n",
+ i, (Reg->Type == EMUL_REG_SYS)? "SYS": "IO",
+ (long long unsigned int) Reg->Address,
+ Reg->Width, Reg->ReadCount, Reg->WriteCount);
#endif
#else
printf("%.2u (%s Address 0x%.4x: Width %.2u) r/w counts: %u/%u\n",
-#endif
i, (Reg->Type == EMUL_REG_SYS)? "SYS": "IO",
Reg->Address, Reg->Width, Reg->ReadCount, Reg->WriteCount);
+#endif
Reg = Reg->Next;
i++;
}
diff -urN acpica-unix2-20130626/tests/aapits/atresource.c acpica-unix2-20130626-aapits/tests/aapits/atresource.c
--- acpica-unix2-20130626/tests/aapits/atresource.c 2013-01-17 12:48:29.000000000 -0700
+++ acpica-unix2-20130626-aapits/tests/aapits/atresource.c 2013-07-25 13:25:49.423565947 -0600
@@ -65,7 +65,7 @@
AapiErrors++;
printf ("API Error: AcpiGetCurrentResources(%s) returned Length %d,"
" expected %d\n",
- Pathname, OutBuffer.Length, RT0000_DEV0_CRS_LEN);
+ Pathname, (int) OutBuffer.Length, RT0000_DEV0_CRS_LEN);
return (AE_ERROR);
}
@@ -381,7 +381,7 @@
AapiErrors++;
printf ("API Error: AcpiGetCurrentResources(%s) returned Length %d,"
" expected %d\n",
- Pathname, OutBuffer.Length, RT0000_DEV0_CRS_LEN);
+ Pathname, (int) OutBuffer.Length, RT0000_DEV0_CRS_LEN);
return (AE_ERROR);
}
@@ -580,7 +580,7 @@
AapiErrors++;
printf ("Api Error: Resource->Length (%d) != %d\n",
CurrentResource->Length,
- ACPI_ROUND_UP_TO_NATIVE_WORD (ACPI_RS_SIZE (ACPI_RESOURCE_IRQ)));
+ (int) (ACPI_ROUND_UP_TO_NATIVE_WORD (ACPI_RS_SIZE (ACPI_RESOURCE_IRQ))));
}
if (CurrentResource->Data.Irq.Triggering != 0) /* Level-Triggered */
@@ -872,7 +872,7 @@
AapiErrors++;
printf ("API Error: AcpiGetPossibleResources(%s) returned Length %d,"
" expected %d\n",
- Pathname, OutBuffer.Length, RT0000_DEV0_CRS_LEN);
+ Pathname, (int) OutBuffer.Length, RT0000_DEV0_CRS_LEN);
return (AE_ERROR);
}
@@ -1814,7 +1814,7 @@
AapiErrors++;
printf ("API Error: AcpiGetIrqRoutingTable(%s) returned Length %d,"
" expected %d\n",
- Pathname, OutBuffer.Length, 0xA48);
+ Pathname, (int) OutBuffer.Length, 0xA48);
return (AE_ERROR);
}
diff -urN acpica-unix2-20130626/tests/aapits/Makefile acpica-unix2-20130626-aapits/tests/aapits/Makefile
--- acpica-unix2-20130626/tests/aapits/Makefile 2013-01-17 12:48:29.000000000 -0700
+++ acpica-unix2-20130626-aapits/tests/aapits/Makefile 2013-07-25 15:17:09.309236422 -0600
@@ -20,37 +20,52 @@
../../source/components/hardware/hwxface.c \
../../source/common/getopt.c \
../../source/components/debugger/dbcmds.c \
+ ../../source/components/debugger/dbconvert.c \
../../source/components/debugger/dbdisply.c \
../../source/components/debugger/dbexec.c \
../../source/components/debugger/dbfileio.c \
../../source/components/debugger/dbhistry.c \
../../source/components/debugger/dbinput.c \
+ ../../source/components/debugger/dbmethod.c \
+ ../../source/components/debugger/dbnames.c \
../../source/components/debugger/dbstats.c \
../../source/components/debugger/dbutils.c \
../../source/components/debugger/dbxface.c \
../../source/components/disassembler/dmbuffer.c \
+ ../../source/components/disassembler/dmdeferred.c \
../../source/components/disassembler/dmnames.c \
../../source/components/disassembler/dmobject.c \
../../source/components/disassembler/dmopcode.c \
../../source/components/disassembler/dmresrc.c \
../../source/components/disassembler/dmresrcl.c \
+ ../../source/components/disassembler/dmresrcl2.c \
../../source/components/disassembler/dmresrcs.c \
../../source/components/disassembler/dmutils.c \
../../source/components/disassembler/dmwalk.c \
../../source/components/events/evevent.c \
+ ../../source/components/events/evglock.c \
../../source/components/events/evgpeblk.c \
../../source/components/events/evgpe.c \
+ ../../source/components/events/evgpeinit.c \
+ ../../source/components/events/evgpeutil.c \
+ ../../source/components/events/evhandler.c \
../../source/components/events/evmisc.c \
../../source/components/events/evregion.c \
../../source/components/events/evrgnini.c \
../../source/components/events/evsci.c \
../../source/components/events/evxface.c \
../../source/components/events/evxfevnt.c \
+ ../../source/components/events/evxfgpe.c \
../../source/components/events/evxfregn.c \
../../source/components/hardware/hwacpi.c \
+ ../../source/components/hardware/hwesleep.c \
../../source/components/hardware/hwgpe.c \
+ ../../source/components/hardware/hwpci.c \
../../source/components/hardware/hwregs.c \
../../source/components/hardware/hwsleep.c \
+ ../../source/components/hardware/hwxfsleep.c \
+ ../../source/components/dispatcher/dsargs.c \
+ ../../source/components/dispatcher/dscontrol.c \
../../source/components/dispatcher/dsfield.c \
../../source/components/dispatcher/dsinit.c \
../../source/components/dispatcher/dsmethod.c \
@@ -60,11 +75,13 @@
../../source/components/dispatcher/dsutils.c \
../../source/components/dispatcher/dswexec.c \
../../source/components/dispatcher/dswload.c \
+ ../../source/components/dispatcher/dswload2.c \
../../source/components/dispatcher/dswscope.c \
../../source/components/dispatcher/dswstate.c \
../../source/components/executer/exconfig.c \
../../source/components/executer/exconvrt.c \
../../source/components/executer/excreate.c \
+ ../../source/components/executer/exdebug.c \
../../source/components/executer/exdump.c \
../../source/components/executer/exfield.c \
../../source/components/executer/exfldio.c \
@@ -87,7 +104,9 @@
../../source/components/executer/exutils.c \
../../source/components/parser/psargs.c \
../../source/components/parser/psloop.c \
+ ../../source/components/parser/psobject.c \
../../source/components/parser/psopcode.c \
+ ../../source/components/parser/psopinfo.c \
../../source/components/parser/psparse.c \
../../source/components/parser/psscope.c \
../../source/components/parser/pstree.c \
@@ -96,6 +115,8 @@
../../source/components/parser/psxface.c \
../../source/components/namespace/nsaccess.c \
../../source/components/namespace/nsalloc.c \
+ ../../source/components/namespace/nsarguments.c \
+ ../../source/components/namespace/nsconvert.c \
../../source/components/namespace/nsdump.c \
../../source/components/namespace/nsdumpdv.c \
../../source/components/namespace/nseval.c \
@@ -105,6 +126,7 @@
../../source/components/namespace/nsobject.c \
../../source/components/namespace/nsparse.c \
../../source/components/namespace/nspredef.c \
+ ../../source/components/namespace/nsprepkg.c \
../../source/components/namespace/nsrepair.c \
../../source/components/namespace/nsrepair2.c \
../../source/components/namespace/nssearch.c \
@@ -117,26 +139,35 @@
../../source/components/resources/rscalc.c \
../../source/components/resources/rscreate.c \
../../source/components/resources/rsdump.c \
+ ../../source/components/resources/rsdumpinfo.c \
+ ../../source/components/resources/rsinfo.c \
../../source/components/resources/rsio.c \
../../source/components/resources/rsirq.c \
../../source/components/resources/rslist.c \
../../source/components/resources/rsmemory.c \
../../source/components/resources/rsmisc.c \
+ ../../source/components/resources/rsserial.c \
../../source/components/resources/rsutils.c \
../../source/components/resources/rsxface.c \
- ../../source/components/resources/rsinfo.c \
../../source/components/tables/tbfadt.c \
../../source/components/tables/tbfind.c \
../../source/components/tables/tbinstal.c \
+ ../../source/components/tables/tbprint.c \
../../source/components/tables/tbutils.c \
../../source/components/tables/tbxface.c \
+ ../../source/components/tables/tbxfload.c \
../../source/components/tables/tbxfroot.c \
+ ../../source/components/utilities/utaddress.c \
../../source/components/utilities/utalloc.c \
+ ../../source/components/utilities/utbuffer.c \
../../source/components/utilities/utcache.c \
../../source/components/utilities/utcopy.c \
../../source/components/utilities/utdebug.c \
+ ../../source/components/utilities/utdecode.c \
../../source/components/utilities/utdelete.c \
+ ../../source/components/utilities/uterror.c \
../../source/components/utilities/uteval.c \
+ ../../source/components/utilities/utexcep.c \
../../source/components/utilities/utglobal.c \
../../source/components/utilities/utids.c \
../../source/components/utilities/utinit.c \
@@ -145,17 +176,23 @@
../../source/components/utilities/utmisc.c \
../../source/components/utilities/utmutex.c \
../../source/components/utilities/utobject.c \
+ ../../source/components/utilities/utosi.c \
+ ../../source/components/utilities/utownerid.c \
+ ../../source/components/utilities/utpredef.c \
../../source/components/utilities/utresrc.c \
../../source/components/utilities/utstate.c \
+ ../../source/components/utilities/utstring.c \
../../source/components/utilities/uttrack.c \
- ../../source/components/utilities/utxface.c
+ ../../source/components/utilities/utxface.c \
+ ../../source/components/utilities/utxferror.c \
+ ../../source/components/utilities/utxfinit.c
# ../../source/components/osunixxf.c
CFLAGS+= -Wall -g -D_LINUX -DNDEBUG -D_CONSOLE -DACPI_EXEC_APP -D_MULTI_THREADED -Wstrict-prototypes -I../../source/include
-acpiexec : $(patsubst %.c,%.o, $(SRCS))
+$(PROG) : $(patsubst %.c,%.o, $(SRCS))
$(CC) $(LDFLAGS) $(patsubst %.c,%.o, $(SRCS)) -o $(PROG)
CLEANFILES= $(PROG)
diff -urN acpica-unix2-20130626/tests/aapits/osunixxf.c acpica-unix2-20130626-aapits/tests/aapits/osunixxf.c
--- acpica-unix2-20130626/tests/aapits/osunixxf.c 2013-01-17 12:48:29.000000000 -0700
+++ acpica-unix2-20130626-aapits/tests/aapits/osunixxf.c 2013-07-25 15:11:08.225425856 -0600
@@ -384,7 +384,6 @@
const char *Fmt,
va_list Args)
{
- INT32 Count = 0;
UINT8 Flags;
@@ -397,7 +396,7 @@
{
/* Output file is open, send the output there */
- Count = vfprintf (AcpiGbl_DebugFile, Fmt, Args);
+ vfprintf (AcpiGbl_DebugFile, Fmt, Args);
}
else
{
@@ -409,7 +408,7 @@
if (Flags & ACPI_DB_CONSOLE_OUTPUT)
{
- Count = vfprintf (AcpiGbl_OutputFile, Fmt, Args);
+ vfprintf (AcpiGbl_OutputFile, Fmt, Args);
}
return;
@@ -1166,3 +1165,23 @@
return (AE_OK);
}
+
+/******************************************************************************
+ *
+ * FUNCTION: AcpiOsWaitEventsComplete
+ *
+ * PARAMETERS: None
+ *
+ * RETURN: None
+ *
+ * DESCRIPTION: Wait for all asynchronous events to complete. This
+ * implementation does nothing.
+ *
+ *****************************************************************************/
+
+void
+AcpiOsWaitEventsComplete (
+ void)
+{
+ return;
+}