acpica-tools/OPT_LDFLAGS.patch
Al Stone 5fcb15b704 Update to 20190816 upstream source and refresh patches
Signed-off-by: Al Stone <ahs3@redhat.com>
2019-10-27 16:01:59 -06:00

27 lines
802 B
Diff

Index: acpica-unix-20190816/generate/unix/Makefile.config
===================================================================
--- acpica-unix-20190816.orig/generate/unix/Makefile.config
+++ acpica-unix-20190816/generate/unix/Makefile.config
@@ -23,6 +23,9 @@
# OPT_CFLAGS can be overridden on the make command line by
# adding OPT_CFLAGS="..." to the invocation.
#
+# OPT_LDFLAGS can be overridden on the make command line by
+# adding OPT_LDFLAGS="..." to the invocation.
+#
# Notes:
# gcc should be version 4 or greater, otherwise some of the options
# used will not be recognized.
@@ -165,6 +168,11 @@ LDFLAGS +=-m32
endif
#
+# Common linker flags
+#
+OPT_LDFLAGS ?=
+
+#
# Optionally disable optimizations. Optimization causes problems on
# some compilers such as gcc 4.4
#