Refresh patches, add one more for big endian machines
Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
parent
b398550f0b
commit
ff28045e70
@ -1,12 +0,0 @@
|
||||
diff -urN acpica-unix-20140114/tests/aapits/Makefile acpica-unix-20140114.patch/tests/aapits/Makefile
|
||||
--- acpica-unix-20140114/tests/aapits/Makefile 2014-01-14 15:02:45.000000000 -0700
|
||||
+++ acpica-unix-20140114.patch/tests/aapits/Makefile 2014-01-23 16:07:50.124972105 -0700
|
||||
@@ -29,6 +29,7 @@
|
||||
../../source/components/debugger/dbmethod.c \
|
||||
../../source/components/debugger/dbnames.c \
|
||||
../../source/components/debugger/dbstats.c \
|
||||
+ ../../source/components/debugger/dbtest.c \
|
||||
../../source/components/debugger/dbutils.c \
|
||||
../../source/components/debugger/dbxface.c \
|
||||
../../source/components/disassembler/dmbuffer.c \
|
||||
|
@ -318,155 +318,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atresource.c acpica-unix2-20130626-
|
||||
diff -urN acpica-unix2-20130626/tests/aapits/Makefile acpica-unix2-20130626-aapits/tests/aapits/Makefile
|
||||
--- acpica-unix2-20130626/tests/aapits/Makefile 2013-01-17 12:48:29.000000000 -0700
|
||||
+++ acpica-unix2-20130626-aapits/tests/aapits/Makefile 2013-07-25 15:17:09.309236422 -0600
|
||||
@@ -20,37 +20,52 @@
|
||||
../../source/components/hardware/hwxface.c \
|
||||
../../source/common/getopt.c \
|
||||
../../source/components/debugger/dbcmds.c \
|
||||
+ ../../source/components/debugger/dbconvert.c \
|
||||
../../source/components/debugger/dbdisply.c \
|
||||
../../source/components/debugger/dbexec.c \
|
||||
../../source/components/debugger/dbfileio.c \
|
||||
../../source/components/debugger/dbhistry.c \
|
||||
../../source/components/debugger/dbinput.c \
|
||||
+ ../../source/components/debugger/dbmethod.c \
|
||||
+ ../../source/components/debugger/dbnames.c \
|
||||
../../source/components/debugger/dbstats.c \
|
||||
../../source/components/debugger/dbutils.c \
|
||||
../../source/components/debugger/dbxface.c \
|
||||
../../source/components/disassembler/dmbuffer.c \
|
||||
+ ../../source/components/disassembler/dmdeferred.c \
|
||||
../../source/components/disassembler/dmnames.c \
|
||||
../../source/components/disassembler/dmobject.c \
|
||||
../../source/components/disassembler/dmopcode.c \
|
||||
../../source/components/disassembler/dmresrc.c \
|
||||
../../source/components/disassembler/dmresrcl.c \
|
||||
+ ../../source/components/disassembler/dmresrcl2.c \
|
||||
../../source/components/disassembler/dmresrcs.c \
|
||||
../../source/components/disassembler/dmutils.c \
|
||||
../../source/components/disassembler/dmwalk.c \
|
||||
../../source/components/events/evevent.c \
|
||||
+ ../../source/components/events/evglock.c \
|
||||
../../source/components/events/evgpeblk.c \
|
||||
../../source/components/events/evgpe.c \
|
||||
+ ../../source/components/events/evgpeinit.c \
|
||||
+ ../../source/components/events/evgpeutil.c \
|
||||
+ ../../source/components/events/evhandler.c \
|
||||
../../source/components/events/evmisc.c \
|
||||
../../source/components/events/evregion.c \
|
||||
../../source/components/events/evrgnini.c \
|
||||
../../source/components/events/evsci.c \
|
||||
../../source/components/events/evxface.c \
|
||||
../../source/components/events/evxfevnt.c \
|
||||
+ ../../source/components/events/evxfgpe.c \
|
||||
../../source/components/events/evxfregn.c \
|
||||
../../source/components/hardware/hwacpi.c \
|
||||
+ ../../source/components/hardware/hwesleep.c \
|
||||
../../source/components/hardware/hwgpe.c \
|
||||
+ ../../source/components/hardware/hwpci.c \
|
||||
../../source/components/hardware/hwregs.c \
|
||||
../../source/components/hardware/hwsleep.c \
|
||||
+ ../../source/components/hardware/hwxfsleep.c \
|
||||
+ ../../source/components/dispatcher/dsargs.c \
|
||||
+ ../../source/components/dispatcher/dscontrol.c \
|
||||
../../source/components/dispatcher/dsfield.c \
|
||||
../../source/components/dispatcher/dsinit.c \
|
||||
../../source/components/dispatcher/dsmethod.c \
|
||||
@@ -60,11 +75,13 @@
|
||||
../../source/components/dispatcher/dsutils.c \
|
||||
../../source/components/dispatcher/dswexec.c \
|
||||
../../source/components/dispatcher/dswload.c \
|
||||
+ ../../source/components/dispatcher/dswload2.c \
|
||||
../../source/components/dispatcher/dswscope.c \
|
||||
../../source/components/dispatcher/dswstate.c \
|
||||
../../source/components/executer/exconfig.c \
|
||||
../../source/components/executer/exconvrt.c \
|
||||
../../source/components/executer/excreate.c \
|
||||
+ ../../source/components/executer/exdebug.c \
|
||||
../../source/components/executer/exdump.c \
|
||||
../../source/components/executer/exfield.c \
|
||||
../../source/components/executer/exfldio.c \
|
||||
@@ -87,7 +104,9 @@
|
||||
../../source/components/executer/exutils.c \
|
||||
../../source/components/parser/psargs.c \
|
||||
../../source/components/parser/psloop.c \
|
||||
+ ../../source/components/parser/psobject.c \
|
||||
../../source/components/parser/psopcode.c \
|
||||
+ ../../source/components/parser/psopinfo.c \
|
||||
../../source/components/parser/psparse.c \
|
||||
../../source/components/parser/psscope.c \
|
||||
../../source/components/parser/pstree.c \
|
||||
@@ -96,6 +115,8 @@
|
||||
../../source/components/parser/psxface.c \
|
||||
../../source/components/namespace/nsaccess.c \
|
||||
../../source/components/namespace/nsalloc.c \
|
||||
+ ../../source/components/namespace/nsarguments.c \
|
||||
+ ../../source/components/namespace/nsconvert.c \
|
||||
../../source/components/namespace/nsdump.c \
|
||||
../../source/components/namespace/nsdumpdv.c \
|
||||
../../source/components/namespace/nseval.c \
|
||||
@@ -105,6 +126,7 @@
|
||||
../../source/components/namespace/nsobject.c \
|
||||
../../source/components/namespace/nsparse.c \
|
||||
../../source/components/namespace/nspredef.c \
|
||||
+ ../../source/components/namespace/nsprepkg.c \
|
||||
../../source/components/namespace/nsrepair.c \
|
||||
../../source/components/namespace/nsrepair2.c \
|
||||
../../source/components/namespace/nssearch.c \
|
||||
@@ -117,26 +139,35 @@
|
||||
../../source/components/resources/rscalc.c \
|
||||
../../source/components/resources/rscreate.c \
|
||||
../../source/components/resources/rsdump.c \
|
||||
+ ../../source/components/resources/rsdumpinfo.c \
|
||||
+ ../../source/components/resources/rsinfo.c \
|
||||
../../source/components/resources/rsio.c \
|
||||
../../source/components/resources/rsirq.c \
|
||||
../../source/components/resources/rslist.c \
|
||||
../../source/components/resources/rsmemory.c \
|
||||
../../source/components/resources/rsmisc.c \
|
||||
+ ../../source/components/resources/rsserial.c \
|
||||
../../source/components/resources/rsutils.c \
|
||||
../../source/components/resources/rsxface.c \
|
||||
- ../../source/components/resources/rsinfo.c \
|
||||
../../source/components/tables/tbfadt.c \
|
||||
../../source/components/tables/tbfind.c \
|
||||
../../source/components/tables/tbinstal.c \
|
||||
+ ../../source/components/tables/tbprint.c \
|
||||
../../source/components/tables/tbutils.c \
|
||||
../../source/components/tables/tbxface.c \
|
||||
+ ../../source/components/tables/tbxfload.c \
|
||||
../../source/components/tables/tbxfroot.c \
|
||||
+ ../../source/components/utilities/utaddress.c \
|
||||
../../source/components/utilities/utalloc.c \
|
||||
+ ../../source/components/utilities/utbuffer.c \
|
||||
../../source/components/utilities/utcache.c \
|
||||
../../source/components/utilities/utcopy.c \
|
||||
../../source/components/utilities/utdebug.c \
|
||||
+ ../../source/components/utilities/utdecode.c \
|
||||
../../source/components/utilities/utdelete.c \
|
||||
+ ../../source/components/utilities/uterror.c \
|
||||
../../source/components/utilities/uteval.c \
|
||||
+ ../../source/components/utilities/utexcep.c \
|
||||
../../source/components/utilities/utglobal.c \
|
||||
../../source/components/utilities/utids.c \
|
||||
../../source/components/utilities/utinit.c \
|
||||
@@ -145,17 +176,23 @@
|
||||
../../source/components/utilities/utmisc.c \
|
||||
../../source/components/utilities/utmutex.c \
|
||||
../../source/components/utilities/utobject.c \
|
||||
+ ../../source/components/utilities/utosi.c \
|
||||
+ ../../source/components/utilities/utownerid.c \
|
||||
+ ../../source/components/utilities/utpredef.c \
|
||||
../../source/components/utilities/utresrc.c \
|
||||
../../source/components/utilities/utstate.c \
|
||||
+ ../../source/components/utilities/utstring.c \
|
||||
../../source/components/utilities/uttrack.c \
|
||||
- ../../source/components/utilities/utxface.c
|
||||
+ ../../source/components/utilities/utxface.c \
|
||||
+ ../../source/components/utilities/utxferror.c \
|
||||
+ ../../source/components/utilities/utxfinit.c
|
||||
# ../../source/components/osunixxf.c
|
||||
|
||||
|
||||
@@ -193,7 +193,7 @@
|
||||
CFLAGS+= -Wall -g -D_LINUX -DNDEBUG -D_CONSOLE -DACPI_EXEC_APP -D_MULTI_THREADED -Wstrict-prototypes -I../../source/include
|
||||
|
||||
|
||||
@ -475,56 +327,3 @@ diff -urN acpica-unix2-20130626/tests/aapits/Makefile acpica-unix2-20130626-aapi
|
||||
$(CC) $(LDFLAGS) $(patsubst %.c,%.o, $(SRCS)) -o $(PROG)
|
||||
|
||||
CLEANFILES= $(PROG)
|
||||
diff -urN acpica-unix2-20130626/tests/aapits/osunixxf.c acpica-unix2-20130626-aapits/tests/aapits/osunixxf.c
|
||||
--- acpica-unix2-20130626/tests/aapits/osunixxf.c 2013-01-17 12:48:29.000000000 -0700
|
||||
+++ acpica-unix2-20130626-aapits/tests/aapits/osunixxf.c 2013-07-25 15:11:08.225425856 -0600
|
||||
@@ -384,7 +384,6 @@
|
||||
const char *Fmt,
|
||||
va_list Args)
|
||||
{
|
||||
- INT32 Count = 0;
|
||||
UINT8 Flags;
|
||||
|
||||
|
||||
@@ -397,7 +396,7 @@
|
||||
{
|
||||
/* Output file is open, send the output there */
|
||||
|
||||
- Count = vfprintf (AcpiGbl_DebugFile, Fmt, Args);
|
||||
+ vfprintf (AcpiGbl_DebugFile, Fmt, Args);
|
||||
}
|
||||
else
|
||||
{
|
||||
@@ -409,7 +408,7 @@
|
||||
|
||||
if (Flags & ACPI_DB_CONSOLE_OUTPUT)
|
||||
{
|
||||
- Count = vfprintf (AcpiGbl_OutputFile, Fmt, Args);
|
||||
+ vfprintf (AcpiGbl_OutputFile, Fmt, Args);
|
||||
}
|
||||
|
||||
return;
|
||||
@@ -1166,3 +1165,23 @@
|
||||
|
||||
return (AE_OK);
|
||||
}
|
||||
+
|
||||
+/******************************************************************************
|
||||
+ *
|
||||
+ * FUNCTION: AcpiOsWaitEventsComplete
|
||||
+ *
|
||||
+ * PARAMETERS: None
|
||||
+ *
|
||||
+ * RETURN: None
|
||||
+ *
|
||||
+ * DESCRIPTION: Wait for all asynchronous events to complete. This
|
||||
+ * implementation does nothing.
|
||||
+ *
|
||||
+ *****************************************************************************/
|
||||
+
|
||||
+void
|
||||
+AcpiOsWaitEventsComplete (
|
||||
+ void)
|
||||
+{
|
||||
+ return;
|
||||
+}
|
||||
|
@ -1,5 +1,5 @@
|
||||
Name: acpica-tools
|
||||
Version: 20140114
|
||||
Version: 20140214
|
||||
Release: 1%{?dist}
|
||||
Summary: ACPICA tools for the development and debug of ACPI tables
|
||||
|
||||
@ -27,7 +27,7 @@ Patch0: debian-big_endian.patch
|
||||
Patch1: debian-unaligned.patch
|
||||
Patch2: name-miscompare.patch
|
||||
Patch3: aapits-linux.patch
|
||||
Patch4: aapits-ld.patch
|
||||
Patch4: asllookup-miscompare.patch
|
||||
|
||||
BuildRequires: bison patchutils flex
|
||||
|
||||
@ -82,7 +82,7 @@ gzip -dc %{SOURCE1} | tar -x --strip-components=1 -f -
|
||||
%patch1 -p1 -b .debian-unaligned
|
||||
%patch2 -p1 -b .name-miscompare
|
||||
%patch3 -p1 -b .aapits-linux
|
||||
%patch4 -p1 -b .aapits-ld
|
||||
%patch4 -p1 -b .asllookup-miscompare
|
||||
|
||||
cp -p %{SOURCE2} README.Fedora
|
||||
cp -p %{SOURCE3} iasl.1
|
||||
@ -187,6 +187,12 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Feb 26 2014 Al Stone <ahs3@redhat.com> - 20140214-1
|
||||
- Update to latest upstream. Closes BZ#1053396.
|
||||
- Remove temporary patch so that AAPITS will build and run.
|
||||
- Add patch to print asllookup.c warning properly on big endian;
|
||||
Closes BZ#1069178.
|
||||
|
||||
* Tue Jan 21 2014 Al Stone <ahs3@redhat.com> - 20140114-1
|
||||
- Update to latest upstream. Closes BZ#1053396.
|
||||
- Remove temporary patch to add Makefile missing from upstream tarball.
|
||||
|
22
asllookup-miscompare.patch
Normal file
22
asllookup-miscompare.patch
Normal file
@ -0,0 +1,22 @@
|
||||
diff -urN acpica-unix2-20140214/source/compiler/asllookup.c acpica-unix2-20140214-patch/source/compiler/asllookup.c
|
||||
--- acpica-unix2-20140214/source/compiler/asllookup.c 2014-02-14 16:23:33.000000000 -0700
|
||||
+++ acpica-unix2-20140214-patch/source/compiler/asllookup.c 2014-02-27 11:50:52.168659866 -0700
|
||||
@@ -120,6 +120,7 @@
|
||||
{
|
||||
ACPI_NAMESPACE_NODE *Node = ACPI_CAST_PTR (ACPI_NAMESPACE_NODE, ObjHandle);
|
||||
ACPI_NAMESPACE_NODE *Next;
|
||||
+ ACPI_NAME_UNION tmp;
|
||||
|
||||
|
||||
/* Referenced flag is set during the namespace xref */
|
||||
@@ -163,8 +164,9 @@
|
||||
* Issue a remark even if it is a reserved name (starts
|
||||
* with an underscore).
|
||||
*/
|
||||
+ ACPI_MOVE_32_TO_32(&tmp.Ascii, Next->Name.Ascii);
|
||||
sprintf (MsgBuffer, "Name is within method [%4.4s]",
|
||||
- Next->Name.Ascii);
|
||||
+ tmp.Ascii);
|
||||
AslError (ASL_REMARK, ASL_MSG_NOT_REFERENCED,
|
||||
LkGetNameOp (Node->Op), MsgBuffer);
|
||||
return (AE_OK);
|
@ -2417,7 +2417,7 @@ diff --git a/source/include/acmacros.h b/source/include/acmacros.h
|
||||
index ee9e745..67fb983 100644
|
||||
--- a/source/include/acmacros.h
|
||||
+++ b/source/include/acmacros.h
|
||||
@@ -107,7 +107,8 @@
|
||||
@@ -113,7 +113,8 @@
|
||||
|
||||
/* 32-bit source, 16/32/64 destination */
|
||||
|
||||
@ -2427,7 +2427,7 @@ index ee9e745..67fb983 100644
|
||||
|
||||
#define ACPI_MOVE_32_TO_32(d, s) {(( UINT8 *)(void *)(d))[0] = ((UINT8 *)(void *)(s))[3];\
|
||||
(( UINT8 *)(void *)(d))[1] = ((UINT8 *)(void *)(s))[2];\
|
||||
@@ -122,9 +123,13 @@
|
||||
@@ -128,9 +129,13 @@
|
||||
|
||||
/* 64-bit source, 16/32/64 destination */
|
||||
|
||||
@ -2443,7 +2443,7 @@ index ee9e745..67fb983 100644
|
||||
|
||||
#define ACPI_MOVE_64_TO_64(d, s) {(( UINT8 *)(void *)(d))[0] = ((UINT8 *)(void *)(s))[7];\
|
||||
(( UINT8 *)(void *)(d))[1] = ((UINT8 *)(void *)(s))[6];\
|
||||
@@ -151,7 +156,9 @@
|
||||
@@ -157,7 +162,9 @@
|
||||
|
||||
/* 32-bit source, 16/32/64 destination */
|
||||
|
||||
|
@ -118,7 +118,7 @@ diff --git a/source/include/actypes.h b/source/include/actypes.h
|
||||
index 07fb7d5..08bdf2f 100644
|
||||
--- a/source/include/actypes.h
|
||||
+++ b/source/include/actypes.h
|
||||
@@ -142,6 +142,19 @@ typedef COMPILER_DEPENDENT_INT64 INT64;
|
||||
@@ -144,6 +157,19 @@ typedef COMPILER_DEPENDENT_INT64 INT64;
|
||||
*/
|
||||
#define ACPI_THREAD_ID UINT64
|
||||
|
||||
@ -138,7 +138,7 @@ index 07fb7d5..08bdf2f 100644
|
||||
|
||||
/*******************************************************************************
|
||||
*
|
||||
@@ -168,19 +181,6 @@ typedef UINT64 ACPI_PHYSICAL_ADDRESS;
|
||||
@@ -183,19 +189,6 @@ typedef UINT64 ACPI_PHYSICAL_ADDRESS;
|
||||
#define ACPI_SIZE_MAX ACPI_UINT64_MAX
|
||||
#define ACPI_USE_NATIVE_DIVIDE /* Has native 64-bit integer support */
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user