Refresh the patches so everything applies properly.
Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
parent
4978c4512b
commit
f1b2c555e8
@ -318,8 +318,8 @@ diff -urN acpica-unix2-20130626/tests/aapits/atresource.c acpica-unix2-20130626-
|
||||
diff -urN acpica-unix2-20130626/tests/aapits/Makefile acpica-unix2-20130626-aapits/tests/aapits/Makefile
|
||||
--- acpica-unix2-20130626/tests/aapits/Makefile 2013-01-17 12:48:29.000000000 -0700
|
||||
+++ acpica-unix2-20130626-aapits/tests/aapits/Makefile 2013-07-25 15:17:09.309236422 -0600
|
||||
@@ -194,7 +194,7 @@
|
||||
CFLAGS+= -Wall -g -D_LINUX -DNDEBUG -D_CONSOLE -DACPI_EXEC_APP -D_MULTI_THREADED -Wstrict-prototypes -I../../source/include
|
||||
@@ -199,7 +199,7 @@
|
||||
CFLAGS+= -Wall -g -D_LINUX -DNDEBUG -D_CONSOLE -DACPI_APITS -DACPI_EXEC_APP -D_MULTI_THREADED -Wstrict-prototypes -I../../source/include
|
||||
|
||||
|
||||
-acpiexec : $(patsubst %.c,%.o, $(SRCS))
|
||||
|
@ -1,19 +1,27 @@
|
||||
diff -urN acpica-unix2-20140325/tests/aapits/Makefile acpica-unix2-20140325/tests/aapits/Makefile
|
||||
--- acpica-unix2-20140325/tests/aapits/Makefile 2014-04-05 14:23:14.683636794 -0600
|
||||
+++ acpica-unix2-20140325-aapits/tests/aapits/Makefile 2014-04-05 15:10:57.879184598 -0600
|
||||
@@ -20,6 +20,7 @@
|
||||
../../source/components/hardware/hwxface.c \
|
||||
diff -Naur acpica-unix2-20140724.orig/tests/aapits/Makefile acpica-unix2-20140724/tests/aapits/Makefile
|
||||
--- acpica-unix2-20140724.orig/tests/aapits/Makefile 2014-07-28 14:32:23.884529332 -0600
|
||||
+++ acpica-unix2-20140724/tests/aapits/Makefile 2014-07-28 14:50:27.367982860 -0600
|
||||
@@ -16,6 +16,7 @@
|
||||
atosxfwrap.c \
|
||||
osunixxf.c \
|
||||
../../source/common/ahids.c \
|
||||
+ ../../source/common/ahuuids.c \
|
||||
../../source/common/cmfsize.c \
|
||||
../../source/common/getopt.c \
|
||||
+ ../../source/common/ahids.c \
|
||||
../../source/components/debugger/dbcmds.c \
|
||||
../../source/components/debugger/dbconvert.c \
|
||||
../../source/components/debugger/dbdisply.c \
|
||||
@@ -154,6 +155,7 @@
|
||||
../../source/components/tables/tbfadt.c \
|
||||
../../source/components/tables/tbfind.c \
|
||||
../../source/components/tables/tbinstal.c \
|
||||
+ ../../source/components/tables/tbdata.c \
|
||||
../../source/components/tables/tbprint.c \
|
||||
../../source/components/tables/tbutils.c \
|
||||
../../source/components/tables/tbxface.c \
|
||||
../../source/components/hardware/hwtimer.c \
|
||||
@@ -174,6 +175,7 @@
|
||||
../../source/components/utilities/utexcep.c \
|
||||
../../source/components/utilities/utfileio.c \
|
||||
../../source/components/utilities/utglobal.c \
|
||||
+ ../../source/components/utilities/uthex.c \
|
||||
../../source/components/utilities/utids.c \
|
||||
../../source/components/utilities/utinit.c \
|
||||
../../source/components/utilities/utlock.c \
|
||||
@@ -189,6 +191,7 @@
|
||||
../../source/components/utilities/utstate.c \
|
||||
../../source/components/utilities/utstring.c \
|
||||
../../source/components/utilities/uttrack.c \
|
||||
+ ../../source/components/utilities/utuuid.c \
|
||||
../../source/components/utilities/utxface.c \
|
||||
../../source/components/utilities/utxferror.c \
|
||||
../../source/components/utilities/utxfinit.c \
|
||||
|
@ -194,6 +194,7 @@ fi
|
||||
* Mon Jul 28 2014 Al Stone <ahs3@redhat.com> - 20140724-1
|
||||
- Update to latest upstream. Closes BZ#1114275.
|
||||
- This update adds support for the 5.1 version of the ACPI specification
|
||||
- Refresh patches so everything applies properly.
|
||||
|
||||
* Fri Jun 6 2014 Dan Horák <dan[at]danny.cz> - 20140424-3
|
||||
- refresh the big endian patch so it applies correctly, fixes build on big endians
|
||||
|
@ -2415,7 +2415,7 @@ diff -up acpica-unix2-20140424/source/include/acmacros.h.debian-big_endian acpic
|
||||
diff -up acpica-unix2-20140424/source/include/platform/aclinux.h.debian-big_endian acpica-unix2-20140424/source/include/platform/aclinux.h
|
||||
--- acpica-unix2-20140424/source/include/platform/aclinux.h.debian-big_endian 2014-04-24 11:49:06.000000000 -0400
|
||||
+++ acpica-unix2-20140424/source/include/platform/aclinux.h 2014-06-06 20:44:28.781825238 -0400
|
||||
@@ -116,6 +116,7 @@
|
||||
@@ -155,6 +155,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <ctype.h>
|
||||
#include <unistd.h>
|
||||
@ -2423,7 +2423,7 @@ diff -up acpica-unix2-20140424/source/include/platform/aclinux.h.debian-big_endi
|
||||
|
||||
/* Define/disable kernel-specific declarators */
|
||||
|
||||
@@ -132,8 +133,7 @@
|
||||
@@ -167,8 +168,7 @@
|
||||
#define ACPI_FLUSH_CPU_CACHE()
|
||||
#define ACPI_CAST_PTHREAD_T(Pthread) ((ACPI_THREAD_ID) (Pthread))
|
||||
|
||||
@ -2433,7 +2433,7 @@ diff -up acpica-unix2-20140424/source/include/platform/aclinux.h.debian-big_endi
|
||||
#define ACPI_MACHINE_WIDTH 64
|
||||
#define COMPILER_DEPENDENT_INT64 long
|
||||
#define COMPILER_DEPENDENT_UINT64 unsigned long
|
||||
@@ -144,6 +144,10 @@
|
||||
@@ -179,6 +179,10 @@
|
||||
#define ACPI_USE_NATIVE_DIVIDE
|
||||
#endif
|
||||
|
||||
|
@ -118,7 +118,7 @@ diff --git a/source/include/actypes.h b/source/include/actypes.h
|
||||
index 07fb7d5..08bdf2f 100644
|
||||
--- a/source/include/actypes.h
|
||||
+++ b/source/include/actypes.h
|
||||
@@ -142,6 +155,19 @@ typedef COMPILER_DEPENDENT_INT64 INT64;
|
||||
@@ -143,6 +156,19 @@ typedef COMPILER_DEPENDENT_INT64 INT64;
|
||||
*/
|
||||
#define ACPI_THREAD_ID UINT64
|
||||
|
||||
@ -138,7 +138,7 @@ index 07fb7d5..08bdf2f 100644
|
||||
|
||||
/*******************************************************************************
|
||||
*
|
||||
@@ -168,19 +181,6 @@ typedef UINT64 ACPI_PHYSICAL_ADDRESS;
|
||||
@@ -169,19 +182,6 @@ typedef UINT64 ACPI_PHYSICAL_ADDRESS;
|
||||
#define ACPI_SIZE_MAX ACPI_UINT64_MAX
|
||||
#define ACPI_USE_NATIVE_DIVIDE /* Has native 64-bit integer support */
|
||||
|
||||
|
Binary file not shown.
Loading…
Reference in New Issue
Block a user