Update to 20140114 versions of upstream

Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
Al Stone 2014-01-24 10:40:50 -07:00
parent 4045c2dad2
commit db6b4f2b56
5 changed files with 22 additions and 157 deletions

12
aapits-ld.patch Normal file
View File

@ -0,0 +1,12 @@
diff -urN acpica-unix-20140114/tests/aapits/Makefile acpica-unix-20140114.patch/tests/aapits/Makefile
--- acpica-unix-20140114/tests/aapits/Makefile 2014-01-14 15:02:45.000000000 -0700
+++ acpica-unix-20140114.patch/tests/aapits/Makefile 2014-01-23 16:07:50.124972105 -0700
@@ -29,6 +29,7 @@
../../source/components/debugger/dbmethod.c \
../../source/components/debugger/dbnames.c \
../../source/components/debugger/dbstats.c \
+ ../../source/components/debugger/dbtest.c \
../../source/components/debugger/dbutils.c \
../../source/components/debugger/dbxface.c \
../../source/components/disassembler/dmbuffer.c \

View File

@ -1,5 +1,5 @@
Name: acpica-tools
Version: 20131218
Version: 20140114
Release: 1%{?dist}
Summary: ACPICA tools for the development and debug of ACPI tables
@ -27,7 +27,7 @@ Patch0: debian-big_endian.patch
Patch1: debian-unaligned.patch
Patch2: name-miscompare.patch
Patch3: aapits-linux.patch
Patch4: examples-makefile.patch
Patch4: aapits-ld.patch
BuildRequires: bison patchutils flex
@ -82,7 +82,7 @@ gzip -dc %{SOURCE1} | tar -x --strip-components=1 -f -
%patch1 -p1 -b .debian-unaligned
%patch2 -p1 -b .name-miscompare
%patch3 -p1 -b .aapits-linux
%patch4 -p1 -b .examples-makefile
%patch4 -p1 -b .aapits-ld
cp -p %{SOURCE2} README.Fedora
cp -p %{SOURCE3} iasl.1
@ -187,6 +187,11 @@ fi
%changelog
* Tue Jan 21 2014 Al Stone <ahs3@redhat.com> - 20140114-1
- Update to latest upstream. Closes BZ#1053396.
- Remove temporary patch to add Makefile missing from upstream tarball.
- Add temporary patch so that AAPITS will build and run.
* Tue Jan 7 2014 Al Stone <ahs3@redhat.com> - 20131218-1
- Update to latest upstream. Closes BZ#1044951.
- Add temporary patch to add Makefile missing from upstream tarball.

View File

@ -235,7 +235,7 @@ Remark 2089 - Object is not referenced ^ (Name is with
Intel ACPI Component Architecture
ASL Optimizing Compiler version VVVVVVVV-YYYY [XXXXXXXXXXX]
Copyright (c) 2000 - 2013 Intel Corporation
Copyright (c) 2000 - 2014 Intel Corporation
Ignoring all errors, forcing AML file generation

View File

@ -1,152 +0,0 @@
diff -urN acpica-unix-20131218/generate/unix/acpiexamples/Makefile acpica-unix-20131218-patch/generate/unix/acpiexamples/Makefile
--- acpica-unix-20131218/generate/unix/acpiexamples/Makefile 1969-12-31 17:00:00.000000000 -0700
+++ acpica-unix-20131218-patch/generate/unix/acpiexamples/Makefile 2014-01-06 19:40:59.042080873 -0700
@@ -0,0 +1,148 @@
+#
+# acpiexamples - Example ACPICA initialization code and control
+# method execution.
+#
+
+#
+# Note: This makefile is intended to be used from within the native
+# ACPICA directory structure, from under generate/unix. It specifically
+# places all object files in a generate/unix subdirectory, not within
+# the various ACPICA source directories. This prevents collisions
+# between different compilations of the same source file with different
+# compile options, and prevents pollution of the source code.
+#
+include ../Makefile.config
+FINAL_PROG = ../$(BINDIR)/acpiexamples
+PROG = $(OBJDIR)/acpiexamples
+
+#
+# Search paths for source files
+#
+vpath %.c \
+ $(ACPIEXAMPLES)\
+ $(ACPICA_DEBUGGER)\
+ $(ACPICA_DISPATCHER)\
+ $(ACPICA_EXECUTER)\
+ $(ACPICA_NAMESPACE)\
+ $(ACPICA_PARSER)\
+ $(ACPICA_TABLES)\
+ $(ACPICA_UTILITIES)\
+ $(ACPICA_COMMON)\
+ $(ACPICA_OSL)
+
+HEADERS = \
+ $(wildcard $(ACPIEXAMPLES)/*.h)
+
+OBJECTS = \
+ $(OBJDIR)/examples.o\
+ $(OBJDIR)/exstubs.o\
+ $(OBJDIR)/extables.o\
+ $(OBJDIR)/dsargs.o\
+ $(OBJDIR)/dscontrol.o\
+ $(OBJDIR)/dsfield.o\
+ $(OBJDIR)/dsinit.o\
+ $(OBJDIR)/dsmethod.o\
+ $(OBJDIR)/dsmthdat.o\
+ $(OBJDIR)/dsobject.o\
+ $(OBJDIR)/dsopcode.o\
+ $(OBJDIR)/dsutils.o\
+ $(OBJDIR)/dswexec.o\
+ $(OBJDIR)/dswload.o\
+ $(OBJDIR)/dswload2.o\
+ $(OBJDIR)/dswscope.o\
+ $(OBJDIR)/dswstate.o\
+ $(OBJDIR)/exconfig.o\
+ $(OBJDIR)/exconvrt.o\
+ $(OBJDIR)/excreate.o\
+ $(OBJDIR)/exdebug.o\
+ $(OBJDIR)/exdump.o\
+ $(OBJDIR)/exfield.o\
+ $(OBJDIR)/exfldio.o\
+ $(OBJDIR)/exmisc.o\
+ $(OBJDIR)/exmutex.o\
+ $(OBJDIR)/exnames.o\
+ $(OBJDIR)/exoparg1.o\
+ $(OBJDIR)/exoparg2.o\
+ $(OBJDIR)/exoparg3.o\
+ $(OBJDIR)/exoparg6.o\
+ $(OBJDIR)/exprep.o\
+ $(OBJDIR)/exregion.o\
+ $(OBJDIR)/exresnte.o\
+ $(OBJDIR)/exresolv.o\
+ $(OBJDIR)/exresop.o\
+ $(OBJDIR)/exstore.o\
+ $(OBJDIR)/exstoren.o\
+ $(OBJDIR)/exstorob.o\
+ $(OBJDIR)/exsystem.o\
+ $(OBJDIR)/exutils.o\
+ $(OBJDIR)/nsaccess.o\
+ $(OBJDIR)/nsalloc.o\
+ $(OBJDIR)/nsconvert.o\
+ $(OBJDIR)/nsdump.o\
+ $(OBJDIR)/nseval.o\
+ $(OBJDIR)/nsinit.o\
+ $(OBJDIR)/nsload.o\
+ $(OBJDIR)/nsnames.o\
+ $(OBJDIR)/nsobject.o\
+ $(OBJDIR)/nsparse.o\
+ $(OBJDIR)/nssearch.o\
+ $(OBJDIR)/nsutils.o\
+ $(OBJDIR)/nswalk.o\
+ $(OBJDIR)/nsxfeval.o\
+ $(OBJDIR)/nsxfname.o\
+ $(OBJDIR)/nsxfobj.o\
+ $(OBJDIR)/osunixxf.o\
+ $(OBJDIR)/psargs.o\
+ $(OBJDIR)/psloop.o\
+ $(OBJDIR)/psobject.o\
+ $(OBJDIR)/psopcode.o\
+ $(OBJDIR)/psopinfo.o\
+ $(OBJDIR)/psparse.o\
+ $(OBJDIR)/psscope.o\
+ $(OBJDIR)/pstree.o\
+ $(OBJDIR)/psutils.o\
+ $(OBJDIR)/pswalk.o\
+ $(OBJDIR)/psxface.o\
+ $(OBJDIR)/tbfadt.o\
+ $(OBJDIR)/tbfind.o\
+ $(OBJDIR)/tbinstal.o\
+ $(OBJDIR)/tbprint.o\
+ $(OBJDIR)/tbutils.o\
+ $(OBJDIR)/tbxface.o\
+ $(OBJDIR)/tbxfload.o\
+ $(OBJDIR)/tbxfroot.o\
+ $(OBJDIR)/utaddress.o\
+ $(OBJDIR)/utalloc.o\
+ $(OBJDIR)/utbuffer.o\
+ $(OBJDIR)/utcache.o\
+ $(OBJDIR)/utcopy.o\
+ $(OBJDIR)/utdebug.o\
+ $(OBJDIR)/utdecode.o\
+ $(OBJDIR)/utdelete.o\
+ $(OBJDIR)/uterror.o\
+ $(OBJDIR)/utexcep.o\
+ $(OBJDIR)/utglobal.o\
+ $(OBJDIR)/utlock.o\
+ $(OBJDIR)/utmath.o\
+ $(OBJDIR)/utmisc.o\
+ $(OBJDIR)/utmutex.o\
+ $(OBJDIR)/utobject.o\
+ $(OBJDIR)/utosi.o\
+ $(OBJDIR)/utownerid.o\
+ $(OBJDIR)/utstate.o\
+ $(OBJDIR)/utstring.o\
+ $(OBJDIR)/utxface.o\
+ $(OBJDIR)/utxferror.o\
+ $(OBJDIR)/utxfinit.o
+
+#
+# Flags specific to acpinames utility
+#
+CFLAGS += \
+ -DACPI_EXAMPLE_APP\
+ -I$(EXAMPLES)
+
+#
+# Common Rules
+#
+include ../Makefile.rules

View File

@ -124,7 +124,7 @@ Remark 2063 - ^ Initializer list shorter t
Intel ACPI Component Architecture
ASL Optimizing Compiler version VVVVVVVV-YYYY [XXXXXXXXXXX]
Copyright (c) 2000 - 2013 Intel Corporation
Copyright (c) 2000 - 2014 Intel Corporation
Ignoring all errors, forcing AML file generation