Update to revision 20160212 and refresh patches

Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
Al Stone 2016-02-22 17:42:58 -07:00
parent 3a372809aa
commit dab6ca1313
9 changed files with 49 additions and 43 deletions

2
.gitignore vendored
View File

@ -44,3 +44,5 @@
/acpitests-unix-20151218.tar.gz
/acpica-unix2-20160108.tar.gz
/acpitests-unix-20160108.tar.gz
/acpica-unix2-20160212.tar.gz
/acpitests-unix-20160212.tar.gz

View File

@ -1,5 +1,5 @@
Name: acpica-tools
Version: 20160108
Version: 20160212
Release: 1%{?dist}
Summary: ACPICA tools for the development and debug of ACPI tables
@ -186,6 +186,10 @@ fi
%changelog
* Mon Feb 22 2016 Al Stone <ahs3@redhat.com> - 20160212-1
- Update to latest upstream. Closes BZ#1307192.
- Refresh patches.
* Mon Jan 11 2016 Al Stone <ahs3@redhat.com> - 20160108-1
- Update to latest upstream. Closes BZ#1297078.
- Refresh patches.

View File

@ -22,7 +22,7 @@ diff --git a/source/compiler/aslcodegen.c b/source/compiler/aslcodegen.c
index cb3a4a5..f63a320 100644
--- a/source/compiler/aslcodegen.c
+++ b/source/compiler/aslcodegen.c
@@ -249,16 +249,12 @@ CgWriteAmlOpcode (
@@ -243,16 +243,12 @@ CgWriteAmlOpcode (
ACPI_PARSE_OBJECT *Op)
{
UINT8 PkgLenFirstByte;
@ -45,7 +45,7 @@ index cb3a4a5..f63a320 100644
/* We expect some DEFAULT_ARGs, just ignore them */
@@ -282,51 +278,52 @@ CgWriteAmlOpcode (
@@ -276,51 +272,52 @@ CgWriteAmlOpcode (
/* Special opcodes for within a field definition */
@ -109,7 +109,7 @@ index cb3a4a5..f63a320 100644
break;
}
@@ -337,8 +334,8 @@ CgWriteAmlOpcode (
@@ -331,8 +328,8 @@ CgWriteAmlOpcode (
if (Op->Asl.AmlPkgLenBytes == 1)
{
/* Simplest case -- no bytes to follow, just write the count */
@ -120,7 +120,7 @@ index cb3a4a5..f63a320 100644
}
else if (Op->Asl.AmlPkgLenBytes != 0)
{
@@ -348,7 +345,7 @@ CgWriteAmlOpcode (
@@ -342,7 +339,7 @@ CgWriteAmlOpcode (
*/
PkgLenFirstByte = (UINT8)
(((UINT32) (Op->Asl.AmlPkgLenBytes - 1) << 6) |
@ -129,7 +129,7 @@ index cb3a4a5..f63a320 100644
CgLocalWriteAmlData (Op, &PkgLenFirstByte, 1);
@@ -356,39 +353,47 @@ CgWriteAmlOpcode (
@@ -350,39 +347,47 @@ CgWriteAmlOpcode (
* Shift the length over by the 4 bits we just stuffed
* in the first byte
*/
@ -189,7 +189,7 @@ index cb3a4a5..f63a320 100644
break;
case AML_STRING_OP:
@@ -422,6 +427,7 @@ CgWriteTableHeader (
@@ -416,6 +421,7 @@ CgWriteTableHeader (
ACPI_PARSE_OBJECT *Op)
{
ACPI_PARSE_OBJECT *Child;
@ -197,7 +197,7 @@ index cb3a4a5..f63a320 100644
/* AML filename */
@@ -458,7 +464,7 @@ CgWriteTableHeader (
@@ -452,7 +458,7 @@ CgWriteTableHeader (
/* OEM Revision */
Child = Child->Asl.Next;
@ -206,7 +206,7 @@ index cb3a4a5..f63a320 100644
/* Compiler ID */
@@ -466,12 +472,13 @@ CgWriteTableHeader (
@@ -460,12 +466,13 @@ CgWriteTableHeader (
/* Compiler version */
@ -223,7 +223,7 @@ index cb3a4a5..f63a320 100644
TableHeader.Checksum = 0;
Op->Asl.FinalAmlOffset = ftell (Gbl_Files[ASL_FILE_AML_OUTPUT].Handle);
@@ -584,7 +591,10 @@ CgWriteNode (
@@ -578,7 +585,10 @@ CgWriteNode (
ACPI_PARSE_OBJECT *Op)
{
ASL_RESOURCE_NODE *Rnode;
@ -235,7 +235,7 @@ index cb3a4a5..f63a320 100644
/* Always check for DEFAULT_ARG and other "Noop" nodes */
/* TBD: this may not be the best place for this check */
@@ -602,13 +612,24 @@ CgWriteNode (
@@ -595,13 +605,24 @@ CgWriteNode (
switch (Op->Asl.AmlOpcode)
{
case AML_RAW_DATA_BYTE:
@ -1549,7 +1549,7 @@ index c7d5455..ec0cb88 100644
UINT32 CurrentByteOffset;
UINT32 PinCount = 0;
UINT32 i;
@@ -353,21 +356,21 @@ RsDoGpioIntDescriptor (
@@ -346,21 +349,21 @@ RsDoGpioIntDescriptor (
{
case 0: /* Interrupt Mode - edge/level [Flag] (_MOD) */
@ -1574,7 +1574,7 @@ index c7d5455..ec0cb88 100644
RsCreateMultiBitField (InitializerOp, ACPI_RESTAG_INTERRUPTSHARE,
CurrentByteOffset + ASL_RESDESC_OFFSET (Gpio.IntFlags), 3, 2);
break;
@@ -381,7 +384,7 @@ RsDoGpioIntDescriptor (
@@ -374,7 +377,7 @@ RsDoGpioIntDescriptor (
case 4: /* Debounce Timeout [WORD] (_DBT) */
@ -1583,7 +1583,7 @@ index c7d5455..ec0cb88 100644
RsCreateWordField (InitializerOp, ACPI_RESTAG_DEBOUNCETIME,
CurrentByteOffset + ASL_RESDESC_OFFSET (Gpio.DebounceTimeout));
break;
@@ -408,7 +411,7 @@ RsDoGpioIntDescriptor (
@@ -401,7 +404,7 @@ RsDoGpioIntDescriptor (
case 7: /* Resource Usage (consumer/producer) */
@ -1592,7 +1592,7 @@ index c7d5455..ec0cb88 100644
break;
case 8: /* Resource Tag (Descriptor Name) */
@@ -473,6 +476,10 @@ RsDoGpioIntDescriptor (
@@ -466,6 +469,10 @@ RsDoGpioIntDescriptor (
InitializerOp = RsCompleteNodeAndGetNext (InitializerOp);
}
@ -1603,7 +1603,7 @@ index c7d5455..ec0cb88 100644
MpSaveGpioInfo (Info->MappingOp, Descriptor,
PinCount, PinList, ResourceSource);
return (Rnode);
@@ -506,6 +513,10 @@ RsDoGpioIoDescriptor (
@@ -499,6 +506,10 @@ RsDoGpioIoDescriptor (
UINT16 VendorLength;
UINT16 InterruptLength;
UINT16 DescriptorSize;
@ -1614,7 +1614,7 @@ index c7d5455..ec0cb88 100644
UINT32 CurrentByteOffset;
UINT32 PinCount = 0;
UINT32 i;
@@ -569,7 +580,7 @@ RsDoGpioIoDescriptor (
@@ -555,7 +566,7 @@ RsDoGpioIoDescriptor (
{
case 0: /* Share Type [Flags] (_SHR) */
@ -1623,7 +1623,7 @@ index c7d5455..ec0cb88 100644
RsCreateBitField (InitializerOp, ACPI_RESTAG_INTERRUPTSHARE,
CurrentByteOffset + ASL_RESDESC_OFFSET (Gpio.IntFlags), 3);
break;
@@ -583,21 +594,21 @@ RsDoGpioIoDescriptor (
@@ -569,21 +580,21 @@ RsDoGpioIoDescriptor (
case 2: /* Debounce Timeout [WORD] (_DBT) */
@ -1648,7 +1648,7 @@ index c7d5455..ec0cb88 100644
RsCreateMultiBitField (InitializerOp, ACPI_RESTAG_IORESTRICTION,
CurrentByteOffset + ASL_RESDESC_OFFSET (Gpio.IntFlags), 0, 2);
break;
@@ -623,7 +634,7 @@ RsDoGpioIoDescriptor (
@@ -609,7 +620,7 @@ RsDoGpioIoDescriptor (
case 7: /* Resource Usage (consumer/producer) */
@ -1657,7 +1657,7 @@ index c7d5455..ec0cb88 100644
break;
case 8: /* Resource Tag (Descriptor Name) */
@@ -687,6 +698,11 @@ RsDoGpioIoDescriptor (
@@ -673,6 +684,11 @@ RsDoGpioIoDescriptor (
InitializerOp = RsCompleteNodeAndGetNext (InitializerOp);
}
@ -1669,7 +1669,7 @@ index c7d5455..ec0cb88 100644
MpSaveGpioInfo (Info->MappingOp, Descriptor,
PinCount, PinList, ResourceSource);
return (Rnode);
@@ -717,6 +733,9 @@ RsDoI2cSerialBusDescriptor (
@@ -703,6 +719,9 @@ RsDoI2cSerialBusDescriptor (
UINT16 ResSourceLength;
UINT16 VendorLength;
UINT16 DescriptorSize;
@ -1679,7 +1679,7 @@ index c7d5455..ec0cb88 100644
UINT32 CurrentByteOffset;
UINT32 i;
@@ -768,7 +787,7 @@ RsDoI2cSerialBusDescriptor (
@@ -747,7 +766,7 @@ RsDoI2cSerialBusDescriptor (
{
case 0: /* Slave Address [WORD] (_ADR) */
@ -1688,7 +1688,7 @@ index c7d5455..ec0cb88 100644
RsCreateWordField (InitializerOp, ACPI_RESTAG_ADDRESS,
CurrentByteOffset + ASL_RESDESC_OFFSET (I2cSerialBus.SlaveAddress));
break;
@@ -782,14 +801,14 @@ RsDoI2cSerialBusDescriptor (
@@ -761,14 +780,14 @@ RsDoI2cSerialBusDescriptor (
case 2: /* Connection Speed [DWORD] (_SPE) */
@ -1705,7 +1705,7 @@ index c7d5455..ec0cb88 100644
RsCreateBitField (InitializerOp, ACPI_RESTAG_MODE,
CurrentByteOffset + ASL_RESDESC_OFFSET (I2cSerialBus.TypeSpecificFlags), 0);
break;
@@ -838,6 +857,9 @@ RsDoI2cSerialBusDescriptor (
@@ -817,6 +836,9 @@ RsDoI2cSerialBusDescriptor (
InitializerOp = RsCompleteNodeAndGetNext (InitializerOp);
}
@ -1715,7 +1715,7 @@ index c7d5455..ec0cb88 100644
MpSaveSerialInfo (Info->MappingOp, Descriptor, ResourceSource);
return (Rnode);
}
@@ -867,6 +889,9 @@ RsDoSpiSerialBusDescriptor (
@@ -846,6 +868,9 @@ RsDoSpiSerialBusDescriptor (
UINT16 ResSourceLength;
UINT16 VendorLength;
UINT16 DescriptorSize;
@ -1725,7 +1725,7 @@ index c7d5455..ec0cb88 100644
UINT32 CurrentByteOffset;
UINT32 i;
@@ -919,21 +944,21 @@ RsDoSpiSerialBusDescriptor (
@@ -891,21 +916,21 @@ RsDoSpiSerialBusDescriptor (
{
case 0: /* Device Selection [WORD] (_ADR) */
@ -1750,7 +1750,7 @@ index c7d5455..ec0cb88 100644
RsCreateBitField (InitializerOp, ACPI_RESTAG_MODE,
CurrentByteOffset + ASL_RESDESC_OFFSET (SpiSerialBus.TypeSpecificFlags), 0);
break;
@@ -954,7 +979,7 @@ RsDoSpiSerialBusDescriptor (
@@ -926,7 +951,7 @@ RsDoSpiSerialBusDescriptor (
case 5: /* Connection Speed [DWORD] (_SPE) */
@ -1759,7 +1759,7 @@ index c7d5455..ec0cb88 100644
RsCreateDwordField (InitializerOp, ACPI_RESTAG_SPEED,
CurrentByteOffset + ASL_RESDESC_OFFSET (SpiSerialBus.ConnectionSpeed));
break;
@@ -1017,6 +1042,10 @@ RsDoSpiSerialBusDescriptor (
@@ -989,6 +1014,10 @@ RsDoSpiSerialBusDescriptor (
InitializerOp = RsCompleteNodeAndGetNext (InitializerOp);
}
@ -1770,7 +1770,7 @@ index c7d5455..ec0cb88 100644
MpSaveSerialInfo (Info->MappingOp, Descriptor, ResourceSource);
return (Rnode);
}
@@ -1046,6 +1075,10 @@ RsDoUartSerialBusDescriptor (
@@ -1018,6 +1047,10 @@ RsDoUartSerialBusDescriptor (
UINT16 ResSourceLength;
UINT16 VendorLength;
UINT16 DescriptorSize;
@ -1781,7 +1781,7 @@ index c7d5455..ec0cb88 100644
UINT32 CurrentByteOffset;
UINT32 i;
@@ -1097,21 +1130,21 @@ RsDoUartSerialBusDescriptor (
@@ -1062,21 +1095,21 @@ RsDoUartSerialBusDescriptor (
{
case 0: /* Connection Speed (Baud Rate) [DWORD] (_SPE) */
@ -1806,7 +1806,7 @@ index c7d5455..ec0cb88 100644
RsCreateMultiBitField (InitializerOp, ACPI_RESTAG_STOPBITS,
CurrentByteOffset + ASL_RESDESC_OFFSET (UartSerialBus.TypeSpecificFlags), 2, 2);
break;
@@ -1125,7 +1158,7 @@ RsDoUartSerialBusDescriptor (
@@ -1090,7 +1123,7 @@ RsDoUartSerialBusDescriptor (
case 4: /* Endianness [Flag] (_END) */
@ -1815,7 +1815,7 @@ index c7d5455..ec0cb88 100644
RsCreateBitField (InitializerOp, ACPI_RESTAG_ENDIANNESS,
CurrentByteOffset + ASL_RESDESC_OFFSET (UartSerialBus.TypeSpecificFlags), 7);
break;
@@ -1139,21 +1172,21 @@ RsDoUartSerialBusDescriptor (
@@ -1104,21 +1137,21 @@ RsDoUartSerialBusDescriptor (
case 6: /* Flow Control [Flags] (_FLC) */
@ -1840,7 +1840,7 @@ index c7d5455..ec0cb88 100644
RsCreateWordField (InitializerOp, ACPI_RESTAG_LENGTH_TX,
CurrentByteOffset + ASL_RESDESC_OFFSET (UartSerialBus.TxFifoSize));
break;
@@ -1212,6 +1245,11 @@ RsDoUartSerialBusDescriptor (
@@ -1177,6 +1210,11 @@ RsDoUartSerialBusDescriptor (
InitializerOp = RsCompleteNodeAndGetNext (InitializerOp);
}

View File

@ -122,7 +122,7 @@ diff --git a/source/include/actypes.h b/source/include/actypes.h
index 7eb6376..5cc118f 100644
--- a/source/include/actypes.h
+++ b/source/include/actypes.h
@@ -143,6 +143,19 @@ typedef COMPILER_DEPENDENT_INT64 INT64;
@@ -143,6 +143,19 @@ typedef COMPILER_DEPENDENT_INT64
*/
#define ACPI_THREAD_ID UINT64
@ -142,7 +142,7 @@ index 7eb6376..5cc118f 100644
/*******************************************************************************
*
@@ -169,19 +182,6 @@ typedef UINT64 ACPI_PHYSICAL_ADDRESS;
@@ -169,19 +182,6 @@ typedef UINT64
#define ACPI_SIZE_MAX ACPI_UINT64_MAX
#define ACPI_USE_NATIVE_DIVIDE /* Has native 64-bit integer support */

View File

@ -25,7 +25,7 @@ diff --git a/generate/unix/iasl/Makefile b/generate/unix/iasl/Makefile
index 8b71edd..b403037 100644
--- a/generate/unix/iasl/Makefile
+++ b/generate/unix/iasl/Makefile
@@ -309,20 +309,21 @@ $(OBJDIR)/prparserparse.c $(OBJDIR)/prparser.y.h : $(ASL_COMPILER)/prparse
@@ -312,20 +312,21 @@ $(OBJDIR)/prparserparse.c $(OBJDIR)/prparser.y.h : $(ASL_COMPILER)/prparse
# Cannot use the common compile warning flags since the C files are created
# by the utilities above and they are not necessarily ANSI C, etc.
#

View File

@ -28,7 +28,7 @@ diff --git a/source/compiler/aslcompile.c b/source/compiler/aslcompile.c
index a564f86..9dbabfb 100644
--- a/source/compiler/aslcompile.c
+++ b/source/compiler/aslcompile.c
@@ -702,7 +702,7 @@ CmCleanupAndExit (
@@ -726,7 +726,7 @@ CmCleanupAndExit (
if (Gbl_ExceptionCount[ASL_ERROR] > ASL_MAX_ERROR_COUNT)
{

View File

@ -14,7 +14,7 @@ diff --git a/source/compiler/aslanalyze.c b/source/compiler/aslanalyze.c
index fd71763..37bfc15 100644
--- a/source/compiler/aslanalyze.c
+++ b/source/compiler/aslanalyze.c
@@ -446,7 +446,7 @@ ApCheckForGpeNameConflict (
@@ -452,7 +452,7 @@ ApCheckForGpeNameConflict (
/* Need a null-terminated string version of NameSeg */
@ -23,7 +23,7 @@ index fd71763..37bfc15 100644
Name[ACPI_NAME_SIZE] = 0;
/*
@@ -473,7 +473,7 @@ ApCheckForGpeNameConflict (
@@ -479,7 +479,7 @@ ApCheckForGpeNameConflict (
* We are now sure we have an _Lxx or _Exx.
* Create the target name that would cause collision (Flip E/L)
*/

View File

@ -11,7 +11,7 @@ diff --git a/source/compiler/aslmain.c b/source/compiler/aslmain.c
index 795a047..63420db 100644
--- a/source/compiler/aslmain.c
+++ b/source/compiler/aslmain.c
@@ -341,18 +341,6 @@ main (
@@ -318,18 +318,6 @@ main (
int ReturnStatus = 0;
@ -20,7 +20,7 @@ index 795a047..63420db 100644
- * be little-endian, and support for big-endian machines needs to
- * be implemented.
- */
- if (AcpiIsBigEndianMachine ())
- if (UtIsBigEndianMachine ())
- {
- fprintf (stderr,
- "iASL is not currently supported on big-endian machines.\n");

View File

@ -1,2 +1,2 @@
59e3e9f58446cfbcf67860d09a5c5c95 acpica-unix2-20160108.tar.gz
faebe1e43f4c80563321b31bb2ac8ed5 acpitests-unix-20160108.tar.gz
454bbd2791a6e35868ddc7e12e16988d acpica-unix2-20160212.tar.gz
f5ded7684428e2c1cc9ce14c97354f9c acpitests-unix-20160212.tar.gz