Make all the supporting build files aware of the new version

Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
Al Stone 2014-01-07 14:35:10 -07:00
parent eec714ff91
commit d3f3d37742
4 changed files with 251 additions and 3 deletions

View File

@ -1,5 +1,5 @@
Name: acpica-tools
Version: 20131115
Version: 20131218
Release: 1%{?dist}
Summary: ACPICA tools for the development and debug of ACPI tables
@ -27,6 +27,7 @@ Patch0: debian-big_endian.patch
Patch1: debian-unaligned.patch
Patch2: name-miscompare.patch
Patch3: aapits-linux.patch
Patch4: examples-makefile.patch
BuildRequires: bison patchutils flex
@ -81,6 +82,7 @@ gzip -dc %{SOURCE1} | tar -x --strip-components=1 -f -
%patch1 -p1 -b .debian-unaligned
%patch2 -p1 -b .name-miscompare
%patch3 -p1 -b .aapits-linux
%patch4 -p1 -b .examples-makefile
cp -p %{SOURCE2} README.Fedora
cp -p %{SOURCE3} iasl.1
@ -185,6 +187,10 @@ fi
%changelog
* Tue Jan 7 2014 Al Stone <ahs3@redhat.com> - 20131218-1
- Update to latest upstream. Closes BZ#1044951.
- Add temporary patch to add Makefile missing from upstream tarball.
* Mon Nov 25 2013 Al Stone <ahs3@redhat.com> - 20131115-1
- Update to latest upstream. Closes BZ#1031255.
- Add a little code to workaround build problems that can occur (the tests

View File

@ -37,6 +37,9 @@ Error 6066 - ^ Method local variable is not initialize
badcode.asl 76: Subtract (MTX1, 4, Local3)
Error 6058 - Invalid type ^ ([Mutex|Reference] found, Subtract operator requires [Integer|String|Buffer])
badcode.asl 80: CreateField (BUF1, 0, Subtract (4, 4), FLD1)
Remark 2089 - Object is not referenced ^ (Name is within method [MTH1])
badcode.asl 80: CreateField (BUF1, 0, Subtract (4, 4), FLD1)
Error 6083 - Operand evaluates to zero ^
@ -190,24 +193,45 @@ Error 6071 - ^ Missing StartDependentFn() macro in
badcode.asl 388: CreateWordField (RSC3, \DWI1._LEN, LEN)
Warning 3128 - ResourceTag larger than Field ^ (Size mismatch, Tag: 32 bits, Field: 16 bits)
badcode.asl 388: CreateWordField (RSC3, \DWI1._LEN, LEN)
Remark 2089 - Object is not referenced ^ (Name is within method [REM1])
badcode.asl 389: CreateByteField (RSC3, \DWI1._MIN, MIN)
Warning 3128 - ResourceTag larger than Field ^ (Size mismatch, Tag: 32 bits, Field: 8 bits)
badcode.asl 389: CreateByteField (RSC3, \DWI1._MIN, MIN)
Remark 2089 - Object is not referenced ^ (Name is within method [REM1])
badcode.asl 390: CreateBitField (RSC3, \DWI1._RNG, RNG1)
Warning 3128 - ResourceTag larger than Field ^ (Size mismatch, Tag: 2 bits, Field: 1 bit)
badcode.asl 390: CreateBitField (RSC3, \DWI1._RNG, RNG1)
Remark 2089 - Object is not referenced ^ (Name is within method [REM1])
badcode.asl 394: CreateQWordField (RSC3, \DWI1._MAX, MAX)
Warning 3129 - ResourceTag smaller than Field ^ (Size mismatch, Tag: 32 bits, Field: 64 bits)
badcode.asl 394: CreateQWordField (RSC3, \DWI1._MAX, MAX)
Remark 2089 - Object is not referenced ^ (Name is within method [REM1])
badcode.asl 395: CreateBitField (RSC3, \DWI1._GRA, GRA)
Warning 3128 - ResourceTag larger than Field ^ (Size mismatch, Tag: 32 bits, Field: 1 bit)
badcode.asl 395: CreateBitField (RSC3, \DWI1._GRA, GRA)
Remark 2089 - Object is not referenced ^ (Name is within method [REM1])
badcode.asl 396: CreateField (RSC3, \DWI1._MIF, 5, MIF)
Warning 3129 - ResourceTag smaller than Field ^ (Size mismatch, Tag: 1 bit, Field: 5 bits)
badcode.asl 396: CreateField (RSC3, \DWI1._MIF, 5, MIF)
Remark 2089 - Object is not referenced ^ (Name is within method [REM1])
badcode.asl 397: CreateField (RSC3, \DWI1._RNG, 3, RNG2)
Warning 3129 - ResourceTag smaller than Field ^ (Size mismatch, Tag: 2 bits, Field: 3 bits)
badcode.asl 397: CreateField (RSC3, \DWI1._RNG, 3, RNG2)
Remark 2089 - Object is not referenced ^ (Name is within method [REM1])
Intel ACPI Component Architecture
ASL Optimizing Compiler version VVVVVVVV-YYYY [XXXXXXXXXXX]
@ -218,4 +242,4 @@ Ignoring all errors, forcing AML file generation
ASL Input: badcode.asl - 401 lines, 6935 bytes, 79 keywords
AML Output: badcode.aml - 1184 bytes, 60 named objects, 19 executable opcodes
Compilation complete. 46 Errors, 21 Warnings, 3 Remarks, 16 Optimizations
Compilation complete. 46 Errors, 21 Warnings, 11 Remarks, 16 Optimizations

152
examples-makefile.patch Normal file
View File

@ -0,0 +1,152 @@
diff -urN acpica-unix-20131218/generate/unix/acpiexamples/Makefile acpica-unix-20131218-patch/generate/unix/acpiexamples/Makefile
--- acpica-unix-20131218/generate/unix/acpiexamples/Makefile 1969-12-31 17:00:00.000000000 -0700
+++ acpica-unix-20131218-patch/generate/unix/acpiexamples/Makefile 2014-01-06 19:40:59.042080873 -0700
@@ -0,0 +1,148 @@
+#
+# acpiexamples - Example ACPICA initialization code and control
+# method execution.
+#
+
+#
+# Note: This makefile is intended to be used from within the native
+# ACPICA directory structure, from under generate/unix. It specifically
+# places all object files in a generate/unix subdirectory, not within
+# the various ACPICA source directories. This prevents collisions
+# between different compilations of the same source file with different
+# compile options, and prevents pollution of the source code.
+#
+include ../Makefile.config
+FINAL_PROG = ../$(BINDIR)/acpiexamples
+PROG = $(OBJDIR)/acpiexamples
+
+#
+# Search paths for source files
+#
+vpath %.c \
+ $(ACPIEXAMPLES)\
+ $(ACPICA_DEBUGGER)\
+ $(ACPICA_DISPATCHER)\
+ $(ACPICA_EXECUTER)\
+ $(ACPICA_NAMESPACE)\
+ $(ACPICA_PARSER)\
+ $(ACPICA_TABLES)\
+ $(ACPICA_UTILITIES)\
+ $(ACPICA_COMMON)\
+ $(ACPICA_OSL)
+
+HEADERS = \
+ $(wildcard $(ACPIEXAMPLES)/*.h)
+
+OBJECTS = \
+ $(OBJDIR)/examples.o\
+ $(OBJDIR)/exstubs.o\
+ $(OBJDIR)/extables.o\
+ $(OBJDIR)/dsargs.o\
+ $(OBJDIR)/dscontrol.o\
+ $(OBJDIR)/dsfield.o\
+ $(OBJDIR)/dsinit.o\
+ $(OBJDIR)/dsmethod.o\
+ $(OBJDIR)/dsmthdat.o\
+ $(OBJDIR)/dsobject.o\
+ $(OBJDIR)/dsopcode.o\
+ $(OBJDIR)/dsutils.o\
+ $(OBJDIR)/dswexec.o\
+ $(OBJDIR)/dswload.o\
+ $(OBJDIR)/dswload2.o\
+ $(OBJDIR)/dswscope.o\
+ $(OBJDIR)/dswstate.o\
+ $(OBJDIR)/exconfig.o\
+ $(OBJDIR)/exconvrt.o\
+ $(OBJDIR)/excreate.o\
+ $(OBJDIR)/exdebug.o\
+ $(OBJDIR)/exdump.o\
+ $(OBJDIR)/exfield.o\
+ $(OBJDIR)/exfldio.o\
+ $(OBJDIR)/exmisc.o\
+ $(OBJDIR)/exmutex.o\
+ $(OBJDIR)/exnames.o\
+ $(OBJDIR)/exoparg1.o\
+ $(OBJDIR)/exoparg2.o\
+ $(OBJDIR)/exoparg3.o\
+ $(OBJDIR)/exoparg6.o\
+ $(OBJDIR)/exprep.o\
+ $(OBJDIR)/exregion.o\
+ $(OBJDIR)/exresnte.o\
+ $(OBJDIR)/exresolv.o\
+ $(OBJDIR)/exresop.o\
+ $(OBJDIR)/exstore.o\
+ $(OBJDIR)/exstoren.o\
+ $(OBJDIR)/exstorob.o\
+ $(OBJDIR)/exsystem.o\
+ $(OBJDIR)/exutils.o\
+ $(OBJDIR)/nsaccess.o\
+ $(OBJDIR)/nsalloc.o\
+ $(OBJDIR)/nsconvert.o\
+ $(OBJDIR)/nsdump.o\
+ $(OBJDIR)/nseval.o\
+ $(OBJDIR)/nsinit.o\
+ $(OBJDIR)/nsload.o\
+ $(OBJDIR)/nsnames.o\
+ $(OBJDIR)/nsobject.o\
+ $(OBJDIR)/nsparse.o\
+ $(OBJDIR)/nssearch.o\
+ $(OBJDIR)/nsutils.o\
+ $(OBJDIR)/nswalk.o\
+ $(OBJDIR)/nsxfeval.o\
+ $(OBJDIR)/nsxfname.o\
+ $(OBJDIR)/nsxfobj.o\
+ $(OBJDIR)/osunixxf.o\
+ $(OBJDIR)/psargs.o\
+ $(OBJDIR)/psloop.o\
+ $(OBJDIR)/psobject.o\
+ $(OBJDIR)/psopcode.o\
+ $(OBJDIR)/psopinfo.o\
+ $(OBJDIR)/psparse.o\
+ $(OBJDIR)/psscope.o\
+ $(OBJDIR)/pstree.o\
+ $(OBJDIR)/psutils.o\
+ $(OBJDIR)/pswalk.o\
+ $(OBJDIR)/psxface.o\
+ $(OBJDIR)/tbfadt.o\
+ $(OBJDIR)/tbfind.o\
+ $(OBJDIR)/tbinstal.o\
+ $(OBJDIR)/tbprint.o\
+ $(OBJDIR)/tbutils.o\
+ $(OBJDIR)/tbxface.o\
+ $(OBJDIR)/tbxfload.o\
+ $(OBJDIR)/tbxfroot.o\
+ $(OBJDIR)/utaddress.o\
+ $(OBJDIR)/utalloc.o\
+ $(OBJDIR)/utbuffer.o\
+ $(OBJDIR)/utcache.o\
+ $(OBJDIR)/utcopy.o\
+ $(OBJDIR)/utdebug.o\
+ $(OBJDIR)/utdecode.o\
+ $(OBJDIR)/utdelete.o\
+ $(OBJDIR)/uterror.o\
+ $(OBJDIR)/utexcep.o\
+ $(OBJDIR)/utglobal.o\
+ $(OBJDIR)/utlock.o\
+ $(OBJDIR)/utmath.o\
+ $(OBJDIR)/utmisc.o\
+ $(OBJDIR)/utmutex.o\
+ $(OBJDIR)/utobject.o\
+ $(OBJDIR)/utosi.o\
+ $(OBJDIR)/utownerid.o\
+ $(OBJDIR)/utstate.o\
+ $(OBJDIR)/utstring.o\
+ $(OBJDIR)/utxface.o\
+ $(OBJDIR)/utxferror.o\
+ $(OBJDIR)/utxfinit.o
+
+#
+# Flags specific to acpinames utility
+#
+CFLAGS += \
+ -DACPI_EXAMPLE_APP\
+ -I$(EXAMPLES)
+
+#
+# Common Rules
+#
+include ../Makefile.rules

View File

@ -1,6 +1,24 @@
grammar.asl 199: Name (_NPK, Package ()
Warning 3133 - ^ Unknown reserved name (_NPK)
grammar.asl 389: Register (SystemIO, 0x08, 0x00, 0x00000000000000B2, , R000)
Remark 2089 - Object is not referenced ^ (Name is within method [_CRS])
grammar.asl 389: Register (SystemIO, 0x08, 0x00, 0x00000000000000B2, , R000)
Remark 2089 - Object is not referenced ^ (Name is within method [_CRS])
grammar.asl 389: Register (SystemIO, 0x08, 0x00, 0x00000000000000B2, , R000)
Remark 2089 - Object is not referenced ^ (Name is within method [_CRS])
grammar.asl 389: Register (SystemIO, 0x08, 0x00, 0x00000000000000B2, , R000)
Remark 2089 - Object is not referenced ^ (Name is within method [_CRS])
grammar.asl 399: CreateByteField (PRT0, R000._ASZ, RSIZ)
Remark 2089 - Object is not referenced ^ (Name is within method [_CRS])
grammar.asl 513: Name (_STR, Unicode ("test"))
Remark 2089 - ^ Object is not referenced (Name is within method [TCOP])
grammar.asl 522: NAME (ESC1, "abcdefg\x00hijklmn")
Warning 3055 - ^ Invalid Hex/Octal Escape - Non-ASCII or NULL
@ -10,12 +28,45 @@ Warning 3055 - ^ Invalid Hex/Octal Escape - Non-
grammar.asl 620: RCIV (Subtract (Arg0, 1))
Remark 2098 - ^ Recursive method call (RCIV)
grammar.asl 701: CreateField (\_SB_.SBUF, 148, 96, FLDV)
Remark 2089 - Object is not referenced ^ (Name is within method [_INI])
grammar.asl 715: MinFixed,
Remark 2089 - Object is not referenced ^ (Name is within method [_CRS])
grammar.asl 716: MaxFixed,
Remark 2089 - Object is not referenced ^ (Name is within method [_CRS])
grammar.asl 717: SubDecode,
Remark 2089 - Object is not referenced ^ (Name is within method [_CRS])
grammar.asl 718: 0x0000,
Remark 2089 - Object is not referenced ^ (Name is within method [_CRS])
grammar.asl 720: 0xfff2,
Remark 2089 - Object is not referenced ^ (Name is within method [_CRS])
grammar.asl 721: 0x0032,
Remark 2089 - Object is not referenced ^ (Name is within method [_CRS])
grammar.asl 722: 0x0002,,,
Remark 2089 - Object is not referenced ^ (Name is within method [_CRS])
grammar.asl 733: Method(_SRS)
Warning 3102 - ^ Reserved method has too few arguments (_SRS requires 1)
grammar.asl 949: Method (_ERR, 2)
Warning 3102 - ^ Reserved method has too few arguments (_ERR requires 3)
grammar.asl 1295: Name(BUFR, Buffer (Local0) {})
Remark 2089 - ^ Object is not referenced (Name is within method [OBJ1])
grammar.asl 1302: Alias (MTX1, MTX2)
Remark 2089 - Object is not referenced ^ (Name is within method [OBJ1])
grammar.asl 1324: CreateField (BUF2, 148, 96, FLD3)
Remark 2089 - Object is not referenced ^ (Name is within method [FLDS])
grammar.asl 1389: Store (0x1234567887654321, QWD2)
Warning 3038 - ^ 64-bit integer in 32-bit table, truncating (DSDT version < 2)
@ -25,6 +76,9 @@ Warning 3038 - ^ 64-bit inte
grammar.asl 1471: SizeOf (BUFO)
Error 6114 - ^ Result is not used, operator has no effect
grammar.asl 1491: Alias (MTX2, MTXA)
Remark 2089 - Object is not referenced ^ (Name is within method [OBJ2])
grammar.asl 1497: Acquire (MTX2, 1)
Warning 3130 - ^ Result is not used, possible operator timeout will be missed
@ -52,6 +106,18 @@ Error 6066 - ^ Method local variable is not init
grammar.asl 6900: Name (_HID, "*PNP0C0A")
Error 6061 - Invalid leading asterisk ^ (*PNP0C0A)
grammar.asl 7754: CreateDWordField (TMD0, 4, DMA0)
Remark 2089 - Object is not referenced ^ (Name is within method [TEST])
grammar.asl 7755: CreateDWordField (TMD0, 8, PIO1)
Remark 2089 - Object is not referenced ^ (Name is within method [TEST])
grammar.asl 7756: CreateDWordField (TMD0, 12, DMA1)
Remark 2089 - Object is not referenced ^ (Name is within method [TEST])
grammar.asl 7757: CreateDWordField (TMD0, 16, CHNF)
Remark 2089 - Object is not referenced ^ (Name is within method [TEST])
grammar.asl 8717: Name (PKG2, Package (4)
Remark 2063 - ^ Initializer list shorter than declared package length
@ -65,4 +131,4 @@ Ignoring all errors, forcing AML file generation
ASL Input: grammar.asl - 10281 lines, 228124 bytes, 4818 keywords
AML Output: grammar.aml - 43476 bytes, 670 named objects, 4148 executable opcodes
Compilation complete. 6 Errors, 10 Warnings, 3 Remarks, 1105 Optimizations
Compilation complete. 6 Errors, 10 Warnings, 25 Remarks, 1105 Optimizations