Add hardening flags for f23

Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
Al Stone 2015-04-06 17:17:50 -06:00
parent d6ed1f40e8
commit c248bcf7ad
2 changed files with 14 additions and 0 deletions

View File

@ -32,6 +32,7 @@ Patch5: aapits-makefile.patch
Patch6: re-enable-big-endian.patch
Patch7: OPT_LDFLAGS.patch
Patch8: int-format.patch
Patch9: f23-harden.patch
BuildRequires: bison patchutils flex
@ -91,6 +92,7 @@ gzip -dc %{SOURCE1} | tar -x --strip-components=1 -f -
%patch6 -p1 -b .re-enable-big-endian
%patch7 -p1 -b .OPT_LDFLAGS
%patch8 -p1 -b .int-format
%patch9 -p1 -b .f23-harden
cp -p %{SOURCE2} README.Fedora
cp -p %{SOURCE3} iasl.1

12
f23-harden.patch Normal file
View File

@ -0,0 +1,12 @@
diff -Naur acpica-unix2-20150204/generate/unix/Makefile.config acpica-unix2-20150204-new/generate/unix/Makefile.config
--- acpica-unix2-20150204/generate/unix/Makefile.config 2015-04-06 17:12:41.069521987 -0600
+++ acpica-unix2-20150204-new/generate/unix/Makefile.config 2015-04-06 17:14:43.218806842 -0600
@@ -159,6 +159,8 @@
OPT_CFLAGS += -D_FORTIFY_SOURCE=2
endif
+OPT_CFLAGS += -fPIC -pie
+
CFLAGS += \
-D$(HOST)\
-D_GNU_SOURCE\