Refresh patches.
Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
parent
295099378e
commit
ba7935a924
@ -1,5 +1,5 @@
|
||||
Name: acpica-tools
|
||||
Version: 20150410
|
||||
Version: 20150515
|
||||
Release: 1%{?dist}
|
||||
Summary: ACPICA tools for the development and debug of ACPI tables
|
||||
|
||||
@ -195,6 +195,10 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu May 28 2015 Al Stone <ahs3@redhat.com> - 20150515-1
|
||||
- Update to latest upstream. Closes BZ#122166
|
||||
- Refresh patches
|
||||
|
||||
* Mon Apr 13 2015 Al Stone <ahs3@redhat.com> - 20150410-1
|
||||
- Update to latest upstream. Closes BZ#1190383
|
||||
- Refresh patches
|
||||
|
@ -2,7 +2,7 @@ Index: src/generate/unix/Makefile.config
|
||||
===================================================================
|
||||
--- src.orig/generate/unix/Makefile.config
|
||||
+++ src/generate/unix/Makefile.config
|
||||
@@ -163,6 +163,8 @@ ifneq ($(NOFORTIFY),TRUE)
|
||||
@@ -167,6 +167,8 @@ ifneq ($(NOFORTIFY),TRUE)
|
||||
OPT_CFLAGS += -D_FORTIFY_SOURCE=2
|
||||
endif
|
||||
|
||||
@ -15,7 +15,7 @@ Index: src/generate/unix/iasl/Makefile
|
||||
===================================================================
|
||||
--- src.orig/generate/unix/iasl/Makefile
|
||||
+++ src/generate/unix/iasl/Makefile
|
||||
@@ -301,20 +301,21 @@ $(OBJDIR)/prparserparse.c : $(ASL_COM
|
||||
@@ -302,20 +302,21 @@ $(OBJDIR)/prparserparse.c : $(ASL_COM
|
||||
# Cannot use the common compile warning flags since the C files are created
|
||||
# by the utilities above and they are not necessarily ANSI C, etc.
|
||||
#
|
||||
|
@ -111,7 +111,7 @@ Index: src/source/compiler/aslprepkg.c
|
||||
===================================================================
|
||||
--- src.orig/source/compiler/aslprepkg.c
|
||||
+++ src/source/compiler/aslprepkg.c
|
||||
@@ -297,7 +297,7 @@ ApCheckPackage (
|
||||
@@ -298,7 +298,7 @@ ApCheckPackage (
|
||||
|
||||
if (Count & 1)
|
||||
{
|
||||
@ -120,37 +120,6 @@ Index: src/source/compiler/aslprepkg.c
|
||||
Predefined->Info.Name, Count);
|
||||
|
||||
AslError (ASL_ERROR, ASL_MSG_RESERVED_PACKAGE_LENGTH,
|
||||
Index: src/source/compiler/aslutils.c
|
||||
===================================================================
|
||||
--- src.orig/source/compiler/aslutils.c
|
||||
+++ src/source/compiler/aslutils.c
|
||||
@@ -77,7 +77,7 @@ UtAttachNameseg (
|
||||
*
|
||||
******************************************************************************/
|
||||
|
||||
-#define ACPI_TABLE_HELP_FORMAT "%8u) %s %s\n"
|
||||
+#define ACPI_TABLE_HELP_FORMAT "%8d) %s %s\n"
|
||||
|
||||
void
|
||||
UtDisplaySupportedTables (
|
||||
@@ -89,7 +89,7 @@ UtDisplaySupportedTables (
|
||||
|
||||
printf ("\nACPI tables supported by iASL version %8.8X:\n"
|
||||
" (Compiler, Disassembler, Template Generator)\n\n",
|
||||
- ACPI_CA_VERSION);
|
||||
+ (UINT32) ACPI_CA_VERSION);
|
||||
|
||||
/* Special tables */
|
||||
|
||||
@@ -104,7 +104,7 @@ UtDisplaySupportedTables (
|
||||
printf ("\n Standard ACPI data tables:\n");
|
||||
for (TableData = AcpiDmTableData, i = 5; TableData->Signature; TableData++, i++)
|
||||
{
|
||||
- printf (ACPI_TABLE_HELP_FORMAT, i, TableData->Signature, TableData->Name);
|
||||
+ printf (ACPI_TABLE_HELP_FORMAT, (int) i, TableData->Signature, TableData->Name);
|
||||
}
|
||||
}
|
||||
|
||||
Index: src/source/components/dispatcher/dsutils.c
|
||||
===================================================================
|
||||
--- src.orig/source/components/dispatcher/dsutils.c
|
||||
|
Loading…
Reference in New Issue
Block a user