Refresh patches for 20160422 version

Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
Al Stone 2016-04-26 09:50:05 -06:00
parent 2440d47407
commit b8ecc85b48
10 changed files with 149 additions and 148 deletions

View File

@ -1,7 +1,7 @@
Index: acpica-unix2-20160318/generate/unix/Makefile.config
Index: acpica-unix2-20160422/generate/unix/Makefile.config
===================================================================
--- acpica-unix2-20160318.orig/generate/unix/Makefile.config
+++ acpica-unix2-20160318/generate/unix/Makefile.config
--- acpica-unix2-20160422.orig/generate/unix/Makefile.config
+++ acpica-unix2-20160422/generate/unix/Makefile.config
@@ -23,6 +23,9 @@
# OPT_CFLAGS can be overridden on the make command line by
# adding OPT_CFLAGS="..." to the invocation.

View File

@ -7,26 +7,27 @@ From: Al Stone <ahs3@redhat.com>
source/compiler/asllookup.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
Index: acpica-unix2-20160318/source/compiler/asllookup.c
Index: acpica-unix2-20160422/source/compiler/asllookup.c
===================================================================
--- acpica-unix2-20160318.orig/source/compiler/asllookup.c
+++ acpica-unix2-20160318/source/compiler/asllookup.c
--- acpica-unix2-20160422.orig/source/compiler/asllookup.c
+++ acpica-unix2-20160422/source/compiler/asllookup.c
@@ -119,6 +119,7 @@ LkIsObjectUsed (
{
ACPI_NAMESPACE_NODE *Node = ACPI_CAST_PTR (ACPI_NAMESPACE_NODE, ObjHandle);
ACPI_NAMESPACE_NODE *Next;
+ ACPI_NAME_UNION tmp;
+ ACPI_NAME_UNION tmp, tmp2;
ASL_METHOD_LOCAL *MethodLocals;
ASL_METHOD_LOCAL *MethodArgs;
UINT32 i;
@@ -227,8 +228,9 @@ LkIsObjectUsed (
@@ -228,8 +229,10 @@ LkIsObjectUsed (
* Issue a remark even if it is a reserved name (starts
* with an underscore).
*/
+ ACPI_MOVE_32_TO_32(&tmp.Ascii, Next->Name.Ascii);
sprintf (MsgBuffer, "Name is within method [%4.4s]",
- Next->Name.Ascii);
+ tmp.Ascii);
+ ACPI_MOVE_32_TO_32(&tmp.Ascii, Node->Name.Ascii);
+ ACPI_MOVE_32_TO_32(&tmp2.Ascii, Next->Name.Ascii);
sprintf (MsgBuffer, "Name [%4.4s] is within a method [%4.4s]",
- Node->Name.Ascii, Next->Name.Ascii);
+ tmp.Ascii, tmp2.Ascii);
AslError (ASL_REMARK, ASL_MSG_NOT_REFERENCED,
LkGetNameOp (Node->Op), MsgBuffer);
return (AE_OK);

View File

@ -7,10 +7,10 @@ From: Al Stone <ahs3@redhat.com>
source/compiler/asllookup.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
Index: acpica-unix2-20160318/source/compiler/asllookup.c
Index: acpica-unix2-20160422/source/compiler/asllookup.c
===================================================================
--- acpica-unix2-20160318.orig/source/compiler/asllookup.c
+++ acpica-unix2-20160318/source/compiler/asllookup.c
--- acpica-unix2-20160422.orig/source/compiler/asllookup.c
+++ acpica-unix2-20160422/source/compiler/asllookup.c
@@ -176,7 +176,8 @@ LkIsObjectUsed (
* We ignore the predefined methods since often, not
* all arguments are needed or used.

View File

@ -18,10 +18,10 @@ support
source/include/platform/aclinux.h | 8 ++
12 files changed, 487 insertions(+), 283 deletions(-)
Index: acpica-unix2-20160318/source/compiler/aslcodegen.c
Index: acpica-unix2-20160422/source/compiler/aslcodegen.c
===================================================================
--- acpica-unix2-20160318.orig/source/compiler/aslcodegen.c
+++ acpica-unix2-20160318/source/compiler/aslcodegen.c
--- acpica-unix2-20160422.orig/source/compiler/aslcodegen.c
+++ acpica-unix2-20160422/source/compiler/aslcodegen.c
@@ -243,16 +243,12 @@ CgWriteAmlOpcode (
ACPI_PARSE_OBJECT *Op)
{
@ -263,10 +263,10 @@ Index: acpica-unix2-20160318/source/compiler/aslcodegen.c
case AML_RAW_DATA_BUFFER:
Index: acpica-unix2-20160318/source/compiler/aslopcodes.c
Index: acpica-unix2-20160422/source/compiler/aslopcodes.c
===================================================================
--- acpica-unix2-20160318.orig/source/compiler/aslopcodes.c
+++ acpica-unix2-20160318/source/compiler/aslopcodes.c
--- acpica-unix2-20160422.orig/source/compiler/aslopcodes.c
+++ acpica-unix2-20160422/source/compiler/aslopcodes.c
@@ -481,6 +481,7 @@ OpcDoUnicode (
UINT32 i;
UINT8 *AsciiString;
@ -285,10 +285,10 @@ Index: acpica-unix2-20160318/source/compiler/aslopcodes.c
}
/*
Index: acpica-unix2-20160318/source/compiler/aslrestype1.c
Index: acpica-unix2-20160422/source/compiler/aslrestype1.c
===================================================================
--- acpica-unix2-20160318.orig/source/compiler/aslrestype1.c
+++ acpica-unix2-20160318/source/compiler/aslrestype1.c
--- acpica-unix2-20160422.orig/source/compiler/aslrestype1.c
+++ acpica-unix2-20160422/source/compiler/aslrestype1.c
@@ -142,6 +142,11 @@ RsDoMemory24Descriptor (
ACPI_PARSE_OBJECT *LengthOp = NULL;
ASL_RESOURCE_NODE *Rnode;
@ -485,10 +485,10 @@ Index: acpica-unix2-20160318/source/compiler/aslrestype1.c
RsCreateDwordField (InitializerOp, ACPI_RESTAG_LENGTH,
CurrentByteOffset + ASL_RESDESC_OFFSET (FixedMemory32.AddressLength));
break;
Index: acpica-unix2-20160318/source/compiler/aslrestype1i.c
Index: acpica-unix2-20160422/source/compiler/aslrestype1i.c
===================================================================
--- acpica-unix2-20160318.orig/source/compiler/aslrestype1i.c
+++ acpica-unix2-20160318/source/compiler/aslrestype1i.c
--- acpica-unix2-20160422.orig/source/compiler/aslrestype1i.c
+++ acpica-unix2-20160422/source/compiler/aslrestype1i.c
@@ -198,6 +198,8 @@ RsDoFixedDmaDescriptor (
ACPI_PARSE_OBJECT *InitializerOp;
ASL_RESOURCE_NODE *Rnode;
@ -625,10 +625,10 @@ Index: acpica-unix2-20160318/source/compiler/aslrestype1i.c
+ ACPI_MOVE_16_TO_16(&Descriptor->Irq.IrqMask, &IrqMask);
return (Rnode);
}
Index: acpica-unix2-20160318/source/compiler/aslrestype2.c
Index: acpica-unix2-20160422/source/compiler/aslrestype2.c
===================================================================
--- acpica-unix2-20160318.orig/source/compiler/aslrestype2.c
+++ acpica-unix2-20160318/source/compiler/aslrestype2.c
--- acpica-unix2-20160422.orig/source/compiler/aslrestype2.c
+++ acpica-unix2-20160422/source/compiler/aslrestype2.c
@@ -76,6 +76,7 @@ RsDoGeneralRegisterDescriptor (
ACPI_PARSE_OBJECT *InitializerOp;
ASL_RESOURCE_NODE *Rnode;
@ -725,10 +725,10 @@ Index: acpica-unix2-20160318/source/compiler/aslrestype2.c
/* Point to end-of-descriptor for vendor data */
Index: acpica-unix2-20160318/source/compiler/aslrestype2d.c
Index: acpica-unix2-20160422/source/compiler/aslrestype2d.c
===================================================================
--- acpica-unix2-20160318.orig/source/compiler/aslrestype2d.c
+++ acpica-unix2-20160318/source/compiler/aslrestype2d.c
--- acpica-unix2-20160422.orig/source/compiler/aslrestype2d.c
+++ acpica-unix2-20160422/source/compiler/aslrestype2d.c
@@ -79,7 +79,13 @@ RsDoDwordIoDescriptor (
ACPI_PARSE_OBJECT *GranOp = NULL;
ASL_RESOURCE_NODE *Rnode;
@ -1084,10 +1084,10 @@ Index: acpica-unix2-20160318/source/compiler/aslrestype2d.c
Rnode->BufferLength = sizeof (AML_RESOURCE_ADDRESS32) +
OptionIndex + StringLength;
return (Rnode);
Index: acpica-unix2-20160318/source/compiler/aslrestype2e.c
Index: acpica-unix2-20160422/source/compiler/aslrestype2e.c
===================================================================
--- acpica-unix2-20160318.orig/source/compiler/aslrestype2e.c
+++ acpica-unix2-20160318/source/compiler/aslrestype2e.c
--- acpica-unix2-20160422.orig/source/compiler/aslrestype2e.c
+++ acpica-unix2-20160422/source/compiler/aslrestype2e.c
@@ -78,6 +78,13 @@ RsDoExtendedIoDescriptor (
ACPI_PARSE_OBJECT *GranOp = NULL;
ASL_RESOURCE_NODE *Rnode;
@ -1193,10 +1193,10 @@ Index: acpica-unix2-20160318/source/compiler/aslrestype2e.c
Rnode->BufferLength = sizeof (AML_RESOURCE_EXTENDED_ADDRESS64) +
StringLength;
return (Rnode);
Index: acpica-unix2-20160318/source/compiler/aslrestype2q.c
Index: acpica-unix2-20160422/source/compiler/aslrestype2q.c
===================================================================
--- acpica-unix2-20160318.orig/source/compiler/aslrestype2q.c
+++ acpica-unix2-20160318/source/compiler/aslrestype2q.c
--- acpica-unix2-20160422.orig/source/compiler/aslrestype2q.c
+++ acpica-unix2-20160422/source/compiler/aslrestype2q.c
@@ -80,7 +80,13 @@ RsDoQwordIoDescriptor (
ASL_RESOURCE_NODE *Rnode;
UINT8 *OptionalFields;
@ -1535,10 +1535,10 @@ Index: acpica-unix2-20160318/source/compiler/aslrestype2q.c
Rnode->BufferLength = sizeof (AML_RESOURCE_ADDRESS64) +
OptionIndex + StringLength;
return (Rnode);
Index: acpica-unix2-20160318/source/compiler/aslrestype2s.c
Index: acpica-unix2-20160422/source/compiler/aslrestype2s.c
===================================================================
--- acpica-unix2-20160318.orig/source/compiler/aslrestype2s.c
+++ acpica-unix2-20160318/source/compiler/aslrestype2s.c
--- acpica-unix2-20160422.orig/source/compiler/aslrestype2s.c
+++ acpica-unix2-20160422/source/compiler/aslrestype2s.c
@@ -290,6 +290,9 @@ RsDoGpioIntDescriptor (
UINT16 VendorLength;
UINT16 InterruptLength;
@ -1679,7 +1679,7 @@ Index: acpica-unix2-20160318/source/compiler/aslrestype2s.c
UINT32 CurrentByteOffset;
UINT32 i;
@@ -747,7 +766,7 @@ RsDoI2cSerialBusDescriptor (
@@ -752,7 +771,7 @@ RsDoI2cSerialBusDescriptor (
{
case 0: /* Slave Address [WORD] (_ADR) */
@ -1688,7 +1688,7 @@ Index: acpica-unix2-20160318/source/compiler/aslrestype2s.c
RsCreateWordField (InitializerOp, ACPI_RESTAG_ADDRESS,
CurrentByteOffset + ASL_RESDESC_OFFSET (I2cSerialBus.SlaveAddress));
break;
@@ -761,14 +780,14 @@ RsDoI2cSerialBusDescriptor (
@@ -766,14 +785,14 @@ RsDoI2cSerialBusDescriptor (
case 2: /* Connection Speed [DWORD] (_SPE) */
@ -1705,7 +1705,7 @@ Index: acpica-unix2-20160318/source/compiler/aslrestype2s.c
RsCreateBitField (InitializerOp, ACPI_RESTAG_MODE,
CurrentByteOffset + ASL_RESDESC_OFFSET (I2cSerialBus.TypeSpecificFlags), 0);
break;
@@ -817,6 +836,9 @@ RsDoI2cSerialBusDescriptor (
@@ -833,6 +852,9 @@ RsDoI2cSerialBusDescriptor (
InitializerOp = RsCompleteNodeAndGetNext (InitializerOp);
}
@ -1715,7 +1715,7 @@ Index: acpica-unix2-20160318/source/compiler/aslrestype2s.c
MpSaveSerialInfo (Info->MappingOp, Descriptor, ResourceSource);
return (Rnode);
}
@@ -846,6 +868,9 @@ RsDoSpiSerialBusDescriptor (
@@ -862,6 +884,9 @@ RsDoSpiSerialBusDescriptor (
UINT16 ResSourceLength;
UINT16 VendorLength;
UINT16 DescriptorSize;
@ -1725,7 +1725,7 @@ Index: acpica-unix2-20160318/source/compiler/aslrestype2s.c
UINT32 CurrentByteOffset;
UINT32 i;
@@ -891,21 +916,21 @@ RsDoSpiSerialBusDescriptor (
@@ -912,21 +937,21 @@ RsDoSpiSerialBusDescriptor (
{
case 0: /* Device Selection [WORD] (_ADR) */
@ -1750,7 +1750,7 @@ Index: acpica-unix2-20160318/source/compiler/aslrestype2s.c
RsCreateBitField (InitializerOp, ACPI_RESTAG_MODE,
CurrentByteOffset + ASL_RESDESC_OFFSET (SpiSerialBus.TypeSpecificFlags), 0);
break;
@@ -926,7 +951,7 @@ RsDoSpiSerialBusDescriptor (
@@ -947,7 +972,7 @@ RsDoSpiSerialBusDescriptor (
case 5: /* Connection Speed [DWORD] (_SPE) */
@ -1759,7 +1759,7 @@ Index: acpica-unix2-20160318/source/compiler/aslrestype2s.c
RsCreateDwordField (InitializerOp, ACPI_RESTAG_SPEED,
CurrentByteOffset + ASL_RESDESC_OFFSET (SpiSerialBus.ConnectionSpeed));
break;
@@ -989,6 +1014,10 @@ RsDoSpiSerialBusDescriptor (
@@ -1021,6 +1046,10 @@ RsDoSpiSerialBusDescriptor (
InitializerOp = RsCompleteNodeAndGetNext (InitializerOp);
}
@ -1770,7 +1770,7 @@ Index: acpica-unix2-20160318/source/compiler/aslrestype2s.c
MpSaveSerialInfo (Info->MappingOp, Descriptor, ResourceSource);
return (Rnode);
}
@@ -1018,6 +1047,10 @@ RsDoUartSerialBusDescriptor (
@@ -1050,6 +1079,10 @@ RsDoUartSerialBusDescriptor (
UINT16 ResSourceLength;
UINT16 VendorLength;
UINT16 DescriptorSize;
@ -1781,7 +1781,7 @@ Index: acpica-unix2-20160318/source/compiler/aslrestype2s.c
UINT32 CurrentByteOffset;
UINT32 i;
@@ -1062,21 +1095,21 @@ RsDoUartSerialBusDescriptor (
@@ -1099,21 +1132,21 @@ RsDoUartSerialBusDescriptor (
{
case 0: /* Connection Speed (Baud Rate) [DWORD] (_SPE) */
@ -1806,7 +1806,7 @@ Index: acpica-unix2-20160318/source/compiler/aslrestype2s.c
RsCreateMultiBitField (InitializerOp, ACPI_RESTAG_STOPBITS,
CurrentByteOffset + ASL_RESDESC_OFFSET (UartSerialBus.TypeSpecificFlags), 2, 2);
break;
@@ -1090,7 +1123,7 @@ RsDoUartSerialBusDescriptor (
@@ -1127,7 +1160,7 @@ RsDoUartSerialBusDescriptor (
case 4: /* Endianness [Flag] (_END) */
@ -1815,7 +1815,7 @@ Index: acpica-unix2-20160318/source/compiler/aslrestype2s.c
RsCreateBitField (InitializerOp, ACPI_RESTAG_ENDIANNESS,
CurrentByteOffset + ASL_RESDESC_OFFSET (UartSerialBus.TypeSpecificFlags), 7);
break;
@@ -1104,21 +1137,21 @@ RsDoUartSerialBusDescriptor (
@@ -1141,21 +1174,21 @@ RsDoUartSerialBusDescriptor (
case 6: /* Flow Control [Flags] (_FLC) */
@ -1840,7 +1840,7 @@ Index: acpica-unix2-20160318/source/compiler/aslrestype2s.c
RsCreateWordField (InitializerOp, ACPI_RESTAG_LENGTH_TX,
CurrentByteOffset + ASL_RESDESC_OFFSET (UartSerialBus.TxFifoSize));
break;
@@ -1177,6 +1210,11 @@ RsDoUartSerialBusDescriptor (
@@ -1225,6 +1258,11 @@ RsDoUartSerialBusDescriptor (
InitializerOp = RsCompleteNodeAndGetNext (InitializerOp);
}
@ -1852,10 +1852,10 @@ Index: acpica-unix2-20160318/source/compiler/aslrestype2s.c
MpSaveSerialInfo (Info->MappingOp, Descriptor, ResourceSource);
return (Rnode);
}
Index: acpica-unix2-20160318/source/compiler/aslrestype2w.c
Index: acpica-unix2-20160422/source/compiler/aslrestype2w.c
===================================================================
--- acpica-unix2-20160318.orig/source/compiler/aslrestype2w.c
+++ acpica-unix2-20160318/source/compiler/aslrestype2w.c
--- acpica-unix2-20160422.orig/source/compiler/aslrestype2w.c
+++ acpica-unix2-20160422/source/compiler/aslrestype2w.c
@@ -81,6 +81,12 @@ RsDoWordIoDescriptor (
UINT8 *OptionalFields;
UINT16 StringLength = 0;
@ -2199,10 +2199,10 @@ Index: acpica-unix2-20160318/source/compiler/aslrestype2w.c
Rnode->BufferLength = sizeof (AML_RESOURCE_ADDRESS16) +
OptionIndex + StringLength;
return (Rnode);
Index: acpica-unix2-20160318/source/include/acmacros.h
Index: acpica-unix2-20160422/source/include/acmacros.h
===================================================================
--- acpica-unix2-20160318.orig/source/include/acmacros.h
+++ acpica-unix2-20160318/source/include/acmacros.h
--- acpica-unix2-20160422.orig/source/include/acmacros.h
+++ acpica-unix2-20160422/source/include/acmacros.h
@@ -100,7 +100,8 @@
/* 32-bit source, 16/32/64 destination */
@ -2240,10 +2240,10 @@ Index: acpica-unix2-20160318/source/include/acmacros.h
#define ACPI_MOVE_32_TO_32(d, s) *(UINT32 *)(void *)(d) = *(UINT32 *)(void *)(s)
#define ACPI_MOVE_32_TO_64(d, s) *(UINT64 *)(void *)(d) = *(UINT32 *)(void *)(s)
Index: acpica-unix2-20160318/source/include/platform/aclinux.h
Index: acpica-unix2-20160422/source/include/platform/aclinux.h
===================================================================
--- acpica-unix2-20160318.orig/source/include/platform/aclinux.h
+++ acpica-unix2-20160318/source/include/platform/aclinux.h
--- acpica-unix2-20160422.orig/source/include/platform/aclinux.h
+++ acpica-unix2-20160422/source/include/platform/aclinux.h
@@ -170,6 +170,7 @@
#include <stdlib.h>
#include <ctype.h>

View File

@ -18,11 +18,11 @@ Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
source/include/actypes.h | 26 +++++++++++++-------------
3 files changed, 32 insertions(+), 21 deletions(-)
Index: acpica-unix2-20160318/source/compiler/asltree.c
Index: acpica-unix2-20160422/source/compiler/asltree.c
===================================================================
--- acpica-unix2-20160318.orig/source/compiler/asltree.c
+++ acpica-unix2-20160318/source/compiler/asltree.c
@@ -890,28 +890,31 @@ TrCreateValuedLeafNode (
--- acpica-unix2-20160422.orig/source/compiler/asltree.c
+++ acpica-unix2-20160422/source/compiler/asltree.c
@@ -913,28 +913,31 @@ TrCreateValuedLeafNode (
"Op %s Value %8.8X%8.8X ",
Op->Asl.LineNumber, Op->Asl.Column, Op, UtGetOpName(ParseOpcode),
ACPI_FORMAT_UINT64 (Value));
@ -59,7 +59,7 @@ Index: acpica-unix2-20160318/source/compiler/asltree.c
break;
case PARSEOP_METHOD:
@@ -921,12 +924,14 @@ TrCreateValuedLeafNode (
@@ -944,12 +947,14 @@ TrCreateValuedLeafNode (
case PARSEOP_INTEGER:
@ -74,10 +74,10 @@ Index: acpica-unix2-20160318/source/compiler/asltree.c
break;
}
Index: acpica-unix2-20160318/source/components/executer/exoparg2.c
Index: acpica-unix2-20160422/source/components/executer/exoparg2.c
===================================================================
--- acpica-unix2-20160318.orig/source/components/executer/exoparg2.c
+++ acpica-unix2-20160318/source/components/executer/exoparg2.c
--- acpica-unix2-20160422.orig/source/components/executer/exoparg2.c
+++ acpica-unix2-20160422/source/components/executer/exoparg2.c
@@ -172,6 +172,8 @@ AcpiExOpcode_2A_2T_1R (
ACPI_OPERAND_OBJECT **Operand = &WalkState->Operands[0];
ACPI_OPERAND_OBJECT *ReturnDesc1 = NULL;
@ -118,10 +118,10 @@ Index: acpica-unix2-20160318/source/components/executer/exoparg2.c
break;
case AML_CONCAT_OP: /* Concatenate (Data1, Data2, Result) */
Index: acpica-unix2-20160318/source/include/actypes.h
Index: acpica-unix2-20160422/source/include/actypes.h
===================================================================
--- acpica-unix2-20160318.orig/source/include/actypes.h
+++ acpica-unix2-20160318/source/include/actypes.h
--- acpica-unix2-20160422.orig/source/include/actypes.h
+++ acpica-unix2-20160422/source/include/actypes.h
@@ -143,6 +143,19 @@ typedef COMPILER_DEPENDENT_INT64
*/
#define ACPI_THREAD_ID UINT64

View File

@ -8,10 +8,10 @@ From: Al Stone <ahs3@redhat.com>
generate/unix/iasl/Makefile | 13 +++++++------
2 files changed, 9 insertions(+), 6 deletions(-)
Index: acpica-unix2-20160318/generate/unix/Makefile.config
Index: acpica-unix2-20160422/generate/unix/Makefile.config
===================================================================
--- acpica-unix2-20160318.orig/generate/unix/Makefile.config
+++ acpica-unix2-20160318/generate/unix/Makefile.config
--- acpica-unix2-20160422.orig/generate/unix/Makefile.config
+++ acpica-unix2-20160422/generate/unix/Makefile.config
@@ -171,6 +171,8 @@ ifneq ($(NOFORTIFY),TRUE)
OPT_CFLAGS += -D_FORTIFY_SOURCE=2
endif
@ -21,11 +21,11 @@ Index: acpica-unix2-20160318/generate/unix/Makefile.config
CFLAGS += \
-D$(HOST)\
-D_GNU_SOURCE\
Index: acpica-unix2-20160318/generate/unix/iasl/Makefile
Index: acpica-unix2-20160422/generate/unix/iasl/Makefile
===================================================================
--- acpica-unix2-20160318.orig/generate/unix/iasl/Makefile
+++ acpica-unix2-20160318/generate/unix/iasl/Makefile
@@ -314,20 +314,21 @@ $(OBJDIR)/prparserparse.c $(OBJDIR)/prpa
--- acpica-unix2-20160422.orig/generate/unix/iasl/Makefile
+++ acpica-unix2-20160422/generate/unix/iasl/Makefile
@@ -317,20 +317,21 @@ $(OBJDIR)/prparserparse.c $(OBJDIR)/prpa
# Cannot use the common compile warning flags since the C files are created
# by the utilities above and they are not necessarily ANSI C, etc.
#

View File

@ -24,10 +24,10 @@ From: Al Stone <ahs3@redhat.com>
source/tools/acpiexec/aemain.c | 2 +-
18 files changed, 28 insertions(+), 28 deletions(-)
Index: acpica-unix2-20160318/source/compiler/aslcompile.c
Index: acpica-unix2-20160422/source/compiler/aslcompile.c
===================================================================
--- acpica-unix2-20160318.orig/source/compiler/aslcompile.c
+++ acpica-unix2-20160318/source/compiler/aslcompile.c
--- acpica-unix2-20160422.orig/source/compiler/aslcompile.c
+++ acpica-unix2-20160422/source/compiler/aslcompile.c
@@ -729,7 +729,7 @@ CmCleanupAndExit (
if (Gbl_ExceptionCount[ASL_ERROR] > ASL_MAX_ERROR_COUNT)
@ -37,10 +37,10 @@ Index: acpica-unix2-20160318/source/compiler/aslcompile.c
ASL_MAX_ERROR_COUNT);
}
Index: acpica-unix2-20160318/source/compiler/aslerror.c
Index: acpica-unix2-20160422/source/compiler/aslerror.c
===================================================================
--- acpica-unix2-20160318.orig/source/compiler/aslerror.c
+++ acpica-unix2-20160318/source/compiler/aslerror.c
--- acpica-unix2-20160422.orig/source/compiler/aslerror.c
+++ acpica-unix2-20160422/source/compiler/aslerror.c
@@ -687,7 +687,7 @@ AslCommonError (
Gbl_ExceptionCount[Level]++;
if (Gbl_ExceptionCount[ASL_ERROR] > ASL_MAX_ERROR_COUNT)
@ -59,10 +59,10 @@ Index: acpica-unix2-20160318/source/compiler/aslerror.c
ASL_MAX_DISABLED_MESSAGES);
return (AE_LIMIT);
}
Index: acpica-unix2-20160318/source/compiler/aslopt.c
Index: acpica-unix2-20160422/source/compiler/aslopt.c
===================================================================
--- acpica-unix2-20160318.orig/source/compiler/aslopt.c
+++ acpica-unix2-20160318/source/compiler/aslopt.c
--- acpica-unix2-20160422.orig/source/compiler/aslopt.c
+++ acpica-unix2-20160422/source/compiler/aslopt.c
@@ -584,7 +584,7 @@ OptOptimizeNamePath (
}
@ -72,10 +72,10 @@ Index: acpica-unix2-20160318/source/compiler/aslopt.c
Op->Asl.LogicalLineNumber,
AcpiPsGetOpcodeName (Op->Common.Parent->Common.AmlOpcode),
AcpiPsGetOpcodeName (Op->Common.AmlOpcode)));
Index: acpica-unix2-20160318/source/compiler/aslpredef.c
Index: acpica-unix2-20160422/source/compiler/aslpredef.c
===================================================================
--- acpica-unix2-20160318.orig/source/compiler/aslpredef.c
+++ acpica-unix2-20160318/source/compiler/aslpredef.c
--- acpica-unix2-20160422.orig/source/compiler/aslpredef.c
+++ acpica-unix2-20160422/source/compiler/aslpredef.c
@@ -114,7 +114,7 @@ ApCheckForPredefinedMethod (
if (MethodInfo->NumArguments != 0)
@ -85,11 +85,11 @@ Index: acpica-unix2-20160318/source/compiler/aslpredef.c
AslError (ASL_WARNING, ASL_MSG_RESERVED_ARG_COUNT_HI, Op,
MsgBuffer);
Index: acpica-unix2-20160318/source/compiler/aslprepkg.c
Index: acpica-unix2-20160422/source/compiler/aslprepkg.c
===================================================================
--- acpica-unix2-20160318.orig/source/compiler/aslprepkg.c
+++ acpica-unix2-20160318/source/compiler/aslprepkg.c
@@ -299,7 +299,7 @@ ApCheckPackage (
--- acpica-unix2-20160422.orig/source/compiler/aslprepkg.c
+++ acpica-unix2-20160422/source/compiler/aslprepkg.c
@@ -309,7 +309,7 @@ ApCheckPackage (
if (Count & 1)
{
@ -98,10 +98,10 @@ Index: acpica-unix2-20160318/source/compiler/aslprepkg.c
Predefined->Info.Name, Count);
AslError (ASL_ERROR, ASL_MSG_RESERVED_PACKAGE_LENGTH,
Index: acpica-unix2-20160318/source/components/debugger/dbexec.c
Index: acpica-unix2-20160422/source/components/debugger/dbexec.c
===================================================================
--- acpica-unix2-20160318.orig/source/components/debugger/dbexec.c
+++ acpica-unix2-20160318/source/components/debugger/dbexec.c
--- acpica-unix2-20160422.orig/source/components/debugger/dbexec.c
+++ acpica-unix2-20160422/source/components/debugger/dbexec.c
@@ -214,7 +214,7 @@ AcpiDbExecuteMethod (
ACPI_ERROR ((AE_INFO,
"Possible overflow of internal debugger "
@ -111,10 +111,10 @@ Index: acpica-unix2-20160318/source/components/debugger/dbexec.c
}
}
Index: acpica-unix2-20160318/source/components/dispatcher/dsmthdat.c
Index: acpica-unix2-20160422/source/components/dispatcher/dsmthdat.c
===================================================================
--- acpica-unix2-20160318.orig/source/components/dispatcher/dsmthdat.c
+++ acpica-unix2-20160318/source/components/dispatcher/dsmthdat.c
--- acpica-unix2-20160422.orig/source/components/dispatcher/dsmthdat.c
+++ acpica-unix2-20160422/source/components/dispatcher/dsmthdat.c
@@ -291,7 +291,7 @@ AcpiDsMethodDataGetNode (
if (Index > ACPI_METHOD_MAX_LOCAL)
{
@ -133,10 +133,10 @@ Index: acpica-unix2-20160318/source/components/dispatcher/dsmthdat.c
Index, ACPI_METHOD_MAX_ARG));
return_ACPI_STATUS (AE_AML_INVALID_INDEX);
}
Index: acpica-unix2-20160318/source/components/dispatcher/dsutils.c
Index: acpica-unix2-20160422/source/components/dispatcher/dsutils.c
===================================================================
--- acpica-unix2-20160318.orig/source/components/dispatcher/dsutils.c
+++ acpica-unix2-20160318/source/components/dispatcher/dsutils.c
--- acpica-unix2-20160422.orig/source/components/dispatcher/dsutils.c
+++ acpica-unix2-20160422/source/components/dispatcher/dsutils.c
@@ -791,7 +791,7 @@ AcpiDsCreateOperands (
}
@ -146,10 +146,10 @@ Index: acpica-unix2-20160318/source/components/dispatcher/dsutils.c
WalkState->NumOperands, ArgCount, Index));
/* Create the interpreter arguments, in reverse order */
Index: acpica-unix2-20160318/source/components/dispatcher/dswscope.c
Index: acpica-unix2-20160422/source/components/dispatcher/dswscope.c
===================================================================
--- acpica-unix2-20160318.orig/source/components/dispatcher/dswscope.c
+++ acpica-unix2-20160318/source/components/dispatcher/dswscope.c
--- acpica-unix2-20160422.orig/source/components/dispatcher/dswscope.c
+++ acpica-unix2-20160422/source/components/dispatcher/dswscope.c
@@ -149,7 +149,7 @@ AcpiDsScopeStackPush (
WalkState->ScopeDepth++;
@ -168,10 +168,10 @@ Index: acpica-unix2-20160318/source/components/dispatcher/dswscope.c
(UINT32) WalkState->ScopeDepth,
AcpiUtGetNodeName (ScopeInfo->Scope.Node),
AcpiUtGetTypeName (ScopeInfo->Common.Value)));
Index: acpica-unix2-20160318/source/components/events/evgpe.c
Index: acpica-unix2-20160422/source/components/events/evgpe.c
===================================================================
--- acpica-unix2-20160318.orig/source/components/events/evgpe.c
+++ acpica-unix2-20160318/source/components/events/evgpe.c
--- acpica-unix2-20160422.orig/source/components/events/evgpe.c
+++ acpica-unix2-20160422/source/components/events/evgpe.c
@@ -430,7 +430,7 @@ AcpiEvGpeDetect (
"Ignore disabled registers for GPE %02X-%02X: "
"RunEnable=%02X, WakeEnable=%02X\n",
@ -190,10 +190,10 @@ Index: acpica-unix2-20160318/source/components/events/evgpe.c
StatusReg, EnableReg,
GpeRegisterInfo->EnableForRun,
GpeRegisterInfo->EnableForWake));
Index: acpica-unix2-20160318/source/components/executer/exdump.c
Index: acpica-unix2-20160422/source/components/executer/exdump.c
===================================================================
--- acpica-unix2-20160318.orig/source/components/executer/exdump.c
+++ acpica-unix2-20160318/source/components/executer/exdump.c
--- acpica-unix2-20160422.orig/source/components/executer/exdump.c
+++ acpica-unix2-20160422/source/components/executer/exdump.c
@@ -668,7 +668,7 @@ AcpiExDumpOperand (
if (Depth > 0)
{
@ -203,10 +203,10 @@ Index: acpica-unix2-20160318/source/components/executer/exdump.c
}
else
{
Index: acpica-unix2-20160318/source/components/executer/exfldio.c
Index: acpica-unix2-20160422/source/components/executer/exfldio.c
===================================================================
--- acpica-unix2-20160318.orig/source/components/executer/exfldio.c
+++ acpica-unix2-20160318/source/components/executer/exfldio.c
--- acpica-unix2-20160422.orig/source/components/executer/exfldio.c
+++ acpica-unix2-20160422/source/components/executer/exfldio.c
@@ -681,8 +681,8 @@ AcpiExWriteWithUpdateRule (
ACPI_ERROR ((AE_INFO,
@ -218,10 +218,10 @@ Index: acpica-unix2-20160318/source/components/executer/exfldio.c
return_ACPI_STATUS (AE_AML_OPERAND_VALUE);
}
}
Index: acpica-unix2-20160318/source/components/executer/exnames.c
Index: acpica-unix2-20160422/source/components/executer/exnames.c
===================================================================
--- acpica-unix2-20160318.orig/source/components/executer/exnames.c
+++ acpica-unix2-20160318/source/components/executer/exnames.c
--- acpica-unix2-20160422.orig/source/components/executer/exnames.c
+++ acpica-unix2-20160422/source/components/executer/exnames.c
@@ -240,7 +240,7 @@ AcpiExNameSegment (
*/
ACPI_DEBUG_PRINT ((ACPI_DB_INFO,
@ -240,11 +240,11 @@ Index: acpica-unix2-20160318/source/components/executer/exnames.c
}
*InAmlAddress = ACPI_CAST_PTR (UINT8, AmlAddress);
Index: acpica-unix2-20160318/source/components/hardware/hwregs.c
Index: acpica-unix2-20160422/source/components/hardware/hwregs.c
===================================================================
--- acpica-unix2-20160318.orig/source/components/hardware/hwregs.c
+++ acpica-unix2-20160318/source/components/hardware/hwregs.c
@@ -434,7 +434,7 @@ AcpiHwClearAcpiStatus (
--- acpica-unix2-20160422.orig/source/components/hardware/hwregs.c
+++ acpica-unix2-20160422/source/components/hardware/hwregs.c
@@ -473,7 +473,7 @@ AcpiHwClearAcpiStatus (
ACPI_DEBUG_PRINT ((ACPI_DB_IO, "About to write %04X to %8.8X%8.8X\n",
@ -253,10 +253,10 @@ Index: acpica-unix2-20160318/source/components/hardware/hwregs.c
ACPI_FORMAT_UINT64 (AcpiGbl_XPm1aStatus.Address)));
LockFlags = AcpiOsAcquireLock (AcpiGbl_HardwareLock);
Index: acpica-unix2-20160318/source/components/tables/tbfadt.c
Index: acpica-unix2-20160422/source/components/tables/tbfadt.c
===================================================================
--- acpica-unix2-20160318.orig/source/components/tables/tbfadt.c
+++ acpica-unix2-20160318/source/components/tables/tbfadt.c
--- acpica-unix2-20160422.orig/source/components/tables/tbfadt.c
+++ acpica-unix2-20160422/source/components/tables/tbfadt.c
@@ -233,7 +233,7 @@ AcpiTbInitGenericAddress (
if (!(Flags & ACPI_FADT_GPE_REGISTER))
{
@ -284,10 +284,10 @@ Index: acpica-unix2-20160318/source/components/tables/tbfadt.c
Name, Address32,
ACPI_FORMAT_UINT64 (Address64->Address),
AcpiGbl_Use32BitFadtAddresses ? 32 : 64));
Index: acpica-unix2-20160318/source/components/tables/tbxfroot.c
Index: acpica-unix2-20160422/source/components/tables/tbxfroot.c
===================================================================
--- acpica-unix2-20160318.orig/source/components/tables/tbxfroot.c
+++ acpica-unix2-20160318/source/components/tables/tbxfroot.c
--- acpica-unix2-20160422.orig/source/components/tables/tbxfroot.c
+++ acpica-unix2-20160422/source/components/tables/tbxfroot.c
@@ -177,7 +177,7 @@ AcpiFindRootPointer (
{
ACPI_ERROR ((AE_INFO,
@ -315,10 +315,10 @@ Index: acpica-unix2-20160318/source/components/tables/tbxfroot.c
return_ACPI_STATUS (AE_NO_MEMORY);
}
Index: acpica-unix2-20160318/source/components/utilities/utownerid.c
Index: acpica-unix2-20160422/source/components/utilities/utownerid.c
===================================================================
--- acpica-unix2-20160318.orig/source/components/utilities/utownerid.c
+++ acpica-unix2-20160318/source/components/utilities/utownerid.c
--- acpica-unix2-20160422.orig/source/components/utilities/utownerid.c
+++ acpica-unix2-20160422/source/components/utilities/utownerid.c
@@ -231,7 +231,7 @@ AcpiUtReleaseOwnerId (
else
{
@ -328,10 +328,10 @@ Index: acpica-unix2-20160318/source/components/utilities/utownerid.c
}
(void) AcpiUtReleaseMutex (ACPI_MTX_CACHES);
Index: acpica-unix2-20160318/source/tools/acpiexec/aemain.c
Index: acpica-unix2-20160422/source/tools/acpiexec/aemain.c
===================================================================
--- acpica-unix2-20160318.orig/source/tools/acpiexec/aemain.c
+++ acpica-unix2-20160318/source/tools/acpiexec/aemain.c
--- acpica-unix2-20160422.orig/source/tools/acpiexec/aemain.c
+++ acpica-unix2-20160422/source/tools/acpiexec/aemain.c
@@ -205,7 +205,7 @@ AeDoOptions (
if (strlen (AcpiGbl_Optarg) > (AE_BUFFER_SIZE -1))

View File

@ -10,11 +10,11 @@ made in the remainder of the function.
source/compiler/aslanalyze.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Index: acpica-unix2-20160318/source/compiler/aslanalyze.c
Index: acpica-unix2-20160422/source/compiler/aslanalyze.c
===================================================================
--- acpica-unix2-20160318.orig/source/compiler/aslanalyze.c
+++ acpica-unix2-20160318/source/compiler/aslanalyze.c
@@ -452,7 +452,7 @@ ApCheckForGpeNameConflict (
--- acpica-unix2-20160422.orig/source/compiler/aslanalyze.c
+++ acpica-unix2-20160422/source/compiler/aslanalyze.c
@@ -461,7 +461,7 @@ ApCheckForGpeNameConflict (
/* Need a null-terminated string version of NameSeg */
@ -23,7 +23,7 @@ Index: acpica-unix2-20160318/source/compiler/aslanalyze.c
Name[ACPI_NAME_SIZE] = 0;
/*
@@ -479,7 +479,7 @@ ApCheckForGpeNameConflict (
@@ -488,7 +488,7 @@ ApCheckForGpeNameConflict (
* We are now sure we have an _Lxx or _Exx.
* Create the target name that would cause collision (Flip E/L)
*/

View File

@ -7,10 +7,10 @@ Al Stone <ahs3@redhat.com>
source/compiler/aslmain.c | 12 ------------
1 file changed, 12 deletions(-)
Index: acpica-unix2-20160318/source/compiler/aslmain.c
Index: acpica-unix2-20160422/source/compiler/aslmain.c
===================================================================
--- acpica-unix2-20160318.orig/source/compiler/aslmain.c
+++ acpica-unix2-20160318/source/compiler/aslmain.c
--- acpica-unix2-20160422.orig/source/compiler/aslmain.c
+++ acpica-unix2-20160422/source/compiler/aslmain.c
@@ -318,18 +318,6 @@ main (
int ReturnStatus = 0;

View File

@ -7,10 +7,10 @@ From: Al Stone <ahs3@redhat.com>
tests/templates/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Index: acpica-unix2-20160318/tests/templates/Makefile
Index: acpica-unix2-20160422/tests/templates/Makefile
===================================================================
--- acpica-unix2-20160318.orig/tests/templates/Makefile
+++ acpica-unix2-20160318/tests/templates/Makefile
--- acpica-unix2-20160422.orig/tests/templates/Makefile
+++ acpica-unix2-20160422/tests/templates/Makefile
@@ -2,7 +2,7 @@
PROG= templates