Update to 20170303 upstream source.

Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
Al Stone 2017-03-31 18:10:23 -06:00
parent 0a2fbe98cf
commit b523322d74
6 changed files with 115 additions and 109 deletions

2
.gitignore vendored
View File

@ -66,3 +66,5 @@
/acpitests-unix-20170119.tar.gz
/acpica-unix2-20170224.tar.gz
/acpitests-unix-20170224.tar.gz
/acpica-unix2-20170303.tar.gz
/acpitests-unix-20170303.tar.gz

View File

@ -1,7 +1,7 @@
Index: acpica-unix2-20161222/generate/unix/Makefile.config
Index: acpica-unix2-20170303/generate/unix/Makefile.config
===================================================================
--- acpica-unix2-20161222.orig/generate/unix/Makefile.config
+++ acpica-unix2-20161222/generate/unix/Makefile.config
--- acpica-unix2-20170303.orig/generate/unix/Makefile.config
+++ acpica-unix2-20170303/generate/unix/Makefile.config
@@ -23,6 +23,9 @@
# OPT_CFLAGS can be overridden on the make command line by
# adding OPT_CFLAGS="..." to the invocation.
@ -21,8 +21,8 @@ Index: acpica-unix2-20161222/generate/unix/Makefile.config
PREFIX ?= /usr
INSTALLDIR = $(PREFIX)/bin
UNAME_S := $(shell uname -s)
@@ -148,6 +151,11 @@ ACPICA_HEADERS = \
OPT_CFLAGS ?= $(CWARNINGFLAGS)
@@ -157,6 +160,11 @@ LDFLAGS +=-m32
endif
#
+# Common linker flags

View File

@ -1,5 +1,5 @@
Name: acpica-tools
Version: 20170224
Version: 20170303
Release: 1%{?dist}
Summary: ACPICA tools for the development and debug of ACPI tables
@ -194,6 +194,10 @@ fi
%changelog
* Fri Mar 31 2017 Al Stone <ahs3@redhat.com> - 20170303-1
- Update to latest upstream. Closes BZ#1381017.
- Refresh patches.
* Fri Mar 31 2017 Al Stone <ahs3@redhat.com> - 20170224-1
- Update to latest upstream. Closes BZ#1381017.
- Refresh patches.

View File

@ -8,11 +8,11 @@ From: Al Stone <ahs3@redhat.com>
generate/unix/iasl/Makefile | 13 +++++++------
2 files changed, 9 insertions(+), 6 deletions(-)
Index: acpica-unix2-20170224/generate/unix/Makefile.config
Index: acpica-unix2-20170303/generate/unix/Makefile.config
===================================================================
--- acpica-unix2-20170224.orig/generate/unix/Makefile.config
+++ acpica-unix2-20170224/generate/unix/Makefile.config
@@ -171,6 +171,8 @@ ifneq ($(NOFORTIFY),TRUE)
--- acpica-unix2-20170303.orig/generate/unix/Makefile.config
+++ acpica-unix2-20170303/generate/unix/Makefile.config
@@ -180,6 +180,8 @@ ifneq ($(NOFORTIFY),TRUE)
OPT_CFLAGS += -D_FORTIFY_SOURCE=2
endif
@ -21,10 +21,10 @@ Index: acpica-unix2-20170224/generate/unix/Makefile.config
CFLAGS += \
-D$(HOST)\
-D_GNU_SOURCE\
Index: acpica-unix2-20170224/generate/unix/iasl/Makefile
Index: acpica-unix2-20170303/generate/unix/iasl/Makefile
===================================================================
--- acpica-unix2-20170224.orig/generate/unix/iasl/Makefile
+++ acpica-unix2-20170224/generate/unix/iasl/Makefile
--- acpica-unix2-20170303.orig/generate/unix/iasl/Makefile
+++ acpica-unix2-20170303/generate/unix/iasl/Makefile
@@ -322,20 +322,21 @@ $(OBJDIR)/prparserparse.c $(OBJDIR)/prpa
# Cannot use the common compile warning flags since the C files are created
# by the utilities above and they are not necessarily ANSI C, etc.

View File

@ -1,2 +1,2 @@
SHA512 (acpica-unix2-20170224.tar.gz) = a3ed492d4589d5b760df4fd6bc12feb244f772ee8a9be67fc99c31c3ca2231024c1f6d9f05f14a138482dc4fc19c75fe84edb84c9f0bbb01818caddac9fa5203
SHA512 (acpitests-unix-20170224.tar.gz) = fdbe0a0a73299c2cf94bf3f70d584884af629378913329de502213dcaa8cd802bb21a8285bd4a88f8b83b19dbab120618de0d06b336de714d40ef0d154c80a41
SHA512 (acpica-unix2-20170303.tar.gz) = 22478b2df4cebfcc09539c9f0d16175319de93dccfc4224cf0b3e0a61970f45b41690adae69ac192e614c02929db6b8a6be2b01b9a5f2c6b83dbcf13cdeb01e5
SHA512 (acpitests-unix-20170303.tar.gz) = 251479440bc83b5cbcc21aea69d8bfec2aaa2429e87b2a9cd13b01ecc8f294a16d892a2fa02f5a4a8adad8777dad5daf1325aeacec97a0b63ad11677341e8bf0

View File

@ -1,7 +1,7 @@
Index: acpica-unix2-20170224/source/common/acfileio.c
Index: acpica-unix2-20170303/source/common/acfileio.c
===================================================================
--- acpica-unix2-20170224.orig/source/common/acfileio.c
+++ acpica-unix2-20170224/source/common/acfileio.c
--- acpica-unix2-20170303.orig/source/common/acfileio.c
+++ acpica-unix2-20170303/source/common/acfileio.c
@@ -250,6 +250,7 @@ AcGetOneTableFromFile (
ACPI_TABLE_HEADER *Table;
INT32 Count;
@ -63,10 +63,10 @@ Index: acpica-unix2-20170224/source/common/acfileio.c
(UINT32) (FileSize - TableOffset));
return (AE_BAD_HEADER);
}
Index: acpica-unix2-20170224/source/common/ahpredef.c
Index: acpica-unix2-20170303/source/common/ahpredef.c
===================================================================
--- acpica-unix2-20170224.orig/source/common/ahpredef.c
+++ acpica-unix2-20170224/source/common/ahpredef.c
--- acpica-unix2-20170303.orig/source/common/ahpredef.c
+++ acpica-unix2-20170303/source/common/ahpredef.c
@@ -358,7 +358,7 @@ AcpiAhMatchPredefinedName (
char *Nameseg)
{
@ -76,10 +76,10 @@ Index: acpica-unix2-20170224/source/common/ahpredef.c
for (Info = AslPredefinedInfo; Info->Name; Info++)
{
Index: acpica-unix2-20170224/source/common/dmtable.c
Index: acpica-unix2-20170303/source/common/dmtable.c
===================================================================
--- acpica-unix2-20170224.orig/source/common/dmtable.c
+++ acpica-unix2-20170224/source/common/dmtable.c
--- acpica-unix2-20170303.orig/source/common/dmtable.c
+++ acpica-unix2-20170303/source/common/dmtable.c
@@ -499,7 +499,7 @@ AcpiDmDumpDataTable (
*/
if (ACPI_COMPARE_NAME (Table->Signature, ACPI_SIG_FACS))
@ -178,10 +178,10 @@ Index: acpica-unix2-20170224/source/common/dmtable.c
AcpiDmNfitSubnames[Temp16]);
break;
Index: acpica-unix2-20170224/source/common/dmtables.c
Index: acpica-unix2-20170303/source/common/dmtables.c
===================================================================
--- acpica-unix2-20170224.orig/source/common/dmtables.c
+++ acpica-unix2-20170224/source/common/dmtables.c
--- acpica-unix2-20170303.orig/source/common/dmtables.c
+++ acpica-unix2-20170303/source/common/dmtables.c
@@ -142,7 +142,9 @@ AdCreateTableHeader (
ACPI_TABLE_HEADER *Table)
{
@ -247,10 +247,10 @@ Index: acpica-unix2-20170224/source/common/dmtables.c
AmlStart = ((UINT8 *) Table + sizeof (ACPI_TABLE_HEADER));
ASL_CV_INIT_FILETREE(Table, AmlStart, AmlLength);
Index: acpica-unix2-20170224/source/common/dmtbdump.c
Index: acpica-unix2-20170303/source/common/dmtbdump.c
===================================================================
--- acpica-unix2-20170224.orig/source/common/dmtbdump.c
+++ acpica-unix2-20170224/source/common/dmtbdump.c
--- acpica-unix2-20170303.orig/source/common/dmtbdump.c
+++ acpica-unix2-20170303/source/common/dmtbdump.c
@@ -277,6 +277,8 @@ AcpiDmDumpRsdt (
UINT32 Entries;
UINT32 Offset;
@ -2064,10 +2064,10 @@ Index: acpica-unix2-20170224/source/common/dmtbdump.c
+ (void) AcpiDmDumpTable (Length, 0, Table, ArgumentsLength,
AcpiDmTableInfoWpbt0);
}
Index: acpica-unix2-20170224/source/compiler/aslrestype2.c
Index: acpica-unix2-20170303/source/compiler/aslrestype2.c
===================================================================
--- acpica-unix2-20170224.orig/source/compiler/aslrestype2.c
+++ acpica-unix2-20170224/source/compiler/aslrestype2.c
--- acpica-unix2-20170303.orig/source/compiler/aslrestype2.c
+++ acpica-unix2-20170303/source/compiler/aslrestype2.c
@@ -98,21 +98,33 @@ RsDoGeneralRegisterDescriptor (
{
case 0: /* Address space */
@ -2114,10 +2114,10 @@ Index: acpica-unix2-20170224/source/compiler/aslrestype2.c
RsCreateByteField (InitializerOp, ACPI_RESTAG_ACCESSSIZE,
CurrentByteOffset + ASL_RESDESC_OFFSET (GenericReg.AccessSize));
Index: acpica-unix2-20170224/source/compiler/dtfield.c
Index: acpica-unix2-20170303/source/compiler/dtfield.c
===================================================================
--- acpica-unix2-20170224.orig/source/compiler/dtfield.c
+++ acpica-unix2-20170224/source/compiler/dtfield.c
--- acpica-unix2-20170303.orig/source/compiler/dtfield.c
+++ acpica-unix2-20170303/source/compiler/dtfield.c
@@ -360,7 +360,27 @@ DtCompileInteger (
DtError (ASL_ERROR, ASL_MSG_INTEGER_SIZE, Field, MsgBuffer);
}
@ -2147,10 +2147,10 @@ Index: acpica-unix2-20170224/source/compiler/dtfield.c
return;
}
Index: acpica-unix2-20170224/source/compiler/dtsubtable.c
Index: acpica-unix2-20170303/source/compiler/dtsubtable.c
===================================================================
--- acpica-unix2-20170224.orig/source/compiler/dtsubtable.c
+++ acpica-unix2-20170224/source/compiler/dtsubtable.c
--- acpica-unix2-20170303.orig/source/compiler/dtsubtable.c
+++ acpica-unix2-20170303/source/compiler/dtsubtable.c
@@ -379,6 +379,21 @@ DtSetSubtableLength (
return;
}
@ -2175,10 +2175,10 @@ Index: acpica-unix2-20170224/source/compiler/dtsubtable.c
+ Subtable->SizeOfLengthField);
+ }
}
Index: acpica-unix2-20170224/source/compiler/dttable1.c
Index: acpica-unix2-20170303/source/compiler/dttable1.c
===================================================================
--- acpica-unix2-20170224.orig/source/compiler/dttable1.c
+++ acpica-unix2-20170224/source/compiler/dttable1.c
--- acpica-unix2-20170303.orig/source/compiler/dttable1.c
+++ acpica-unix2-20170303/source/compiler/dttable1.c
@@ -282,6 +282,8 @@ DtCompileCsrt (
DT_FIELD **PFieldList = (DT_FIELD **) List;
UINT32 DescriptorCount;
@ -2552,10 +2552,10 @@ Index: acpica-unix2-20170224/source/compiler/dttable1.c
return (AE_OK);
}
Index: acpica-unix2-20170224/source/compiler/dttable2.c
Index: acpica-unix2-20170303/source/compiler/dttable2.c
===================================================================
--- acpica-unix2-20170224.orig/source/compiler/dttable2.c
+++ acpica-unix2-20170224/source/compiler/dttable2.c
--- acpica-unix2-20170303.orig/source/compiler/dttable2.c
+++ acpica-unix2-20170303/source/compiler/dttable2.c
@@ -346,7 +346,7 @@ DtCompileMpst (
DtPushSubtable (Subtable);
@ -2712,10 +2712,10 @@ Index: acpica-unix2-20170224/source/compiler/dttable2.c
ParentTable = DtPeekSubtable ();
DtInsertSubtable (ParentTable, Subtable);
Index: acpica-unix2-20170224/source/components/disassembler/dmbuffer.c
Index: acpica-unix2-20170303/source/components/disassembler/dmbuffer.c
===================================================================
--- acpica-unix2-20170224.orig/source/components/disassembler/dmbuffer.c
+++ acpica-unix2-20170224/source/components/disassembler/dmbuffer.c
--- acpica-unix2-20170303.orig/source/components/disassembler/dmbuffer.c
+++ acpica-unix2-20170303/source/components/disassembler/dmbuffer.c
@@ -204,7 +204,7 @@ AcpiDmByteList (
@ -2791,10 +2791,10 @@ Index: acpica-unix2-20170224/source/components/disassembler/dmbuffer.c
NextOp = AcpiPsGetDepthNext (NULL, Op);
if (!NextOp)
Index: acpica-unix2-20170224/source/components/disassembler/dmopcode.c
Index: acpica-unix2-20170303/source/components/disassembler/dmopcode.c
===================================================================
--- acpica-unix2-20170224.orig/source/components/disassembler/dmopcode.c
+++ acpica-unix2-20170224/source/components/disassembler/dmopcode.c
--- acpica-unix2-20170303.orig/source/components/disassembler/dmopcode.c
+++ acpica-unix2-20170303/source/components/disassembler/dmopcode.c
@@ -253,6 +253,7 @@ AcpiDmPredefinedDescription (
char *NameString;
int LastCharIsDigit;
@ -2814,7 +2814,7 @@ Index: acpica-unix2-20170224/source/components/disassembler/dmopcode.c
if (NameString[0] != '_')
{
return;
@@ -881,25 +884,27 @@ AcpiDmDisassembleOneOp (
@@ -884,25 +887,27 @@ AcpiDmDisassembleOneOp (
AcpiDmNamestring (Op->Common.Value.Name);
break;
@ -2847,10 +2847,10 @@ Index: acpica-unix2-20170224/source/components/disassembler/dmopcode.c
Info->BitOffset += Offset;
if (Info->BitOffset % 8 == 0)
Index: acpica-unix2-20170224/source/components/disassembler/dmresrcl2.c
Index: acpica-unix2-20170303/source/components/disassembler/dmresrcl2.c
===================================================================
--- acpica-unix2-20170224.orig/source/components/disassembler/dmresrcl2.c
+++ acpica-unix2-20170224/source/components/disassembler/dmresrcl2.c
--- acpica-unix2-20170303.orig/source/components/disassembler/dmresrcl2.c
+++ acpica-unix2-20170303/source/components/disassembler/dmresrcl2.c
@@ -191,22 +191,24 @@ AcpiDmGpioCommon (
char *DeviceName = NULL;
UINT32 PinCount;
@ -3072,10 +3072,10 @@ Index: acpica-unix2-20170224/source/components/disassembler/dmresrcl2.c
DeviceName = ACPI_ADD_PTR (char, Resource, ResourceSourceOffset);
AcpiUtPrintString (DeviceName, ACPI_UINT16_MAX);
Index: acpica-unix2-20170224/source/components/disassembler/dmresrcl.c
Index: acpica-unix2-20170303/source/components/disassembler/dmresrcl.c
===================================================================
--- acpica-unix2-20170224.orig/source/components/disassembler/dmresrcl.c
+++ acpica-unix2-20170224/source/components/disassembler/dmresrcl.c
--- acpica-unix2-20170303.orig/source/components/disassembler/dmresrcl.c
+++ acpica-unix2-20170303/source/components/disassembler/dmresrcl.c
@@ -141,7 +141,8 @@ AcpiDmMemoryFields (
UINT32 Level)
{
@ -3224,10 +3224,10 @@ Index: acpica-unix2-20170224/source/components/disassembler/dmresrcl.c
}
AcpiDmIndent (Level);
Index: acpica-unix2-20170224/source/components/disassembler/dmresrcs.c
Index: acpica-unix2-20170303/source/components/disassembler/dmresrcs.c
===================================================================
--- acpica-unix2-20170224.orig/source/components/disassembler/dmresrcs.c
+++ acpica-unix2-20170224/source/components/disassembler/dmresrcs.c
--- acpica-unix2-20170303.orig/source/components/disassembler/dmresrcs.c
+++ acpica-unix2-20170303/source/components/disassembler/dmresrcs.c
@@ -72,6 +72,7 @@ AcpiDmIrqDescriptor (
UINT32 Length,
UINT32 Level)
@ -3284,10 +3284,10 @@ Index: acpica-unix2-20170224/source/components/disassembler/dmresrcs.c
AcpiDmIndent (Level + 1);
AcpiDmDumpInteger8 (Resource->FixedIo.AddressLength, "Length");
Index: acpica-unix2-20170224/source/components/dispatcher/dsfield.c
Index: acpica-unix2-20170303/source/components/dispatcher/dsfield.c
===================================================================
--- acpica-unix2-20170224.orig/source/components/dispatcher/dsfield.c
+++ acpica-unix2-20170224/source/components/dispatcher/dsfield.c
--- acpica-unix2-20170303.orig/source/components/dispatcher/dsfield.c
+++ acpica-unix2-20170303/source/components/dispatcher/dsfield.c
@@ -318,6 +318,7 @@ AcpiDsGetFieldNames (
ACPI_STATUS Status;
UINT64 Position;
@ -3332,10 +3332,10 @@ Index: acpica-unix2-20170224/source/components/dispatcher/dsfield.c
if (ACPI_FAILURE (Status))
{
ACPI_ERROR_NAMESPACE ((char *) &Arg->Named.Name, Status);
Index: acpica-unix2-20170224/source/components/events/evgpeblk.c
Index: acpica-unix2-20170303/source/components/events/evgpeblk.c
===================================================================
--- acpica-unix2-20170224.orig/source/components/events/evgpeblk.c
+++ acpica-unix2-20170224/source/components/events/evgpeblk.c
--- acpica-unix2-20170303.orig/source/components/events/evgpeblk.c
+++ acpica-unix2-20170303/source/components/events/evgpeblk.c
@@ -376,6 +376,7 @@ AcpiEvCreateGpeBlock (
ACPI_STATUS Status;
ACPI_GPE_BLOCK_INFO *GpeBlock;
@ -3368,10 +3368,10 @@ Index: acpica-unix2-20170224/source/components/events/evgpeblk.c
InterruptNumber == AcpiGbl_FADT.SciInterrupt ? " (SCI)" : ""));
/* Update global count of currently available GPEs */
Index: acpica-unix2-20170224/source/components/hardware/hwregs.c
Index: acpica-unix2-20170303/source/components/hardware/hwregs.c
===================================================================
--- acpica-unix2-20170224.orig/source/components/hardware/hwregs.c
+++ acpica-unix2-20170224/source/components/hardware/hwregs.c
--- acpica-unix2-20170303.orig/source/components/hardware/hwregs.c
+++ acpica-unix2-20170303/source/components/hardware/hwregs.c
@@ -197,7 +197,7 @@ AcpiHwValidateRegister (
* Address must not be null. A null address also indicates an optional
* ACPI register that is not supported, so no error message.
@ -3381,10 +3381,10 @@ Index: acpica-unix2-20170224/source/components/hardware/hwregs.c
if (!(*Address))
{
return (AE_BAD_ADDRESS);
Index: acpica-unix2-20170224/source/components/hardware/hwvalid.c
Index: acpica-unix2-20170303/source/components/hardware/hwvalid.c
===================================================================
--- acpica-unix2-20170224.orig/source/components/hardware/hwvalid.c
+++ acpica-unix2-20170224/source/components/hardware/hwvalid.c
--- acpica-unix2-20170303.orig/source/components/hardware/hwvalid.c
+++ acpica-unix2-20170303/source/components/hardware/hwvalid.c
@@ -135,6 +135,8 @@ AcpiHwValidateIoRequest (
UINT32 ByteWidth;
ACPI_IO_ADDRESS LastAddress;
@ -3406,10 +3406,10 @@ Index: acpica-unix2-20170224/source/components/hardware/hwvalid.c
{
ACPI_ERROR ((AE_INFO,
"Illegal I/O port address/length above 64K: %8.8X%8.8X/0x%X",
Index: acpica-unix2-20170224/source/components/namespace/nsaccess.c
Index: acpica-unix2-20170303/source/components/namespace/nsaccess.c
===================================================================
--- acpica-unix2-20170224.orig/source/components/namespace/nsaccess.c
+++ acpica-unix2-20170224/source/components/namespace/nsaccess.c
--- acpica-unix2-20170303.orig/source/components/namespace/nsaccess.c
+++ acpica-unix2-20170303/source/components/namespace/nsaccess.c
@@ -309,6 +309,7 @@ AcpiNsLookup (
ACPI_OBJECT_TYPE ThisSearchType;
UINT32 SearchParentFlag = ACPI_NS_SEARCH_PARENT;
@ -3430,10 +3430,10 @@ Index: acpica-unix2-20170224/source/components/namespace/nsaccess.c
AcpiUtGetTypeName (ThisNode->Type),
AcpiUtGetTypeName (TypeToCheckFor)));
}
Index: acpica-unix2-20170224/source/components/namespace/nsparse.c
Index: acpica-unix2-20170303/source/components/namespace/nsparse.c
===================================================================
--- acpica-unix2-20170224.orig/source/components/namespace/nsparse.c
+++ acpica-unix2-20170224/source/components/namespace/nsparse.c
--- acpica-unix2-20170303.orig/source/components/namespace/nsparse.c
+++ acpica-unix2-20170303/source/components/namespace/nsparse.c
@@ -196,13 +196,14 @@ AcpiNsOneCompleteParse (
/* Table must consist of at least a complete header */
@ -3451,10 +3451,10 @@ Index: acpica-unix2-20170224/source/components/namespace/nsparse.c
Status = AcpiTbGetOwnerId (TableIndex, &OwnerId);
if (ACPI_FAILURE (Status))
Index: acpica-unix2-20170224/source/components/tables/tbdata.c
Index: acpica-unix2-20170303/source/components/tables/tbdata.c
===================================================================
--- acpica-unix2-20170224.orig/source/components/tables/tbdata.c
+++ acpica-unix2-20170224/source/components/tables/tbdata.c
--- acpica-unix2-20170303.orig/source/components/tables/tbdata.c
+++ acpica-unix2-20170303/source/components/tables/tbdata.c
@@ -407,6 +407,7 @@ AcpiTbVerifyTempTable (
char *Signature)
{
@ -3473,10 +3473,10 @@ Index: acpica-unix2-20170224/source/components/tables/tbdata.c
if (ACPI_FAILURE (Status))
{
ACPI_EXCEPTION ((AE_INFO, AE_NO_MEMORY,
Index: acpica-unix2-20170224/source/components/tables/tbfadt.c
Index: acpica-unix2-20170303/source/components/tables/tbfadt.c
===================================================================
--- acpica-unix2-20170224.orig/source/components/tables/tbfadt.c
+++ acpica-unix2-20170224/source/components/tables/tbfadt.c
--- acpica-unix2-20170303.orig/source/components/tables/tbfadt.c
+++ acpica-unix2-20170303/source/components/tables/tbfadt.c
@@ -520,6 +520,8 @@ AcpiTbConvertFadt (
UINT8 Length;
UINT8 Flags;
@ -3556,10 +3556,10 @@ Index: acpica-unix2-20170224/source/components/tables/tbfadt.c
"PmRegisters", 0);
}
}
Index: acpica-unix2-20170224/source/components/tables/tbfind.c
Index: acpica-unix2-20170303/source/components/tables/tbfind.c
===================================================================
--- acpica-unix2-20170224.orig/source/components/tables/tbfind.c
+++ acpica-unix2-20170224/source/components/tables/tbfind.c
--- acpica-unix2-20170303.orig/source/components/tables/tbfind.c
+++ acpica-unix2-20170303/source/components/tables/tbfind.c
@@ -108,8 +108,11 @@ AcpiTbFindTable (
(void) AcpiUtAcquireMutex (ACPI_MTX_TABLES);
for (i = 0; i < AcpiGbl_RootTableList.CurrentTableCount; ++i)
@ -3573,10 +3573,10 @@ Index: acpica-unix2-20170224/source/components/tables/tbfind.c
{
/* Not the requested table */
Index: acpica-unix2-20170224/source/components/tables/tbprint.c
Index: acpica-unix2-20170303/source/components/tables/tbprint.c
===================================================================
--- acpica-unix2-20170224.orig/source/components/tables/tbprint.c
+++ acpica-unix2-20170224/source/components/tables/tbprint.c
--- acpica-unix2-20170303.orig/source/components/tables/tbprint.c
+++ acpica-unix2-20170303/source/components/tables/tbprint.c
@@ -143,15 +143,18 @@ AcpiTbPrintTableHeader (
ACPI_TABLE_HEADER *Header)
{
@ -3618,10 +3618,10 @@ Index: acpica-unix2-20170224/source/components/tables/tbprint.c
}
}
Index: acpica-unix2-20170224/source/components/tables/tbutils.c
Index: acpica-unix2-20170303/source/components/tables/tbutils.c
===================================================================
--- acpica-unix2-20170224.orig/source/components/tables/tbutils.c
+++ acpica-unix2-20170224/source/components/tables/tbutils.c
--- acpica-unix2-20170303.orig/source/components/tables/tbutils.c
+++ acpica-unix2-20170303/source/components/tables/tbutils.c
@@ -238,7 +238,7 @@ AcpiTbGetRootTableEntry (
* 64-bit platform, XSDT: Move (unaligned) 64-bit to local,
* return 64-bit
@ -3681,10 +3681,10 @@ Index: acpica-unix2-20170224/source/components/tables/tbutils.c
{
AcpiGbl_FadtIndex = TableIndex;
AcpiTbParseFadt ();
Index: acpica-unix2-20170224/source/components/tables/tbxface.c
Index: acpica-unix2-20170303/source/components/tables/tbxface.c
===================================================================
--- acpica-unix2-20170224.orig/source/components/tables/tbxface.c
+++ acpica-unix2-20170224/source/components/tables/tbxface.c
--- acpica-unix2-20170303.orig/source/components/tables/tbxface.c
+++ acpica-unix2-20170303/source/components/tables/tbxface.c
@@ -263,8 +263,11 @@ AcpiGetTableHeader (
for (i = 0, j = 0; i < AcpiGbl_RootTableList.CurrentTableCount; i++)
@ -3698,10 +3698,10 @@ Index: acpica-unix2-20170224/source/components/tables/tbxface.c
{
continue;
}
Index: acpica-unix2-20170224/source/components/tables/tbxfload.c
Index: acpica-unix2-20170303/source/components/tables/tbxfload.c
===================================================================
--- acpica-unix2-20170224.orig/source/components/tables/tbxfload.c
+++ acpica-unix2-20170224/source/components/tables/tbxfload.c
--- acpica-unix2-20170303.orig/source/components/tables/tbxfload.c
+++ acpica-unix2-20170303/source/components/tables/tbxfload.c
@@ -156,6 +156,7 @@ AcpiTbLoadNamespace (
ACPI_TABLE_DESC *Table;
UINT32 TablesLoaded = 0;
@ -3721,10 +3721,10 @@ Index: acpica-unix2-20170224/source/components/tables/tbxfload.c
ACPI_FAILURE (AcpiTbValidateTable (Table)))
{
Status = AE_NO_ACPI_TABLES;
Index: acpica-unix2-20170224/source/include/acmacros.h
Index: acpica-unix2-20170303/source/include/acmacros.h
===================================================================
--- acpica-unix2-20170224.orig/source/include/acmacros.h
+++ acpica-unix2-20170224/source/include/acmacros.h
--- acpica-unix2-20170303.orig/source/include/acmacros.h
+++ acpica-unix2-20170303/source/include/acmacros.h
@@ -98,7 +98,9 @@
((UINT8 *)(void *)(d))[6] = ((UINT8 *)(void *)(s))[1];\
((UINT8 *)(void *)(d))[7] = ((UINT8 *)(void *)(s))[0];}
@ -3788,10 +3788,10 @@ Index: acpica-unix2-20170224/source/include/acmacros.h
#define ACPI_MOVE_32_TO_16(d, s) ACPI_MOVE_16_TO_16(d, s) /* Truncate to 16 */
Index: acpica-unix2-20170224/source/include/platform/aclinux.h
Index: acpica-unix2-20170303/source/include/platform/aclinux.h
===================================================================
--- acpica-unix2-20170224.orig/source/include/platform/aclinux.h
+++ acpica-unix2-20170224/source/include/platform/aclinux.h
--- acpica-unix2-20170303.orig/source/include/platform/aclinux.h
+++ acpica-unix2-20170303/source/include/platform/aclinux.h
@@ -219,6 +219,10 @@
#define __cdecl
#endif
@ -3803,10 +3803,10 @@ Index: acpica-unix2-20170224/source/include/platform/aclinux.h
#endif /* __KERNEL__ */
#endif /* __ACLINUX_H__ */
Index: acpica-unix2-20170224/source/tools/acpiexec/aetables.c
Index: acpica-unix2-20170303/source/tools/acpiexec/aetables.c
===================================================================
--- acpica-unix2-20170224.orig/source/tools/acpiexec/aetables.c
+++ acpica-unix2-20170224/source/tools/acpiexec/aetables.c
--- acpica-unix2-20170303.orig/source/tools/acpiexec/aetables.c
+++ acpica-unix2-20170303/source/tools/acpiexec/aetables.c
@@ -146,21 +146,25 @@ AeInitializeTableHeader (
char *Signature,
UINT32 Length)