Clean up patches for the new upstream source.
Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
parent
685b568a04
commit
a03e600feb
@ -1,7 +1,7 @@
|
|||||||
diff -urN acpica-unix2-20130626/tests/aapits/atexec.c acpica-unix2-20130626-aapits/tests/aapits/atexec.c
|
diff -urN acpica-unix2-20130626/tests/aapits/atexec.c acpica-unix2-20130626-aapits/tests/aapits/atexec.c
|
||||||
--- acpica-unix2-20130626/tests/aapits/atexec.c 2013-01-17 12:48:28.000000000 -0700
|
--- acpica-unix2-20130626/tests/aapits/atexec.c 2013-01-17 12:48:28.000000000 -0700
|
||||||
+++ acpica-unix2-20130626-aapits/tests/aapits/atexec.c 2013-07-25 13:44:23.023894441 -0600
|
+++ acpica-unix2-20130626-aapits/tests/aapits/atexec.c 2013-07-25 13:44:23.023894441 -0600
|
||||||
@@ -530,6 +530,7 @@
|
@@ -639,6 +639,7 @@
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
||||||
@ -9,7 +9,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atexec.c acpica-unix2-20130626-aapi
|
|||||||
/*******************************************************************************
|
/*******************************************************************************
|
||||||
*
|
*
|
||||||
* FUNCTION: AtBuildLocalRSDT
|
* FUNCTION: AtBuildLocalRSDT
|
||||||
@@ -648,8 +649,9 @@
|
@@ -757,8 +758,9 @@
|
||||||
LocalRSDT->Header.Checksum = (UINT8)~LocalRSDT->Header.Checksum;
|
LocalRSDT->Header.Checksum = (UINT8)~LocalRSDT->Header.Checksum;
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
@ -19,7 +19,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atexec.c acpica-unix2-20130626-aapi
|
|||||||
/*******************************************************************************
|
/*******************************************************************************
|
||||||
*
|
*
|
||||||
* FUNCTION: AtBuildLocalXSDT
|
* FUNCTION: AtBuildLocalXSDT
|
||||||
@@ -1315,7 +1319,7 @@
|
@@ -1424,7 +1426,7 @@
|
||||||
ACPI_WARNING ((AE_INFO,
|
ACPI_WARNING ((AE_INFO,
|
||||||
"Request on [%4.4s] is beyond region limit Req-%X+%X, Base=%X, Len-%X\n",
|
"Request on [%4.4s] is beyond region limit Req-%X+%X, Base=%X, Len-%X\n",
|
||||||
(RegionObject->Region.Node)->Name.Ascii, (UINT32) Address,
|
(RegionObject->Region.Node)->Name.Ascii, (UINT32) Address,
|
||||||
@ -28,7 +28,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atexec.c acpica-unix2-20130626-aapi
|
|||||||
|
|
||||||
return (AE_AML_REGION_LIMIT);
|
return (AE_AML_REGION_LIMIT);
|
||||||
}
|
}
|
||||||
@@ -1683,7 +1687,9 @@
|
@@ -1792,7 +1796,9 @@
|
||||||
Path, Obj.Integer.Value, Value);
|
Path, Obj.Integer.Value, Value);
|
||||||
#else
|
#else
|
||||||
printf ("API Error: Value of %s is 0x%llx instead of expected 0x%llx\n",
|
printf ("API Error: Value of %s is 0x%llx instead of expected 0x%llx\n",
|
||||||
@ -39,7 +39,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atexec.c acpica-unix2-20130626-aapi
|
|||||||
#endif
|
#endif
|
||||||
Status = AE_ERROR;
|
Status = AE_ERROR;
|
||||||
}
|
}
|
||||||
@@ -1762,7 +1768,7 @@
|
@@ -1871,7 +1877,7 @@
|
||||||
{
|
{
|
||||||
TestErrors++;
|
TestErrors++;
|
||||||
printf ("Test Error: cannot allocate buffer of %d bytes\n",
|
printf ("Test Error: cannot allocate buffer of %d bytes\n",
|
||||||
@ -48,7 +48,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atexec.c acpica-unix2-20130626-aapi
|
|||||||
return (AE_NO_MEMORY);
|
return (AE_NO_MEMORY);
|
||||||
}
|
}
|
||||||
Results.Pointer = Object;
|
Results.Pointer = Object;
|
||||||
@@ -1843,7 +1849,8 @@
|
@@ -1952,7 +1956,8 @@
|
||||||
{
|
{
|
||||||
printf ("AtCheckBuffer: unexpected length %d of Buffer vs"
|
printf ("AtCheckBuffer: unexpected length %d of Buffer vs"
|
||||||
" calculated %d bytes\n",
|
" calculated %d bytes\n",
|
||||||
@ -58,7 +58,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atexec.c acpica-unix2-20130626-aapi
|
|||||||
}
|
}
|
||||||
|
|
||||||
/* Initialize the return buffer structure */
|
/* Initialize the return buffer structure */
|
||||||
@@ -1852,7 +1859,7 @@
|
@@ -1961,7 +1968,7 @@
|
||||||
{
|
{
|
||||||
TestErrors++;
|
TestErrors++;
|
||||||
printf ("Test Error: cannot allocate buffer of %d bytes\n",
|
printf ("Test Error: cannot allocate buffer of %d bytes\n",
|
||||||
@ -70,7 +70,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atexec.c acpica-unix2-20130626-aapi
|
|||||||
diff -urN acpica-unix2-20130626/tests/aapits/atinit.c acpica-unix2-20130626-aapits/tests/aapits/atinit.c
|
diff -urN acpica-unix2-20130626/tests/aapits/atinit.c acpica-unix2-20130626-aapits/tests/aapits/atinit.c
|
||||||
--- acpica-unix2-20130626/tests/aapits/atinit.c 2013-01-17 12:48:28.000000000 -0700
|
--- acpica-unix2-20130626/tests/aapits/atinit.c 2013-01-17 12:48:28.000000000 -0700
|
||||||
+++ acpica-unix2-20130626-aapits/tests/aapits/atinit.c 2013-07-25 13:20:19.706705960 -0600
|
+++ acpica-unix2-20130626-aapits/tests/aapits/atinit.c 2013-07-25 13:20:19.706705960 -0600
|
||||||
@@ -2915,7 +2915,7 @@
|
@@ -3024,7 +3024,7 @@
|
||||||
AapiErrors++;
|
AapiErrors++;
|
||||||
printf ("API Error: AcpiGetSystemInfo() returned"
|
printf ("API Error: AcpiGetSystemInfo() returned"
|
||||||
" Length %d, expected %d\n",
|
" Length %d, expected %d\n",
|
||||||
@ -79,7 +79,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atinit.c acpica-unix2-20130626-aapi
|
|||||||
return (AE_ERROR);
|
return (AE_ERROR);
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -2937,7 +2937,7 @@
|
@@ -3046,7 +3046,7 @@
|
||||||
AapiErrors++;
|
AapiErrors++;
|
||||||
printf ("API Error: AcpiGetSystemInfo() returned"
|
printf ("API Error: AcpiGetSystemInfo() returned"
|
||||||
" Length %d, expected %d\n",
|
" Length %d, expected %d\n",
|
||||||
@ -88,7 +88,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atinit.c acpica-unix2-20130626-aapi
|
|||||||
return (AE_ERROR);
|
return (AE_ERROR);
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -2957,7 +2957,7 @@
|
@@ -3066,7 +3066,7 @@
|
||||||
AapiErrors++;
|
AapiErrors++;
|
||||||
printf ("API Error: AcpiGetSystemInfo() returned"
|
printf ("API Error: AcpiGetSystemInfo() returned"
|
||||||
" Length %d, expected %d\n",
|
" Length %d, expected %d\n",
|
||||||
@ -97,7 +97,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atinit.c acpica-unix2-20130626-aapi
|
|||||||
return (AE_ERROR);
|
return (AE_ERROR);
|
||||||
}
|
}
|
||||||
else if (OutBuffer.Pointer != &Info)
|
else if (OutBuffer.Pointer != &Info)
|
||||||
@@ -3040,7 +3040,7 @@
|
@@ -3149,7 +3149,7 @@
|
||||||
AapiErrors++;
|
AapiErrors++;
|
||||||
printf ("API Error: AcpiGetSystemInfo() returned"
|
printf ("API Error: AcpiGetSystemInfo() returned"
|
||||||
" Length %d, expected %d\n",
|
" Length %d, expected %d\n",
|
||||||
@ -106,7 +106,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atinit.c acpica-unix2-20130626-aapi
|
|||||||
return (AE_ERROR);
|
return (AE_ERROR);
|
||||||
}
|
}
|
||||||
else if (OutBuffer.Pointer != &Info)
|
else if (OutBuffer.Pointer != &Info)
|
||||||
@@ -3105,7 +3105,7 @@
|
@@ -3214,7 +3214,7 @@
|
||||||
AapiErrors++;
|
AapiErrors++;
|
||||||
printf ("API Error: AcpiGetSystemInfo() returned"
|
printf ("API Error: AcpiGetSystemInfo() returned"
|
||||||
" Length %d, expected %d\n",
|
" Length %d, expected %d\n",
|
||||||
@ -118,7 +118,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atinit.c acpica-unix2-20130626-aapi
|
|||||||
diff -urN acpica-unix2-20130626/tests/aapits/atmain.c acpica-unix2-20130626-aapits/tests/aapits/atmain.c
|
diff -urN acpica-unix2-20130626/tests/aapits/atmain.c acpica-unix2-20130626-aapits/tests/aapits/atmain.c
|
||||||
--- acpica-unix2-20130626/tests/aapits/atmain.c 2013-01-17 12:48:28.000000000 -0700
|
--- acpica-unix2-20130626/tests/aapits/atmain.c 2013-01-17 12:48:28.000000000 -0700
|
||||||
+++ acpica-unix2-20130626-aapits/tests/aapits/atmain.c 2013-07-25 13:18:22.083323948 -0600
|
+++ acpica-unix2-20130626-aapits/tests/aapits/atmain.c 2013-07-25 13:18:22.083323948 -0600
|
||||||
@@ -206,7 +206,7 @@
|
@@ -315,7 +315,7 @@
|
||||||
{
|
{
|
||||||
printf ("ACPICA API TS err: test num %ld of test case %ld"
|
printf ("ACPICA API TS err: test num %ld of test case %ld"
|
||||||
" is not implemented\n",
|
" is not implemented\n",
|
||||||
@ -127,7 +127,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atmain.c acpica-unix2-20130626-aapi
|
|||||||
return (AtRetNotImpl);
|
return (AtRetNotImpl);
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -321,7 +323,7 @@
|
@@ -430,7 +432,7 @@
|
||||||
if (test_case < 1 || test_case > AT_TEST_CASE_NUM)
|
if (test_case < 1 || test_case > AT_TEST_CASE_NUM)
|
||||||
{
|
{
|
||||||
printf ("ACPICA API TS err: test case %ld is out of range 1 - %d\n",
|
printf ("ACPICA API TS err: test case %ld is out of range 1 - %d\n",
|
||||||
@ -136,7 +136,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atmain.c acpica-unix2-20130626-aapi
|
|||||||
return (AtRetBadParam);
|
return (AtRetBadParam);
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -329,7 +331,7 @@
|
@@ -438,7 +440,7 @@
|
||||||
if (test_num < 0 || test_num > AtTestCase[test_case].TestsNum)
|
if (test_num < 0 || test_num > AtTestCase[test_case].TestsNum)
|
||||||
{
|
{
|
||||||
printf ("ACPICA API TS err: test num %ld is out of range 0 - %d\n",
|
printf ("ACPICA API TS err: test num %ld is out of range 0 - %d\n",
|
||||||
@ -148,7 +148,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atmain.c acpica-unix2-20130626-aapi
|
|||||||
diff -urN acpica-unix2-20130626/tests/aapits/atnamespace.c acpica-unix2-20130626-aapits/tests/aapits/atnamespace.c
|
diff -urN acpica-unix2-20130626/tests/aapits/atnamespace.c acpica-unix2-20130626-aapits/tests/aapits/atnamespace.c
|
||||||
--- acpica-unix2-20130626/tests/aapits/atnamespace.c 2013-01-17 12:48:28.000000000 -0700
|
--- acpica-unix2-20130626/tests/aapits/atnamespace.c 2013-01-17 12:48:28.000000000 -0700
|
||||||
+++ acpica-unix2-20130626-aapits/tests/aapits/atnamespace.c 2013-07-25 13:24:15.366466707 -0600
|
+++ acpica-unix2-20130626-aapits/tests/aapits/atnamespace.c 2013-07-25 13:24:15.366466707 -0600
|
||||||
@@ -2426,7 +2426,8 @@
|
@@ -2535,7 +2535,8 @@
|
||||||
#else
|
#else
|
||||||
printf ("API Error: Address of %s (0x%llX) != (0x%llX)\n",
|
printf ("API Error: Address of %s (0x%llX) != (0x%llX)\n",
|
||||||
PathNames[2 * i + 1],
|
PathNames[2 * i + 1],
|
||||||
@ -158,7 +158,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atnamespace.c acpica-unix2-20130626
|
|||||||
#endif
|
#endif
|
||||||
#else
|
#else
|
||||||
printf ("API Error: Address of %s (0x%X) != (0x%X)\n",
|
printf ("API Error: Address of %s (0x%X) != (0x%X)\n",
|
||||||
@@ -2799,7 +2800,8 @@
|
@@ -2908,7 +2909,8 @@
|
||||||
TestErrors++;
|
TestErrors++;
|
||||||
printf ("AtGetNextObjectTypeCommon: different numbers of entities"
|
printf ("AtGetNextObjectTypeCommon: different numbers of entities"
|
||||||
"in TypesNames (%d) and LevelTypes0000 (%d)\n",
|
"in TypesNames (%d) and LevelTypes0000 (%d)\n",
|
||||||
@ -168,7 +168,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atnamespace.c acpica-unix2-20130626
|
|||||||
return (AE_ERROR);
|
return (AE_ERROR);
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -4083,7 +4085,9 @@
|
@@ -4192,7 +4194,9 @@
|
||||||
Pathname, Obj.Integer.Value, Value);
|
Pathname, Obj.Integer.Value, Value);
|
||||||
#else
|
#else
|
||||||
printf ("API Error: Value of %s is 0x%llx instead of expected 0x%llx\n",
|
printf ("API Error: Value of %s is 0x%llx instead of expected 0x%llx\n",
|
||||||
@ -179,7 +179,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atnamespace.c acpica-unix2-20130626
|
|||||||
#endif
|
#endif
|
||||||
Status = AE_ERROR;
|
Status = AE_ERROR;
|
||||||
}
|
}
|
||||||
@@ -5090,7 +5094,7 @@
|
@@ -5199,7 +5203,7 @@
|
||||||
{
|
{
|
||||||
AapiErrors++;
|
AapiErrors++;
|
||||||
printf ("API Error: AcpiOsAllocate(%d) returned NULL\n",
|
printf ("API Error: AcpiOsAllocate(%d) returned NULL\n",
|
||||||
@ -191,7 +191,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atnamespace.c acpica-unix2-20130626
|
|||||||
diff -urN acpica-unix2-20130626/tests/aapits/atosxfctrl.c acpica-unix2-20130626-aapits/tests/aapits/atosxfctrl.c
|
diff -urN acpica-unix2-20130626/tests/aapits/atosxfctrl.c acpica-unix2-20130626-aapits/tests/aapits/atosxfctrl.c
|
||||||
--- acpica-unix2-20130626/tests/aapits/atosxfctrl.c 2013-01-17 12:48:28.000000000 -0700
|
--- acpica-unix2-20130626/tests/aapits/atosxfctrl.c 2013-01-17 12:48:28.000000000 -0700
|
||||||
+++ acpica-unix2-20130626-aapits/tests/aapits/atosxfctrl.c 2013-07-25 13:30:00.375492751 -0600
|
+++ acpica-unix2-20130626-aapits/tests/aapits/atosxfctrl.c 2013-07-25 13:30:00.375492751 -0600
|
||||||
@@ -622,13 +622,15 @@
|
@@ -737,13 +737,15 @@
|
||||||
#if ACPI_MACHINE_WIDTH == 64
|
#if ACPI_MACHINE_WIDTH == 64
|
||||||
#ifdef _MSC_VER
|
#ifdef _MSC_VER
|
||||||
printf("OsxfCtrlFingReg: unexpected Width %d of Reg 0x%I64x\n",
|
printf("OsxfCtrlFingReg: unexpected Width %d of Reg 0x%I64x\n",
|
||||||
@ -208,7 +208,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atosxfctrl.c acpica-unix2-20130626-
|
|||||||
return (NULL);
|
return (NULL);
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -649,15 +651,19 @@
|
@@ -764,15 +766,19 @@
|
||||||
#ifdef _MSC_VER
|
#ifdef _MSC_VER
|
||||||
printf("OsxfCtrlFingReg: intersection Regs (0x%I64x: 0x%x)"
|
printf("OsxfCtrlFingReg: intersection Regs (0x%I64x: 0x%x)"
|
||||||
" and (0x%I64x: 0x%x)\n",
|
" and (0x%I64x: 0x%x)\n",
|
||||||
@ -229,7 +229,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atosxfctrl.c acpica-unix2-20130626-
|
|||||||
return (NULL);
|
return (NULL);
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
@@ -671,13 +677,15 @@
|
@@ -786,13 +792,15 @@
|
||||||
#if ACPI_MACHINE_WIDTH == 64
|
#if ACPI_MACHINE_WIDTH == 64
|
||||||
#ifdef _MSC_VER
|
#ifdef _MSC_VER
|
||||||
printf("OsxfCtrlFingReg: no memory for Reg (0x%I64x: 0x%x)\n",
|
printf("OsxfCtrlFingReg: no memory for Reg (0x%I64x: 0x%x)\n",
|
||||||
@ -246,7 +246,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atosxfctrl.c acpica-unix2-20130626-
|
|||||||
return (NULL);
|
return (NULL);
|
||||||
}
|
}
|
||||||
Reg->Type = Type;
|
Reg->Type = Type;
|
||||||
@@ -817,14 +825,19 @@
|
@@ -932,14 +940,19 @@
|
||||||
#if ACPI_MACHINE_WIDTH == 64
|
#if ACPI_MACHINE_WIDTH == 64
|
||||||
#ifdef _MSC_VER
|
#ifdef _MSC_VER
|
||||||
printf("%.2u (%s Address 0x%I64x: Width %.2u) r/w counts: %u/%u\n",
|
printf("%.2u (%s Address 0x%I64x: Width %.2u) r/w counts: %u/%u\n",
|
||||||
@ -270,7 +270,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atosxfctrl.c acpica-unix2-20130626-
|
|||||||
diff -urN acpica-unix2-20130626/tests/aapits/atresource.c acpica-unix2-20130626-aapits/tests/aapits/atresource.c
|
diff -urN acpica-unix2-20130626/tests/aapits/atresource.c acpica-unix2-20130626-aapits/tests/aapits/atresource.c
|
||||||
--- acpica-unix2-20130626/tests/aapits/atresource.c 2013-01-17 12:48:29.000000000 -0700
|
--- acpica-unix2-20130626/tests/aapits/atresource.c 2013-01-17 12:48:29.000000000 -0700
|
||||||
+++ acpica-unix2-20130626-aapits/tests/aapits/atresource.c 2013-07-25 13:25:49.423565947 -0600
|
+++ acpica-unix2-20130626-aapits/tests/aapits/atresource.c 2013-07-25 13:25:49.423565947 -0600
|
||||||
@@ -65,7 +65,7 @@
|
@@ -174,7 +174,7 @@
|
||||||
AapiErrors++;
|
AapiErrors++;
|
||||||
printf ("API Error: AcpiGetCurrentResources(%s) returned Length %d,"
|
printf ("API Error: AcpiGetCurrentResources(%s) returned Length %d,"
|
||||||
" expected %d\n",
|
" expected %d\n",
|
||||||
@ -279,7 +279,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atresource.c acpica-unix2-20130626-
|
|||||||
return (AE_ERROR);
|
return (AE_ERROR);
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -381,7 +381,7 @@
|
@@ -490,7 +490,7 @@
|
||||||
AapiErrors++;
|
AapiErrors++;
|
||||||
printf ("API Error: AcpiGetCurrentResources(%s) returned Length %d,"
|
printf ("API Error: AcpiGetCurrentResources(%s) returned Length %d,"
|
||||||
" expected %d\n",
|
" expected %d\n",
|
||||||
@ -288,7 +288,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atresource.c acpica-unix2-20130626-
|
|||||||
return (AE_ERROR);
|
return (AE_ERROR);
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -580,7 +580,7 @@
|
@@ -689,7 +689,7 @@
|
||||||
AapiErrors++;
|
AapiErrors++;
|
||||||
printf ("Api Error: Resource->Length (%d) != %d\n",
|
printf ("Api Error: Resource->Length (%d) != %d\n",
|
||||||
CurrentResource->Length,
|
CurrentResource->Length,
|
||||||
@ -297,7 +297,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atresource.c acpica-unix2-20130626-
|
|||||||
}
|
}
|
||||||
|
|
||||||
if (CurrentResource->Data.Irq.Triggering != 0) /* Level-Triggered */
|
if (CurrentResource->Data.Irq.Triggering != 0) /* Level-Triggered */
|
||||||
@@ -872,7 +872,7 @@
|
@@ -981,7 +981,7 @@
|
||||||
AapiErrors++;
|
AapiErrors++;
|
||||||
printf ("API Error: AcpiGetPossibleResources(%s) returned Length %d,"
|
printf ("API Error: AcpiGetPossibleResources(%s) returned Length %d,"
|
||||||
" expected %d\n",
|
" expected %d\n",
|
||||||
@ -306,7 +306,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atresource.c acpica-unix2-20130626-
|
|||||||
return (AE_ERROR);
|
return (AE_ERROR);
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -1814,7 +1814,7 @@
|
@@ -1923,7 +1923,7 @@
|
||||||
AapiErrors++;
|
AapiErrors++;
|
||||||
printf ("API Error: AcpiGetIrqRoutingTable(%s) returned Length %d,"
|
printf ("API Error: AcpiGetIrqRoutingTable(%s) returned Length %d,"
|
||||||
" expected %d\n",
|
" expected %d\n",
|
||||||
|
@ -27,7 +27,6 @@ Patch0: debian-big_endian.patch
|
|||||||
Patch1: debian-unaligned.patch
|
Patch1: debian-unaligned.patch
|
||||||
Patch2: name-miscompare.patch
|
Patch2: name-miscompare.patch
|
||||||
Patch3: aapits-linux.patch
|
Patch3: aapits-linux.patch
|
||||||
Patch4: makefile-config.patch
|
|
||||||
|
|
||||||
BuildRequires: bison patchutils flex
|
BuildRequires: bison patchutils flex
|
||||||
|
|
||||||
@ -82,7 +81,6 @@ gzip -dc %{SOURCE1} | tar -x --strip-components=1 -f -
|
|||||||
%patch1 -p1 -b .debian-unaligned
|
%patch1 -p1 -b .debian-unaligned
|
||||||
%patch2 -p1 -b .name-miscompare
|
%patch2 -p1 -b .name-miscompare
|
||||||
%patch3 -p1 -b .aapits-linux
|
%patch3 -p1 -b .aapits-linux
|
||||||
%patch4 -p1 -b .makefile-config
|
|
||||||
|
|
||||||
cp -p %{SOURCE2} README.Fedora
|
cp -p %{SOURCE2} README.Fedora
|
||||||
cp -p %{SOURCE3} iasl.1
|
cp -p %{SOURCE3} iasl.1
|
||||||
@ -189,6 +187,9 @@ fi
|
|||||||
%changelog
|
%changelog
|
||||||
* Mon Nov 25 2013 Al Stone <ahs3@redhat.com> - 20131115-1
|
* Mon Nov 25 2013 Al Stone <ahs3@redhat.com> - 20131115-1
|
||||||
- Update to latest upstream. Closes BZ#1031255.
|
- Update to latest upstream. Closes BZ#1031255.
|
||||||
|
- Add a little code to workaround build problems that can occur (the tests
|
||||||
|
will fail) when a build starts before midnight, but ends after midnight
|
||||||
|
- Remove patch to include Makefile.config that was missing from tarball.
|
||||||
|
|
||||||
* Wed Oct 09 2013 Al Stone <ahs3@redhat.com> - 20130927-1
|
* Wed Oct 09 2013 Al Stone <ahs3@redhat.com> - 20130927-1
|
||||||
- Update to latest upstream. Closes BZ#1013090.
|
- Update to latest upstream. Closes BZ#1013090.
|
||||||
|
@ -2458,7 +2458,7 @@ diff --git a/source/include/platform/aclinux.h b/source/include/platform/aclinux
|
|||||||
index 3bc85bc..1bace7f 100644
|
index 3bc85bc..1bace7f 100644
|
||||||
--- a/source/include/platform/aclinux.h
|
--- a/source/include/platform/aclinux.h
|
||||||
+++ b/source/include/platform/aclinux.h
|
+++ b/source/include/platform/aclinux.h
|
||||||
@@ -81,13 +81,14 @@
|
@@ -83,13 +83,14 @@
|
||||||
#include <stdlib.h>
|
#include <stdlib.h>
|
||||||
#include <ctype.h>
|
#include <ctype.h>
|
||||||
#include <unistd.h>
|
#include <unistd.h>
|
||||||
@ -2467,14 +2467,14 @@ index 3bc85bc..1bace7f 100644
|
|||||||
/* Host-dependent types and defines for user-space ACPICA */
|
/* Host-dependent types and defines for user-space ACPICA */
|
||||||
|
|
||||||
#define ACPI_FLUSH_CPU_CACHE()
|
#define ACPI_FLUSH_CPU_CACHE()
|
||||||
#define ACPI_CAST_PTHREAD_T(pthread) ((ACPI_THREAD_ID) (pthread))
|
#define ACPI_CAST_PTHREAD_T(Pthread) ((ACPI_THREAD_ID) (Pthread))
|
||||||
|
|
||||||
-#if defined(__ia64__) || defined(__x86_64__) || defined(__aarch64__)
|
-#if defined(__ia64__) || defined(__x86_64__) || defined(__aarch64__)
|
||||||
+#if __SIZEOF_LONG__ == 8
|
+#if __SIZEOF_LONG__ == 8
|
||||||
#define ACPI_MACHINE_WIDTH 64
|
#define ACPI_MACHINE_WIDTH 64
|
||||||
#define COMPILER_DEPENDENT_INT64 long
|
#define COMPILER_DEPENDENT_INT64 long
|
||||||
#define COMPILER_DEPENDENT_UINT64 unsigned long
|
#define COMPILER_DEPENDENT_UINT64 unsigned long
|
||||||
@@ -98,6 +99,10 @@
|
@@ -100,6 +99,10 @@
|
||||||
#define ACPI_USE_NATIVE_DIVIDE
|
#define ACPI_USE_NATIVE_DIVIDE
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
|
@ -1,219 +0,0 @@
|
|||||||
diff -urN acpica-unix2-20130927/generate/unix/Makefile.config acpica-unix2-20130927-patch/generate/unix/Makefile.config
|
|
||||||
--- acpica-unix2-20130927/generate/unix/Makefile.config 1969-12-31 17:00:00.000000000 -0700
|
|
||||||
+++ acpica-unix2-20130927-patch/generate/unix/Makefile.config 2013-10-09 12:27:41.138512023 -0600
|
|
||||||
@@ -0,0 +1,215 @@
|
|
||||||
+#
|
|
||||||
+# Makefile.config
|
|
||||||
+#
|
|
||||||
+# Common configuration and setup file to generate the ACPICA tools and
|
|
||||||
+# utilities: the iASL compiler, acpiexec, acpihelp, acpinames, acpisrc,
|
|
||||||
+# acpixtract, acpibin.
|
|
||||||
+#
|
|
||||||
+# This file is included by the individual makefiles for each tool.
|
|
||||||
+#
|
|
||||||
+
|
|
||||||
+#
|
|
||||||
+# Note: This makefile is intended to be used from within the native
|
|
||||||
+# ACPICA directory structure, from under generate/unix. It specifically
|
|
||||||
+# places all object files in a generate/unix subdirectory, not within
|
|
||||||
+# the various ACPICA source directories. This prevents collisions
|
|
||||||
+# between different compilations of the same source file with different
|
|
||||||
+# compile options, and prevents pollution of the source code.
|
|
||||||
+#
|
|
||||||
+
|
|
||||||
+#
|
|
||||||
+# Configuration
|
|
||||||
+#
|
|
||||||
+# OPT_CFLAGS can be overridden on the make command line by
|
|
||||||
+# adding OPT_CFLAGS="..." to the invocation.
|
|
||||||
+#
|
|
||||||
+# Notes:
|
|
||||||
+# gcc should be version 4 or greater, otherwise some of the options
|
|
||||||
+# used will not be recognized.
|
|
||||||
+# Optional: Set HOST to an appropriate value (_LINUX, _FreeBSD, _APPLE, _CYGWIN, etc.)
|
|
||||||
+# See include/platform/acenv.h for supported values.
|
|
||||||
+# Note: HOST is not nearly as important for applications as it
|
|
||||||
+# is for the kernel-resident version of ACPICA, and it may
|
|
||||||
+# not be necessary to change it.
|
|
||||||
+#
|
|
||||||
+.SUFFIXES :
|
|
||||||
+PROGS = acpibin acpidump acpiexec acpihelp acpinames acpisrc acpixtract iasl
|
|
||||||
+HOST ?= _CYGWIN
|
|
||||||
+CC = gcc
|
|
||||||
+
|
|
||||||
+#
|
|
||||||
+# Common defines
|
|
||||||
+#
|
|
||||||
+OBJDIR = obj
|
|
||||||
+BINDIR = bin
|
|
||||||
+COMPILEOBJ = $(CC) -c $(CFLAGS) $(OPT_CFLAGS) -o $@ $<
|
|
||||||
+LINKPROG = $(CC) $(OBJECTS) -o $(PROG) $(LDFLAGS)
|
|
||||||
+PREFIX ?= /usr
|
|
||||||
+INSTALLDIR = $(PREFIX)/bin
|
|
||||||
+
|
|
||||||
+ifeq ($(HOST), _APPLE)
|
|
||||||
+INSTALL = cp
|
|
||||||
+INSTALLFLAGS ?= -f
|
|
||||||
+else
|
|
||||||
+INSTALL = install
|
|
||||||
+INSTALLFLAGS ?= -m 555 -s
|
|
||||||
+endif
|
|
||||||
+
|
|
||||||
+INSTALLPROG = \
|
|
||||||
+ mkdir -p $(DESTDIR)$(INSTALLDIR); \
|
|
||||||
+ $(INSTALL) $(INSTALLFLAGS) ../$(BINDIR)/$(PROG) $(DESTDIR)$(INSTALLDIR)/$(PROG)
|
|
||||||
+
|
|
||||||
+#
|
|
||||||
+# Rename a .exe file if necessary
|
|
||||||
+#
|
|
||||||
+RENAMEPROG = \
|
|
||||||
+ @if [ -e "$(PROG).exe" ] ; then \
|
|
||||||
+ mv $(PROG).exe $(PROG); \
|
|
||||||
+ echo "Renamed $(PROG).exe to $(PROG)"; \
|
|
||||||
+ fi;
|
|
||||||
+
|
|
||||||
+#
|
|
||||||
+# Copy the final executable to the local bin directory
|
|
||||||
+#
|
|
||||||
+COPYPROG = \
|
|
||||||
+ @mkdir -p ../$(BINDIR); \
|
|
||||||
+ cp -f $(PROG) ../$(BINDIR); \
|
|
||||||
+ echo "Copied $(PROG) to $(FINAL_PROG)";
|
|
||||||
+
|
|
||||||
+#
|
|
||||||
+# Main ACPICA source directories
|
|
||||||
+#
|
|
||||||
+ACPICA_SRC = ../../../source
|
|
||||||
+ACPICA_COMMON = $(ACPICA_SRC)/common
|
|
||||||
+ACPICA_TOOLS = $(ACPICA_SRC)/tools
|
|
||||||
+ACPICA_OSL = $(ACPICA_SRC)/os_specific/service_layers
|
|
||||||
+ACPICA_CORE = $(ACPICA_SRC)/components
|
|
||||||
+ACPICA_INCLUDE = $(ACPICA_SRC)/include
|
|
||||||
+ACPICA_DEBUGGER = $(ACPICA_CORE)/debugger
|
|
||||||
+ACPICA_DISASSEMBLER = $(ACPICA_CORE)/disassembler
|
|
||||||
+ACPICA_DISPATCHER = $(ACPICA_CORE)/dispatcher
|
|
||||||
+ACPICA_EVENTS = $(ACPICA_CORE)/events
|
|
||||||
+ACPICA_EXECUTER = $(ACPICA_CORE)/executer
|
|
||||||
+ACPICA_HARDWARE = $(ACPICA_CORE)/hardware
|
|
||||||
+ACPICA_NAMESPACE = $(ACPICA_CORE)/namespace
|
|
||||||
+ACPICA_PARSER = $(ACPICA_CORE)/parser
|
|
||||||
+ACPICA_RESOURCES = $(ACPICA_CORE)/resources
|
|
||||||
+ACPICA_TABLES = $(ACPICA_CORE)/tables
|
|
||||||
+ACPICA_UTILITIES = $(ACPICA_CORE)/utilities
|
|
||||||
+
|
|
||||||
+#
|
|
||||||
+# ACPICA tool and utility source directories
|
|
||||||
+#
|
|
||||||
+ACPIBIN = $(ACPICA_TOOLS)/acpibin
|
|
||||||
+ACPIDUMP = $(ACPICA_TOOLS)/acpidump
|
|
||||||
+ACPIEXEC = $(ACPICA_TOOLS)/acpiexec
|
|
||||||
+ACPIHELP = $(ACPICA_TOOLS)/acpihelp
|
|
||||||
+ACPINAMES = $(ACPICA_TOOLS)/acpinames
|
|
||||||
+ACPISRC = $(ACPICA_TOOLS)/acpisrc
|
|
||||||
+ACPIXTRACT = $(ACPICA_TOOLS)/acpixtract
|
|
||||||
+ASL_COMPILER = $(ACPICA_SRC)/compiler
|
|
||||||
+
|
|
||||||
+#
|
|
||||||
+# Common ACPICA header files
|
|
||||||
+#
|
|
||||||
+ACPICA_HEADERS = \
|
|
||||||
+ $(wildcard $(ACPICA_INCLUDE)/*.h) \
|
|
||||||
+ $(wildcard $(ACPICA_INCLUDE)/platform/*.h)
|
|
||||||
+
|
|
||||||
+#
|
|
||||||
+# Common compiler flags
|
|
||||||
+#
|
|
||||||
+# Flags/option notes:
|
|
||||||
+# Global optimization flags (such as -O2, -Os) are not used,
|
|
||||||
+# since they cause issues on some compilers (such as gcc 4.4)
|
|
||||||
+# The _GNU_SOURCE symbol is required for many hosts.
|
|
||||||
+#
|
|
||||||
+OPT_CFLAGS ?= \
|
|
||||||
+ -D_FORTIFY_SOURCE=2\
|
|
||||||
+ $(CWARNINGFLAGS)
|
|
||||||
+
|
|
||||||
+CFLAGS += \
|
|
||||||
+ -D$(HOST)\
|
|
||||||
+ -D_GNU_SOURCE\
|
|
||||||
+ -I$(ACPICA_INCLUDE)
|
|
||||||
+
|
|
||||||
+#
|
|
||||||
+# Common compiler warning flags. The warning flags in addition
|
|
||||||
+# to -Wall are not automatically included in -Wall.
|
|
||||||
+#
|
|
||||||
+CWARNINGFLAGS = \
|
|
||||||
+ -ansi\
|
|
||||||
+ -Wall\
|
|
||||||
+ -Wbad-function-cast\
|
|
||||||
+ -Wdeclaration-after-statement\
|
|
||||||
+ -Werror\
|
|
||||||
+ -Wformat=2\
|
|
||||||
+ -Wmissing-declarations\
|
|
||||||
+ -Wmissing-prototypes\
|
|
||||||
+ -Wstrict-aliasing=0\
|
|
||||||
+ -Wstrict-prototypes\
|
|
||||||
+ -Wswitch-default\
|
|
||||||
+ -Wpointer-arith\
|
|
||||||
+ -Wundef
|
|
||||||
+
|
|
||||||
+#
|
|
||||||
+# Common gcc 4+ warning flags
|
|
||||||
+#
|
|
||||||
+CWARNINGFLAGS += \
|
|
||||||
+ -Waddress\
|
|
||||||
+ -Waggregate-return\
|
|
||||||
+ -Wchar-subscripts\
|
|
||||||
+ -Wmissing-declarations\
|
|
||||||
+ -Wmissing-field-initializers\
|
|
||||||
+ -Wnested-externs\
|
|
||||||
+ -Wold-style-definition\
|
|
||||||
+ -Wno-format-nonliteral\
|
|
||||||
+ -Wredundant-decls
|
|
||||||
+
|
|
||||||
+#
|
|
||||||
+# Per-host flags and exclusions
|
|
||||||
+#
|
|
||||||
+ifneq ($(HOST), _FreeBSD)
|
|
||||||
+ CWARNINGFLAGS += \
|
|
||||||
+ -Wempty-body
|
|
||||||
+
|
|
||||||
+ ifneq ($(HOST), _APPLE)
|
|
||||||
+ CWARNINGFLAGS += \
|
|
||||||
+ -Wlogical-op\
|
|
||||||
+ -Wmissing-parameter-type\
|
|
||||||
+ -Wold-style-declaration\
|
|
||||||
+ -Wtype-limits
|
|
||||||
+ endif
|
|
||||||
+endif
|
|
||||||
+
|
|
||||||
+#
|
|
||||||
+# Extra warning flags (for possible future use)
|
|
||||||
+#
|
|
||||||
+#CWARNINGFLAGS += \
|
|
||||||
+# -Wcast-qual\
|
|
||||||
+# -Wconversion\
|
|
||||||
+# -Wshadow\
|
|
||||||
+
|
|
||||||
+#
|
|
||||||
+# Bison/Flex configuration
|
|
||||||
+#
|
|
||||||
+# -y: act like yacc
|
|
||||||
+#
|
|
||||||
+# -i: generate case insensitive scanner
|
|
||||||
+# -s: suppress default rule, abort on unknown input
|
|
||||||
+#
|
|
||||||
+# Optional for Bison/yacc:
|
|
||||||
+# -v: verbose, produces a .output file
|
|
||||||
+# -d: produces the defines header file
|
|
||||||
+#
|
|
||||||
+# Berkeley yacc configuration
|
|
||||||
+#
|
|
||||||
+#YACC= byacc
|
|
||||||
+#YFLAGS +=
|
|
||||||
+#
|
|
||||||
+YACC= bison
|
|
||||||
+YFLAGS += -y
|
|
||||||
+
|
|
||||||
+LEX= flex
|
|
||||||
+LFLAGS += -i -s
|
|
||||||
+
|
|
Loading…
Reference in New Issue
Block a user