aslts: fix the ASLTS makefile so the test suite will actually run
Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
parent
461b6bd9e3
commit
9ee91c538e
@ -35,6 +35,7 @@ Patch8: asllookup-ppc64.patch
|
||||
Patch9: template.patch
|
||||
Patch10: free.patch
|
||||
Patch11: update-big-endian.patch
|
||||
Patch12: aslts.patch
|
||||
|
||||
BuildRequires: bison patchutils flex
|
||||
|
||||
@ -96,6 +97,7 @@ gzip -dc %{SOURCE1} | tar -x --strip-components=1 -f -
|
||||
%patch9 -p1 -b .template
|
||||
%patch10 -p1 -b .free
|
||||
%patch11 -p1 -b .update-big-endian
|
||||
%patch12 -p1 -b .aslts
|
||||
|
||||
cp -p %{SOURCE2} README.Fedora
|
||||
cp -p %{SOURCE3} iasl.1
|
||||
@ -193,6 +195,7 @@ fi
|
||||
* Fri Jan 27 2017 Al Stone <ahs3@redhat.com> - 20170119-1
|
||||
- Update to latest upstream. Closes BZ#1381017.
|
||||
- Refresh patches.
|
||||
- Add patch to fix ASLTS.
|
||||
|
||||
* Mon Jan 9 2017 Al Stone <ahs3@redhat.com> - 20161222-1
|
||||
- Update to latest upstream. Closes BZ#1381017.
|
||||
|
12
aslts.patch
Normal file
12
aslts.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Naur acpica-unix2-20170119.orig/tests/aslts/Makefile.def acpica-unix2-20170119/tests/aslts/Makefile.def
|
||||
--- acpica-unix2-20170119.orig/tests/aslts/Makefile.def 2017-01-27 17:36:03.736555369 -0700
|
||||
+++ acpica-unix2-20170119/tests/aslts/Makefile.def 2017-01-27 17:36:46.171389519 -0700
|
||||
@@ -123,7 +123,7 @@
|
||||
if [ x$$base != xaslts ]; then \
|
||||
echo "Bad base name of ASLTS Test Suite: <$$base> of <$$dd>"; exit 1; \
|
||||
else \
|
||||
- x=`"$(ASL)" -va xxx | grep "Compiler version"`; \
|
||||
+ x=`"$(ASL)" -va xxx | grep "Compiler/Disassembler version"`; \
|
||||
echo "---- iASL version: $$x"; \
|
||||
if [ -z "$$x" ]; then \
|
||||
echo "Bad iASL 2: bad signon <$(ASL)>"; exit 1; \
|
Loading…
Reference in New Issue
Block a user