Update to 20160318 upstream sources
Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
parent
dd9e328dd5
commit
7d2a7f8daf
2
.gitignore
vendored
2
.gitignore
vendored
@ -46,3 +46,5 @@
|
||||
/acpitests-unix-20160108.tar.gz
|
||||
/acpica-unix2-20160212.tar.gz
|
||||
/acpitests-unix-20160212.tar.gz
|
||||
/acpica-unix2-20160318.tar.gz
|
||||
/acpitests-unix-20160318.tar.gz
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: acpica-unix2-20151124/generate/unix/Makefile.config
|
||||
Index: acpica-unix2-20160318/generate/unix/Makefile.config
|
||||
===================================================================
|
||||
--- acpica-unix2-20151124.orig/generate/unix/Makefile.config
|
||||
+++ acpica-unix2-20151124/generate/unix/Makefile.config
|
||||
--- acpica-unix2-20160318.orig/generate/unix/Makefile.config
|
||||
+++ acpica-unix2-20160318/generate/unix/Makefile.config
|
||||
@@ -23,6 +23,9 @@
|
||||
# OPT_CFLAGS can be overridden on the make command line by
|
||||
# adding OPT_CFLAGS="..." to the invocation.
|
||||
@ -21,7 +21,7 @@ Index: acpica-unix2-20151124/generate/unix/Makefile.config
|
||||
PREFIX ?= /usr
|
||||
INSTALLDIR = $(PREFIX)/bin
|
||||
UNAME_S := $(shell uname -s)
|
||||
@@ -144,6 +147,11 @@ ACPICA_HEADERS = \
|
||||
@@ -148,6 +151,11 @@ ACPICA_HEADERS = \
|
||||
OPT_CFLAGS ?= $(CWARNINGFLAGS)
|
||||
|
||||
#
|
||||
|
@ -1,5 +1,5 @@
|
||||
Name: acpica-tools
|
||||
Version: 20160212
|
||||
Version: 20160318
|
||||
Release: 1%{?dist}
|
||||
Summary: ACPICA tools for the development and debug of ACPI tables
|
||||
|
||||
@ -186,6 +186,10 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Mar 19 2016 Al Stone <ahs3@redhat.com> - 20160318-1
|
||||
- Update to latest upstream. Closes BZ#1319359.
|
||||
- Refresh patches.
|
||||
|
||||
* Mon Feb 22 2016 Al Stone <ahs3@redhat.com> - 20160212-1
|
||||
- Update to latest upstream. Closes BZ#1307192.
|
||||
- Refresh patches.
|
||||
|
@ -7,10 +7,10 @@ From: Al Stone <ahs3@redhat.com>
|
||||
source/compiler/asllookup.c | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/source/compiler/asllookup.c b/source/compiler/asllookup.c
|
||||
index 49b4901..9a1d489 100644
|
||||
--- a/source/compiler/asllookup.c
|
||||
+++ b/source/compiler/asllookup.c
|
||||
Index: acpica-unix2-20160318/source/compiler/asllookup.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/compiler/asllookup.c
|
||||
+++ acpica-unix2-20160318/source/compiler/asllookup.c
|
||||
@@ -119,6 +119,7 @@ LkIsObjectUsed (
|
||||
{
|
||||
ACPI_NAMESPACE_NODE *Node = ACPI_CAST_PTR (ACPI_NAMESPACE_NODE, ObjHandle);
|
||||
|
@ -7,10 +7,10 @@ From: Al Stone <ahs3@redhat.com>
|
||||
source/compiler/asllookup.c | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/source/compiler/asllookup.c b/source/compiler/asllookup.c
|
||||
index 9a1d489..a226f7d 100644
|
||||
--- a/source/compiler/asllookup.c
|
||||
+++ b/source/compiler/asllookup.c
|
||||
Index: acpica-unix2-20160318/source/compiler/asllookup.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/compiler/asllookup.c
|
||||
+++ acpica-unix2-20160318/source/compiler/asllookup.c
|
||||
@@ -176,7 +176,8 @@ LkIsObjectUsed (
|
||||
* We ignore the predefined methods since often, not
|
||||
* all arguments are needed or used.
|
||||
|
@ -18,10 +18,10 @@ support
|
||||
source/include/platform/aclinux.h | 8 ++
|
||||
12 files changed, 487 insertions(+), 283 deletions(-)
|
||||
|
||||
diff --git a/source/compiler/aslcodegen.c b/source/compiler/aslcodegen.c
|
||||
index cb3a4a5..f63a320 100644
|
||||
--- a/source/compiler/aslcodegen.c
|
||||
+++ b/source/compiler/aslcodegen.c
|
||||
Index: acpica-unix2-20160318/source/compiler/aslcodegen.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/compiler/aslcodegen.c
|
||||
+++ acpica-unix2-20160318/source/compiler/aslcodegen.c
|
||||
@@ -243,16 +243,12 @@ CgWriteAmlOpcode (
|
||||
ACPI_PARSE_OBJECT *Op)
|
||||
{
|
||||
@ -235,7 +235,7 @@ index cb3a4a5..f63a320 100644
|
||||
|
||||
/* Always check for DEFAULT_ARG and other "Noop" nodes */
|
||||
/* TBD: this may not be the best place for this check */
|
||||
@@ -595,13 +605,24 @@ CgWriteNode (
|
||||
@@ -601,13 +611,24 @@ CgWriteNode (
|
||||
switch (Op->Asl.AmlOpcode)
|
||||
{
|
||||
case AML_RAW_DATA_BYTE:
|
||||
@ -263,11 +263,11 @@ index cb3a4a5..f63a320 100644
|
||||
|
||||
case AML_RAW_DATA_BUFFER:
|
||||
|
||||
diff --git a/source/compiler/aslopcodes.c b/source/compiler/aslopcodes.c
|
||||
index e0b73ec..84bdfd6 100644
|
||||
--- a/source/compiler/aslopcodes.c
|
||||
+++ b/source/compiler/aslopcodes.c
|
||||
@@ -534,6 +534,7 @@ OpcDoUnicode (
|
||||
Index: acpica-unix2-20160318/source/compiler/aslopcodes.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/compiler/aslopcodes.c
|
||||
+++ acpica-unix2-20160318/source/compiler/aslopcodes.c
|
||||
@@ -481,6 +481,7 @@ OpcDoUnicode (
|
||||
UINT32 i;
|
||||
UINT8 *AsciiString;
|
||||
UINT16 *UnicodeString;
|
||||
@ -275,7 +275,7 @@ index e0b73ec..84bdfd6 100644
|
||||
ACPI_PARSE_OBJECT *BufferLengthOp;
|
||||
|
||||
|
||||
@@ -560,7 +561,8 @@ OpcDoUnicode (
|
||||
@@ -507,7 +508,8 @@ OpcDoUnicode (
|
||||
|
||||
for (i = 0; i < Count; i++)
|
||||
{
|
||||
@ -285,10 +285,10 @@ index e0b73ec..84bdfd6 100644
|
||||
}
|
||||
|
||||
/*
|
||||
diff --git a/source/compiler/aslrestype1.c b/source/compiler/aslrestype1.c
|
||||
index 3f967ca..c9f52f4 100644
|
||||
--- a/source/compiler/aslrestype1.c
|
||||
+++ b/source/compiler/aslrestype1.c
|
||||
Index: acpica-unix2-20160318/source/compiler/aslrestype1.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/compiler/aslrestype1.c
|
||||
+++ acpica-unix2-20160318/source/compiler/aslrestype1.c
|
||||
@@ -142,6 +142,11 @@ RsDoMemory24Descriptor (
|
||||
ACPI_PARSE_OBJECT *LengthOp = NULL;
|
||||
ASL_RESOURCE_NODE *Rnode;
|
||||
@ -485,10 +485,10 @@ index 3f967ca..c9f52f4 100644
|
||||
RsCreateDwordField (InitializerOp, ACPI_RESTAG_LENGTH,
|
||||
CurrentByteOffset + ASL_RESDESC_OFFSET (FixedMemory32.AddressLength));
|
||||
break;
|
||||
diff --git a/source/compiler/aslrestype1i.c b/source/compiler/aslrestype1i.c
|
||||
index 07fc146..28f396e 100644
|
||||
--- a/source/compiler/aslrestype1i.c
|
||||
+++ b/source/compiler/aslrestype1i.c
|
||||
Index: acpica-unix2-20160318/source/compiler/aslrestype1i.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/compiler/aslrestype1i.c
|
||||
+++ acpica-unix2-20160318/source/compiler/aslrestype1i.c
|
||||
@@ -198,6 +198,8 @@ RsDoFixedDmaDescriptor (
|
||||
ACPI_PARSE_OBJECT *InitializerOp;
|
||||
ASL_RESOURCE_NODE *Rnode;
|
||||
@ -625,10 +625,10 @@ index 07fc146..28f396e 100644
|
||||
+ ACPI_MOVE_16_TO_16(&Descriptor->Irq.IrqMask, &IrqMask);
|
||||
return (Rnode);
|
||||
}
|
||||
diff --git a/source/compiler/aslrestype2.c b/source/compiler/aslrestype2.c
|
||||
index 4a01795..dd6853c 100644
|
||||
--- a/source/compiler/aslrestype2.c
|
||||
+++ b/source/compiler/aslrestype2.c
|
||||
Index: acpica-unix2-20160318/source/compiler/aslrestype2.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/compiler/aslrestype2.c
|
||||
+++ acpica-unix2-20160318/source/compiler/aslrestype2.c
|
||||
@@ -76,6 +76,7 @@ RsDoGeneralRegisterDescriptor (
|
||||
ACPI_PARSE_OBJECT *InitializerOp;
|
||||
ASL_RESOURCE_NODE *Rnode;
|
||||
@ -725,10 +725,10 @@ index 4a01795..dd6853c 100644
|
||||
|
||||
/* Point to end-of-descriptor for vendor data */
|
||||
|
||||
diff --git a/source/compiler/aslrestype2d.c b/source/compiler/aslrestype2d.c
|
||||
index caca601..f1c737b 100644
|
||||
--- a/source/compiler/aslrestype2d.c
|
||||
+++ b/source/compiler/aslrestype2d.c
|
||||
Index: acpica-unix2-20160318/source/compiler/aslrestype2d.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/compiler/aslrestype2d.c
|
||||
+++ acpica-unix2-20160318/source/compiler/aslrestype2d.c
|
||||
@@ -79,7 +79,13 @@ RsDoDwordIoDescriptor (
|
||||
ACPI_PARSE_OBJECT *GranOp = NULL;
|
||||
ASL_RESOURCE_NODE *Rnode;
|
||||
@ -1084,10 +1084,10 @@ index caca601..f1c737b 100644
|
||||
Rnode->BufferLength = sizeof (AML_RESOURCE_ADDRESS32) +
|
||||
OptionIndex + StringLength;
|
||||
return (Rnode);
|
||||
diff --git a/source/compiler/aslrestype2e.c b/source/compiler/aslrestype2e.c
|
||||
index eec1247..989ba5f 100644
|
||||
--- a/source/compiler/aslrestype2e.c
|
||||
+++ b/source/compiler/aslrestype2e.c
|
||||
Index: acpica-unix2-20160318/source/compiler/aslrestype2e.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/compiler/aslrestype2e.c
|
||||
+++ acpica-unix2-20160318/source/compiler/aslrestype2e.c
|
||||
@@ -78,6 +78,13 @@ RsDoExtendedIoDescriptor (
|
||||
ACPI_PARSE_OBJECT *GranOp = NULL;
|
||||
ASL_RESOURCE_NODE *Rnode;
|
||||
@ -1193,10 +1193,10 @@ index eec1247..989ba5f 100644
|
||||
Rnode->BufferLength = sizeof (AML_RESOURCE_EXTENDED_ADDRESS64) +
|
||||
StringLength;
|
||||
return (Rnode);
|
||||
diff --git a/source/compiler/aslrestype2q.c b/source/compiler/aslrestype2q.c
|
||||
index 229daae..a0ce2ae 100644
|
||||
--- a/source/compiler/aslrestype2q.c
|
||||
+++ b/source/compiler/aslrestype2q.c
|
||||
Index: acpica-unix2-20160318/source/compiler/aslrestype2q.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/compiler/aslrestype2q.c
|
||||
+++ acpica-unix2-20160318/source/compiler/aslrestype2q.c
|
||||
@@ -80,7 +80,13 @@ RsDoQwordIoDescriptor (
|
||||
ASL_RESOURCE_NODE *Rnode;
|
||||
UINT8 *OptionalFields;
|
||||
@ -1535,10 +1535,10 @@ index 229daae..a0ce2ae 100644
|
||||
Rnode->BufferLength = sizeof (AML_RESOURCE_ADDRESS64) +
|
||||
OptionIndex + StringLength;
|
||||
return (Rnode);
|
||||
diff --git a/source/compiler/aslrestype2s.c b/source/compiler/aslrestype2s.c
|
||||
index c7d5455..ec0cb88 100644
|
||||
--- a/source/compiler/aslrestype2s.c
|
||||
+++ b/source/compiler/aslrestype2s.c
|
||||
Index: acpica-unix2-20160318/source/compiler/aslrestype2s.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/compiler/aslrestype2s.c
|
||||
+++ acpica-unix2-20160318/source/compiler/aslrestype2s.c
|
||||
@@ -290,6 +290,9 @@ RsDoGpioIntDescriptor (
|
||||
UINT16 VendorLength;
|
||||
UINT16 InterruptLength;
|
||||
@ -1852,10 +1852,10 @@ index c7d5455..ec0cb88 100644
|
||||
MpSaveSerialInfo (Info->MappingOp, Descriptor, ResourceSource);
|
||||
return (Rnode);
|
||||
}
|
||||
diff --git a/source/compiler/aslrestype2w.c b/source/compiler/aslrestype2w.c
|
||||
index 98257ad..83c4688 100644
|
||||
--- a/source/compiler/aslrestype2w.c
|
||||
+++ b/source/compiler/aslrestype2w.c
|
||||
Index: acpica-unix2-20160318/source/compiler/aslrestype2w.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/compiler/aslrestype2w.c
|
||||
+++ acpica-unix2-20160318/source/compiler/aslrestype2w.c
|
||||
@@ -81,6 +81,12 @@ RsDoWordIoDescriptor (
|
||||
UINT8 *OptionalFields;
|
||||
UINT16 StringLength = 0;
|
||||
@ -2199,10 +2199,10 @@ index 98257ad..83c4688 100644
|
||||
Rnode->BufferLength = sizeof (AML_RESOURCE_ADDRESS16) +
|
||||
OptionIndex + StringLength;
|
||||
return (Rnode);
|
||||
diff --git a/source/include/acmacros.h b/source/include/acmacros.h
|
||||
index 2dc5c20..967ee78 100644
|
||||
--- a/source/include/acmacros.h
|
||||
+++ b/source/include/acmacros.h
|
||||
Index: acpica-unix2-20160318/source/include/acmacros.h
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/include/acmacros.h
|
||||
+++ acpica-unix2-20160318/source/include/acmacros.h
|
||||
@@ -100,7 +100,8 @@
|
||||
|
||||
/* 32-bit source, 16/32/64 destination */
|
||||
@ -2240,10 +2240,10 @@ index 2dc5c20..967ee78 100644
|
||||
#define ACPI_MOVE_32_TO_32(d, s) *(UINT32 *)(void *)(d) = *(UINT32 *)(void *)(s)
|
||||
#define ACPI_MOVE_32_TO_64(d, s) *(UINT64 *)(void *)(d) = *(UINT32 *)(void *)(s)
|
||||
|
||||
diff --git a/source/include/platform/aclinux.h b/source/include/platform/aclinux.h
|
||||
index 473055f..b37d9f0 100644
|
||||
--- a/source/include/platform/aclinux.h
|
||||
+++ b/source/include/platform/aclinux.h
|
||||
Index: acpica-unix2-20160318/source/include/platform/aclinux.h
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/include/platform/aclinux.h
|
||||
+++ acpica-unix2-20160318/source/include/platform/aclinux.h
|
||||
@@ -170,6 +170,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <ctype.h>
|
||||
|
@ -18,10 +18,10 @@ Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
|
||||
source/include/actypes.h | 26 +++++++++++++-------------
|
||||
3 files changed, 32 insertions(+), 21 deletions(-)
|
||||
|
||||
diff --git a/source/compiler/asltree.c b/source/compiler/asltree.c
|
||||
index 5067640..68f139d 100644
|
||||
--- a/source/compiler/asltree.c
|
||||
+++ b/source/compiler/asltree.c
|
||||
Index: acpica-unix2-20160318/source/compiler/asltree.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/compiler/asltree.c
|
||||
+++ acpica-unix2-20160318/source/compiler/asltree.c
|
||||
@@ -890,28 +890,31 @@ TrCreateValuedLeafNode (
|
||||
"Op %s Value %8.8X%8.8X ",
|
||||
Op->Asl.LineNumber, Op->Asl.Column, Op, UtGetOpName(ParseOpcode),
|
||||
@ -74,10 +74,10 @@ index 5067640..68f139d 100644
|
||||
break;
|
||||
}
|
||||
|
||||
diff --git a/source/components/executer/exoparg2.c b/source/components/executer/exoparg2.c
|
||||
index 25b4be3..0997868 100644
|
||||
--- a/source/components/executer/exoparg2.c
|
||||
+++ b/source/components/executer/exoparg2.c
|
||||
Index: acpica-unix2-20160318/source/components/executer/exoparg2.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/components/executer/exoparg2.c
|
||||
+++ acpica-unix2-20160318/source/components/executer/exoparg2.c
|
||||
@@ -172,6 +172,8 @@ AcpiExOpcode_2A_2T_1R (
|
||||
ACPI_OPERAND_OBJECT **Operand = &WalkState->Operands[0];
|
||||
ACPI_OPERAND_OBJECT *ReturnDesc1 = NULL;
|
||||
@ -118,10 +118,10 @@ index 25b4be3..0997868 100644
|
||||
break;
|
||||
|
||||
case AML_CONCAT_OP: /* Concatenate (Data1, Data2, Result) */
|
||||
diff --git a/source/include/actypes.h b/source/include/actypes.h
|
||||
index 7eb6376..5cc118f 100644
|
||||
--- a/source/include/actypes.h
|
||||
+++ b/source/include/actypes.h
|
||||
Index: acpica-unix2-20160318/source/include/actypes.h
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/include/actypes.h
|
||||
+++ acpica-unix2-20160318/source/include/actypes.h
|
||||
@@ -143,6 +143,19 @@ typedef COMPILER_DEPENDENT_INT64
|
||||
*/
|
||||
#define ACPI_THREAD_ID UINT64
|
||||
|
@ -8,11 +8,11 @@ From: Al Stone <ahs3@redhat.com>
|
||||
generate/unix/iasl/Makefile | 13 +++++++------
|
||||
2 files changed, 9 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/generate/unix/Makefile.config b/generate/unix/Makefile.config
|
||||
index 2c67be4..e8a419e 100644
|
||||
--- a/generate/unix/Makefile.config
|
||||
+++ b/generate/unix/Makefile.config
|
||||
@@ -167,6 +167,8 @@ ifneq ($(NOFORTIFY),TRUE)
|
||||
Index: acpica-unix2-20160318/generate/unix/Makefile.config
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/generate/unix/Makefile.config
|
||||
+++ acpica-unix2-20160318/generate/unix/Makefile.config
|
||||
@@ -171,6 +171,8 @@ ifneq ($(NOFORTIFY),TRUE)
|
||||
OPT_CFLAGS += -D_FORTIFY_SOURCE=2
|
||||
endif
|
||||
|
||||
@ -21,11 +21,11 @@ index 2c67be4..e8a419e 100644
|
||||
CFLAGS += \
|
||||
-D$(HOST)\
|
||||
-D_GNU_SOURCE\
|
||||
diff --git a/generate/unix/iasl/Makefile b/generate/unix/iasl/Makefile
|
||||
index 8b71edd..b403037 100644
|
||||
--- a/generate/unix/iasl/Makefile
|
||||
+++ b/generate/unix/iasl/Makefile
|
||||
@@ -312,20 +312,21 @@ $(OBJDIR)/prparserparse.c $(OBJDIR)/prparser.y.h : $(ASL_COMPILER)/prparse
|
||||
Index: acpica-unix2-20160318/generate/unix/iasl/Makefile
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/generate/unix/iasl/Makefile
|
||||
+++ acpica-unix2-20160318/generate/unix/iasl/Makefile
|
||||
@@ -314,20 +314,21 @@ $(OBJDIR)/prparserparse.c $(OBJDIR)/prpa
|
||||
# Cannot use the common compile warning flags since the C files are created
|
||||
# by the utilities above and they are not necessarily ANSI C, etc.
|
||||
#
|
||||
|
154
int-format.patch
154
int-format.patch
@ -24,11 +24,11 @@ From: Al Stone <ahs3@redhat.com>
|
||||
source/tools/acpiexec/aemain.c | 2 +-
|
||||
18 files changed, 28 insertions(+), 28 deletions(-)
|
||||
|
||||
diff --git a/source/compiler/aslcompile.c b/source/compiler/aslcompile.c
|
||||
index a564f86..9dbabfb 100644
|
||||
--- a/source/compiler/aslcompile.c
|
||||
+++ b/source/compiler/aslcompile.c
|
||||
@@ -726,7 +726,7 @@ CmCleanupAndExit (
|
||||
Index: acpica-unix2-20160318/source/compiler/aslcompile.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/compiler/aslcompile.c
|
||||
+++ acpica-unix2-20160318/source/compiler/aslcompile.c
|
||||
@@ -729,7 +729,7 @@ CmCleanupAndExit (
|
||||
|
||||
if (Gbl_ExceptionCount[ASL_ERROR] > ASL_MAX_ERROR_COUNT)
|
||||
{
|
||||
@ -37,10 +37,10 @@ index a564f86..9dbabfb 100644
|
||||
ASL_MAX_ERROR_COUNT);
|
||||
}
|
||||
|
||||
diff --git a/source/compiler/aslerror.c b/source/compiler/aslerror.c
|
||||
index 2c0516a..bf230ff 100644
|
||||
--- a/source/compiler/aslerror.c
|
||||
+++ b/source/compiler/aslerror.c
|
||||
Index: acpica-unix2-20160318/source/compiler/aslerror.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/compiler/aslerror.c
|
||||
+++ acpica-unix2-20160318/source/compiler/aslerror.c
|
||||
@@ -687,7 +687,7 @@ AslCommonError (
|
||||
Gbl_ExceptionCount[Level]++;
|
||||
if (Gbl_ExceptionCount[ASL_ERROR] > ASL_MAX_ERROR_COUNT)
|
||||
@ -59,11 +59,11 @@ index 2c0516a..bf230ff 100644
|
||||
ASL_MAX_DISABLED_MESSAGES);
|
||||
return (AE_LIMIT);
|
||||
}
|
||||
diff --git a/source/compiler/aslopt.c b/source/compiler/aslopt.c
|
||||
index 05af0be..95b0c10 100644
|
||||
--- a/source/compiler/aslopt.c
|
||||
+++ b/source/compiler/aslopt.c
|
||||
@@ -576,7 +576,7 @@ OptOptimizeNamePath (
|
||||
Index: acpica-unix2-20160318/source/compiler/aslopt.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/compiler/aslopt.c
|
||||
+++ acpica-unix2-20160318/source/compiler/aslopt.c
|
||||
@@ -584,7 +584,7 @@ OptOptimizeNamePath (
|
||||
}
|
||||
|
||||
ACPI_DEBUG_PRINT_RAW ((ACPI_DB_OPTIMIZATIONS,
|
||||
@ -72,10 +72,10 @@ index 05af0be..95b0c10 100644
|
||||
Op->Asl.LogicalLineNumber,
|
||||
AcpiPsGetOpcodeName (Op->Common.Parent->Common.AmlOpcode),
|
||||
AcpiPsGetOpcodeName (Op->Common.AmlOpcode)));
|
||||
diff --git a/source/compiler/aslpredef.c b/source/compiler/aslpredef.c
|
||||
index 7dd10b5..16df04a 100644
|
||||
--- a/source/compiler/aslpredef.c
|
||||
+++ b/source/compiler/aslpredef.c
|
||||
Index: acpica-unix2-20160318/source/compiler/aslpredef.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/compiler/aslpredef.c
|
||||
+++ acpica-unix2-20160318/source/compiler/aslpredef.c
|
||||
@@ -114,7 +114,7 @@ ApCheckForPredefinedMethod (
|
||||
|
||||
if (MethodInfo->NumArguments != 0)
|
||||
@ -85,10 +85,10 @@ index 7dd10b5..16df04a 100644
|
||||
|
||||
AslError (ASL_WARNING, ASL_MSG_RESERVED_ARG_COUNT_HI, Op,
|
||||
MsgBuffer);
|
||||
diff --git a/source/compiler/aslprepkg.c b/source/compiler/aslprepkg.c
|
||||
index ff80b57..e70b401 100644
|
||||
--- a/source/compiler/aslprepkg.c
|
||||
+++ b/source/compiler/aslprepkg.c
|
||||
Index: acpica-unix2-20160318/source/compiler/aslprepkg.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/compiler/aslprepkg.c
|
||||
+++ acpica-unix2-20160318/source/compiler/aslprepkg.c
|
||||
@@ -299,7 +299,7 @@ ApCheckPackage (
|
||||
|
||||
if (Count & 1)
|
||||
@ -98,10 +98,10 @@ index ff80b57..e70b401 100644
|
||||
Predefined->Info.Name, Count);
|
||||
|
||||
AslError (ASL_ERROR, ASL_MSG_RESERVED_PACKAGE_LENGTH,
|
||||
diff --git a/source/components/debugger/dbexec.c b/source/components/debugger/dbexec.c
|
||||
index b2836eb..d9fa628 100644
|
||||
--- a/source/components/debugger/dbexec.c
|
||||
+++ b/source/components/debugger/dbexec.c
|
||||
Index: acpica-unix2-20160318/source/components/debugger/dbexec.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/components/debugger/dbexec.c
|
||||
+++ acpica-unix2-20160318/source/components/debugger/dbexec.c
|
||||
@@ -214,7 +214,7 @@ AcpiDbExecuteMethod (
|
||||
ACPI_ERROR ((AE_INFO,
|
||||
"Possible overflow of internal debugger "
|
||||
@ -111,10 +111,10 @@ index b2836eb..d9fa628 100644
|
||||
}
|
||||
}
|
||||
|
||||
diff --git a/source/components/dispatcher/dsmthdat.c b/source/components/dispatcher/dsmthdat.c
|
||||
index 2040a33..5af6184 100644
|
||||
--- a/source/components/dispatcher/dsmthdat.c
|
||||
+++ b/source/components/dispatcher/dsmthdat.c
|
||||
Index: acpica-unix2-20160318/source/components/dispatcher/dsmthdat.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/components/dispatcher/dsmthdat.c
|
||||
+++ acpica-unix2-20160318/source/components/dispatcher/dsmthdat.c
|
||||
@@ -291,7 +291,7 @@ AcpiDsMethodDataGetNode (
|
||||
if (Index > ACPI_METHOD_MAX_LOCAL)
|
||||
{
|
||||
@ -133,10 +133,10 @@ index 2040a33..5af6184 100644
|
||||
Index, ACPI_METHOD_MAX_ARG));
|
||||
return_ACPI_STATUS (AE_AML_INVALID_INDEX);
|
||||
}
|
||||
diff --git a/source/components/dispatcher/dsutils.c b/source/components/dispatcher/dsutils.c
|
||||
index a32b3d4..586204e 100644
|
||||
--- a/source/components/dispatcher/dsutils.c
|
||||
+++ b/source/components/dispatcher/dsutils.c
|
||||
Index: acpica-unix2-20160318/source/components/dispatcher/dsutils.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/components/dispatcher/dsutils.c
|
||||
+++ acpica-unix2-20160318/source/components/dispatcher/dsutils.c
|
||||
@@ -791,7 +791,7 @@ AcpiDsCreateOperands (
|
||||
}
|
||||
|
||||
@ -146,10 +146,10 @@ index a32b3d4..586204e 100644
|
||||
WalkState->NumOperands, ArgCount, Index));
|
||||
|
||||
/* Create the interpreter arguments, in reverse order */
|
||||
diff --git a/source/components/dispatcher/dswscope.c b/source/components/dispatcher/dswscope.c
|
||||
index f67f2c4..4227ddb 100644
|
||||
--- a/source/components/dispatcher/dswscope.c
|
||||
+++ b/source/components/dispatcher/dswscope.c
|
||||
Index: acpica-unix2-20160318/source/components/dispatcher/dswscope.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/components/dispatcher/dswscope.c
|
||||
+++ acpica-unix2-20160318/source/components/dispatcher/dswscope.c
|
||||
@@ -149,7 +149,7 @@ AcpiDsScopeStackPush (
|
||||
WalkState->ScopeDepth++;
|
||||
|
||||
@ -168,10 +168,10 @@ index f67f2c4..4227ddb 100644
|
||||
(UINT32) WalkState->ScopeDepth,
|
||||
AcpiUtGetNodeName (ScopeInfo->Scope.Node),
|
||||
AcpiUtGetTypeName (ScopeInfo->Common.Value)));
|
||||
diff --git a/source/components/events/evgpe.c b/source/components/events/evgpe.c
|
||||
index 04a1f1e..b9c6566 100644
|
||||
--- a/source/components/events/evgpe.c
|
||||
+++ b/source/components/events/evgpe.c
|
||||
Index: acpica-unix2-20160318/source/components/events/evgpe.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/components/events/evgpe.c
|
||||
+++ acpica-unix2-20160318/source/components/events/evgpe.c
|
||||
@@ -430,7 +430,7 @@ AcpiEvGpeDetect (
|
||||
"Ignore disabled registers for GPE %02X-%02X: "
|
||||
"RunEnable=%02X, WakeEnable=%02X\n",
|
||||
@ -190,11 +190,11 @@ index 04a1f1e..b9c6566 100644
|
||||
StatusReg, EnableReg,
|
||||
GpeRegisterInfo->EnableForRun,
|
||||
GpeRegisterInfo->EnableForWake));
|
||||
diff --git a/source/components/executer/exdump.c b/source/components/executer/exdump.c
|
||||
index a09d779..e46eb3b 100644
|
||||
--- a/source/components/executer/exdump.c
|
||||
+++ b/source/components/executer/exdump.c
|
||||
@@ -671,7 +671,7 @@ AcpiExDumpOperand (
|
||||
Index: acpica-unix2-20160318/source/components/executer/exdump.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/components/executer/exdump.c
|
||||
+++ acpica-unix2-20160318/source/components/executer/exdump.c
|
||||
@@ -668,7 +668,7 @@ AcpiExDumpOperand (
|
||||
if (Depth > 0)
|
||||
{
|
||||
ACPI_DEBUG_PRINT ((ACPI_DB_EXEC, "%*s[%u] %p ",
|
||||
@ -203,10 +203,10 @@ index a09d779..e46eb3b 100644
|
||||
}
|
||||
else
|
||||
{
|
||||
diff --git a/source/components/executer/exfldio.c b/source/components/executer/exfldio.c
|
||||
index c5d9399..53c7cea 100644
|
||||
--- a/source/components/executer/exfldio.c
|
||||
+++ b/source/components/executer/exfldio.c
|
||||
Index: acpica-unix2-20160318/source/components/executer/exfldio.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/components/executer/exfldio.c
|
||||
+++ acpica-unix2-20160318/source/components/executer/exfldio.c
|
||||
@@ -681,8 +681,8 @@ AcpiExWriteWithUpdateRule (
|
||||
|
||||
ACPI_ERROR ((AE_INFO,
|
||||
@ -218,10 +218,10 @@ index c5d9399..53c7cea 100644
|
||||
return_ACPI_STATUS (AE_AML_OPERAND_VALUE);
|
||||
}
|
||||
}
|
||||
diff --git a/source/components/executer/exnames.c b/source/components/executer/exnames.c
|
||||
index f679de6..8874f4b 100644
|
||||
--- a/source/components/executer/exnames.c
|
||||
+++ b/source/components/executer/exnames.c
|
||||
Index: acpica-unix2-20160318/source/components/executer/exnames.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/components/executer/exnames.c
|
||||
+++ acpica-unix2-20160318/source/components/executer/exnames.c
|
||||
@@ -240,7 +240,7 @@ AcpiExNameSegment (
|
||||
*/
|
||||
ACPI_DEBUG_PRINT ((ACPI_DB_INFO,
|
||||
@ -240,11 +240,11 @@ index f679de6..8874f4b 100644
|
||||
}
|
||||
|
||||
*InAmlAddress = ACPI_CAST_PTR (UINT8, AmlAddress);
|
||||
diff --git a/source/components/hardware/hwregs.c b/source/components/hardware/hwregs.c
|
||||
index d7ef3ca..1d3de44 100644
|
||||
--- a/source/components/hardware/hwregs.c
|
||||
+++ b/source/components/hardware/hwregs.c
|
||||
@@ -300,7 +300,7 @@ AcpiHwClearAcpiStatus (
|
||||
Index: acpica-unix2-20160318/source/components/hardware/hwregs.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/components/hardware/hwregs.c
|
||||
+++ acpica-unix2-20160318/source/components/hardware/hwregs.c
|
||||
@@ -434,7 +434,7 @@ AcpiHwClearAcpiStatus (
|
||||
|
||||
|
||||
ACPI_DEBUG_PRINT ((ACPI_DB_IO, "About to write %04X to %8.8X%8.8X\n",
|
||||
@ -253,10 +253,10 @@ index d7ef3ca..1d3de44 100644
|
||||
ACPI_FORMAT_UINT64 (AcpiGbl_XPm1aStatus.Address)));
|
||||
|
||||
LockFlags = AcpiOsAcquireLock (AcpiGbl_HardwareLock);
|
||||
diff --git a/source/components/tables/tbfadt.c b/source/components/tables/tbfadt.c
|
||||
index bfb80e5..0e6e793 100644
|
||||
--- a/source/components/tables/tbfadt.c
|
||||
+++ b/source/components/tables/tbfadt.c
|
||||
Index: acpica-unix2-20160318/source/components/tables/tbfadt.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/components/tables/tbfadt.c
|
||||
+++ acpica-unix2-20160318/source/components/tables/tbfadt.c
|
||||
@@ -233,7 +233,7 @@ AcpiTbInitGenericAddress (
|
||||
if (!(Flags & ACPI_FADT_GPE_REGISTER))
|
||||
{
|
||||
@ -275,7 +275,7 @@ index bfb80e5..0e6e793 100644
|
||||
RegisterName, Address32, ACPI_FORMAT_UINT64 (Address64),
|
||||
AcpiGbl_Use32BitFadtAddresses ? 32 : 64));
|
||||
|
||||
@@ -617,7 +617,7 @@ AcpiTbConvertFadt (
|
||||
@@ -618,7 +618,7 @@ AcpiTbConvertFadt (
|
||||
|
||||
ACPI_BIOS_WARNING ((AE_INFO,
|
||||
"32/64X address mismatch in FADT/%s: "
|
||||
@ -284,10 +284,10 @@ index bfb80e5..0e6e793 100644
|
||||
Name, Address32,
|
||||
ACPI_FORMAT_UINT64 (Address64->Address),
|
||||
AcpiGbl_Use32BitFadtAddresses ? 32 : 64));
|
||||
diff --git a/source/components/tables/tbxfroot.c b/source/components/tables/tbxfroot.c
|
||||
index 455f133..0a287bc 100644
|
||||
--- a/source/components/tables/tbxfroot.c
|
||||
+++ b/source/components/tables/tbxfroot.c
|
||||
Index: acpica-unix2-20160318/source/components/tables/tbxfroot.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/components/tables/tbxfroot.c
|
||||
+++ acpica-unix2-20160318/source/components/tables/tbxfroot.c
|
||||
@@ -177,7 +177,7 @@ AcpiFindRootPointer (
|
||||
{
|
||||
ACPI_ERROR ((AE_INFO,
|
||||
@ -315,10 +315,10 @@ index 455f133..0a287bc 100644
|
||||
|
||||
return_ACPI_STATUS (AE_NO_MEMORY);
|
||||
}
|
||||
diff --git a/source/components/utilities/utownerid.c b/source/components/utilities/utownerid.c
|
||||
index dc3922a..ed0aa63 100644
|
||||
--- a/source/components/utilities/utownerid.c
|
||||
+++ b/source/components/utilities/utownerid.c
|
||||
Index: acpica-unix2-20160318/source/components/utilities/utownerid.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/components/utilities/utownerid.c
|
||||
+++ acpica-unix2-20160318/source/components/utilities/utownerid.c
|
||||
@@ -231,7 +231,7 @@ AcpiUtReleaseOwnerId (
|
||||
else
|
||||
{
|
||||
@ -328,10 +328,10 @@ index dc3922a..ed0aa63 100644
|
||||
}
|
||||
|
||||
(void) AcpiUtReleaseMutex (ACPI_MTX_CACHES);
|
||||
diff --git a/source/tools/acpiexec/aemain.c b/source/tools/acpiexec/aemain.c
|
||||
index a5f168c..f680b41 100644
|
||||
--- a/source/tools/acpiexec/aemain.c
|
||||
+++ b/source/tools/acpiexec/aemain.c
|
||||
Index: acpica-unix2-20160318/source/tools/acpiexec/aemain.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/tools/acpiexec/aemain.c
|
||||
+++ acpica-unix2-20160318/source/tools/acpiexec/aemain.c
|
||||
@@ -205,7 +205,7 @@ AeDoOptions (
|
||||
|
||||
if (strlen (AcpiGbl_Optarg) > (AE_BUFFER_SIZE -1))
|
||||
|
@ -10,10 +10,10 @@ made in the remainder of the function.
|
||||
source/compiler/aslanalyze.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/source/compiler/aslanalyze.c b/source/compiler/aslanalyze.c
|
||||
index fd71763..37bfc15 100644
|
||||
--- a/source/compiler/aslanalyze.c
|
||||
+++ b/source/compiler/aslanalyze.c
|
||||
Index: acpica-unix2-20160318/source/compiler/aslanalyze.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/compiler/aslanalyze.c
|
||||
+++ acpica-unix2-20160318/source/compiler/aslanalyze.c
|
||||
@@ -452,7 +452,7 @@ ApCheckForGpeNameConflict (
|
||||
|
||||
/* Need a null-terminated string version of NameSeg */
|
||||
|
@ -7,10 +7,10 @@ Al Stone <ahs3@redhat.com>
|
||||
source/compiler/aslmain.c | 12 ------------
|
||||
1 file changed, 12 deletions(-)
|
||||
|
||||
diff --git a/source/compiler/aslmain.c b/source/compiler/aslmain.c
|
||||
index 795a047..63420db 100644
|
||||
--- a/source/compiler/aslmain.c
|
||||
+++ b/source/compiler/aslmain.c
|
||||
Index: acpica-unix2-20160318/source/compiler/aslmain.c
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/source/compiler/aslmain.c
|
||||
+++ acpica-unix2-20160318/source/compiler/aslmain.c
|
||||
@@ -318,18 +318,6 @@ main (
|
||||
int ReturnStatus = 0;
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
454bbd2791a6e35868ddc7e12e16988d acpica-unix2-20160212.tar.gz
|
||||
f5ded7684428e2c1cc9ce14c97354f9c acpitests-unix-20160212.tar.gz
|
||||
e7cae9328666178d779e9c50f9e5bdf5 acpica-unix2-20160318.tar.gz
|
||||
66f1d02eb6841d74fe98690166d98db9 acpitests-unix-20160318.tar.gz
|
||||
|
@ -7,10 +7,10 @@ From: Al Stone <ahs3@redhat.com>
|
||||
tests/templates/Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tests/templates/Makefile b/tests/templates/Makefile
|
||||
index 1880dcc..6dce27d 100644
|
||||
--- a/tests/templates/Makefile
|
||||
+++ b/tests/templates/Makefile
|
||||
Index: acpica-unix2-20160318/tests/templates/Makefile
|
||||
===================================================================
|
||||
--- acpica-unix2-20160318.orig/tests/templates/Makefile
|
||||
+++ acpica-unix2-20160318/tests/templates/Makefile
|
||||
@@ -2,7 +2,7 @@
|
||||
PROG= templates
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user