Refresh patches
Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
parent
c154a4d409
commit
702e10de46
@ -21,7 +21,7 @@ Index: src/generate/unix/Makefile.config
|
||||
PREFIX ?= /usr
|
||||
INSTALLDIR = $(PREFIX)/bin
|
||||
UNAME_S := $(shell uname -s)
|
||||
@@ -140,6 +143,11 @@ ACPICA_HEADERS = \
|
||||
@@ -144,6 +147,11 @@ ACPICA_HEADERS = \
|
||||
OPT_CFLAGS ?= $(CWARNINGFLAGS)
|
||||
|
||||
#
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: acpica-tools
|
||||
Version: 20150515
|
||||
Release: 3%{?dist}
|
||||
Version: 20150619
|
||||
Release: 1%{?dist}
|
||||
Summary: ACPICA tools for the development and debug of ACPI tables
|
||||
|
||||
Group: Development/Languages
|
||||
@ -32,10 +32,6 @@ Patch5: re-enable-big-endian.patch
|
||||
Patch6: OPT_LDFLAGS.patch
|
||||
Patch7: int-format.patch
|
||||
Patch8: f23-harden.patch
|
||||
Patch9: acuuid.patch
|
||||
Patch10: nodevmem.patch
|
||||
Patch11: arm-madt.patch
|
||||
Patch12: segfault.patch
|
||||
|
||||
BuildRequires: bison patchutils flex
|
||||
|
||||
@ -95,10 +91,6 @@ gzip -dc %{SOURCE1} | tar -x --strip-components=1 -f -
|
||||
%patch6 -p1 -b .OPT_LDFLAGS
|
||||
%patch7 -p1 -b .int-format
|
||||
%patch8 -p1 -b .f23-harden
|
||||
%patch9 -p1 -b .acuuid
|
||||
%patch10 -p1 -b .nodevmem
|
||||
%patch11 -p1 -b .arm-madt
|
||||
%patch12 -p1 -b .segfault
|
||||
|
||||
cp -p %{SOURCE2} README.Fedora
|
||||
cp -p %{SOURCE3} iasl.1
|
||||
@ -203,6 +195,10 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jun 29 2015 Al Stone <ahs3@redhat.com> - 20150619-1
|
||||
- Update to latest upstream. Closes BZ#1232512.
|
||||
- Refresh patches
|
||||
|
||||
* Tue Jun 16 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 20150515-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
|
@ -70,25 +70,25 @@ Warning 3122 - ^ Called method may not always return a val
|
||||
badcode.asl 126: Method (MTH5) {Store (MTH4(), Local0)}
|
||||
Error 6080 - Called method returns no value ^
|
||||
|
||||
badcode.asl 132: Name (_HID, "*PNP0C0A")
|
||||
badcode.asl 132: Name (_HID, "*PNP0C0A") // Illegal leading asterisk
|
||||
Error 6061 - Invalid leading asterisk ^ (*PNP0C0A)
|
||||
|
||||
badcode.asl 136: Name (_HID, "PNP")
|
||||
badcode.asl 136: Name (_HID, "PNP") // Too short, must be 7 or 8 chars
|
||||
Error 6033 - ^ _HID string must be exactly 7 or 8 characters (PNP)
|
||||
|
||||
badcode.asl 140: Name (_HID, "MYDEVICE01")
|
||||
badcode.asl 140: Name (_HID, "MYDEVICE01") // Too long, must be 7 or 8 chars
|
||||
Error 6033 - ^ _HID string must be exactly 7 or 8 characters (MYDEVICE01)
|
||||
|
||||
badcode.asl 144: Name (_HID, "acpi0001")
|
||||
badcode.asl 144: Name (_HID, "acpi0001") // non-hex chars must be uppercase
|
||||
Error 6034 - ^ _HID prefix must be all uppercase or decimal digits (acpi0001)
|
||||
|
||||
badcode.asl 148: Name (_HID, "PNP-123")
|
||||
badcode.asl 148: Name (_HID, "PNP-123") // HID must be alphanumeric
|
||||
Error 6002 - ^ String must be entirely alphanumeric (PNP-123)
|
||||
|
||||
badcode.asl 152: Name (_HID, "")
|
||||
badcode.asl 152: Name (_HID, "") // Illegal Null HID
|
||||
Error 6091 - ^ Invalid zero-length (null) string
|
||||
|
||||
badcode.asl 153: Name (_CID, "")
|
||||
badcode.asl 153: Name (_CID, "") // Illegal Null CID
|
||||
Error 6091 - ^ Invalid zero-length (null) string
|
||||
|
||||
badcode.asl 158: Name (_PRW, 4)
|
||||
@ -142,49 +142,49 @@ Error 6019 - ^ Dependent function macros can
|
||||
badcode.asl 225: })
|
||||
Error 6070 - ^ Missing EndDependentFn() macro in dependent resource list
|
||||
|
||||
badcode.asl 242: 0x00002000,
|
||||
badcode.asl 242: 0x00002000, // Length
|
||||
Error 6049 - ^ Length is larger than Min/Max window
|
||||
|
||||
badcode.asl 247: 0x00001001,
|
||||
badcode.asl 247: 0x00001001, // Range Minimum
|
||||
Error 6001 - ^ Must be a multiple of alignment/granularity value
|
||||
|
||||
badcode.asl 248: 0x00002002,
|
||||
badcode.asl 248: 0x00002002, // Range Maximum
|
||||
Error 6001 - ^ Must be a multiple of alignment/granularity value
|
||||
|
||||
badcode.asl 255: 0xFFFF,
|
||||
badcode.asl 255: 0xFFFF, // Address
|
||||
Warning 3060 - ^ Maximum 10-bit ISA address (0x3FF)
|
||||
|
||||
badcode.asl 264: 0x05
|
||||
badcode.asl 264: 0x05 // Access Size
|
||||
Error 6042 - ^ Invalid AccessSize (Maximum is 4 - QWord access)
|
||||
|
||||
badcode.asl 268: QWordSpace (0xB0, ResourceConsumer, PosDecode, MinFixed, MaxFixed, 0xA5,
|
||||
Error 6139 - Constant out of range ^ (0xB0, allowable: 0xC0-0xFF)
|
||||
|
||||
badcode.asl 279: 0x0200,
|
||||
badcode.asl 279: 0x0200, // Range Minimum
|
||||
Error 6051 - ^ Address Min is greater than Address Max
|
||||
|
||||
badcode.asl 291: 0x00001002,
|
||||
badcode.asl 291: 0x00001002, // Length
|
||||
Error 6049 - ^ Length is larger than Min/Max window
|
||||
|
||||
badcode.asl 296: 0x00000010,
|
||||
Error 6048 - ^ Granularity must be zero or a power of two minus one
|
||||
|
||||
badcode.asl 305: 0x0000000000000B02,
|
||||
badcode.asl 305: 0x0000000000000B02, // Range Minimum
|
||||
Error 6001 - ^ Must be a multiple of alignment/granularity value
|
||||
|
||||
badcode.asl 315: 0x00000000002FFFFE,
|
||||
badcode.asl 315: 0x00000000002FFFFE, // Range Maximum
|
||||
Error 6001 - ^ Must be a multiple of alignment/granularity value (-1)
|
||||
|
||||
badcode.asl 326: 0x00000000,
|
||||
badcode.asl 326: 0x00000000, // Length
|
||||
Error 6043 - ^ Invalid combination of Length and Min/Max fixed flags
|
||||
|
||||
badcode.asl 335: 0x00000100,
|
||||
badcode.asl 335: 0x00000100, // Length
|
||||
Error 6043 - ^ Invalid combination of Length and Min/Max fixed flags
|
||||
|
||||
badcode.asl 344: 0x00000200,
|
||||
badcode.asl 344: 0x00000200, // Length
|
||||
Error 6043 - ^ Invalid combination of Length and Min/Max fixed flags
|
||||
|
||||
badcode.asl 349: 0x0000000F,
|
||||
badcode.asl 349: 0x0000000F, // Granularity
|
||||
Error 6047 - ^ Granularity must be zero for fixed Min/Max
|
||||
|
||||
badcode.asl 358: DWordIO (ResourceProducer, MinFixed, MaxFixed, PosDecode, EntireRange,
|
||||
@ -242,7 +242,7 @@ Copyright (c) 2000 - 2015 Intel Corporation
|
||||
|
||||
Ignoring all errors, forcing AML file generation
|
||||
|
||||
ASL Input: badcode.asl - 401 lines, 6935 bytes, 79 keywords
|
||||
ASL Input: badcode.asl - 402 lines, 11480 bytes, 79 keywords
|
||||
AML Output: badcode.aml - 1184 bytes, 60 named objects, 19 executable opcodes
|
||||
|
||||
Compilation complete. 46 Errors, 22 Warnings, 11 Remarks, 16 Optimizations, 1 Constants Folded
|
||||
|
@ -2,7 +2,7 @@ Index: src/source/compiler/aslcodegen.c
|
||||
===================================================================
|
||||
--- src.orig/source/compiler/aslcodegen.c
|
||||
+++ src/source/compiler/aslcodegen.c
|
||||
@@ -246,16 +246,12 @@ CgWriteAmlOpcode (
|
||||
@@ -249,16 +249,12 @@ CgWriteAmlOpcode (
|
||||
ACPI_PARSE_OBJECT *Op)
|
||||
{
|
||||
UINT8 PkgLenFirstByte;
|
||||
@ -25,7 +25,7 @@ Index: src/source/compiler/aslcodegen.c
|
||||
|
||||
/* We expect some DEFAULT_ARGs, just ignore them */
|
||||
|
||||
@@ -278,51 +274,52 @@ CgWriteAmlOpcode (
|
||||
@@ -281,51 +277,52 @@ CgWriteAmlOpcode (
|
||||
|
||||
/* Special opcodes for within a field definition */
|
||||
|
||||
@ -89,7 +89,7 @@ Index: src/source/compiler/aslcodegen.c
|
||||
break;
|
||||
}
|
||||
|
||||
@@ -333,8 +330,8 @@ CgWriteAmlOpcode (
|
||||
@@ -336,8 +333,8 @@ CgWriteAmlOpcode (
|
||||
if (Op->Asl.AmlPkgLenBytes == 1)
|
||||
{
|
||||
/* Simplest case -- no bytes to follow, just write the count */
|
||||
@ -100,7 +100,7 @@ Index: src/source/compiler/aslcodegen.c
|
||||
}
|
||||
else if (Op->Asl.AmlPkgLenBytes != 0)
|
||||
{
|
||||
@@ -344,7 +341,7 @@ CgWriteAmlOpcode (
|
||||
@@ -347,7 +344,7 @@ CgWriteAmlOpcode (
|
||||
*/
|
||||
PkgLenFirstByte = (UINT8)
|
||||
(((UINT32) (Op->Asl.AmlPkgLenBytes - 1) << 6) |
|
||||
@ -109,7 +109,7 @@ Index: src/source/compiler/aslcodegen.c
|
||||
|
||||
CgLocalWriteAmlData (Op, &PkgLenFirstByte, 1);
|
||||
|
||||
@@ -352,37 +349,44 @@ CgWriteAmlOpcode (
|
||||
@@ -355,37 +352,44 @@ CgWriteAmlOpcode (
|
||||
* Shift the length over by the 4 bits we just stuffed
|
||||
* in the first byte
|
||||
*/
|
||||
@ -167,7 +167,7 @@ Index: src/source/compiler/aslcodegen.c
|
||||
break;
|
||||
|
||||
case AML_STRING_OP:
|
||||
@@ -416,6 +420,7 @@ CgWriteTableHeader (
|
||||
@@ -419,6 +423,7 @@ CgWriteTableHeader (
|
||||
ACPI_PARSE_OBJECT *Op)
|
||||
{
|
||||
ACPI_PARSE_OBJECT *Child;
|
||||
@ -175,7 +175,7 @@ Index: src/source/compiler/aslcodegen.c
|
||||
|
||||
|
||||
/* AML filename */
|
||||
@@ -452,7 +457,7 @@ CgWriteTableHeader (
|
||||
@@ -455,7 +460,7 @@ CgWriteTableHeader (
|
||||
/* OEM Revision */
|
||||
|
||||
Child = Child->Asl.Next;
|
||||
@ -184,7 +184,7 @@ Index: src/source/compiler/aslcodegen.c
|
||||
|
||||
/* Compiler ID */
|
||||
|
||||
@@ -460,11 +465,12 @@ CgWriteTableHeader (
|
||||
@@ -463,11 +468,12 @@ CgWriteTableHeader (
|
||||
|
||||
/* Compiler version */
|
||||
|
||||
@ -199,7 +199,7 @@ Index: src/source/compiler/aslcodegen.c
|
||||
TableHeader.Checksum = 0;
|
||||
|
||||
CgLocalWriteAmlData (Op, &TableHeader, sizeof (ACPI_TABLE_HEADER));
|
||||
@@ -528,7 +534,10 @@ CgWriteNode (
|
||||
@@ -531,7 +537,10 @@ CgWriteNode (
|
||||
ACPI_PARSE_OBJECT *Op)
|
||||
{
|
||||
ASL_RESOURCE_NODE *Rnode;
|
||||
@ -211,7 +211,7 @@ Index: src/source/compiler/aslcodegen.c
|
||||
|
||||
/* Always check for DEFAULT_ARG and other "Noop" nodes */
|
||||
/* TBD: this may not be the best place for this check */
|
||||
@@ -546,13 +555,24 @@ CgWriteNode (
|
||||
@@ -549,13 +558,24 @@ CgWriteNode (
|
||||
switch (Op->Asl.AmlOpcode)
|
||||
{
|
||||
case AML_RAW_DATA_BYTE:
|
||||
|
@ -49,25 +49,25 @@ Remark 2098 - ^ Recursive method call (RCIV)
|
||||
grammar.asl 701: CreateField (\_SB_.SBUF, 148, 96, FLDV)
|
||||
Remark 2089 - Object is not referenced ^ (Name is within method [_INI])
|
||||
|
||||
grammar.asl 715: MinFixed,
|
||||
grammar.asl 715: MinFixed, // Range is notfixed
|
||||
Remark 2089 - Object is not referenced ^ (Name is within method [_CRS])
|
||||
|
||||
grammar.asl 716: MaxFixed,
|
||||
grammar.asl 716: MaxFixed, // Range is not fixed
|
||||
Remark 2089 - Object is not referenced ^ (Name is within method [_CRS])
|
||||
|
||||
grammar.asl 717: SubDecode,
|
||||
grammar.asl 717: SubDecode, // SubDecode
|
||||
Remark 2089 - Object is not referenced ^ (Name is within method [_CRS])
|
||||
|
||||
grammar.asl 718: 0x0000,
|
||||
grammar.asl 718: 0x0000, // Granularity
|
||||
Remark 2089 - Object is not referenced ^ (Name is within method [_CRS])
|
||||
|
||||
grammar.asl 720: 0xfff2,
|
||||
grammar.asl 720: 0xfff2, // Max
|
||||
Remark 2089 - Object is not referenced ^ (Name is within method [_CRS])
|
||||
|
||||
grammar.asl 721: 0x0032,
|
||||
grammar.asl 721: 0x0032, // Translation
|
||||
Remark 2089 - Object is not referenced ^ (Name is within method [_CRS])
|
||||
|
||||
grammar.asl 722: 0x0002,,,
|
||||
grammar.asl 722: 0x0002,,, // Range Length
|
||||
Remark 2089 - Object is not referenced ^ (Name is within method [_CRS])
|
||||
|
||||
grammar.asl 733: Method(_SRS)
|
||||
@ -229,10 +229,10 @@ Warning 3046 - Invalid or unknown escape sequence ^
|
||||
grammar.asl 6706: Device (BITI)
|
||||
Warning 3141 - Missing dependency ^ (Device object requires a _HID or _ADR in same scope)
|
||||
|
||||
grammar.asl 6814: And (Local0, 1, Local0)
|
||||
grammar.asl 6814: And (Local0, 1, Local0) // Local0 &= 1
|
||||
Error 6066 - ^ Method local variable is not initialized (Local0)
|
||||
|
||||
grammar.asl 6900: Name (_HID, "*PNP0C0A")
|
||||
grammar.asl 6900: Name (_HID, "*PNP0C0A") // Control Method Battey ID
|
||||
Error 6061 - Invalid leading asterisk ^ (*PNP0C0A)
|
||||
|
||||
grammar.asl 6909: Device (IDX3)
|
||||
@ -290,7 +290,7 @@ Copyright (c) 2000 - 2015 Intel Corporation
|
||||
|
||||
Ignoring all errors, forcing AML file generation
|
||||
|
||||
ASL Input: grammar.asl - 10281 lines, 228124 bytes, 4818 keywords
|
||||
ASL Input: grammar.asl - 10282 lines, 322891 bytes, 4818 keywords
|
||||
AML Output: grammar.aml - 43476 bytes, 670 named objects, 4148 executable opcodes
|
||||
|
||||
Compilation complete. 6 Errors, 64 Warnings, 25 Remarks, 1105 Optimizations
|
||||
|
@ -2,7 +2,7 @@ Index: src/source/compiler/aslcompile.c
|
||||
===================================================================
|
||||
--- src.orig/source/compiler/aslcompile.c
|
||||
+++ src/source/compiler/aslcompile.c
|
||||
@@ -688,7 +688,7 @@ CmCleanupAndExit (
|
||||
@@ -692,7 +692,7 @@ CmCleanupAndExit (
|
||||
|
||||
if (Gbl_ExceptionCount[ASL_ERROR] > ASL_MAX_ERROR_COUNT)
|
||||
{
|
||||
@ -159,7 +159,7 @@ Index: src/source/components/events/evgpe.c
|
||||
===================================================================
|
||||
--- src.orig/source/components/events/evgpe.c
|
||||
+++ src/source/components/events/evgpe.c
|
||||
@@ -429,7 +429,7 @@ AcpiEvGpeDetect (
|
||||
@@ -430,7 +430,7 @@ AcpiEvGpeDetect (
|
||||
"Ignore disabled registers for GPE %02X-%02X: "
|
||||
"RunEnable=%02X, WakeEnable=%02X\n",
|
||||
GpeRegisterInfo->BaseGpeNumber,
|
||||
@ -168,7 +168,7 @@ Index: src/source/components/events/evgpe.c
|
||||
GpeRegisterInfo->EnableForRun,
|
||||
GpeRegisterInfo->EnableForWake));
|
||||
continue;
|
||||
@@ -455,7 +455,7 @@ AcpiEvGpeDetect (
|
||||
@@ -456,7 +456,7 @@ AcpiEvGpeDetect (
|
||||
"Read registers for GPE %02X-%02X: Status=%02X, Enable=%02X, "
|
||||
"RunEnable=%02X, WakeEnable=%02X\n",
|
||||
GpeRegisterInfo->BaseGpeNumber,
|
||||
@ -181,7 +181,7 @@ Index: src/source/components/executer/exdump.c
|
||||
===================================================================
|
||||
--- src.orig/source/components/executer/exdump.c
|
||||
+++ src/source/components/executer/exdump.c
|
||||
@@ -663,7 +663,7 @@ AcpiExDumpOperand (
|
||||
@@ -664,7 +664,7 @@ AcpiExDumpOperand (
|
||||
if (Depth > 0)
|
||||
{
|
||||
ACPI_DEBUG_PRINT ((ACPI_DB_EXEC, "%*s[%u] %p ",
|
||||
@ -247,7 +247,7 @@ Index: src/source/components/tables/tbfadt.c
|
||||
RegisterName, Address32, ACPI_FORMAT_UINT64 (Address64),
|
||||
AcpiGbl_Use32BitFadtAddresses ? 32 : 64));
|
||||
|
||||
@@ -612,7 +612,7 @@ AcpiTbConvertFadt (
|
||||
@@ -617,7 +617,7 @@ AcpiTbConvertFadt (
|
||||
|
||||
ACPI_BIOS_WARNING ((AE_INFO,
|
||||
"32/64X address mismatch in FADT/%s: "
|
||||
|
Loading…
Reference in New Issue
Block a user