Refresh current patches to be in sync with upstream

Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
Al Stone 2014-04-05 15:31:31 -06:00
parent a0fc0b5e88
commit 6794d0ffbc
3 changed files with 16 additions and 6 deletions

View File

@ -318,7 +318,7 @@ diff -urN acpica-unix2-20130626/tests/aapits/atresource.c acpica-unix2-20130626-
diff -urN acpica-unix2-20130626/tests/aapits/Makefile acpica-unix2-20130626-aapits/tests/aapits/Makefile
--- acpica-unix2-20130626/tests/aapits/Makefile 2013-01-17 12:48:29.000000000 -0700
+++ acpica-unix2-20130626-aapits/tests/aapits/Makefile 2013-07-25 15:17:09.309236422 -0600
@@ -193,7 +193,7 @@
@@ -194,7 +194,7 @@
CFLAGS+= -Wall -g -D_LINUX -DNDEBUG -D_CONSOLE -DACPI_EXEC_APP -D_MULTI_THREADED -Wstrict-prototypes -I../../source/include

View File

@ -2417,7 +2417,7 @@ diff --git a/source/include/acmacros.h b/source/include/acmacros.h
index ee9e745..67fb983 100644
--- a/source/include/acmacros.h
+++ b/source/include/acmacros.h
@@ -113,7 +113,8 @@
@@ -111,7 +111,8 @@
/* 32-bit source, 16/32/64 destination */
@ -2427,7 +2427,7 @@ index ee9e745..67fb983 100644
#define ACPI_MOVE_32_TO_32(d, s) {(( UINT8 *)(void *)(d))[0] = ((UINT8 *)(void *)(s))[3];\
(( UINT8 *)(void *)(d))[1] = ((UINT8 *)(void *)(s))[2];\
@@ -128,9 +129,13 @@
@@ -126,9 +127,13 @@
/* 64-bit source, 16/32/64 destination */
@ -2443,7 +2443,7 @@ index ee9e745..67fb983 100644
#define ACPI_MOVE_64_TO_64(d, s) {(( UINT8 *)(void *)(d))[0] = ((UINT8 *)(void *)(s))[7];\
(( UINT8 *)(void *)(d))[1] = ((UINT8 *)(void *)(s))[6];\
@@ -157,7 +162,9 @@
@@ -155,7 +160,9 @@
/* 32-bit source, 16/32/64 destination */
@ -2464,6 +2464,16 @@ index 3bc85bc..1bace7f 100644
#include <unistd.h>
+#include <endian.h>
/* Define/disable kernel-specific declarators */
#ifndef __init
#define __init
#endif
#ifndef __iomem
#define __iomem
#endif
/* Host-dependent types and defines for user-space ACPICA */
#define ACPI_FLUSH_CPU_CACHE()

View File

@ -118,7 +118,7 @@ diff --git a/source/include/actypes.h b/source/include/actypes.h
index 07fb7d5..08bdf2f 100644
--- a/source/include/actypes.h
+++ b/source/include/actypes.h
@@ -144,6 +157,19 @@ typedef COMPILER_DEPENDENT_INT64 INT64;
@@ -142,6 +155,19 @@ typedef COMPILER_DEPENDENT_INT64 INT64;
*/
#define ACPI_THREAD_ID UINT64
@ -138,7 +138,7 @@ index 07fb7d5..08bdf2f 100644
/*******************************************************************************
*
@@ -183,19 +189,6 @@ typedef UINT64 ACPI_PHYSICAL_ADDRESS;
@@ -168,19 +181,6 @@ typedef UINT64 ACPI_PHYSICAL_ADDRESS;
#define ACPI_SIZE_MAX ACPI_UINT64_MAX
#define ACPI_USE_NATIVE_DIVIDE /* Has native 64-bit integer support */