Update to 20161117 source from upstream.

Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
Al Stone 2017-01-09 17:09:49 -07:00
parent ec8dd1f16b
commit 5c5a616a54
16 changed files with 556 additions and 683 deletions

2
.gitignore vendored
View File

@ -58,3 +58,5 @@
/acpitests-unix-20160831.tar.gz
/acpica-unix2-20160930.tar.gz
/acpitests-unix-20160930.tar.gz
/acpica-unix2-20161117.tar.gz
/acpitests-unix-20161117.tar.gz

View File

@ -1,7 +1,7 @@
Index: acpica-unix2-20160422/generate/unix/Makefile.config
Index: acpica-unix2-20161117/generate/unix/Makefile.config
===================================================================
--- acpica-unix2-20160422.orig/generate/unix/Makefile.config
+++ acpica-unix2-20160422/generate/unix/Makefile.config
--- acpica-unix2-20161117.orig/generate/unix/Makefile.config
+++ acpica-unix2-20161117/generate/unix/Makefile.config
@@ -23,6 +23,9 @@
# OPT_CFLAGS can be overridden on the make command line by
# adding OPT_CFLAGS="..." to the invocation.

View File

@ -1,6 +1,6 @@
Name: acpica-tools
Version: 20160930
Release: 3%{?dist}
Version: 20161117
Release: 1%{?dist}
Summary: ACPICA tools for the development and debug of ACPI tables
Group: Development/Languages
@ -192,6 +192,10 @@ fi
%changelog
* Mon Jan 9 2017 Al Stone <ahs3@redhat.com> - 20161117-1
- Update to latest upstream. Closes BZ#1381017.
- Refresh patches.
* Mon Jan 9 2017 Al Stone <ahs3@redhat.com> - 20160930-3
- Restructure the repairs for big-endian support to simplify patching -- it is
all combined into update-big-endian.patch now. (NB: this version may still

View File

@ -7,10 +7,10 @@ From: Al Stone <ahs3@redhat.com>
source/compiler/asllookup.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
Index: acpica-unix2-20160422/source/compiler/asllookup.c
Index: acpica-unix2-20161117/source/compiler/asllookup.c
===================================================================
--- acpica-unix2-20160422.orig/source/compiler/asllookup.c
+++ acpica-unix2-20160422/source/compiler/asllookup.c
--- acpica-unix2-20161117.orig/source/compiler/asllookup.c
+++ acpica-unix2-20161117/source/compiler/asllookup.c
@@ -119,6 +119,7 @@ LkIsObjectUsed (
{
ACPI_NAMESPACE_NODE *Node = ACPI_CAST_PTR (ACPI_NAMESPACE_NODE, ObjHandle);

View File

@ -7,10 +7,10 @@ From: Al Stone <ahs3@redhat.com>
source/compiler/asllookup.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
Index: acpica-unix2-20160422/source/compiler/asllookup.c
Index: acpica-unix2-20161117/source/compiler/asllookup.c
===================================================================
--- acpica-unix2-20160422.orig/source/compiler/asllookup.c
+++ acpica-unix2-20160422/source/compiler/asllookup.c
--- acpica-unix2-20161117.orig/source/compiler/asllookup.c
+++ acpica-unix2-20161117/source/compiler/asllookup.c
@@ -176,7 +176,8 @@ LkIsObjectUsed (
* We ignore the predefined methods since often, not
* all arguments are needed or used.

View File

@ -18,10 +18,10 @@ support
source/include/platform/aclinux.h | 8 ++
12 files changed, 487 insertions(+), 283 deletions(-)
Index: acpica-unix-20160527/source/compiler/aslcodegen.c
Index: acpica-unix2-20161117/source/compiler/aslcodegen.c
===================================================================
--- acpica-unix-20160527.orig/source/compiler/aslcodegen.c
+++ acpica-unix-20160527/source/compiler/aslcodegen.c
--- acpica-unix2-20161117.orig/source/compiler/aslcodegen.c
+++ acpica-unix2-20161117/source/compiler/aslcodegen.c
@@ -243,16 +243,12 @@ CgWriteAmlOpcode (
ACPI_PARSE_OBJECT *Op)
{
@ -263,11 +263,11 @@ Index: acpica-unix-20160527/source/compiler/aslcodegen.c
case AML_RAW_DATA_BUFFER:
Index: acpica-unix-20160527/source/compiler/aslopcodes.c
Index: acpica-unix2-20161117/source/compiler/aslopcodes.c
===================================================================
--- acpica-unix-20160527.orig/source/compiler/aslopcodes.c
+++ acpica-unix-20160527/source/compiler/aslopcodes.c
@@ -481,6 +481,7 @@ OpcDoUnicode (
--- acpica-unix2-20161117.orig/source/compiler/aslopcodes.c
+++ acpica-unix2-20161117/source/compiler/aslopcodes.c
@@ -485,6 +485,7 @@ OpcDoUnicode (
UINT32 i;
UINT8 *AsciiString;
UINT16 *UnicodeString;
@ -275,7 +275,7 @@ Index: acpica-unix-20160527/source/compiler/aslopcodes.c
ACPI_PARSE_OBJECT *BufferLengthOp;
@@ -507,7 +508,8 @@ OpcDoUnicode (
@@ -511,7 +512,8 @@ OpcDoUnicode (
for (i = 0; i < Count; i++)
{
@ -285,10 +285,10 @@ Index: acpica-unix-20160527/source/compiler/aslopcodes.c
}
/*
Index: acpica-unix-20160527/source/compiler/aslrestype1.c
Index: acpica-unix2-20161117/source/compiler/aslrestype1.c
===================================================================
--- acpica-unix-20160527.orig/source/compiler/aslrestype1.c
+++ acpica-unix-20160527/source/compiler/aslrestype1.c
--- acpica-unix2-20161117.orig/source/compiler/aslrestype1.c
+++ acpica-unix2-20161117/source/compiler/aslrestype1.c
@@ -142,6 +142,11 @@ RsDoMemory24Descriptor (
ACPI_PARSE_OBJECT *LengthOp = NULL;
ASL_RESOURCE_NODE *Rnode;
@ -485,10 +485,10 @@ Index: acpica-unix-20160527/source/compiler/aslrestype1.c
RsCreateDwordField (InitializerOp, ACPI_RESTAG_LENGTH,
CurrentByteOffset + ASL_RESDESC_OFFSET (FixedMemory32.AddressLength));
break;
Index: acpica-unix-20160527/source/compiler/aslrestype1i.c
Index: acpica-unix2-20161117/source/compiler/aslrestype1i.c
===================================================================
--- acpica-unix-20160527.orig/source/compiler/aslrestype1i.c
+++ acpica-unix-20160527/source/compiler/aslrestype1i.c
--- acpica-unix2-20161117.orig/source/compiler/aslrestype1i.c
+++ acpica-unix2-20161117/source/compiler/aslrestype1i.c
@@ -198,6 +198,8 @@ RsDoFixedDmaDescriptor (
ACPI_PARSE_OBJECT *InitializerOp;
ASL_RESOURCE_NODE *Rnode;
@ -625,10 +625,10 @@ Index: acpica-unix-20160527/source/compiler/aslrestype1i.c
+ ACPI_MOVE_16_TO_16(&Descriptor->Irq.IrqMask, &IrqMask);
return (Rnode);
}
Index: acpica-unix-20160527/source/compiler/aslrestype2.c
Index: acpica-unix2-20161117/source/compiler/aslrestype2.c
===================================================================
--- acpica-unix-20160527.orig/source/compiler/aslrestype2.c
+++ acpica-unix-20160527/source/compiler/aslrestype2.c
--- acpica-unix2-20161117.orig/source/compiler/aslrestype2.c
+++ acpica-unix2-20161117/source/compiler/aslrestype2.c
@@ -76,6 +76,7 @@ RsDoGeneralRegisterDescriptor (
ACPI_PARSE_OBJECT *InitializerOp;
ASL_RESOURCE_NODE *Rnode;
@ -658,7 +658,7 @@ Index: acpica-unix-20160527/source/compiler/aslrestype2.c
RsCreateQwordField (InitializerOp, ACPI_RESTAG_ADDRESS,
CurrentByteOffset + ASL_RESDESC_OFFSET (GenericReg.Address));
break;
@@ -172,6 +176,7 @@ RsDoInterruptDescriptor (
@@ -177,6 +181,7 @@ RsDoInterruptDescriptor (
AML_RESOURCE *Rover = NULL;
ACPI_PARSE_OBJECT *InitializerOp;
ASL_RESOURCE_NODE *Rnode;
@ -666,7 +666,7 @@ Index: acpica-unix-20160527/source/compiler/aslrestype2.c
UINT16 StringLength = 0;
UINT32 OptionIndex = 0;
UINT32 CurrentByteOffset;
@@ -220,7 +225,7 @@ RsDoInterruptDescriptor (
@@ -225,7 +230,7 @@ RsDoInterruptDescriptor (
* Initial descriptor length -- may be enlarged if there are
* optional fields present
*/
@ -675,7 +675,7 @@ Index: acpica-unix-20160527/source/compiler/aslrestype2.c
Descriptor->ExtendedIrq.InterruptCount = 0;
Rover = ACPI_CAST_PTR (AML_RESOURCE,
@@ -328,10 +333,11 @@ RsDoInterruptDescriptor (
@@ -333,10 +338,11 @@ RsDoInterruptDescriptor (
/* Save the integer and move pointer to the next one */
@ -689,7 +689,7 @@ Index: acpica-unix-20160527/source/compiler/aslrestype2.c
/* Case 7: First interrupt number in list */
@@ -367,7 +373,7 @@ RsDoInterruptDescriptor (
@@ -372,7 +378,7 @@ RsDoInterruptDescriptor (
{
Rover->ByteItem = ResSourceIndex;
Rover = ACPI_ADD_PTR (AML_RESOURCE, &(Rover->ByteItem), 1);
@ -698,7 +698,7 @@ Index: acpica-unix-20160527/source/compiler/aslrestype2.c
}
/* Add optional ResSource string if present */
@@ -379,14 +385,15 @@ RsDoInterruptDescriptor (
@@ -384,14 +390,15 @@ RsDoInterruptDescriptor (
Rover = ACPI_ADD_PTR (
AML_RESOURCE, &(Rover->ByteItem), StringLength);
@ -716,7 +716,7 @@ Index: acpica-unix-20160527/source/compiler/aslrestype2.c
return (Rnode);
}
@@ -434,7 +441,7 @@ RsDoVendorLargeDescriptor (
@@ -439,7 +446,7 @@ RsDoVendorLargeDescriptor (
Descriptor = Rnode->Buffer;
Descriptor->VendorLarge.DescriptorType = ACPI_RESOURCE_NAME_VENDOR_LARGE;
@ -725,10 +725,10 @@ Index: acpica-unix-20160527/source/compiler/aslrestype2.c
/* Point to end-of-descriptor for vendor data */
Index: acpica-unix-20160527/source/compiler/aslrestype2d.c
Index: acpica-unix2-20161117/source/compiler/aslrestype2d.c
===================================================================
--- acpica-unix-20160527.orig/source/compiler/aslrestype2d.c
+++ acpica-unix-20160527/source/compiler/aslrestype2d.c
--- acpica-unix2-20161117.orig/source/compiler/aslrestype2d.c
+++ acpica-unix2-20161117/source/compiler/aslrestype2d.c
@@ -79,7 +79,13 @@ RsDoDwordIoDescriptor (
ACPI_PARSE_OBJECT *GranOp = NULL;
ASL_RESOURCE_NODE *Rnode;
@ -1084,10 +1084,10 @@ Index: acpica-unix-20160527/source/compiler/aslrestype2d.c
Rnode->BufferLength = sizeof (AML_RESOURCE_ADDRESS32) +
OptionIndex + StringLength;
return (Rnode);
Index: acpica-unix-20160527/source/compiler/aslrestype2e.c
Index: acpica-unix2-20161117/source/compiler/aslrestype2e.c
===================================================================
--- acpica-unix-20160527.orig/source/compiler/aslrestype2e.c
+++ acpica-unix-20160527/source/compiler/aslrestype2e.c
--- acpica-unix2-20161117.orig/source/compiler/aslrestype2e.c
+++ acpica-unix2-20161117/source/compiler/aslrestype2e.c
@@ -78,6 +78,13 @@ RsDoExtendedIoDescriptor (
ACPI_PARSE_OBJECT *GranOp = NULL;
ASL_RESOURCE_NODE *Rnode;
@ -1193,10 +1193,10 @@ Index: acpica-unix-20160527/source/compiler/aslrestype2e.c
Rnode->BufferLength = sizeof (AML_RESOURCE_EXTENDED_ADDRESS64) +
StringLength;
return (Rnode);
Index: acpica-unix-20160527/source/compiler/aslrestype2q.c
Index: acpica-unix2-20161117/source/compiler/aslrestype2q.c
===================================================================
--- acpica-unix-20160527.orig/source/compiler/aslrestype2q.c
+++ acpica-unix-20160527/source/compiler/aslrestype2q.c
--- acpica-unix2-20161117.orig/source/compiler/aslrestype2q.c
+++ acpica-unix2-20161117/source/compiler/aslrestype2q.c
@@ -80,7 +80,13 @@ RsDoQwordIoDescriptor (
ASL_RESOURCE_NODE *Rnode;
UINT8 *OptionalFields;
@ -1535,10 +1535,10 @@ Index: acpica-unix-20160527/source/compiler/aslrestype2q.c
Rnode->BufferLength = sizeof (AML_RESOURCE_ADDRESS64) +
OptionIndex + StringLength;
return (Rnode);
Index: acpica-unix-20160527/source/compiler/aslrestype2s.c
Index: acpica-unix2-20161117/source/compiler/aslrestype2s.c
===================================================================
--- acpica-unix-20160527.orig/source/compiler/aslrestype2s.c
+++ acpica-unix-20160527/source/compiler/aslrestype2s.c
--- acpica-unix2-20161117.orig/source/compiler/aslrestype2s.c
+++ acpica-unix2-20161117/source/compiler/aslrestype2s.c
@@ -290,6 +290,9 @@ RsDoGpioIntDescriptor (
UINT16 VendorLength;
UINT16 InterruptLength;
@ -1852,10 +1852,10 @@ Index: acpica-unix-20160527/source/compiler/aslrestype2s.c
MpSaveSerialInfo (Info->MappingOp, Descriptor, ResourceSource);
return (Rnode);
}
Index: acpica-unix-20160527/source/compiler/aslrestype2w.c
Index: acpica-unix2-20161117/source/compiler/aslrestype2w.c
===================================================================
--- acpica-unix-20160527.orig/source/compiler/aslrestype2w.c
+++ acpica-unix-20160527/source/compiler/aslrestype2w.c
--- acpica-unix2-20161117.orig/source/compiler/aslrestype2w.c
+++ acpica-unix2-20161117/source/compiler/aslrestype2w.c
@@ -81,6 +81,12 @@ RsDoWordIoDescriptor (
UINT8 *OptionalFields;
UINT16 StringLength = 0;
@ -2199,10 +2199,10 @@ Index: acpica-unix-20160527/source/compiler/aslrestype2w.c
Rnode->BufferLength = sizeof (AML_RESOURCE_ADDRESS16) +
OptionIndex + StringLength;
return (Rnode);
Index: acpica-unix-20160527/source/include/acmacros.h
Index: acpica-unix2-20161117/source/include/acmacros.h
===================================================================
--- acpica-unix-20160527.orig/source/include/acmacros.h
+++ acpica-unix-20160527/source/include/acmacros.h
--- acpica-unix2-20161117.orig/source/include/acmacros.h
+++ acpica-unix2-20161117/source/include/acmacros.h
@@ -100,7 +100,8 @@
/* 32-bit source, 16/32/64 destination */
@ -2240,10 +2240,10 @@ Index: acpica-unix-20160527/source/include/acmacros.h
#define ACPI_MOVE_32_TO_32(d, s) *(UINT32 *)(void *)(d) = *(UINT32 *)(void *)(s)
#define ACPI_MOVE_32_TO_64(d, s) *(UINT64 *)(void *)(d) = *(UINT32 *)(void *)(s)
Index: acpica-unix-20160527/source/include/platform/aclinux.h
Index: acpica-unix2-20161117/source/include/platform/aclinux.h
===================================================================
--- acpica-unix-20160729.orig/source/include/platform/aclinux.h
+++ acpica-unix-20160729/source/include/platform/aclinux.h
--- acpica-unix2-20161117.orig/source/include/platform/aclinux.h
+++ acpica-unix2-20161117/source/include/platform/aclinux.h
@@ -179,6 +179,7 @@
#ifdef ACPI_USE_STANDARD_HEADERS
@ -2252,25 +2252,3 @@ Index: acpica-unix-20160527/source/include/platform/aclinux.h
#endif
/* Define/disable kernel-specific declarators */
@@ -190,8 +191,7 @@
#define ACPI_FLUSH_CPU_CACHE()
#define ACPI_CAST_PTHREAD_T(Pthread) ((ACPI_THREAD_ID) (Pthread))
-#if defined(__ia64__) || defined(__x86_64__) ||\
- defined(__aarch64__) || defined(__PPC64__)
+#if __SIZEOF_LONG__ == 8
#define ACPI_MACHINE_WIDTH 64
#define COMPILER_DEPENDENT_INT64 long
#define COMPILER_DEPENDENT_UINT64 unsigned long
@@ -202,6 +202,10 @@
#define ACPI_USE_NATIVE_DIVIDE
#endif
+#if __BYTE_ORDER == __BIG_ENDIAN
+#define ACPI_BIG_ENDIAN
+#endif
+
#ifndef __cdecl
#define __cdecl
#endif

View File

@ -18,10 +18,10 @@ Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
source/include/actypes.h | 26 +++++++++++++-------------
3 files changed, 32 insertions(+), 21 deletions(-)
Index: acpica-unix2-20160422/source/compiler/asltree.c
Index: acpica-unix2-20161117/source/compiler/asltree.c
===================================================================
--- acpica-unix2-20160422.orig/source/compiler/asltree.c
+++ acpica-unix2-20160422/source/compiler/asltree.c
--- acpica-unix2-20161117.orig/source/compiler/asltree.c
+++ acpica-unix2-20161117/source/compiler/asltree.c
@@ -913,28 +913,31 @@ TrCreateValuedLeafNode (
"Op %s Value %8.8X%8.8X ",
Op->Asl.LineNumber, Op->Asl.Column, Op, UtGetOpName(ParseOpcode),
@ -74,10 +74,10 @@ Index: acpica-unix2-20160422/source/compiler/asltree.c
break;
}
Index: acpica-unix2-20160422/source/components/executer/exoparg2.c
Index: acpica-unix2-20161117/source/components/executer/exoparg2.c
===================================================================
--- acpica-unix2-20160422.orig/source/components/executer/exoparg2.c
+++ acpica-unix2-20160422/source/components/executer/exoparg2.c
--- acpica-unix2-20161117.orig/source/components/executer/exoparg2.c
+++ acpica-unix2-20161117/source/components/executer/exoparg2.c
@@ -172,6 +172,8 @@ AcpiExOpcode_2A_2T_1R (
ACPI_OPERAND_OBJECT **Operand = &WalkState->Operands[0];
ACPI_OPERAND_OBJECT *ReturnDesc1 = NULL;
@ -118,10 +118,10 @@ Index: acpica-unix2-20160422/source/components/executer/exoparg2.c
break;
case AML_CONCAT_OP: /* Concatenate (Data1, Data2, Result) */
Index: acpica-unix2-20160422/source/include/actypes.h
Index: acpica-unix2-20161117/source/include/actypes.h
===================================================================
--- acpica-unix2-20160422.orig/source/include/actypes.h
+++ acpica-unix2-20160422/source/include/actypes.h
--- acpica-unix2-20161117.orig/source/include/actypes.h
+++ acpica-unix2-20161117/source/include/actypes.h
@@ -143,6 +143,19 @@ typedef COMPILER_DEPENDENT_INT64
*/
#define ACPI_THREAD_ID UINT64

View File

@ -8,10 +8,10 @@ From: Al Stone <ahs3@redhat.com>
generate/unix/iasl/Makefile | 13 +++++++------
2 files changed, 9 insertions(+), 6 deletions(-)
Index: acpica-unix2-20160831/generate/unix/Makefile.config
Index: acpica-unix2-20161117/generate/unix/Makefile.config
===================================================================
--- acpica-unix2-20160831.orig/generate/unix/Makefile.config
+++ acpica-unix2-20160831/generate/unix/Makefile.config
--- acpica-unix2-20161117.orig/generate/unix/Makefile.config
+++ acpica-unix2-20161117/generate/unix/Makefile.config
@@ -171,6 +171,8 @@ ifneq ($(NOFORTIFY),TRUE)
OPT_CFLAGS += -D_FORTIFY_SOURCE=2
endif
@ -21,10 +21,10 @@ Index: acpica-unix2-20160831/generate/unix/Makefile.config
CFLAGS += \
-D$(HOST)\
-D_GNU_SOURCE\
Index: acpica-unix2-20160831/generate/unix/iasl/Makefile
Index: acpica-unix2-20161117/generate/unix/iasl/Makefile
===================================================================
--- acpica-unix2-20160831.orig/generate/unix/iasl/Makefile
+++ acpica-unix2-20160831/generate/unix/iasl/Makefile
--- acpica-unix2-20161117.orig/generate/unix/iasl/Makefile
+++ acpica-unix2-20161117/generate/unix/iasl/Makefile
@@ -319,20 +319,21 @@ $(OBJDIR)/prparserparse.c $(OBJDIR)/prpa
# Cannot use the common compile warning flags since the C files are created
# by the utilities above and they are not necessarily ANSI C, etc.

View File

@ -1,9 +1,10 @@
This prevents a segfault when an Include file does not exist.
diff -Naur acpica-unix2-20160930/source/compiler/aslfiles.c acpica-unix2-20160930-s390/source/compiler/aslfiles.c
--- acpica-unix2-20160930/source/compiler/aslfiles.c 2016-09-30 10:43:56.000000000 -0600
+++ acpica-unix2-20160930-s390/source/compiler/aslfiles.c 2016-12-06 18:55:08.693785207 -0700
@@ -319,7 +319,7 @@
Index: acpica-unix2-20161117/source/compiler/aslfiles.c
===================================================================
--- acpica-unix2-20161117.orig/source/compiler/aslfiles.c
+++ acpica-unix2-20161117/source/compiler/aslfiles.c
@@ -319,7 +319,7 @@ FlOpenIncludeWithPrefix (
if (!IncludeFile)
{
fprintf (stderr, "Could not open include file %s\n", Pathname);

View File

@ -24,10 +24,10 @@ From: Al Stone <ahs3@redhat.com>
source/tools/acpiexec/aemain.c | 2 +-
18 files changed, 28 insertions(+), 28 deletions(-)
Index: acpica-unix2-20160831/source/compiler/aslcompile.c
Index: acpica-unix2-20161117/source/compiler/aslcompile.c
===================================================================
--- acpica-unix2-20160831.orig/source/compiler/aslcompile.c
+++ acpica-unix2-20160831/source/compiler/aslcompile.c
--- acpica-unix2-20161117.orig/source/compiler/aslcompile.c
+++ acpica-unix2-20161117/source/compiler/aslcompile.c
@@ -729,7 +729,7 @@ CmCleanupAndExit (
if (Gbl_ExceptionCount[ASL_ERROR] > ASL_MAX_ERROR_COUNT)
@ -37,10 +37,10 @@ Index: acpica-unix2-20160831/source/compiler/aslcompile.c
ASL_MAX_ERROR_COUNT);
}
Index: acpica-unix2-20160831/source/compiler/aslerror.c
Index: acpica-unix2-20161117/source/compiler/aslerror.c
===================================================================
--- acpica-unix2-20160831.orig/source/compiler/aslerror.c
+++ acpica-unix2-20160831/source/compiler/aslerror.c
--- acpica-unix2-20161117.orig/source/compiler/aslerror.c
+++ acpica-unix2-20161117/source/compiler/aslerror.c
@@ -687,7 +687,7 @@ AslCommonError (
Gbl_ExceptionCount[Level]++;
if (Gbl_ExceptionCount[ASL_ERROR] > ASL_MAX_ERROR_COUNT)
@ -59,10 +59,10 @@ Index: acpica-unix2-20160831/source/compiler/aslerror.c
ASL_MAX_DISABLED_MESSAGES);
return (AE_LIMIT);
}
Index: acpica-unix2-20160831/source/compiler/aslopt.c
Index: acpica-unix2-20161117/source/compiler/aslopt.c
===================================================================
--- acpica-unix2-20160831.orig/source/compiler/aslopt.c
+++ acpica-unix2-20160831/source/compiler/aslopt.c
--- acpica-unix2-20161117.orig/source/compiler/aslopt.c
+++ acpica-unix2-20161117/source/compiler/aslopt.c
@@ -584,7 +584,7 @@ OptOptimizeNamePath (
}
@ -72,10 +72,10 @@ Index: acpica-unix2-20160831/source/compiler/aslopt.c
Op->Asl.LogicalLineNumber,
AcpiPsGetOpcodeName (Op->Common.Parent->Common.AmlOpcode),
AcpiPsGetOpcodeName (Op->Common.AmlOpcode)));
Index: acpica-unix2-20160831/source/compiler/aslpredef.c
Index: acpica-unix2-20161117/source/compiler/aslpredef.c
===================================================================
--- acpica-unix2-20160831.orig/source/compiler/aslpredef.c
+++ acpica-unix2-20160831/source/compiler/aslpredef.c
--- acpica-unix2-20161117.orig/source/compiler/aslpredef.c
+++ acpica-unix2-20161117/source/compiler/aslpredef.c
@@ -114,7 +114,7 @@ ApCheckForPredefinedMethod (
if (MethodInfo->NumArguments != 0)
@ -85,10 +85,10 @@ Index: acpica-unix2-20160831/source/compiler/aslpredef.c
AslError (ASL_WARNING, ASL_MSG_RESERVED_ARG_COUNT_HI, Op,
MsgBuffer);
Index: acpica-unix2-20160831/source/compiler/aslprepkg.c
Index: acpica-unix2-20161117/source/compiler/aslprepkg.c
===================================================================
--- acpica-unix2-20160831.orig/source/compiler/aslprepkg.c
+++ acpica-unix2-20160831/source/compiler/aslprepkg.c
--- acpica-unix2-20161117.orig/source/compiler/aslprepkg.c
+++ acpica-unix2-20161117/source/compiler/aslprepkg.c
@@ -309,7 +309,7 @@ ApCheckPackage (
if (Count & 1)
@ -98,10 +98,10 @@ Index: acpica-unix2-20160831/source/compiler/aslprepkg.c
Predefined->Info.Name, Count);
AslError (ASL_ERROR, ASL_MSG_RESERVED_PACKAGE_LENGTH,
Index: acpica-unix2-20160831/source/components/debugger/dbexec.c
Index: acpica-unix2-20161117/source/components/debugger/dbexec.c
===================================================================
--- acpica-unix2-20160831.orig/source/components/debugger/dbexec.c
+++ acpica-unix2-20160831/source/components/debugger/dbexec.c
--- acpica-unix2-20161117.orig/source/components/debugger/dbexec.c
+++ acpica-unix2-20161117/source/components/debugger/dbexec.c
@@ -214,7 +214,7 @@ AcpiDbExecuteMethod (
ACPI_ERROR ((AE_INFO,
"Possible overflow of internal debugger "
@ -111,10 +111,10 @@ Index: acpica-unix2-20160831/source/components/debugger/dbexec.c
}
}
Index: acpica-unix2-20160831/source/components/dispatcher/dsmthdat.c
Index: acpica-unix2-20161117/source/components/dispatcher/dsmthdat.c
===================================================================
--- acpica-unix2-20160831.orig/source/components/dispatcher/dsmthdat.c
+++ acpica-unix2-20160831/source/components/dispatcher/dsmthdat.c
--- acpica-unix2-20161117.orig/source/components/dispatcher/dsmthdat.c
+++ acpica-unix2-20161117/source/components/dispatcher/dsmthdat.c
@@ -291,7 +291,7 @@ AcpiDsMethodDataGetNode (
if (Index > ACPI_METHOD_MAX_LOCAL)
{
@ -133,10 +133,10 @@ Index: acpica-unix2-20160831/source/components/dispatcher/dsmthdat.c
Index, ACPI_METHOD_MAX_ARG));
return_ACPI_STATUS (AE_AML_INVALID_INDEX);
}
Index: acpica-unix2-20160831/source/components/dispatcher/dsutils.c
Index: acpica-unix2-20161117/source/components/dispatcher/dsutils.c
===================================================================
--- acpica-unix2-20160831.orig/source/components/dispatcher/dsutils.c
+++ acpica-unix2-20160831/source/components/dispatcher/dsutils.c
--- acpica-unix2-20161117.orig/source/components/dispatcher/dsutils.c
+++ acpica-unix2-20161117/source/components/dispatcher/dsutils.c
@@ -793,7 +793,7 @@ AcpiDsCreateOperands (
}
@ -146,10 +146,10 @@ Index: acpica-unix2-20160831/source/components/dispatcher/dsutils.c
WalkState->NumOperands, ArgCount, Index));
/* Create the interpreter arguments, in reverse order */
Index: acpica-unix2-20160831/source/components/dispatcher/dswscope.c
Index: acpica-unix2-20161117/source/components/dispatcher/dswscope.c
===================================================================
--- acpica-unix2-20160831.orig/source/components/dispatcher/dswscope.c
+++ acpica-unix2-20160831/source/components/dispatcher/dswscope.c
--- acpica-unix2-20161117.orig/source/components/dispatcher/dswscope.c
+++ acpica-unix2-20161117/source/components/dispatcher/dswscope.c
@@ -149,7 +149,7 @@ AcpiDsScopeStackPush (
WalkState->ScopeDepth++;
@ -168,10 +168,10 @@ Index: acpica-unix2-20160831/source/components/dispatcher/dswscope.c
(UINT32) WalkState->ScopeDepth,
AcpiUtGetNodeName (ScopeInfo->Scope.Node),
AcpiUtGetTypeName (ScopeInfo->Common.Value)));
Index: acpica-unix2-20160831/source/components/events/evgpe.c
Index: acpica-unix2-20161117/source/components/events/evgpe.c
===================================================================
--- acpica-unix2-20160831.orig/source/components/events/evgpe.c
+++ acpica-unix2-20160831/source/components/events/evgpe.c
--- acpica-unix2-20161117.orig/source/components/events/evgpe.c
+++ acpica-unix2-20161117/source/components/events/evgpe.c
@@ -494,7 +494,7 @@ AcpiEvGpeDetect (
"Ignore disabled registers for GPE %02X-%02X: "
"RunEnable=%02X, WakeEnable=%02X\n",
@ -190,10 +190,10 @@ Index: acpica-unix2-20160831/source/components/events/evgpe.c
StatusReg, EnableReg,
GpeRegisterInfo->EnableForRun,
GpeRegisterInfo->EnableForWake));
Index: acpica-unix2-20160831/source/components/executer/exdump.c
Index: acpica-unix2-20161117/source/components/executer/exdump.c
===================================================================
--- acpica-unix2-20160831.orig/source/components/executer/exdump.c
+++ acpica-unix2-20160831/source/components/executer/exdump.c
--- acpica-unix2-20161117.orig/source/components/executer/exdump.c
+++ acpica-unix2-20161117/source/components/executer/exdump.c
@@ -668,7 +668,7 @@ AcpiExDumpOperand (
if (Depth > 0)
{
@ -203,10 +203,10 @@ Index: acpica-unix2-20160831/source/components/executer/exdump.c
}
else
{
Index: acpica-unix2-20160831/source/components/executer/exfldio.c
Index: acpica-unix2-20161117/source/components/executer/exfldio.c
===================================================================
--- acpica-unix2-20160831.orig/source/components/executer/exfldio.c
+++ acpica-unix2-20160831/source/components/executer/exfldio.c
--- acpica-unix2-20161117.orig/source/components/executer/exfldio.c
+++ acpica-unix2-20161117/source/components/executer/exfldio.c
@@ -681,8 +681,8 @@ AcpiExWriteWithUpdateRule (
ACPI_ERROR ((AE_INFO,
@ -218,10 +218,10 @@ Index: acpica-unix2-20160831/source/components/executer/exfldio.c
return_ACPI_STATUS (AE_AML_OPERAND_VALUE);
}
}
Index: acpica-unix2-20160831/source/components/executer/exnames.c
Index: acpica-unix2-20161117/source/components/executer/exnames.c
===================================================================
--- acpica-unix2-20160831.orig/source/components/executer/exnames.c
+++ acpica-unix2-20160831/source/components/executer/exnames.c
--- acpica-unix2-20161117.orig/source/components/executer/exnames.c
+++ acpica-unix2-20161117/source/components/executer/exnames.c
@@ -240,7 +240,7 @@ AcpiExNameSegment (
*/
ACPI_DEBUG_PRINT ((ACPI_DB_INFO,
@ -240,10 +240,10 @@ Index: acpica-unix2-20160831/source/components/executer/exnames.c
}
*InAmlAddress = ACPI_CAST_PTR (UINT8, AmlAddress);
Index: acpica-unix2-20160831/source/components/hardware/hwregs.c
Index: acpica-unix2-20161117/source/components/hardware/hwregs.c
===================================================================
--- acpica-unix2-20160831.orig/source/components/hardware/hwregs.c
+++ acpica-unix2-20160831/source/components/hardware/hwregs.c
--- acpica-unix2-20161117.orig/source/components/hardware/hwregs.c
+++ acpica-unix2-20161117/source/components/hardware/hwregs.c
@@ -300,7 +300,7 @@ AcpiHwClearAcpiStatus (
@ -253,10 +253,10 @@ Index: acpica-unix2-20160831/source/components/hardware/hwregs.c
ACPI_FORMAT_UINT64 (AcpiGbl_XPm1aStatus.Address)));
LockFlags = AcpiOsAcquireLock (AcpiGbl_HardwareLock);
Index: acpica-unix2-20160831/source/components/tables/tbfadt.c
Index: acpica-unix2-20161117/source/components/tables/tbfadt.c
===================================================================
--- acpica-unix2-20160831.orig/source/components/tables/tbfadt.c
+++ acpica-unix2-20160831/source/components/tables/tbfadt.c
--- acpica-unix2-20161117.orig/source/components/tables/tbfadt.c
+++ acpica-unix2-20161117/source/components/tables/tbfadt.c
@@ -233,7 +233,7 @@ AcpiTbInitGenericAddress (
if (!(Flags & ACPI_FADT_GPE_REGISTER))
{
@ -275,7 +275,7 @@ Index: acpica-unix2-20160831/source/components/tables/tbfadt.c
RegisterName, Address32, ACPI_FORMAT_UINT64 (Address64),
AcpiGbl_Use32BitFadtAddresses ? 32 : 64));
@@ -621,7 +621,7 @@ AcpiTbConvertFadt (
@@ -620,7 +620,7 @@ AcpiTbConvertFadt (
ACPI_BIOS_WARNING ((AE_INFO,
"32/64X address mismatch in FADT/%s: "
@ -284,10 +284,10 @@ Index: acpica-unix2-20160831/source/components/tables/tbfadt.c
Name, Address32,
ACPI_FORMAT_UINT64 (Address64->Address),
AcpiGbl_Use32BitFadtAddresses ? 32 : 64));
Index: acpica-unix2-20160831/source/components/tables/tbxfroot.c
Index: acpica-unix2-20161117/source/components/tables/tbxfroot.c
===================================================================
--- acpica-unix2-20160831.orig/source/components/tables/tbxfroot.c
+++ acpica-unix2-20160831/source/components/tables/tbxfroot.c
--- acpica-unix2-20161117.orig/source/components/tables/tbxfroot.c
+++ acpica-unix2-20161117/source/components/tables/tbxfroot.c
@@ -177,7 +177,7 @@ AcpiFindRootPointer (
{
ACPI_ERROR ((AE_INFO,
@ -315,10 +315,10 @@ Index: acpica-unix2-20160831/source/components/tables/tbxfroot.c
return_ACPI_STATUS (AE_NO_MEMORY);
}
Index: acpica-unix2-20160831/source/components/utilities/utownerid.c
Index: acpica-unix2-20161117/source/components/utilities/utownerid.c
===================================================================
--- acpica-unix2-20160831.orig/source/components/utilities/utownerid.c
+++ acpica-unix2-20160831/source/components/utilities/utownerid.c
--- acpica-unix2-20161117.orig/source/components/utilities/utownerid.c
+++ acpica-unix2-20161117/source/components/utilities/utownerid.c
@@ -231,7 +231,7 @@ AcpiUtReleaseOwnerId (
else
{
@ -328,10 +328,10 @@ Index: acpica-unix2-20160831/source/components/utilities/utownerid.c
}
(void) AcpiUtReleaseMutex (ACPI_MTX_CACHES);
Index: acpica-unix2-20160831/source/tools/acpiexec/aemain.c
Index: acpica-unix2-20161117/source/tools/acpiexec/aemain.c
===================================================================
--- acpica-unix2-20160831.orig/source/tools/acpiexec/aemain.c
+++ acpica-unix2-20160831/source/tools/acpiexec/aemain.c
--- acpica-unix2-20161117.orig/source/tools/acpiexec/aemain.c
+++ acpica-unix2-20161117/source/tools/acpiexec/aemain.c
@@ -207,7 +207,7 @@ AeDoOptions (
if (strlen (AcpiGbl_Optarg) > (AE_BUFFER_SIZE -1))

View File

@ -10,10 +10,10 @@ made in the remainder of the function.
source/compiler/aslanalyze.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Index: acpica-unix2-20160422/source/compiler/aslanalyze.c
Index: acpica-unix2-20161117/source/compiler/aslanalyze.c
===================================================================
--- acpica-unix2-20160422.orig/source/compiler/aslanalyze.c
+++ acpica-unix2-20160422/source/compiler/aslanalyze.c
--- acpica-unix2-20161117.orig/source/compiler/aslanalyze.c
+++ acpica-unix2-20161117/source/compiler/aslanalyze.c
@@ -461,7 +461,7 @@ ApCheckForGpeNameConflict (
/* Need a null-terminated string version of NameSeg */

View File

@ -7,10 +7,10 @@ Al Stone <ahs3@redhat.com>
source/compiler/aslmain.c | 12 ------------
1 file changed, 12 deletions(-)
Index: acpica-unix2-20160831/source/compiler/aslmain.c
Index: acpica-unix2-20161117/source/compiler/aslmain.c
===================================================================
--- acpica-unix2-20160831.orig/source/compiler/aslmain.c
+++ acpica-unix2-20160831/source/compiler/aslmain.c
--- acpica-unix2-20161117.orig/source/compiler/aslmain.c
+++ acpica-unix2-20161117/source/compiler/aslmain.c
@@ -99,18 +99,6 @@ main (
int ReturnStatus = 0;

View File

@ -1,6 +1,7 @@
diff -Naur acpica-unix2-20160831/source/include/platform/aclinux.h acpica-unix2-20160831-s390x/source/include/platform/aclinux.h
--- acpica-unix2-20160831/source/include/platform/aclinux.h 2016-09-01 15:18:36.306268594 -0600
+++ acpica-unix2-20160831-s390x/source/include/platform/aclinux.h 2016-09-01 16:01:34.955157827 -0600
Index: acpica-unix2-20161117/source/include/platform/aclinux.h
===================================================================
--- acpica-unix2-20161117.orig/source/include/platform/aclinux.h
+++ acpica-unix2-20161117/source/include/platform/aclinux.h
@@ -194,7 +194,8 @@
#define ACPI_CAST_PTHREAD_T(Pthread) ((ACPI_THREAD_ID) (Pthread))

View File

@ -1,2 +1,2 @@
44a36d5ac3faaaca4b0c0df6c14f9e93 acpica-unix2-20160930.tar.gz
067a3b96e5f8cc211aeb0444d135af8e acpitests-unix-20160930.tar.gz
SHA512 (acpica-unix2-20161117.tar.gz) = fc7626a0729dc87043faec68027c5b6c98b62c95075f5b83aba6110a43a51719c555b550a42f4f624617a99e7d33cb8503f147c6a1dbb25f2cd6644538f4c9a2
SHA512 (acpitests-unix-20161117.tar.gz) = 8b68bc294c31a56b0d7bd9ea61ddadb25b978e4fade16db7fb8bbb8ca0e89f364fc49a2b17c1d7f694bc79007934aa2ef00e06f0fb9675f5fa5029cf53b9e0e8

View File

@ -7,10 +7,10 @@ From: Al Stone <ahs3@redhat.com>
tests/templates/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Index: acpica-unix2-20160422/tests/templates/Makefile
Index: acpica-unix2-20161117/tests/templates/Makefile
===================================================================
--- acpica-unix2-20160422.orig/tests/templates/Makefile
+++ acpica-unix2-20160422/tests/templates/Makefile
--- acpica-unix2-20161117.orig/tests/templates/Makefile
+++ acpica-unix2-20161117/tests/templates/Makefile
@@ -2,7 +2,7 @@
PROG= templates

File diff suppressed because it is too large Load Diff