Update to 20170929 upstream source, refresh patches
Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
parent
228382991b
commit
51ac8fe2c8
2
.gitignore
vendored
2
.gitignore
vendored
@ -76,3 +76,5 @@
|
|||||||
/acpitests-unix-20170728.tar.gz
|
/acpitests-unix-20170728.tar.gz
|
||||||
/acpica-unix2-20170831.tar.gz
|
/acpica-unix2-20170831.tar.gz
|
||||||
/acpitests-unix-20170831.tar.gz
|
/acpitests-unix-20170831.tar.gz
|
||||||
|
/acpica-unix2-20170929.tar.gz
|
||||||
|
/acpitests-unix-20170929.tar.gz
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
Name: acpica-tools
|
Name: acpica-tools
|
||||||
Version: 20170831
|
Version: 20170929
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: ACPICA tools for the development and debug of ACPI tables
|
Summary: ACPICA tools for the development and debug of ACPI tables
|
||||||
|
|
||||||
@ -32,7 +32,6 @@ Patch5: template.patch
|
|||||||
Patch6: free.patch
|
Patch6: free.patch
|
||||||
Patch7: ppc64le.patch
|
Patch7: ppc64le.patch
|
||||||
Patch8: arm7hl.patch
|
Patch8: arm7hl.patch
|
||||||
Patch9: aslts-acpibin.patch
|
|
||||||
|
|
||||||
BuildRequires: bison patchutils flex
|
BuildRequires: bison patchutils flex
|
||||||
|
|
||||||
@ -91,7 +90,6 @@ gzip -dc %{SOURCE1} | tar -x --strip-components=1 -f -
|
|||||||
%patch6 -p1 -b .free
|
%patch6 -p1 -b .free
|
||||||
%patch7 -p1 -b .ppc64le
|
%patch7 -p1 -b .ppc64le
|
||||||
%patch8 -p1 -b .arm7hl
|
%patch8 -p1 -b .arm7hl
|
||||||
%patch9 -p1 -b .aslts-acpibin
|
|
||||||
|
|
||||||
cp -p %{SOURCE2} README.Fedora
|
cp -p %{SOURCE2} README.Fedora
|
||||||
cp -p %{SOURCE3} iasl.1
|
cp -p %{SOURCE3} iasl.1
|
||||||
@ -186,6 +184,10 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Oct 6 2017 Al Stone <ahs3@redhat.com> - 20170929-1
|
||||||
|
- Update to 20170929 source tree, including patch refeshes
|
||||||
|
- Removed aslts-acpibin.patch to fix PATH problem in ASLTS; in upstream now
|
||||||
|
|
||||||
* Wed Sep 27 2017 Al Stone <ahs3@redhat.com> - 20170831-1
|
* Wed Sep 27 2017 Al Stone <ahs3@redhat.com> - 20170831-1
|
||||||
- Update to 20170831 source tree, including patch refeshes
|
- Update to 20170831 source tree, including patch refeshes
|
||||||
- Add aslts-acpibin.patch to fix PATH problem in ASLTS that prevents
|
- Add aslts-acpibin.patch to fix PATH problem in ASLTS that prevents
|
||||||
|
@ -1,130 +0,0 @@
|
|||||||
diff -Naur acpica-unix2-20170831.orig/tests/aslts/bin/Do acpica-unix2-20170831/tests/aslts/bin/Do
|
|
||||||
--- acpica-unix2-20170831.orig/tests/aslts/bin/Do 2017-09-27 14:34:19.377122047 -0600
|
|
||||||
+++ acpica-unix2-20170831/tests/aslts/bin/Do 2017-09-27 14:42:18.728970485 -0600
|
|
||||||
@@ -20,12 +20,13 @@
|
|
||||||
#
|
|
||||||
# ASL - iASL compiler
|
|
||||||
# acpiexec - AcpiExec utility
|
|
||||||
+# acpibin - AcpiBin utility
|
|
||||||
# ASLTSDIR - pathname of root directory of aslts test suite
|
|
||||||
#
|
|
||||||
# External definitions required for particular command:
|
|
||||||
#
|
|
||||||
# 0 - ASLTSDIR, ASL
|
|
||||||
-# 1 - ASLTSDIR, acpiexec
|
|
||||||
+# 1 - ASLTSDIR, acpiexec, acpibin
|
|
||||||
# 2 - ASLTSDIR
|
|
||||||
# 3 - none
|
|
||||||
# 4 - ASLTSDIR
|
|
||||||
@@ -339,7 +340,7 @@
|
|
||||||
for f in $disasm_compile_dir/*
|
|
||||||
do
|
|
||||||
filename=`basename $f`
|
|
||||||
- acpibin -a "$f" "$normal_compile_dir/$filename" > /dev/null
|
|
||||||
+ $acpibin -a "$f" "$normal_compile_dir/$filename" > /dev/null
|
|
||||||
if [ $? -ne 0 ]; then
|
|
||||||
echo "[[ Error: $mode Binary compare for $filename failed ]]"
|
|
||||||
else
|
|
||||||
@@ -791,6 +792,12 @@
|
|
||||||
do_exit 1 "Undefined acpiexec variable! Set it to pathname of AcpiExec utility."
|
|
||||||
fi
|
|
||||||
|
|
||||||
+ # Check access to AcpiBin utility
|
|
||||||
+
|
|
||||||
+ if [ ! -f "$acpibin" ]; then
|
|
||||||
+ do_exit 1 "Undefined acpibin variable! Set it to pathname of AcpiBin utility."
|
|
||||||
+ fi
|
|
||||||
+
|
|
||||||
shift 1
|
|
||||||
ASLTSRUN_PARAMS=
|
|
||||||
|
|
||||||
diff -Naur acpica-unix2-20170831.orig/tests/aslts/HOW_TO_INSTALL acpica-unix2-20170831/tests/aslts/HOW_TO_INSTALL
|
|
||||||
--- acpica-unix2-20170831.orig/tests/aslts/HOW_TO_INSTALL 2017-09-27 14:34:19.376122049 -0600
|
|
||||||
+++ acpica-unix2-20170831/tests/aslts/HOW_TO_INSTALL 2017-09-27 14:39:12.832417070 -0600
|
|
||||||
@@ -49,12 +49,16 @@
|
|
||||||
> export ASL="c:/acpica/libraries/iasl.exe"
|
|
||||||
|
|
||||||
|
|
||||||
- For test execution, two additional variables are required:
|
|
||||||
+ For test execution, three additional variables are required:
|
|
||||||
|
|
||||||
acpiexec - path to acpiexec utility: (example)
|
|
||||||
|
|
||||||
> export acpiexec="c:/acpica/libraries/acpiexec.exe"
|
|
||||||
|
|
||||||
+ acpibin - path to acpibin utility: (example)
|
|
||||||
+
|
|
||||||
+ > export acpibin="c:/acpica/libraries/acpibin.exe"
|
|
||||||
+
|
|
||||||
ASLTSDIR - path to the aslts directory: (example)
|
|
||||||
|
|
||||||
> export ASLTSDIR="c:/acpica/tests/aslts"
|
|
||||||
diff -Naur acpica-unix2-20170831.orig/tests/aslts/HOW_TO_USE acpica-unix2-20170831/tests/aslts/HOW_TO_USE
|
|
||||||
--- acpica-unix2-20170831.orig/tests/aslts/HOW_TO_USE 2017-09-27 14:34:19.376122049 -0600
|
|
||||||
+++ acpica-unix2-20170831/tests/aslts/HOW_TO_USE 2017-09-27 14:39:49.601328739 -0600
|
|
||||||
@@ -32,6 +32,10 @@
|
|
||||||
|
|
||||||
> export acpiexec="c:/acpica/libraries/acpiexec.exe"
|
|
||||||
|
|
||||||
+ acpibin - path to acpibin utility: (example)
|
|
||||||
+
|
|
||||||
+ > export acpibin="c:/acpica/libraries/acpibin.exe"
|
|
||||||
+
|
|
||||||
ASLTSDIR - path to the aslts directory: (example)
|
|
||||||
|
|
||||||
> export ASLTSDIR="c:/acpica/tests/aslts"
|
|
||||||
diff -Naur acpica-unix2-20170831.orig/tests/aslts.sh acpica-unix2-20170831/tests/aslts.sh
|
|
||||||
--- acpica-unix2-20170831.orig/tests/aslts.sh 2017-09-27 14:34:19.375122051 -0600
|
|
||||||
+++ acpica-unix2-20170831/tests/aslts.sh 2017-09-27 14:37:51.920611447 -0600
|
|
||||||
@@ -7,6 +7,7 @@
|
|
||||||
postfix=`date +%H%M%S`
|
|
||||||
tmp_iasl=/tmp/iasl-$postfix
|
|
||||||
tmp_acpiexec=/tmp/acpiexec-$postfix
|
|
||||||
+tmp_acpibin=/tmp/acpibin-$postfix
|
|
||||||
|
|
||||||
TEST_CASES=
|
|
||||||
TEST_MODES=
|
|
||||||
@@ -65,6 +66,7 @@
|
|
||||||
|
|
||||||
export ASL=$tmp_iasl
|
|
||||||
export acpiexec=$tmp_acpiexec
|
|
||||||
+ export acpibin=$tmp_acpibin
|
|
||||||
export ASLTSDIR=$aslts_dir
|
|
||||||
export PATH=$ASLTSDIR/bin:$PATH
|
|
||||||
}
|
|
||||||
@@ -75,7 +77,7 @@
|
|
||||||
|
|
||||||
restore_dir=$PWD
|
|
||||||
cd ${generation_dir}
|
|
||||||
- rm -f $tmp_iasl $tmp_acpiexec
|
|
||||||
+ rm -f $tmp_iasl $tmp_acpiexec $tmp_acpibin
|
|
||||||
|
|
||||||
# Build native-width iASL compiler and acpiexec
|
|
||||||
if [ ! -e bin/iasl -o ! -e bin/acpiexec ]; then
|
|
||||||
@@ -91,6 +93,7 @@
|
|
||||||
echo "Installing ACPICA tools"
|
|
||||||
cp bin/iasl $tmp_iasl
|
|
||||||
cp bin/acpiexec $tmp_acpiexec
|
|
||||||
+ cp bin/acpibin $tmp_acpibin
|
|
||||||
else
|
|
||||||
echo "Could not find iASL/acpiexec tools"
|
|
||||||
exit
|
|
||||||
@@ -103,6 +106,9 @@
|
|
||||||
elif [ ! -f $tmp_acpiexec ] ; then
|
|
||||||
echo "acpiexec utility not found"
|
|
||||||
exit
|
|
||||||
+ elif [ ! -f $tmp_acpibin ] ; then
|
|
||||||
+ echo "acpibin utility not found"
|
|
||||||
+ exit
|
|
||||||
fi
|
|
||||||
|
|
||||||
cd $restore_dir
|
|
||||||
@@ -140,7 +146,7 @@
|
|
||||||
echo "ASL Test Suite Finished: `date`"
|
|
||||||
echo " Started: $start_time"
|
|
||||||
|
|
||||||
- rm -f $tmp_iasl $tmp_acpiexec
|
|
||||||
+ rm -f $tmp_iasl $tmp_acpiexec $tmp_acpibin
|
|
||||||
fi;
|
|
||||||
}
|
|
||||||
|
|
956
big-endian.patch
956
big-endian.patch
File diff suppressed because it is too large
Load Diff
@ -8,10 +8,10 @@ From: Al Stone <ahs3@redhat.com>
|
|||||||
generate/unix/iasl/Makefile | 13 +++++++------
|
generate/unix/iasl/Makefile | 13 +++++++------
|
||||||
2 files changed, 9 insertions(+), 6 deletions(-)
|
2 files changed, 9 insertions(+), 6 deletions(-)
|
||||||
|
|
||||||
Index: acpica-unix2-20170831/generate/unix/Makefile.config
|
Index: acpica-unix2-20170929/generate/unix/Makefile.config
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20170831.orig/generate/unix/Makefile.config
|
--- acpica-unix2-20170929.orig/generate/unix/Makefile.config
|
||||||
+++ acpica-unix2-20170831/generate/unix/Makefile.config
|
+++ acpica-unix2-20170929/generate/unix/Makefile.config
|
||||||
@@ -182,6 +182,8 @@ ifneq ($(NOFORTIFY),TRUE)
|
@@ -182,6 +182,8 @@ ifneq ($(NOFORTIFY),TRUE)
|
||||||
OPT_CFLAGS += -D_FORTIFY_SOURCE=2
|
OPT_CFLAGS += -D_FORTIFY_SOURCE=2
|
||||||
endif
|
endif
|
||||||
@ -21,11 +21,11 @@ Index: acpica-unix2-20170831/generate/unix/Makefile.config
|
|||||||
CFLAGS += \
|
CFLAGS += \
|
||||||
-D$(HOST)\
|
-D$(HOST)\
|
||||||
-D_GNU_SOURCE\
|
-D_GNU_SOURCE\
|
||||||
Index: acpica-unix2-20170831/generate/unix/iasl/Makefile
|
Index: acpica-unix2-20170929/generate/unix/iasl/Makefile
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20170831.orig/generate/unix/iasl/Makefile
|
--- acpica-unix2-20170929.orig/generate/unix/iasl/Makefile
|
||||||
+++ acpica-unix2-20170831/generate/unix/iasl/Makefile
|
+++ acpica-unix2-20170929/generate/unix/iasl/Makefile
|
||||||
@@ -336,26 +336,27 @@ $(OBJDIR)/prparserparse.c $(OBJDIR)/prpa
|
@@ -338,26 +338,27 @@ $(OBJDIR)/prparserparse.c $(OBJDIR)/prpa
|
||||||
# Cannot use the common compile warning flags since the C files are created
|
# Cannot use the common compile warning flags since the C files are created
|
||||||
# by the utilities above and they are not necessarily ANSI C, etc.
|
# by the utilities above and they are not necessarily ANSI C, etc.
|
||||||
#
|
#
|
||||||
|
@ -1,10 +1,10 @@
|
|||||||
This prevents a segfault when an Include file does not exist.
|
This prevents a segfault when an Include file does not exist.
|
||||||
|
|
||||||
Index: acpica-unix2-20161222/source/compiler/aslfiles.c
|
Index: acpica-unix2-20170929/source/compiler/aslfiles.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20161222.orig/source/compiler/aslfiles.c
|
--- acpica-unix2-20170929.orig/source/compiler/aslfiles.c
|
||||||
+++ acpica-unix2-20161222/source/compiler/aslfiles.c
|
+++ acpica-unix2-20170929/source/compiler/aslfiles.c
|
||||||
@@ -319,7 +319,7 @@ FlOpenIncludeWithPrefix (
|
@@ -318,7 +318,7 @@ FlOpenIncludeWithPrefix (
|
||||||
if (!IncludeFile)
|
if (!IncludeFile)
|
||||||
{
|
{
|
||||||
fprintf (stderr, "Could not open include file %s\n", Pathname);
|
fprintf (stderr, "Could not open include file %s\n", Pathname);
|
||||||
|
116
int-format.patch
116
int-format.patch
@ -24,11 +24,11 @@ From: Al Stone <ahs3@redhat.com>
|
|||||||
source/tools/acpiexec/aemain.c | 2 +-
|
source/tools/acpiexec/aemain.c | 2 +-
|
||||||
18 files changed, 28 insertions(+), 28 deletions(-)
|
18 files changed, 28 insertions(+), 28 deletions(-)
|
||||||
|
|
||||||
Index: acpica-unix2-20170831/source/compiler/aslcompile.c
|
Index: acpica-unix2-20170929/source/compiler/aslcompile.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20170831.orig/source/compiler/aslcompile.c
|
--- acpica-unix2-20170929.orig/source/compiler/aslcompile.c
|
||||||
+++ acpica-unix2-20170831/source/compiler/aslcompile.c
|
+++ acpica-unix2-20170929/source/compiler/aslcompile.c
|
||||||
@@ -751,7 +751,7 @@ CmCleanupAndExit (
|
@@ -750,7 +750,7 @@ CmCleanupAndExit (
|
||||||
|
|
||||||
if (Gbl_ExceptionCount[ASL_ERROR] > ASL_MAX_ERROR_COUNT)
|
if (Gbl_ExceptionCount[ASL_ERROR] > ASL_MAX_ERROR_COUNT)
|
||||||
{
|
{
|
||||||
@ -37,11 +37,11 @@ Index: acpica-unix2-20170831/source/compiler/aslcompile.c
|
|||||||
ASL_MAX_ERROR_COUNT);
|
ASL_MAX_ERROR_COUNT);
|
||||||
}
|
}
|
||||||
|
|
||||||
Index: acpica-unix2-20170831/source/compiler/aslerror.c
|
Index: acpica-unix2-20170929/source/compiler/aslerror.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20170831.orig/source/compiler/aslerror.c
|
--- acpica-unix2-20170929.orig/source/compiler/aslerror.c
|
||||||
+++ acpica-unix2-20170831/source/compiler/aslerror.c
|
+++ acpica-unix2-20170929/source/compiler/aslerror.c
|
||||||
@@ -702,7 +702,7 @@ AslCommonError (
|
@@ -873,7 +873,7 @@ AslLogNewError (
|
||||||
Gbl_ExceptionCount[Level]++;
|
Gbl_ExceptionCount[Level]++;
|
||||||
if (Gbl_ExceptionCount[ASL_ERROR] > ASL_MAX_ERROR_COUNT)
|
if (Gbl_ExceptionCount[ASL_ERROR] > ASL_MAX_ERROR_COUNT)
|
||||||
{
|
{
|
||||||
@ -50,7 +50,7 @@ Index: acpica-unix2-20170831/source/compiler/aslerror.c
|
|||||||
|
|
||||||
Gbl_SourceLine = 0;
|
Gbl_SourceLine = 0;
|
||||||
Gbl_NextError = Gbl_ErrorLog;
|
Gbl_NextError = Gbl_ErrorLog;
|
||||||
@@ -857,7 +857,7 @@ AslDisableException (
|
@@ -1029,7 +1029,7 @@ AslDisableException (
|
||||||
|
|
||||||
if (Gbl_DisabledMessagesIndex >= ASL_MAX_DISABLED_MESSAGES)
|
if (Gbl_DisabledMessagesIndex >= ASL_MAX_DISABLED_MESSAGES)
|
||||||
{
|
{
|
||||||
@ -59,10 +59,10 @@ Index: acpica-unix2-20170831/source/compiler/aslerror.c
|
|||||||
ASL_MAX_DISABLED_MESSAGES);
|
ASL_MAX_DISABLED_MESSAGES);
|
||||||
return (AE_LIMIT);
|
return (AE_LIMIT);
|
||||||
}
|
}
|
||||||
Index: acpica-unix2-20170831/source/compiler/aslopt.c
|
Index: acpica-unix2-20170929/source/compiler/aslopt.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20170831.orig/source/compiler/aslopt.c
|
--- acpica-unix2-20170929.orig/source/compiler/aslopt.c
|
||||||
+++ acpica-unix2-20170831/source/compiler/aslopt.c
|
+++ acpica-unix2-20170929/source/compiler/aslopt.c
|
||||||
@@ -584,7 +584,7 @@ OptOptimizeNamePath (
|
@@ -584,7 +584,7 @@ OptOptimizeNamePath (
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -72,10 +72,10 @@ Index: acpica-unix2-20170831/source/compiler/aslopt.c
|
|||||||
Op->Asl.LogicalLineNumber,
|
Op->Asl.LogicalLineNumber,
|
||||||
AcpiPsGetOpcodeName (Op->Common.Parent->Common.AmlOpcode),
|
AcpiPsGetOpcodeName (Op->Common.Parent->Common.AmlOpcode),
|
||||||
AcpiPsGetOpcodeName (Op->Common.AmlOpcode)));
|
AcpiPsGetOpcodeName (Op->Common.AmlOpcode)));
|
||||||
Index: acpica-unix2-20170831/source/compiler/aslpredef.c
|
Index: acpica-unix2-20170929/source/compiler/aslpredef.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20170831.orig/source/compiler/aslpredef.c
|
--- acpica-unix2-20170929.orig/source/compiler/aslpredef.c
|
||||||
+++ acpica-unix2-20170831/source/compiler/aslpredef.c
|
+++ acpica-unix2-20170929/source/compiler/aslpredef.c
|
||||||
@@ -114,7 +114,7 @@ ApCheckForPredefinedMethod (
|
@@ -114,7 +114,7 @@ ApCheckForPredefinedMethod (
|
||||||
|
|
||||||
if (MethodInfo->NumArguments != 0)
|
if (MethodInfo->NumArguments != 0)
|
||||||
@ -85,10 +85,10 @@ Index: acpica-unix2-20170831/source/compiler/aslpredef.c
|
|||||||
|
|
||||||
AslError (ASL_WARNING, ASL_MSG_RESERVED_ARG_COUNT_HI, Op,
|
AslError (ASL_WARNING, ASL_MSG_RESERVED_ARG_COUNT_HI, Op,
|
||||||
MsgBuffer);
|
MsgBuffer);
|
||||||
Index: acpica-unix2-20170831/source/compiler/aslprepkg.c
|
Index: acpica-unix2-20170929/source/compiler/aslprepkg.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20170831.orig/source/compiler/aslprepkg.c
|
--- acpica-unix2-20170929.orig/source/compiler/aslprepkg.c
|
||||||
+++ acpica-unix2-20170831/source/compiler/aslprepkg.c
|
+++ acpica-unix2-20170929/source/compiler/aslprepkg.c
|
||||||
@@ -309,7 +309,7 @@ ApCheckPackage (
|
@@ -309,7 +309,7 @@ ApCheckPackage (
|
||||||
|
|
||||||
if (Count & 1)
|
if (Count & 1)
|
||||||
@ -98,10 +98,10 @@ Index: acpica-unix2-20170831/source/compiler/aslprepkg.c
|
|||||||
Predefined->Info.Name, Count);
|
Predefined->Info.Name, Count);
|
||||||
|
|
||||||
AslError (ASL_ERROR, ASL_MSG_RESERVED_PACKAGE_LENGTH,
|
AslError (ASL_ERROR, ASL_MSG_RESERVED_PACKAGE_LENGTH,
|
||||||
Index: acpica-unix2-20170831/source/components/debugger/dbexec.c
|
Index: acpica-unix2-20170929/source/components/debugger/dbexec.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20170831.orig/source/components/debugger/dbexec.c
|
--- acpica-unix2-20170929.orig/source/components/debugger/dbexec.c
|
||||||
+++ acpica-unix2-20170831/source/components/debugger/dbexec.c
|
+++ acpica-unix2-20170929/source/components/debugger/dbexec.c
|
||||||
@@ -226,7 +226,7 @@ AcpiDbExecuteMethod (
|
@@ -226,7 +226,7 @@ AcpiDbExecuteMethod (
|
||||||
ACPI_ERROR ((AE_INFO,
|
ACPI_ERROR ((AE_INFO,
|
||||||
"Possible overflow of internal debugger "
|
"Possible overflow of internal debugger "
|
||||||
@ -111,10 +111,10 @@ Index: acpica-unix2-20170831/source/components/debugger/dbexec.c
|
|||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
Index: acpica-unix2-20170831/source/components/dispatcher/dsmthdat.c
|
Index: acpica-unix2-20170929/source/components/dispatcher/dsmthdat.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20170831.orig/source/components/dispatcher/dsmthdat.c
|
--- acpica-unix2-20170929.orig/source/components/dispatcher/dsmthdat.c
|
||||||
+++ acpica-unix2-20170831/source/components/dispatcher/dsmthdat.c
|
+++ acpica-unix2-20170929/source/components/dispatcher/dsmthdat.c
|
||||||
@@ -291,7 +291,7 @@ AcpiDsMethodDataGetNode (
|
@@ -291,7 +291,7 @@ AcpiDsMethodDataGetNode (
|
||||||
if (Index > ACPI_METHOD_MAX_LOCAL)
|
if (Index > ACPI_METHOD_MAX_LOCAL)
|
||||||
{
|
{
|
||||||
@ -133,10 +133,10 @@ Index: acpica-unix2-20170831/source/components/dispatcher/dsmthdat.c
|
|||||||
Index, ACPI_METHOD_MAX_ARG));
|
Index, ACPI_METHOD_MAX_ARG));
|
||||||
return_ACPI_STATUS (AE_AML_INVALID_INDEX);
|
return_ACPI_STATUS (AE_AML_INVALID_INDEX);
|
||||||
}
|
}
|
||||||
Index: acpica-unix2-20170831/source/components/dispatcher/dsutils.c
|
Index: acpica-unix2-20170929/source/components/dispatcher/dsutils.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20170831.orig/source/components/dispatcher/dsutils.c
|
--- acpica-unix2-20170929.orig/source/components/dispatcher/dsutils.c
|
||||||
+++ acpica-unix2-20170831/source/components/dispatcher/dsutils.c
|
+++ acpica-unix2-20170929/source/components/dispatcher/dsutils.c
|
||||||
@@ -787,7 +787,7 @@ AcpiDsCreateOperands (
|
@@ -787,7 +787,7 @@ AcpiDsCreateOperands (
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -146,10 +146,10 @@ Index: acpica-unix2-20170831/source/components/dispatcher/dsutils.c
|
|||||||
WalkState->NumOperands, ArgCount, Index));
|
WalkState->NumOperands, ArgCount, Index));
|
||||||
|
|
||||||
/* Create the interpreter arguments, in reverse order */
|
/* Create the interpreter arguments, in reverse order */
|
||||||
Index: acpica-unix2-20170831/source/components/dispatcher/dswscope.c
|
Index: acpica-unix2-20170929/source/components/dispatcher/dswscope.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20170831.orig/source/components/dispatcher/dswscope.c
|
--- acpica-unix2-20170929.orig/source/components/dispatcher/dswscope.c
|
||||||
+++ acpica-unix2-20170831/source/components/dispatcher/dswscope.c
|
+++ acpica-unix2-20170929/source/components/dispatcher/dswscope.c
|
||||||
@@ -149,7 +149,7 @@ AcpiDsScopeStackPush (
|
@@ -149,7 +149,7 @@ AcpiDsScopeStackPush (
|
||||||
WalkState->ScopeDepth++;
|
WalkState->ScopeDepth++;
|
||||||
|
|
||||||
@ -168,10 +168,10 @@ Index: acpica-unix2-20170831/source/components/dispatcher/dswscope.c
|
|||||||
(UINT32) WalkState->ScopeDepth,
|
(UINT32) WalkState->ScopeDepth,
|
||||||
AcpiUtGetNodeName (ScopeInfo->Scope.Node),
|
AcpiUtGetNodeName (ScopeInfo->Scope.Node),
|
||||||
AcpiUtGetTypeName (ScopeInfo->Common.Value)));
|
AcpiUtGetTypeName (ScopeInfo->Common.Value)));
|
||||||
Index: acpica-unix2-20170831/source/components/events/evgpe.c
|
Index: acpica-unix2-20170929/source/components/events/evgpe.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20170831.orig/source/components/events/evgpe.c
|
--- acpica-unix2-20170929.orig/source/components/events/evgpe.c
|
||||||
+++ acpica-unix2-20170831/source/components/events/evgpe.c
|
+++ acpica-unix2-20170929/source/components/events/evgpe.c
|
||||||
@@ -494,7 +494,7 @@ AcpiEvGpeDetect (
|
@@ -494,7 +494,7 @@ AcpiEvGpeDetect (
|
||||||
"Ignore disabled registers for GPE %02X-%02X: "
|
"Ignore disabled registers for GPE %02X-%02X: "
|
||||||
"RunEnable=%02X, WakeEnable=%02X\n",
|
"RunEnable=%02X, WakeEnable=%02X\n",
|
||||||
@ -190,10 +190,10 @@ Index: acpica-unix2-20170831/source/components/events/evgpe.c
|
|||||||
(UINT32) StatusReg, (UINT32) EnableReg,
|
(UINT32) StatusReg, (UINT32) EnableReg,
|
||||||
GpeRegisterInfo->EnableForRun,
|
GpeRegisterInfo->EnableForRun,
|
||||||
GpeRegisterInfo->EnableForWake));
|
GpeRegisterInfo->EnableForWake));
|
||||||
Index: acpica-unix2-20170831/source/components/executer/exdump.c
|
Index: acpica-unix2-20170929/source/components/executer/exdump.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20170831.orig/source/components/executer/exdump.c
|
--- acpica-unix2-20170929.orig/source/components/executer/exdump.c
|
||||||
+++ acpica-unix2-20170831/source/components/executer/exdump.c
|
+++ acpica-unix2-20170929/source/components/executer/exdump.c
|
||||||
@@ -678,7 +678,7 @@ AcpiExDumpOperand (
|
@@ -678,7 +678,7 @@ AcpiExDumpOperand (
|
||||||
if (Depth > 0)
|
if (Depth > 0)
|
||||||
{
|
{
|
||||||
@ -203,10 +203,10 @@ Index: acpica-unix2-20170831/source/components/executer/exdump.c
|
|||||||
}
|
}
|
||||||
else
|
else
|
||||||
{
|
{
|
||||||
Index: acpica-unix2-20170831/source/components/executer/exfldio.c
|
Index: acpica-unix2-20170929/source/components/executer/exfldio.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20170831.orig/source/components/executer/exfldio.c
|
--- acpica-unix2-20170929.orig/source/components/executer/exfldio.c
|
||||||
+++ acpica-unix2-20170831/source/components/executer/exfldio.c
|
+++ acpica-unix2-20170929/source/components/executer/exfldio.c
|
||||||
@@ -681,8 +681,8 @@ AcpiExWriteWithUpdateRule (
|
@@ -681,8 +681,8 @@ AcpiExWriteWithUpdateRule (
|
||||||
|
|
||||||
ACPI_ERROR ((AE_INFO,
|
ACPI_ERROR ((AE_INFO,
|
||||||
@ -218,10 +218,10 @@ Index: acpica-unix2-20170831/source/components/executer/exfldio.c
|
|||||||
return_ACPI_STATUS (AE_AML_OPERAND_VALUE);
|
return_ACPI_STATUS (AE_AML_OPERAND_VALUE);
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
Index: acpica-unix2-20170831/source/components/executer/exnames.c
|
Index: acpica-unix2-20170929/source/components/executer/exnames.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20170831.orig/source/components/executer/exnames.c
|
--- acpica-unix2-20170929.orig/source/components/executer/exnames.c
|
||||||
+++ acpica-unix2-20170831/source/components/executer/exnames.c
|
+++ acpica-unix2-20170929/source/components/executer/exnames.c
|
||||||
@@ -240,7 +240,7 @@ AcpiExNameSegment (
|
@@ -240,7 +240,7 @@ AcpiExNameSegment (
|
||||||
*/
|
*/
|
||||||
ACPI_DEBUG_PRINT ((ACPI_DB_INFO,
|
ACPI_DEBUG_PRINT ((ACPI_DB_INFO,
|
||||||
@ -240,10 +240,10 @@ Index: acpica-unix2-20170831/source/components/executer/exnames.c
|
|||||||
}
|
}
|
||||||
|
|
||||||
*InAmlAddress = ACPI_CAST_PTR (UINT8, AmlAddress);
|
*InAmlAddress = ACPI_CAST_PTR (UINT8, AmlAddress);
|
||||||
Index: acpica-unix2-20170831/source/components/hardware/hwregs.c
|
Index: acpica-unix2-20170929/source/components/hardware/hwregs.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20170831.orig/source/components/hardware/hwregs.c
|
--- acpica-unix2-20170929.orig/source/components/hardware/hwregs.c
|
||||||
+++ acpica-unix2-20170831/source/components/hardware/hwregs.c
|
+++ acpica-unix2-20170929/source/components/hardware/hwregs.c
|
||||||
@@ -460,7 +460,7 @@ AcpiHwClearAcpiStatus (
|
@@ -460,7 +460,7 @@ AcpiHwClearAcpiStatus (
|
||||||
|
|
||||||
|
|
||||||
@ -253,10 +253,10 @@ Index: acpica-unix2-20170831/source/components/hardware/hwregs.c
|
|||||||
ACPI_FORMAT_UINT64 (AcpiGbl_XPm1aStatus.Address)));
|
ACPI_FORMAT_UINT64 (AcpiGbl_XPm1aStatus.Address)));
|
||||||
|
|
||||||
LockFlags = AcpiOsAcquireLock (AcpiGbl_HardwareLock);
|
LockFlags = AcpiOsAcquireLock (AcpiGbl_HardwareLock);
|
||||||
Index: acpica-unix2-20170831/source/components/tables/tbfadt.c
|
Index: acpica-unix2-20170929/source/components/tables/tbfadt.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20170831.orig/source/components/tables/tbfadt.c
|
--- acpica-unix2-20170929.orig/source/components/tables/tbfadt.c
|
||||||
+++ acpica-unix2-20170831/source/components/tables/tbfadt.c
|
+++ acpica-unix2-20170929/source/components/tables/tbfadt.c
|
||||||
@@ -233,7 +233,7 @@ AcpiTbInitGenericAddress (
|
@@ -233,7 +233,7 @@ AcpiTbInitGenericAddress (
|
||||||
if (!(Flags & ACPI_FADT_GPE_REGISTER))
|
if (!(Flags & ACPI_FADT_GPE_REGISTER))
|
||||||
{
|
{
|
||||||
@ -284,10 +284,10 @@ Index: acpica-unix2-20170831/source/components/tables/tbfadt.c
|
|||||||
Name, Address32,
|
Name, Address32,
|
||||||
ACPI_FORMAT_UINT64 (Address64->Address),
|
ACPI_FORMAT_UINT64 (Address64->Address),
|
||||||
AcpiGbl_Use32BitFadtAddresses ? 32 : 64));
|
AcpiGbl_Use32BitFadtAddresses ? 32 : 64));
|
||||||
Index: acpica-unix2-20170831/source/components/tables/tbxfroot.c
|
Index: acpica-unix2-20170929/source/components/tables/tbxfroot.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20170831.orig/source/components/tables/tbxfroot.c
|
--- acpica-unix2-20170929.orig/source/components/tables/tbxfroot.c
|
||||||
+++ acpica-unix2-20170831/source/components/tables/tbxfroot.c
|
+++ acpica-unix2-20170929/source/components/tables/tbxfroot.c
|
||||||
@@ -177,7 +177,7 @@ AcpiFindRootPointer (
|
@@ -177,7 +177,7 @@ AcpiFindRootPointer (
|
||||||
{
|
{
|
||||||
ACPI_ERROR ((AE_INFO,
|
ACPI_ERROR ((AE_INFO,
|
||||||
@ -315,10 +315,10 @@ Index: acpica-unix2-20170831/source/components/tables/tbxfroot.c
|
|||||||
|
|
||||||
return_ACPI_STATUS (AE_NO_MEMORY);
|
return_ACPI_STATUS (AE_NO_MEMORY);
|
||||||
}
|
}
|
||||||
Index: acpica-unix2-20170831/source/components/utilities/utownerid.c
|
Index: acpica-unix2-20170929/source/components/utilities/utownerid.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20170831.orig/source/components/utilities/utownerid.c
|
--- acpica-unix2-20170929.orig/source/components/utilities/utownerid.c
|
||||||
+++ acpica-unix2-20170831/source/components/utilities/utownerid.c
|
+++ acpica-unix2-20170929/source/components/utilities/utownerid.c
|
||||||
@@ -237,7 +237,7 @@ AcpiUtReleaseOwnerId (
|
@@ -237,7 +237,7 @@ AcpiUtReleaseOwnerId (
|
||||||
else
|
else
|
||||||
{
|
{
|
||||||
@ -328,11 +328,11 @@ Index: acpica-unix2-20170831/source/components/utilities/utownerid.c
|
|||||||
}
|
}
|
||||||
|
|
||||||
(void) AcpiUtReleaseMutex (ACPI_MTX_CACHES);
|
(void) AcpiUtReleaseMutex (ACPI_MTX_CACHES);
|
||||||
Index: acpica-unix2-20170831/source/tools/acpiexec/aemain.c
|
Index: acpica-unix2-20170929/source/tools/acpiexec/aemain.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20170831.orig/source/tools/acpiexec/aemain.c
|
--- acpica-unix2-20170929.orig/source/tools/acpiexec/aemain.c
|
||||||
+++ acpica-unix2-20170831/source/tools/acpiexec/aemain.c
|
+++ acpica-unix2-20170929/source/tools/acpiexec/aemain.c
|
||||||
@@ -203,7 +203,7 @@ AeDoOptions (
|
@@ -205,7 +205,7 @@ AeDoOptions (
|
||||||
|
|
||||||
if (strlen (AcpiGbl_Optarg) > (AE_BUFFER_SIZE -1))
|
if (strlen (AcpiGbl_Optarg) > (AE_BUFFER_SIZE -1))
|
||||||
{
|
{
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (acpica-unix2-20170831.tar.gz) = 5c8ba2587b765078e40ca3d1f292dd1555f5fb8753bfdea7f4aef15f53e7e33b5bf57375e4c6caacac743328a2d025fd00bc34b1f37e2b4573e20e64bdd194fb
|
SHA512 (acpica-unix2-20170929.tar.gz) = 038c4cb600c2a28c8099909278d21c00144026239e7f67f8e0e6714bccf2344d16acd69a415afeaa41ee6d1970d377db729564757516c1972a283afe6c3bca23
|
||||||
SHA512 (acpitests-unix-20170831.tar.gz) = e2ef1c26c202ee9efb93b4bdd169576792580e25b8fd622d0c33eeab8daf6f1195f4a6befd3b911242ebb3700d1f8316f4fd93218c76d2504c2daec5d8722f0b
|
SHA512 (acpitests-unix-20170929.tar.gz) = 0cac16f172ffe1f46aceee8e23d7b7f7f7f220e88f027d83d68ab8db0709eb2fef971a13606ee7969f8bb7b8e512ec44637b750dc7a5616a7c1665698807b1e8
|
||||||
|
Loading…
Reference in New Issue
Block a user