Update to 20180209 upstream source, including patch refreshes

Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
Al Stone 2018-03-06 15:25:45 -07:00
parent 6dbedeea26
commit 49c3e9a267
9 changed files with 364 additions and 343 deletions

2
.gitignore vendored
View File

@ -85,3 +85,5 @@ series
/acpitests-unix-20171215.tar.gz
/acpica-unix2-20180105.tar.gz
/acpitests-unix-20180105.tar.gz
/acpica-unix2-20180209.tar.gz
/acpitests-unix-20180209.tar.gz

View File

@ -1,6 +1,6 @@
Name: acpica-tools
Version: 20180105
Release: 3%{?dist}
Version: 20180209
Release: 1%{?dist}
Summary: ACPICA tools for the development and debug of ACPI tables
Group: Development/Languages
@ -192,6 +192,9 @@ fi
%changelog
* Tue Mar 6 2018 Al Stone <ahs3@redhat.com> - 20180209-1
- Update to 20180209 source tree, including patch refeshes. Closes BZ#1544048
* Fri Feb 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 20180105-3
- Escape macros in %%changelog

File diff suppressed because it is too large Load Diff

View File

@ -8,10 +8,10 @@ From: Al Stone <ahs3@redhat.com>
generate/unix/iasl/Makefile | 13 +++++++------
2 files changed, 9 insertions(+), 6 deletions(-)
Index: acpica-unix2-20170929/generate/unix/Makefile.config
Index: acpica-unix2-20180209/generate/unix/Makefile.config
===================================================================
--- acpica-unix2-20170929.orig/generate/unix/Makefile.config
+++ acpica-unix2-20170929/generate/unix/Makefile.config
--- acpica-unix2-20180209.orig/generate/unix/Makefile.config
+++ acpica-unix2-20180209/generate/unix/Makefile.config
@@ -182,6 +182,8 @@ ifneq ($(NOFORTIFY),TRUE)
OPT_CFLAGS += -D_FORTIFY_SOURCE=2
endif
@ -21,11 +21,11 @@ Index: acpica-unix2-20170929/generate/unix/Makefile.config
CFLAGS += \
-D$(HOST)\
-D_GNU_SOURCE\
Index: acpica-unix2-20170929/generate/unix/iasl/Makefile
Index: acpica-unix2-20180209/generate/unix/iasl/Makefile
===================================================================
--- acpica-unix2-20170929.orig/generate/unix/iasl/Makefile
+++ acpica-unix2-20170929/generate/unix/iasl/Makefile
@@ -338,26 +338,27 @@ $(OBJDIR)/prparserparse.c $(OBJDIR)/prpa
--- acpica-unix2-20180209.orig/generate/unix/iasl/Makefile
+++ acpica-unix2-20180209/generate/unix/iasl/Makefile
@@ -344,26 +344,27 @@ $(OBJDIR)/prparserparse.c $(OBJDIR)/prpa
# Cannot use the common compile warning flags since the C files are created
# by the utilities above and they are not necessarily ANSI C, etc.
#

View File

@ -24,10 +24,10 @@ From: Al Stone <ahs3@redhat.com>
source/tools/acpiexec/aemain.c | 2 +-
18 files changed, 28 insertions(+), 28 deletions(-)
Index: acpica-unix-20171110/source/compiler/aslcompile.c
Index: acpica-unix2-20180209/source/compiler/aslcompile.c
===================================================================
--- acpica-unix-20171110.orig/source/compiler/aslcompile.c
+++ acpica-unix-20171110/source/compiler/aslcompile.c
--- acpica-unix2-20180209.orig/source/compiler/aslcompile.c
+++ acpica-unix2-20180209/source/compiler/aslcompile.c
@@ -750,7 +750,7 @@ CmCleanupAndExit (
if (Gbl_ExceptionCount[ASL_ERROR] > ASL_MAX_ERROR_COUNT)
@ -37,11 +37,11 @@ Index: acpica-unix-20171110/source/compiler/aslcompile.c
ASL_MAX_ERROR_COUNT);
}
Index: acpica-unix-20171110/source/compiler/aslerror.c
Index: acpica-unix2-20180209/source/compiler/aslerror.c
===================================================================
--- acpica-unix-20171110.orig/source/compiler/aslerror.c
+++ acpica-unix-20171110/source/compiler/aslerror.c
@@ -873,7 +873,7 @@ AslLogNewError (
--- acpica-unix2-20180209.orig/source/compiler/aslerror.c
+++ acpica-unix2-20180209/source/compiler/aslerror.c
@@ -880,7 +880,7 @@ AslLogNewError (
Gbl_ExceptionCount[Level]++;
if (Gbl_ExceptionCount[ASL_ERROR] > ASL_MAX_ERROR_COUNT)
{
@ -50,7 +50,7 @@ Index: acpica-unix-20171110/source/compiler/aslerror.c
Gbl_SourceLine = 0;
Gbl_NextError = Gbl_ErrorLog;
@@ -1029,7 +1029,7 @@ AslDisableException (
@@ -1036,7 +1036,7 @@ AslDisableException (
if (Gbl_DisabledMessagesIndex >= ASL_MAX_DISABLED_MESSAGES)
{
@ -59,10 +59,10 @@ Index: acpica-unix-20171110/source/compiler/aslerror.c
ASL_MAX_DISABLED_MESSAGES);
return (AE_LIMIT);
}
Index: acpica-unix-20171110/source/compiler/aslopt.c
Index: acpica-unix2-20180209/source/compiler/aslopt.c
===================================================================
--- acpica-unix-20171110.orig/source/compiler/aslopt.c
+++ acpica-unix-20171110/source/compiler/aslopt.c
--- acpica-unix2-20180209.orig/source/compiler/aslopt.c
+++ acpica-unix2-20180209/source/compiler/aslopt.c
@@ -584,7 +584,7 @@ OptOptimizeNamePath (
}
@ -72,10 +72,10 @@ Index: acpica-unix-20171110/source/compiler/aslopt.c
Op->Asl.LogicalLineNumber,
AcpiPsGetOpcodeName (Op->Common.Parent->Common.AmlOpcode),
AcpiPsGetOpcodeName (Op->Common.AmlOpcode)));
Index: acpica-unix-20171110/source/compiler/aslpredef.c
Index: acpica-unix2-20180209/source/compiler/aslpredef.c
===================================================================
--- acpica-unix-20171110.orig/source/compiler/aslpredef.c
+++ acpica-unix-20171110/source/compiler/aslpredef.c
--- acpica-unix2-20180209.orig/source/compiler/aslpredef.c
+++ acpica-unix2-20180209/source/compiler/aslpredef.c
@@ -114,7 +114,7 @@ ApCheckForPredefinedMethod (
if (MethodInfo->NumArguments != 0)
@ -85,10 +85,10 @@ Index: acpica-unix-20171110/source/compiler/aslpredef.c
AslError (ASL_WARNING, ASL_MSG_RESERVED_ARG_COUNT_HI, Op,
MsgBuffer);
Index: acpica-unix-20171110/source/compiler/aslprepkg.c
Index: acpica-unix2-20180209/source/compiler/aslprepkg.c
===================================================================
--- acpica-unix-20171110.orig/source/compiler/aslprepkg.c
+++ acpica-unix-20171110/source/compiler/aslprepkg.c
--- acpica-unix2-20180209.orig/source/compiler/aslprepkg.c
+++ acpica-unix2-20180209/source/compiler/aslprepkg.c
@@ -309,7 +309,7 @@ ApCheckPackage (
if (Count & 1)
@ -98,10 +98,10 @@ Index: acpica-unix-20171110/source/compiler/aslprepkg.c
Predefined->Info.Name, Count);
AslError (ASL_ERROR, ASL_MSG_RESERVED_PACKAGE_LENGTH,
Index: acpica-unix-20171110/source/components/debugger/dbexec.c
Index: acpica-unix2-20180209/source/components/debugger/dbexec.c
===================================================================
--- acpica-unix-20171110.orig/source/components/debugger/dbexec.c
+++ acpica-unix-20171110/source/components/debugger/dbexec.c
--- acpica-unix2-20180209.orig/source/components/debugger/dbexec.c
+++ acpica-unix2-20180209/source/components/debugger/dbexec.c
@@ -230,7 +230,7 @@ AcpiDbExecuteMethod (
ACPI_ERROR ((AE_INFO,
"Possible overflow of internal debugger "
@ -111,10 +111,10 @@ Index: acpica-unix-20171110/source/components/debugger/dbexec.c
}
}
Index: acpica-unix-20171110/source/components/dispatcher/dsmthdat.c
Index: acpica-unix2-20180209/source/components/dispatcher/dsmthdat.c
===================================================================
--- acpica-unix-20171110.orig/source/components/dispatcher/dsmthdat.c
+++ acpica-unix-20171110/source/components/dispatcher/dsmthdat.c
--- acpica-unix2-20180209.orig/source/components/dispatcher/dsmthdat.c
+++ acpica-unix2-20180209/source/components/dispatcher/dsmthdat.c
@@ -291,7 +291,7 @@ AcpiDsMethodDataGetNode (
if (Index > ACPI_METHOD_MAX_LOCAL)
{
@ -133,10 +133,10 @@ Index: acpica-unix-20171110/source/components/dispatcher/dsmthdat.c
Index, ACPI_METHOD_MAX_ARG));
return_ACPI_STATUS (AE_AML_INVALID_INDEX);
}
Index: acpica-unix-20171110/source/components/dispatcher/dsutils.c
Index: acpica-unix2-20180209/source/components/dispatcher/dsutils.c
===================================================================
--- acpica-unix-20171110.orig/source/components/dispatcher/dsutils.c
+++ acpica-unix-20171110/source/components/dispatcher/dsutils.c
--- acpica-unix2-20180209.orig/source/components/dispatcher/dsutils.c
+++ acpica-unix2-20180209/source/components/dispatcher/dsutils.c
@@ -788,7 +788,7 @@ AcpiDsCreateOperands (
}
@ -146,10 +146,10 @@ Index: acpica-unix-20171110/source/components/dispatcher/dsutils.c
WalkState->NumOperands, ArgCount, Index));
/* Create the interpreter arguments, in reverse order */
Index: acpica-unix-20171110/source/components/dispatcher/dswscope.c
Index: acpica-unix2-20180209/source/components/dispatcher/dswscope.c
===================================================================
--- acpica-unix-20171110.orig/source/components/dispatcher/dswscope.c
+++ acpica-unix-20171110/source/components/dispatcher/dswscope.c
--- acpica-unix2-20180209.orig/source/components/dispatcher/dswscope.c
+++ acpica-unix2-20180209/source/components/dispatcher/dswscope.c
@@ -149,7 +149,7 @@ AcpiDsScopeStackPush (
WalkState->ScopeDepth++;
@ -168,10 +168,10 @@ Index: acpica-unix-20171110/source/components/dispatcher/dswscope.c
(UINT32) WalkState->ScopeDepth,
AcpiUtGetNodeName (ScopeInfo->Scope.Node),
AcpiUtGetTypeName (ScopeInfo->Common.Value)));
Index: acpica-unix-20171110/source/components/events/evgpe.c
Index: acpica-unix2-20180209/source/components/events/evgpe.c
===================================================================
--- acpica-unix-20171110.orig/source/components/events/evgpe.c
+++ acpica-unix-20171110/source/components/events/evgpe.c
--- acpica-unix2-20180209.orig/source/components/events/evgpe.c
+++ acpica-unix2-20180209/source/components/events/evgpe.c
@@ -494,7 +494,7 @@ AcpiEvGpeDetect (
"Ignore disabled registers for GPE %02X-%02X: "
"RunEnable=%02X, WakeEnable=%02X\n",
@ -190,10 +190,10 @@ Index: acpica-unix-20171110/source/components/events/evgpe.c
(UINT32) StatusReg, (UINT32) EnableReg,
GpeRegisterInfo->EnableForRun,
GpeRegisterInfo->EnableForWake));
Index: acpica-unix-20171110/source/components/executer/exdump.c
Index: acpica-unix2-20180209/source/components/executer/exdump.c
===================================================================
--- acpica-unix-20171110.orig/source/components/executer/exdump.c
+++ acpica-unix-20171110/source/components/executer/exdump.c
--- acpica-unix2-20180209.orig/source/components/executer/exdump.c
+++ acpica-unix2-20180209/source/components/executer/exdump.c
@@ -678,7 +678,7 @@ AcpiExDumpOperand (
if (Depth > 0)
{
@ -203,10 +203,10 @@ Index: acpica-unix-20171110/source/components/executer/exdump.c
}
else
{
Index: acpica-unix-20171110/source/components/executer/exfldio.c
Index: acpica-unix2-20180209/source/components/executer/exfldio.c
===================================================================
--- acpica-unix-20171110.orig/source/components/executer/exfldio.c
+++ acpica-unix-20171110/source/components/executer/exfldio.c
--- acpica-unix2-20180209.orig/source/components/executer/exfldio.c
+++ acpica-unix2-20180209/source/components/executer/exfldio.c
@@ -681,8 +681,8 @@ AcpiExWriteWithUpdateRule (
ACPI_ERROR ((AE_INFO,
@ -218,11 +218,11 @@ Index: acpica-unix-20171110/source/components/executer/exfldio.c
return_ACPI_STATUS (AE_AML_OPERAND_VALUE);
}
}
Index: acpica-unix-20171110/source/components/executer/exnames.c
Index: acpica-unix2-20180209/source/components/executer/exnames.c
===================================================================
--- acpica-unix-20171110.orig/source/components/executer/exnames.c
+++ acpica-unix-20171110/source/components/executer/exnames.c
@@ -240,7 +240,7 @@ AcpiExNameSegment (
--- acpica-unix2-20180209.orig/source/components/executer/exnames.c
+++ acpica-unix2-20180209/source/components/executer/exnames.c
@@ -237,7 +237,7 @@ AcpiExNameSegment (
*/
ACPI_DEBUG_PRINT ((ACPI_DB_INFO,
"Leading character is not alpha: %02Xh (not a name)\n",
@ -231,7 +231,7 @@ Index: acpica-unix-20171110/source/components/executer/exnames.c
Status = AE_CTRL_PENDING;
}
else
@@ -252,7 +252,7 @@ AcpiExNameSegment (
@@ -249,7 +249,7 @@ AcpiExNameSegment (
Status = AE_AML_BAD_NAME;
ACPI_ERROR ((AE_INFO,
"Bad character 0x%02x in name, at %p",
@ -240,10 +240,10 @@ Index: acpica-unix-20171110/source/components/executer/exnames.c
}
*InAmlAddress = ACPI_CAST_PTR (UINT8, AmlAddress);
Index: acpica-unix-20171110/source/components/hardware/hwregs.c
Index: acpica-unix2-20180209/source/components/hardware/hwregs.c
===================================================================
--- acpica-unix-20171110.orig/source/components/hardware/hwregs.c
+++ acpica-unix-20171110/source/components/hardware/hwregs.c
--- acpica-unix2-20180209.orig/source/components/hardware/hwregs.c
+++ acpica-unix2-20180209/source/components/hardware/hwregs.c
@@ -460,7 +460,7 @@ AcpiHwClearAcpiStatus (
@ -253,10 +253,10 @@ Index: acpica-unix-20171110/source/components/hardware/hwregs.c
ACPI_FORMAT_UINT64 (AcpiGbl_XPm1aStatus.Address)));
LockFlags = AcpiOsAcquireLock (AcpiGbl_HardwareLock);
Index: acpica-unix-20171110/source/components/tables/tbfadt.c
Index: acpica-unix2-20180209/source/components/tables/tbfadt.c
===================================================================
--- acpica-unix-20171110.orig/source/components/tables/tbfadt.c
+++ acpica-unix-20171110/source/components/tables/tbfadt.c
--- acpica-unix2-20180209.orig/source/components/tables/tbfadt.c
+++ acpica-unix2-20180209/source/components/tables/tbfadt.c
@@ -233,7 +233,7 @@ AcpiTbInitGenericAddress (
if (!(Flags & ACPI_FADT_GPE_REGISTER))
{
@ -284,10 +284,10 @@ Index: acpica-unix-20171110/source/components/tables/tbfadt.c
Name, Address32,
ACPI_FORMAT_UINT64 (Address64->Address),
AcpiGbl_Use32BitFadtAddresses ? 32 : 64));
Index: acpica-unix-20171110/source/components/tables/tbxfroot.c
Index: acpica-unix2-20180209/source/components/tables/tbxfroot.c
===================================================================
--- acpica-unix-20171110.orig/source/components/tables/tbxfroot.c
+++ acpica-unix-20171110/source/components/tables/tbxfroot.c
--- acpica-unix2-20180209.orig/source/components/tables/tbxfroot.c
+++ acpica-unix2-20180209/source/components/tables/tbxfroot.c
@@ -177,7 +177,7 @@ AcpiFindRootPointer (
{
ACPI_ERROR ((AE_INFO,
@ -315,10 +315,10 @@ Index: acpica-unix-20171110/source/components/tables/tbxfroot.c
return_ACPI_STATUS (AE_NO_MEMORY);
}
Index: acpica-unix-20171110/source/components/utilities/utownerid.c
Index: acpica-unix2-20180209/source/components/utilities/utownerid.c
===================================================================
--- acpica-unix-20171110.orig/source/components/utilities/utownerid.c
+++ acpica-unix-20171110/source/components/utilities/utownerid.c
--- acpica-unix2-20180209.orig/source/components/utilities/utownerid.c
+++ acpica-unix2-20180209/source/components/utilities/utownerid.c
@@ -237,7 +237,7 @@ AcpiUtReleaseOwnerId (
else
{
@ -328,10 +328,10 @@ Index: acpica-unix-20171110/source/components/utilities/utownerid.c
}
(void) AcpiUtReleaseMutex (ACPI_MTX_CACHES);
Index: acpica-unix-20171110/source/tools/acpiexec/aemain.c
Index: acpica-unix2-20180209/source/tools/acpiexec/aemain.c
===================================================================
--- acpica-unix-20171110.orig/source/tools/acpiexec/aemain.c
+++ acpica-unix-20171110/source/tools/acpiexec/aemain.c
--- acpica-unix2-20180209.orig/source/tools/acpiexec/aemain.c
+++ acpica-unix2-20180209/source/tools/acpiexec/aemain.c
@@ -205,7 +205,7 @@ AeDoOptions (
if (strlen (AcpiGbl_Optarg) > (AE_BUFFER_SIZE -1))

View File

@ -1,5 +1,7 @@
--- a/source/compiler/aslparseop.c
+++ b/source/compiler/aslparseop.c
Index: acpica-unix2-20180209/source/compiler/aslparseop.c
===================================================================
--- acpica-unix2-20180209.orig/source/compiler/aslparseop.c
+++ acpica-unix2-20180209/source/compiler/aslparseop.c
@@ -283,7 +283,16 @@ TrCreateValuedLeafOp (
@ -18,9 +20,11 @@
DbgPrint (ASL_PARSE_OUTPUT,
"\nCreateValuedLeafOp Ln/Col %u/%u NewOp %p "
--- a/source/include/platform/aclinux.h
+++ b/source/include/platform/aclinux.h
@@ -225,10 +225,8 @@
Index: acpica-unix2-20180209/source/include/platform/aclinux.h
===================================================================
--- acpica-unix2-20180209.orig/source/include/platform/aclinux.h
+++ acpica-unix2-20180209/source/include/platform/aclinux.h
@@ -226,10 +226,8 @@
#endif
#if __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__

View File

@ -1,8 +1,8 @@
Index: acpica-unix2-20170728/source/include/platform/aclinux.h
Index: acpica-unix2-20180209/source/include/platform/aclinux.h
===================================================================
--- acpica-unix2-20170728.orig/source/include/platform/aclinux.h
+++ acpica-unix2-20170728/source/include/platform/aclinux.h
@@ -226,9 +226,11 @@
--- acpica-unix2-20180209.orig/source/include/platform/aclinux.h
+++ acpica-unix2-20180209/source/include/platform/aclinux.h
@@ -227,9 +227,11 @@
#define __cdecl
#endif

View File

@ -3,9 +3,11 @@ Description: Stop listing all 64bit architectures
64bit architectures.
Author: Adrian Bunk <bunk@debian.org>
--- acpica-unix-20170831.orig/source/include/platform/aclinux.h
+++ acpica-unix-20170831/source/include/platform/aclinux.h
@@ -208,9 +208,7 @@
Index: acpica-unix2-20180209/source/include/platform/aclinux.h
===================================================================
--- acpica-unix2-20180209.orig/source/include/platform/aclinux.h
+++ acpica-unix2-20180209/source/include/platform/aclinux.h
@@ -209,9 +209,7 @@
#define ACPI_FLUSH_CPU_CACHE()
#define ACPI_CAST_PTHREAD_T(Pthread) ((ACPI_THREAD_ID) (Pthread))

View File

@ -1,2 +1,2 @@
SHA512 (acpica-unix2-20180105.tar.gz) = 5466481397174309fce4134317fc98cf00770a4ef7481608e68c718a60c11e78d04833ff183c7e2ec3a40835ceb3351e9f193d217460880afd2c6ec16592213f
SHA512 (acpitests-unix-20180105.tar.gz) = 2baecb9d884b5b497d3453780e3a30f3d01e6b7569af4cb7c13ee2db143eab18bd8a44d8b0f452d527bdf3be090cc6d17c8b947a307a94ff55c4262b87739c80
SHA512 (acpica-unix2-20180209.tar.gz) = d4d7b038477da499b2310c2cc38f76a5f4eac721aa8d0e25a5dbeec76d99c0be761ee3abc5737cc63e9a8a86dc4511926d0806474341a0b4d245113af8f7e67d
SHA512 (acpitests-unix-20180209.tar.gz) = 411e264e8dffa18f57496938be65e235f513c571e6e384a4a6d21737456b42c815ec91d42fe14eae7875bffb791308ad2f00d6fd6d943a14f90b3bb9e7b4c7f1