Refresh some of the patches
Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
parent
52f35f0fe2
commit
3a82d24e0b
@ -1,5 +1,5 @@
|
|||||||
Name: acpica-tools
|
Name: acpica-tools
|
||||||
Version: 20160729
|
Version: 20160831
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: ACPICA tools for the development and debug of ACPI tables
|
Summary: ACPICA tools for the development and debug of ACPI tables
|
||||||
|
|
||||||
@ -186,6 +186,10 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 1 2016 Al Stone <ahs3@redhat.com> - 20160831-1
|
||||||
|
- Update to latest upstream. Closes BZ#1372107.
|
||||||
|
- Refresh patches.
|
||||||
|
|
||||||
* Tue Aug 2 2016 Al Stone <ahs3@redhat.com> - 20160729-1
|
* Tue Aug 2 2016 Al Stone <ahs3@redhat.com> - 20160729-1
|
||||||
- Update to latest upstream. Closes BZ#1361737.
|
- Update to latest upstream. Closes BZ#1361737.
|
||||||
- Refresh patches.
|
- Refresh patches.
|
||||||
|
@ -8,10 +8,10 @@ From: Al Stone <ahs3@redhat.com>
|
|||||||
generate/unix/iasl/Makefile | 13 +++++++------
|
generate/unix/iasl/Makefile | 13 +++++++------
|
||||||
2 files changed, 9 insertions(+), 6 deletions(-)
|
2 files changed, 9 insertions(+), 6 deletions(-)
|
||||||
|
|
||||||
Index: acpica-unix2-20160422/generate/unix/Makefile.config
|
Index: acpica-unix2-20160831/generate/unix/Makefile.config
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20160422.orig/generate/unix/Makefile.config
|
--- acpica-unix2-20160831.orig/generate/unix/Makefile.config
|
||||||
+++ acpica-unix2-20160422/generate/unix/Makefile.config
|
+++ acpica-unix2-20160831/generate/unix/Makefile.config
|
||||||
@@ -171,6 +171,8 @@ ifneq ($(NOFORTIFY),TRUE)
|
@@ -171,6 +171,8 @@ ifneq ($(NOFORTIFY),TRUE)
|
||||||
OPT_CFLAGS += -D_FORTIFY_SOURCE=2
|
OPT_CFLAGS += -D_FORTIFY_SOURCE=2
|
||||||
endif
|
endif
|
||||||
@ -21,11 +21,11 @@ Index: acpica-unix2-20160422/generate/unix/Makefile.config
|
|||||||
CFLAGS += \
|
CFLAGS += \
|
||||||
-D$(HOST)\
|
-D$(HOST)\
|
||||||
-D_GNU_SOURCE\
|
-D_GNU_SOURCE\
|
||||||
Index: acpica-unix2-20160422/generate/unix/iasl/Makefile
|
Index: acpica-unix2-20160831/generate/unix/iasl/Makefile
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20160422.orig/generate/unix/iasl/Makefile
|
--- acpica-unix2-20160831.orig/generate/unix/iasl/Makefile
|
||||||
+++ acpica-unix2-20160422/generate/unix/iasl/Makefile
|
+++ acpica-unix2-20160831/generate/unix/iasl/Makefile
|
||||||
@@ -317,20 +317,21 @@ $(OBJDIR)/prparserparse.c $(OBJDIR)/prpa
|
@@ -319,20 +319,21 @@ $(OBJDIR)/prparserparse.c $(OBJDIR)/prpa
|
||||||
# Cannot use the common compile warning flags since the C files are created
|
# Cannot use the common compile warning flags since the C files are created
|
||||||
# by the utilities above and they are not necessarily ANSI C, etc.
|
# by the utilities above and they are not necessarily ANSI C, etc.
|
||||||
#
|
#
|
||||||
|
116
int-format.patch
116
int-format.patch
@ -24,10 +24,10 @@ From: Al Stone <ahs3@redhat.com>
|
|||||||
source/tools/acpiexec/aemain.c | 2 +-
|
source/tools/acpiexec/aemain.c | 2 +-
|
||||||
18 files changed, 28 insertions(+), 28 deletions(-)
|
18 files changed, 28 insertions(+), 28 deletions(-)
|
||||||
|
|
||||||
Index: acpica-unix-20160527/source/compiler/aslcompile.c
|
Index: acpica-unix2-20160831/source/compiler/aslcompile.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix-20160527.orig/source/compiler/aslcompile.c
|
--- acpica-unix2-20160831.orig/source/compiler/aslcompile.c
|
||||||
+++ acpica-unix-20160527/source/compiler/aslcompile.c
|
+++ acpica-unix2-20160831/source/compiler/aslcompile.c
|
||||||
@@ -729,7 +729,7 @@ CmCleanupAndExit (
|
@@ -729,7 +729,7 @@ CmCleanupAndExit (
|
||||||
|
|
||||||
if (Gbl_ExceptionCount[ASL_ERROR] > ASL_MAX_ERROR_COUNT)
|
if (Gbl_ExceptionCount[ASL_ERROR] > ASL_MAX_ERROR_COUNT)
|
||||||
@ -37,10 +37,10 @@ Index: acpica-unix-20160527/source/compiler/aslcompile.c
|
|||||||
ASL_MAX_ERROR_COUNT);
|
ASL_MAX_ERROR_COUNT);
|
||||||
}
|
}
|
||||||
|
|
||||||
Index: acpica-unix-20160527/source/compiler/aslerror.c
|
Index: acpica-unix2-20160831/source/compiler/aslerror.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix-20160527.orig/source/compiler/aslerror.c
|
--- acpica-unix2-20160831.orig/source/compiler/aslerror.c
|
||||||
+++ acpica-unix-20160527/source/compiler/aslerror.c
|
+++ acpica-unix2-20160831/source/compiler/aslerror.c
|
||||||
@@ -687,7 +687,7 @@ AslCommonError (
|
@@ -687,7 +687,7 @@ AslCommonError (
|
||||||
Gbl_ExceptionCount[Level]++;
|
Gbl_ExceptionCount[Level]++;
|
||||||
if (Gbl_ExceptionCount[ASL_ERROR] > ASL_MAX_ERROR_COUNT)
|
if (Gbl_ExceptionCount[ASL_ERROR] > ASL_MAX_ERROR_COUNT)
|
||||||
@ -59,10 +59,10 @@ Index: acpica-unix-20160527/source/compiler/aslerror.c
|
|||||||
ASL_MAX_DISABLED_MESSAGES);
|
ASL_MAX_DISABLED_MESSAGES);
|
||||||
return (AE_LIMIT);
|
return (AE_LIMIT);
|
||||||
}
|
}
|
||||||
Index: acpica-unix-20160527/source/compiler/aslopt.c
|
Index: acpica-unix2-20160831/source/compiler/aslopt.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix-20160527.orig/source/compiler/aslopt.c
|
--- acpica-unix2-20160831.orig/source/compiler/aslopt.c
|
||||||
+++ acpica-unix-20160527/source/compiler/aslopt.c
|
+++ acpica-unix2-20160831/source/compiler/aslopt.c
|
||||||
@@ -584,7 +584,7 @@ OptOptimizeNamePath (
|
@@ -584,7 +584,7 @@ OptOptimizeNamePath (
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -72,10 +72,10 @@ Index: acpica-unix-20160527/source/compiler/aslopt.c
|
|||||||
Op->Asl.LogicalLineNumber,
|
Op->Asl.LogicalLineNumber,
|
||||||
AcpiPsGetOpcodeName (Op->Common.Parent->Common.AmlOpcode),
|
AcpiPsGetOpcodeName (Op->Common.Parent->Common.AmlOpcode),
|
||||||
AcpiPsGetOpcodeName (Op->Common.AmlOpcode)));
|
AcpiPsGetOpcodeName (Op->Common.AmlOpcode)));
|
||||||
Index: acpica-unix-20160527/source/compiler/aslpredef.c
|
Index: acpica-unix2-20160831/source/compiler/aslpredef.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix-20160527.orig/source/compiler/aslpredef.c
|
--- acpica-unix2-20160831.orig/source/compiler/aslpredef.c
|
||||||
+++ acpica-unix-20160527/source/compiler/aslpredef.c
|
+++ acpica-unix2-20160831/source/compiler/aslpredef.c
|
||||||
@@ -114,7 +114,7 @@ ApCheckForPredefinedMethod (
|
@@ -114,7 +114,7 @@ ApCheckForPredefinedMethod (
|
||||||
|
|
||||||
if (MethodInfo->NumArguments != 0)
|
if (MethodInfo->NumArguments != 0)
|
||||||
@ -85,10 +85,10 @@ Index: acpica-unix-20160527/source/compiler/aslpredef.c
|
|||||||
|
|
||||||
AslError (ASL_WARNING, ASL_MSG_RESERVED_ARG_COUNT_HI, Op,
|
AslError (ASL_WARNING, ASL_MSG_RESERVED_ARG_COUNT_HI, Op,
|
||||||
MsgBuffer);
|
MsgBuffer);
|
||||||
Index: acpica-unix-20160527/source/compiler/aslprepkg.c
|
Index: acpica-unix2-20160831/source/compiler/aslprepkg.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix-20160527.orig/source/compiler/aslprepkg.c
|
--- acpica-unix2-20160831.orig/source/compiler/aslprepkg.c
|
||||||
+++ acpica-unix-20160527/source/compiler/aslprepkg.c
|
+++ acpica-unix2-20160831/source/compiler/aslprepkg.c
|
||||||
@@ -309,7 +309,7 @@ ApCheckPackage (
|
@@ -309,7 +309,7 @@ ApCheckPackage (
|
||||||
|
|
||||||
if (Count & 1)
|
if (Count & 1)
|
||||||
@ -98,10 +98,10 @@ Index: acpica-unix-20160527/source/compiler/aslprepkg.c
|
|||||||
Predefined->Info.Name, Count);
|
Predefined->Info.Name, Count);
|
||||||
|
|
||||||
AslError (ASL_ERROR, ASL_MSG_RESERVED_PACKAGE_LENGTH,
|
AslError (ASL_ERROR, ASL_MSG_RESERVED_PACKAGE_LENGTH,
|
||||||
Index: acpica-unix-20160527/source/components/debugger/dbexec.c
|
Index: acpica-unix2-20160831/source/components/debugger/dbexec.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix-20160527.orig/source/components/debugger/dbexec.c
|
--- acpica-unix2-20160831.orig/source/components/debugger/dbexec.c
|
||||||
+++ acpica-unix-20160527/source/components/debugger/dbexec.c
|
+++ acpica-unix2-20160831/source/components/debugger/dbexec.c
|
||||||
@@ -214,7 +214,7 @@ AcpiDbExecuteMethod (
|
@@ -214,7 +214,7 @@ AcpiDbExecuteMethod (
|
||||||
ACPI_ERROR ((AE_INFO,
|
ACPI_ERROR ((AE_INFO,
|
||||||
"Possible overflow of internal debugger "
|
"Possible overflow of internal debugger "
|
||||||
@ -111,10 +111,10 @@ Index: acpica-unix-20160527/source/components/debugger/dbexec.c
|
|||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
Index: acpica-unix-20160527/source/components/dispatcher/dsmthdat.c
|
Index: acpica-unix2-20160831/source/components/dispatcher/dsmthdat.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix-20160527.orig/source/components/dispatcher/dsmthdat.c
|
--- acpica-unix2-20160831.orig/source/components/dispatcher/dsmthdat.c
|
||||||
+++ acpica-unix-20160527/source/components/dispatcher/dsmthdat.c
|
+++ acpica-unix2-20160831/source/components/dispatcher/dsmthdat.c
|
||||||
@@ -291,7 +291,7 @@ AcpiDsMethodDataGetNode (
|
@@ -291,7 +291,7 @@ AcpiDsMethodDataGetNode (
|
||||||
if (Index > ACPI_METHOD_MAX_LOCAL)
|
if (Index > ACPI_METHOD_MAX_LOCAL)
|
||||||
{
|
{
|
||||||
@ -133,10 +133,10 @@ Index: acpica-unix-20160527/source/components/dispatcher/dsmthdat.c
|
|||||||
Index, ACPI_METHOD_MAX_ARG));
|
Index, ACPI_METHOD_MAX_ARG));
|
||||||
return_ACPI_STATUS (AE_AML_INVALID_INDEX);
|
return_ACPI_STATUS (AE_AML_INVALID_INDEX);
|
||||||
}
|
}
|
||||||
Index: acpica-unix-20160527/source/components/dispatcher/dsutils.c
|
Index: acpica-unix2-20160831/source/components/dispatcher/dsutils.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix-20160527.orig/source/components/dispatcher/dsutils.c
|
--- acpica-unix2-20160831.orig/source/components/dispatcher/dsutils.c
|
||||||
+++ acpica-unix-20160527/source/components/dispatcher/dsutils.c
|
+++ acpica-unix2-20160831/source/components/dispatcher/dsutils.c
|
||||||
@@ -793,7 +793,7 @@ AcpiDsCreateOperands (
|
@@ -793,7 +793,7 @@ AcpiDsCreateOperands (
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -146,10 +146,10 @@ Index: acpica-unix-20160527/source/components/dispatcher/dsutils.c
|
|||||||
WalkState->NumOperands, ArgCount, Index));
|
WalkState->NumOperands, ArgCount, Index));
|
||||||
|
|
||||||
/* Create the interpreter arguments, in reverse order */
|
/* Create the interpreter arguments, in reverse order */
|
||||||
Index: acpica-unix-20160527/source/components/dispatcher/dswscope.c
|
Index: acpica-unix2-20160831/source/components/dispatcher/dswscope.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix-20160527.orig/source/components/dispatcher/dswscope.c
|
--- acpica-unix2-20160831.orig/source/components/dispatcher/dswscope.c
|
||||||
+++ acpica-unix-20160527/source/components/dispatcher/dswscope.c
|
+++ acpica-unix2-20160831/source/components/dispatcher/dswscope.c
|
||||||
@@ -149,7 +149,7 @@ AcpiDsScopeStackPush (
|
@@ -149,7 +149,7 @@ AcpiDsScopeStackPush (
|
||||||
WalkState->ScopeDepth++;
|
WalkState->ScopeDepth++;
|
||||||
|
|
||||||
@ -168,11 +168,11 @@ Index: acpica-unix-20160527/source/components/dispatcher/dswscope.c
|
|||||||
(UINT32) WalkState->ScopeDepth,
|
(UINT32) WalkState->ScopeDepth,
|
||||||
AcpiUtGetNodeName (ScopeInfo->Scope.Node),
|
AcpiUtGetNodeName (ScopeInfo->Scope.Node),
|
||||||
AcpiUtGetTypeName (ScopeInfo->Common.Value)));
|
AcpiUtGetTypeName (ScopeInfo->Common.Value)));
|
||||||
Index: acpica-unix-20160527/source/components/events/evgpe.c
|
Index: acpica-unix2-20160831/source/components/events/evgpe.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix-20160527.orig/source/components/events/evgpe.c
|
--- acpica-unix2-20160831.orig/source/components/events/evgpe.c
|
||||||
+++ acpica-unix-20160527/source/components/events/evgpe.c
|
+++ acpica-unix2-20160831/source/components/events/evgpe.c
|
||||||
@@ -430,7 +430,7 @@ AcpiEvGpeDetect (
|
@@ -494,7 +494,7 @@ AcpiEvGpeDetect (
|
||||||
"Ignore disabled registers for GPE %02X-%02X: "
|
"Ignore disabled registers for GPE %02X-%02X: "
|
||||||
"RunEnable=%02X, WakeEnable=%02X\n",
|
"RunEnable=%02X, WakeEnable=%02X\n",
|
||||||
GpeRegisterInfo->BaseGpeNumber,
|
GpeRegisterInfo->BaseGpeNumber,
|
||||||
@ -181,7 +181,7 @@ Index: acpica-unix-20160527/source/components/events/evgpe.c
|
|||||||
GpeRegisterInfo->EnableForRun,
|
GpeRegisterInfo->EnableForRun,
|
||||||
GpeRegisterInfo->EnableForWake));
|
GpeRegisterInfo->EnableForWake));
|
||||||
continue;
|
continue;
|
||||||
@@ -456,7 +456,7 @@ AcpiEvGpeDetect (
|
@@ -520,7 +520,7 @@ AcpiEvGpeDetect (
|
||||||
"Read registers for GPE %02X-%02X: Status=%02X, Enable=%02X, "
|
"Read registers for GPE %02X-%02X: Status=%02X, Enable=%02X, "
|
||||||
"RunEnable=%02X, WakeEnable=%02X\n",
|
"RunEnable=%02X, WakeEnable=%02X\n",
|
||||||
GpeRegisterInfo->BaseGpeNumber,
|
GpeRegisterInfo->BaseGpeNumber,
|
||||||
@ -190,10 +190,10 @@ Index: acpica-unix-20160527/source/components/events/evgpe.c
|
|||||||
StatusReg, EnableReg,
|
StatusReg, EnableReg,
|
||||||
GpeRegisterInfo->EnableForRun,
|
GpeRegisterInfo->EnableForRun,
|
||||||
GpeRegisterInfo->EnableForWake));
|
GpeRegisterInfo->EnableForWake));
|
||||||
Index: acpica-unix-20160527/source/components/executer/exdump.c
|
Index: acpica-unix2-20160831/source/components/executer/exdump.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix-20160527.orig/source/components/executer/exdump.c
|
--- acpica-unix2-20160831.orig/source/components/executer/exdump.c
|
||||||
+++ acpica-unix-20160527/source/components/executer/exdump.c
|
+++ acpica-unix2-20160831/source/components/executer/exdump.c
|
||||||
@@ -668,7 +668,7 @@ AcpiExDumpOperand (
|
@@ -668,7 +668,7 @@ AcpiExDumpOperand (
|
||||||
if (Depth > 0)
|
if (Depth > 0)
|
||||||
{
|
{
|
||||||
@ -203,10 +203,10 @@ Index: acpica-unix-20160527/source/components/executer/exdump.c
|
|||||||
}
|
}
|
||||||
else
|
else
|
||||||
{
|
{
|
||||||
Index: acpica-unix-20160527/source/components/executer/exfldio.c
|
Index: acpica-unix2-20160831/source/components/executer/exfldio.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix-20160527.orig/source/components/executer/exfldio.c
|
--- acpica-unix2-20160831.orig/source/components/executer/exfldio.c
|
||||||
+++ acpica-unix-20160527/source/components/executer/exfldio.c
|
+++ acpica-unix2-20160831/source/components/executer/exfldio.c
|
||||||
@@ -681,8 +681,8 @@ AcpiExWriteWithUpdateRule (
|
@@ -681,8 +681,8 @@ AcpiExWriteWithUpdateRule (
|
||||||
|
|
||||||
ACPI_ERROR ((AE_INFO,
|
ACPI_ERROR ((AE_INFO,
|
||||||
@ -218,10 +218,10 @@ Index: acpica-unix-20160527/source/components/executer/exfldio.c
|
|||||||
return_ACPI_STATUS (AE_AML_OPERAND_VALUE);
|
return_ACPI_STATUS (AE_AML_OPERAND_VALUE);
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
Index: acpica-unix-20160527/source/components/executer/exnames.c
|
Index: acpica-unix2-20160831/source/components/executer/exnames.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix-20160527.orig/source/components/executer/exnames.c
|
--- acpica-unix2-20160831.orig/source/components/executer/exnames.c
|
||||||
+++ acpica-unix-20160527/source/components/executer/exnames.c
|
+++ acpica-unix2-20160831/source/components/executer/exnames.c
|
||||||
@@ -240,7 +240,7 @@ AcpiExNameSegment (
|
@@ -240,7 +240,7 @@ AcpiExNameSegment (
|
||||||
*/
|
*/
|
||||||
ACPI_DEBUG_PRINT ((ACPI_DB_INFO,
|
ACPI_DEBUG_PRINT ((ACPI_DB_INFO,
|
||||||
@ -240,10 +240,10 @@ Index: acpica-unix-20160527/source/components/executer/exnames.c
|
|||||||
}
|
}
|
||||||
|
|
||||||
*InAmlAddress = ACPI_CAST_PTR (UINT8, AmlAddress);
|
*InAmlAddress = ACPI_CAST_PTR (UINT8, AmlAddress);
|
||||||
Index: acpica-unix-20160527/source/components/hardware/hwregs.c
|
Index: acpica-unix2-20160831/source/components/hardware/hwregs.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix-20160527.orig/source/components/hardware/hwregs.c
|
--- acpica-unix2-20160831.orig/source/components/hardware/hwregs.c
|
||||||
+++ acpica-unix-20160527/source/components/hardware/hwregs.c
|
+++ acpica-unix2-20160831/source/components/hardware/hwregs.c
|
||||||
@@ -300,7 +300,7 @@ AcpiHwClearAcpiStatus (
|
@@ -300,7 +300,7 @@ AcpiHwClearAcpiStatus (
|
||||||
|
|
||||||
|
|
||||||
@ -253,10 +253,10 @@ Index: acpica-unix-20160527/source/components/hardware/hwregs.c
|
|||||||
ACPI_FORMAT_UINT64 (AcpiGbl_XPm1aStatus.Address)));
|
ACPI_FORMAT_UINT64 (AcpiGbl_XPm1aStatus.Address)));
|
||||||
|
|
||||||
LockFlags = AcpiOsAcquireLock (AcpiGbl_HardwareLock);
|
LockFlags = AcpiOsAcquireLock (AcpiGbl_HardwareLock);
|
||||||
Index: acpica-unix-20160527/source/components/tables/tbfadt.c
|
Index: acpica-unix2-20160831/source/components/tables/tbfadt.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix-20160527.orig/source/components/tables/tbfadt.c
|
--- acpica-unix2-20160831.orig/source/components/tables/tbfadt.c
|
||||||
+++ acpica-unix-20160527/source/components/tables/tbfadt.c
|
+++ acpica-unix2-20160831/source/components/tables/tbfadt.c
|
||||||
@@ -233,7 +233,7 @@ AcpiTbInitGenericAddress (
|
@@ -233,7 +233,7 @@ AcpiTbInitGenericAddress (
|
||||||
if (!(Flags & ACPI_FADT_GPE_REGISTER))
|
if (!(Flags & ACPI_FADT_GPE_REGISTER))
|
||||||
{
|
{
|
||||||
@ -275,7 +275,7 @@ Index: acpica-unix-20160527/source/components/tables/tbfadt.c
|
|||||||
RegisterName, Address32, ACPI_FORMAT_UINT64 (Address64),
|
RegisterName, Address32, ACPI_FORMAT_UINT64 (Address64),
|
||||||
AcpiGbl_Use32BitFadtAddresses ? 32 : 64));
|
AcpiGbl_Use32BitFadtAddresses ? 32 : 64));
|
||||||
|
|
||||||
@@ -618,7 +618,7 @@ AcpiTbConvertFadt (
|
@@ -621,7 +621,7 @@ AcpiTbConvertFadt (
|
||||||
|
|
||||||
ACPI_BIOS_WARNING ((AE_INFO,
|
ACPI_BIOS_WARNING ((AE_INFO,
|
||||||
"32/64X address mismatch in FADT/%s: "
|
"32/64X address mismatch in FADT/%s: "
|
||||||
@ -284,10 +284,10 @@ Index: acpica-unix-20160527/source/components/tables/tbfadt.c
|
|||||||
Name, Address32,
|
Name, Address32,
|
||||||
ACPI_FORMAT_UINT64 (Address64->Address),
|
ACPI_FORMAT_UINT64 (Address64->Address),
|
||||||
AcpiGbl_Use32BitFadtAddresses ? 32 : 64));
|
AcpiGbl_Use32BitFadtAddresses ? 32 : 64));
|
||||||
Index: acpica-unix-20160527/source/components/tables/tbxfroot.c
|
Index: acpica-unix2-20160831/source/components/tables/tbxfroot.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix-20160527.orig/source/components/tables/tbxfroot.c
|
--- acpica-unix2-20160831.orig/source/components/tables/tbxfroot.c
|
||||||
+++ acpica-unix-20160527/source/components/tables/tbxfroot.c
|
+++ acpica-unix2-20160831/source/components/tables/tbxfroot.c
|
||||||
@@ -177,7 +177,7 @@ AcpiFindRootPointer (
|
@@ -177,7 +177,7 @@ AcpiFindRootPointer (
|
||||||
{
|
{
|
||||||
ACPI_ERROR ((AE_INFO,
|
ACPI_ERROR ((AE_INFO,
|
||||||
@ -315,10 +315,10 @@ Index: acpica-unix-20160527/source/components/tables/tbxfroot.c
|
|||||||
|
|
||||||
return_ACPI_STATUS (AE_NO_MEMORY);
|
return_ACPI_STATUS (AE_NO_MEMORY);
|
||||||
}
|
}
|
||||||
Index: acpica-unix-20160527/source/components/utilities/utownerid.c
|
Index: acpica-unix2-20160831/source/components/utilities/utownerid.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix-20160527.orig/source/components/utilities/utownerid.c
|
--- acpica-unix2-20160831.orig/source/components/utilities/utownerid.c
|
||||||
+++ acpica-unix-20160527/source/components/utilities/utownerid.c
|
+++ acpica-unix2-20160831/source/components/utilities/utownerid.c
|
||||||
@@ -231,7 +231,7 @@ AcpiUtReleaseOwnerId (
|
@@ -231,7 +231,7 @@ AcpiUtReleaseOwnerId (
|
||||||
else
|
else
|
||||||
{
|
{
|
||||||
@ -328,11 +328,11 @@ Index: acpica-unix-20160527/source/components/utilities/utownerid.c
|
|||||||
}
|
}
|
||||||
|
|
||||||
(void) AcpiUtReleaseMutex (ACPI_MTX_CACHES);
|
(void) AcpiUtReleaseMutex (ACPI_MTX_CACHES);
|
||||||
Index: acpica-unix-20160527/source/tools/acpiexec/aemain.c
|
Index: acpica-unix2-20160831/source/tools/acpiexec/aemain.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix-20160527.orig/source/tools/acpiexec/aemain.c
|
--- acpica-unix2-20160831.orig/source/tools/acpiexec/aemain.c
|
||||||
+++ acpica-unix-20160527/source/tools/acpiexec/aemain.c
|
+++ acpica-unix2-20160831/source/tools/acpiexec/aemain.c
|
||||||
@@ -205,7 +205,7 @@ AeDoOptions (
|
@@ -207,7 +207,7 @@ AeDoOptions (
|
||||||
|
|
||||||
if (strlen (AcpiGbl_Optarg) > (AE_BUFFER_SIZE -1))
|
if (strlen (AcpiGbl_Optarg) > (AE_BUFFER_SIZE -1))
|
||||||
{
|
{
|
||||||
|
@ -7,11 +7,11 @@ Al Stone <ahs3@redhat.com>
|
|||||||
source/compiler/aslmain.c | 12 ------------
|
source/compiler/aslmain.c | 12 ------------
|
||||||
1 file changed, 12 deletions(-)
|
1 file changed, 12 deletions(-)
|
||||||
|
|
||||||
Index: acpica-unix2-20160422/source/compiler/aslmain.c
|
Index: acpica-unix2-20160831/source/compiler/aslmain.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- acpica-unix2-20160422.orig/source/compiler/aslmain.c
|
--- acpica-unix2-20160831.orig/source/compiler/aslmain.c
|
||||||
+++ acpica-unix2-20160422/source/compiler/aslmain.c
|
+++ acpica-unix2-20160831/source/compiler/aslmain.c
|
||||||
@@ -318,18 +318,6 @@ main (
|
@@ -99,18 +99,6 @@ main (
|
||||||
int ReturnStatus = 0;
|
int ReturnStatus = 0;
|
||||||
|
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user