Add patch to ensure ASLTS always reports errors when they occur.

Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
Al Stone 2014-10-01 12:06:53 -06:00
parent c328591a0a
commit 1c109dbf8c
2 changed files with 28 additions and 0 deletions

View File

@ -30,6 +30,7 @@ Patch3: aapits-linux.patch
Patch4: asllookup-miscompare.patch
Patch5: aapits-makefile.patch
Patch6: re-enable-big-endian.patch
Patch7: aslts-always-reports.patch
BuildRequires: bison patchutils flex
@ -87,6 +88,7 @@ gzip -dc %{SOURCE1} | tar -x --strip-components=1 -f -
%patch4 -p1 -b .asllookup-miscompare
%patch5 -p1 -b .aapits-makefile
%patch6 -p1 -b .re-enable-big-endian
%patch7 -p1 -b .aslts-always-reports
cp -p %{SOURCE2} README.Fedora
cp -p %{SOURCE3} iasl.1
@ -194,6 +196,8 @@ fi
* Wed Oct 1 2014 Al Stone <ahs3@redhat.com> - 20140926-1
- Update to latest upstream. Closes BZ#1147131.
- Refresh patches
- Add patch to ensure ASLTS always reports when an error occurs, instead
of glossing over it.
* Fri Aug 29 2014 Al Stone <ahs3@redhat.com> - 20140828-1
- Update to latest upstream. Closes BZ#1135352.

View File

@ -0,0 +1,24 @@
From Dean Nelson <dnelson@redhat.com>
Ensure that any errors found by iasl are actually reported by the
ASLTS. In the past, some were not and therefore just glossed over.
diff --git a/tests/aslts/Makefile.def b/tests/aslts/Makefile.def
--- a/tests/aslts/Makefile.def
+++ b/tests/aslts/Makefile.def
@@ -72,7 +72,14 @@
"$(ASL)" $$CUR_ASLFLAGS "$(COMMON_ASL_FLAGS)" $(ADD_ASLFLAGS) $$j.asl >> $(COMPILER_LOG) 2>> $(COMPILER_ERROR_LOG); \
ret=$$?; \
echo "" >> $(COMPILER_LOG); \
- if [ $$ret != 0 ]; then rval=1; echo "**** Unexpected iASL failure!"; exit 1; fi; \
+ if [ $$ret != 0 ]; then \
+ rval=1; \
+ echo "---- Test path: $$dd" >> /dev/stderr; \
+ echo "---- Test type: $$CUR_AMLDIR (Flags $(COMMON_ASL_FLAGS) $$CUR_ASLFLAGS $(ADD_ASLFLAGS))" >> /dev/stderr; \
+ tail -2 $(COMPILER_LOG) >> /dev/stderr; \
+ echo "**** Unexpected iASL failure!" >> /dev/stderr; \
+ exit 1; \
+ fi; \
done; \
if [ $$ret != 0 ]; then break; fi; \
for j in ${AMLMOD}; do \