- prevent setfacl --restore from SIGSEGV on malformed restore file
(#576550)
This commit is contained in:
parent
65a8c0260d
commit
f6b390280a
27
acl-2.2.49-setfacl-restore.patch
Normal file
27
acl-2.2.49-setfacl-restore.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
diff --git a/setfacl/setfacl.c b/setfacl/setfacl.c
|
||||||
|
index 7142af0..23784a7 100644
|
||||||
|
--- a/setfacl/setfacl.c
|
||||||
|
+++ b/setfacl/setfacl.c
|
||||||
|
@@ -125,7 +125,7 @@ restore(
|
||||||
|
uid_t uid;
|
||||||
|
gid_t gid;
|
||||||
|
mode_t mask, flags;
|
||||||
|
- struct do_set_args args;
|
||||||
|
+ struct do_set_args args = { 0 };
|
||||||
|
int line = 0, backup_line;
|
||||||
|
int error, status = 0;
|
||||||
|
int chmod_required = 0;
|
||||||
|
diff --git a/test/misc.test b/test/misc.test
|
||||||
|
index e6140da..a910bd0 100644
|
||||||
|
--- a/test/misc.test
|
||||||
|
+++ b/test/misc.test
|
||||||
|
@@ -424,3 +424,9 @@ Now, chmod should change the group_obj entry
|
||||||
|
>
|
||||||
|
|
||||||
|
$ rmdir d
|
||||||
|
+
|
||||||
|
+Malformed restore file
|
||||||
|
+
|
||||||
|
+ $ echo "# owner: root" > f
|
||||||
|
+ $ setfacl --restore=f 2>&1
|
||||||
|
+ >setfacl: f: No filename found in line 0, aborting
|
14
acl.spec
14
acl.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Access control list utilities
|
Summary: Access control list utilities
|
||||||
Name: acl
|
Name: acl
|
||||||
Version: 2.2.49
|
Version: 2.2.49
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: gawk
|
BuildRequires: gawk
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -19,6 +19,9 @@ Patch3: acl-2.2.49-bz467936.patch
|
|||||||
# prepare the test-suite for SELinux and arbitrary umask
|
# prepare the test-suite for SELinux and arbitrary umask
|
||||||
Patch4: acl-2.2.49-tests.patch
|
Patch4: acl-2.2.49-tests.patch
|
||||||
|
|
||||||
|
# bz #576550
|
||||||
|
Patch5: acl-2.2.49-setfacl-restore.patch
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
URL: http://oss.sgi.com/projects/xfs/
|
URL: http://oss.sgi.com/projects/xfs/
|
||||||
@ -57,11 +60,17 @@ defined in POSIX 1003.1e draft standard 17.
|
|||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
%patch4 -p1
|
%patch4 -p1
|
||||||
|
%patch5 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
touch .census
|
touch .census
|
||||||
# acl abuses libexecdir
|
# acl abuses libexecdir
|
||||||
%configure --libdir=/%{_lib} --libexecdir=%{_libdir}
|
%configure --libdir=/%{_lib} --libexecdir=%{_libdir}
|
||||||
|
|
||||||
|
# uncomment to turn on optimizations
|
||||||
|
# sed -i 's/-O2/-O0/' libtool include/builddefs
|
||||||
|
# unset CFLAGS
|
||||||
|
|
||||||
make %{?_smp_mflags} LIBTOOL="libtool --tag=CC"
|
make %{?_smp_mflags} LIBTOOL="libtool --tag=CC"
|
||||||
|
|
||||||
%check
|
%check
|
||||||
@ -125,6 +134,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
/%{_lib}/libacl.so.*
|
/%{_lib}/libacl.so.*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 24 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-6
|
||||||
|
- prevent setfacl --restore from SIGSEGV on malformed restore file (#576550)
|
||||||
|
|
||||||
* Wed Mar 10 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-5
|
* Wed Mar 10 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-5
|
||||||
- run the test-suite if possible
|
- run the test-suite if possible
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user