Added support for short cmdline params (e.g. -n)
This commit is contained in:
parent
71326ac80a
commit
e49204ba44
106
acl-2.2.39-params.patch
Normal file
106
acl-2.2.39-params.patch
Normal file
@ -0,0 +1,106 @@
|
||||
diff -urp acl-2.2.39/getfacl/getfacl.c acl-2.2.39mzk/getfacl/getfacl.c
|
||||
--- acl-2.2.39/getfacl/getfacl.c 2007-07-25 13:12:13.000000000 +0200
|
||||
+++ acl-2.2.39mzk/getfacl/getfacl.c 2007-07-25 12:51:14.000000000 +0200
|
||||
@@ -42,7 +42,7 @@
|
||||
#define POSIXLY_CORRECT_STR "POSIXLY_CORRECT"
|
||||
|
||||
#if !POSIXLY_CORRECT
|
||||
-# define CMD_LINE_OPTIONS "dRLP"
|
||||
+# define CMD_LINE_OPTIONS "aceEsRLPtpndvh"
|
||||
#endif
|
||||
#define POSIXLY_CMD_LINE_OPTIONS "d"
|
||||
|
||||
@@ -540,18 +540,18 @@ void help(void)
|
||||
#if !POSIXLY_CORRECT
|
||||
} else {
|
||||
printf(_(
|
||||
-" --access display the file access control list only\n"
|
||||
+" -a, --access display the file access control list only\n"
|
||||
" -d, --default display the default access control list only\n"
|
||||
-" --omit-header do not display the comment header\n"
|
||||
-" --all-effective print all effective rights\n"
|
||||
-" --no-effective print no effective rights\n"
|
||||
-" --skip-base skip files that only have the base entries\n"
|
||||
+" -c, --omit-header do not display the comment header\n"
|
||||
+" -e, --all-effective print all effective rights\n"
|
||||
+" -E, --no-effective print no effective rights\n"
|
||||
+" -s, --skip-base skip files that only have the base entries\n"
|
||||
" -R, --recursive recurse into subdirectories\n"
|
||||
" -L, --logical logical walk, follow symbolic links\n"
|
||||
-" -P --physical physical walk, do not follow symbolic links\n"
|
||||
-" --tabular use tabular output format\n"
|
||||
-" --numeric print numeric user/group identifiers\n"
|
||||
-" --absolute-names don't strip leading '/' in pathnames\n"));
|
||||
+" -P, --physical physical walk, do not follow symbolic links\n"
|
||||
+" -t, --tabular use tabular output format\n"
|
||||
+" -n, --numeric print numeric user/group identifiers\n"
|
||||
+" -p, --absolute-names don't strip leading '/' in pathnames\n"));
|
||||
}
|
||||
#endif
|
||||
printf(_(
|
||||
diff -urp acl-2.2.39/man/man1/getfacl.1 acl-2.2.39mzk/man/man1/getfacl.1
|
||||
--- acl-2.2.39/man/man1/getfacl.1 2006-06-20 08:51:25.000000000 +0200
|
||||
+++ acl-2.2.39mzk/man/man1/getfacl.1 2007-07-25 13:17:17.000000000 +0200
|
||||
@@ -12,10 +12,10 @@ getfacl \- get file access control lists
|
||||
.SH SYNOPSIS
|
||||
|
||||
.B getfacl
|
||||
-[\-dRLPvh] file ...
|
||||
+[\-aceEsRLPrpndvh] file ...
|
||||
|
||||
.B getfacl
|
||||
-[\-dRLPvh] \-
|
||||
+[\-aceEsRLPrpndvh] \-
|
||||
|
||||
.SH DESCRIPTION
|
||||
For each file, getfacl displays the file name, owner, the group,
|
||||
@@ -78,22 +78,22 @@ accessing the file mode.
|
||||
|
||||
.SS OPTIONS
|
||||
.TP 4
|
||||
-.I \-\-access
|
||||
+.I \-a, \-\-access
|
||||
Display the file access control list.
|
||||
.TP
|
||||
.I \-d, \-\-default
|
||||
Display the default access control list.
|
||||
.TP
|
||||
-.I \-\-omit-header
|
||||
+.I \-c, \-\-omit-header
|
||||
Do not display the comment header (the first three lines of each file's output).
|
||||
.TP
|
||||
-.I \-\-all-effective
|
||||
+.I \-e, \-\-all-effective
|
||||
Print all effective rights comments, even if identical to the rights defined by the ACL entry.
|
||||
.TP
|
||||
-.I \-\-no-effective
|
||||
+.I \-E, \-\-no-effective
|
||||
Do not print effective rights comments.
|
||||
.TP
|
||||
-.I \-\-skip-base
|
||||
+.I \-s, \-\-skip-base
|
||||
Skip files that only have the base ACL entries (owner, group, others).
|
||||
.TP
|
||||
.I \-R, \-\-recursive
|
||||
@@ -108,17 +108,17 @@ subdirectories.
|
||||
Physical walk, skip all symbolic links. This also skips symbolic link
|
||||
arguments.
|
||||
.TP
|
||||
-.I \-\-tabular
|
||||
+.I \-t, \-\-tabular
|
||||
Use an alternative tabular output format. The ACL and the default ACL are displayed side by side. Permissions that are ineffective due to the ACL mask entry are displayed capitalized. The entry tag names for the ACL_USER_OBJ and ACL_GROUP_OBJ entries are also displayed in capital letters, which helps in spotting those entries.
|
||||
.TP
|
||||
-.I \-\-absolute-names
|
||||
+.I \-p, \-\-absolute-names
|
||||
Do not strip leading slash characters (`/'). The default behavior is to
|
||||
strip leading slash characters.
|
||||
.TP
|
||||
-.I \-\-version
|
||||
+.I \-v, \-\-version
|
||||
Print the version of getfacl and exit.
|
||||
.TP
|
||||
-.I \-\-help
|
||||
+.I \-h, \-\-help
|
||||
Print help explaining the command line options.
|
||||
.TP
|
||||
.I \-\-
|
6
acl.spec
6
acl.spec
@ -9,6 +9,7 @@ Patch0: acl-2.2.3-multilib.patch
|
||||
Patch1: acl-2.2.39-build.patch
|
||||
Patch2: acl-2.2.39-path_max.patch
|
||||
Patch3: acl-2.2.39-walk.patch
|
||||
Patch4: acl-2.2.39-params.patch
|
||||
BuildRequires: autoconf, libtool >= 1.5, gettext
|
||||
License: GPL
|
||||
Group: System Environment/Base
|
||||
@ -47,6 +48,7 @@ defined in POSIX 1003.1e draft standard 17.
|
||||
%patch1 -p1 -b .build
|
||||
%patch2 -p1 -b .path_max
|
||||
%patch3 -p1 -b .walk
|
||||
%patch4 -p1 -b .params
|
||||
autoconf
|
||||
|
||||
%build
|
||||
@ -102,6 +104,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
/%{_lib}/libacl.so.*
|
||||
|
||||
%changelog
|
||||
* Wed Jul 25 2007 Jiri Moskovcak <jmoskovc@redhat.com>
|
||||
- Added support fort short params to getfacl
|
||||
- Resolves: #204087
|
||||
|
||||
* Wed Mar 21 2007 Thomas Woerner <twoerner@redhat.com> 2.2.39-3.1
|
||||
- new improved walk patch with fixed getfacl exit code (rhbz#232884)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user