upstream release - 2.2.52
This commit is contained in:
parent
0eb56be2be
commit
c6736e9e8e
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
acl-2.2.49.src.tar.gz
|
||||
/acl-2.2.50.src.tar.gz
|
||||
/acl-2.2.51.src.tar.gz
|
||||
/acl-2.2.52.src.tar.gz
|
||||
|
@ -1,8 +1,15 @@
|
||||
From 320b3ca0a544fd5024ddfeca6f491a0344b9ecd2 Mon Sep 17 00:00:00 2001
|
||||
From: John Bradshaw <john@johnbradshaw.org>
|
||||
Date: Sat, 5 Feb 2011 18:14:27 +0000
|
||||
Subject: [PATCH] setfacl.1: fix typo 'inclu de' -> 'include'
|
||||
|
||||
Bug: https://bugzilla.redhat.com/675451
|
||||
---
|
||||
man/man1/setfacl.1 | 4 ++--
|
||||
1 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/man/man1/setfacl.1 b/man/man1/setfacl.1
|
||||
index 25908e2..776f22d 100644
|
||||
index 64f0e33..0c7c046 100644
|
||||
--- a/man/man1/setfacl.1
|
||||
+++ b/man/man1/setfacl.1
|
||||
@@ -240,8 +240,8 @@ owner, owning group, or others entry, a copy of the ACL owner, owning group, or
|
||||
@ -16,3 +23,6 @@ index 25908e2..776f22d 100644
|
||||
.I \-n
|
||||
option description).
|
||||
.PP
|
||||
--
|
||||
1.7.1
|
||||
|
25
0002-acl-2.2.52-docdir.patch
Normal file
25
0002-acl-2.2.52-docdir.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From b4e37109d66d698772e2513c0f79e818b4235897 Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Mon, 20 May 2013 13:17:14 +0200
|
||||
Subject: [PATCH] builddefs.in: use pkg version in $(PKG_DOC_DIR)
|
||||
|
||||
---
|
||||
include/builddefs.in | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/include/builddefs.in b/include/builddefs.in
|
||||
index d9931db..47bfdd6 100644
|
||||
--- a/include/builddefs.in
|
||||
+++ b/include/builddefs.in
|
||||
@@ -34,7 +34,7 @@ PKG_LIB_DIR = @libdir@@libdirsuffix@
|
||||
PKG_DEVLIB_DIR = @libexecdir@@libdirsuffix@
|
||||
PKG_INC_DIR = @includedir@
|
||||
PKG_MAN_DIR = @mandir@
|
||||
-PKG_DOC_DIR = @datadir@/doc/@pkg_name@
|
||||
+PKG_DOC_DIR = @datadir@/doc/@pkg_name@-@pkg_version@
|
||||
PKG_LOCALE_DIR = @datadir@/locale
|
||||
|
||||
CC = @cc@
|
||||
--
|
||||
1.7.1
|
||||
|
@ -1,58 +1,14 @@
|
||||
diff --git a/test/cp.test b/test/cp.test
|
||||
index a888c04..4a75ffd 100644
|
||||
--- a/test/cp.test
|
||||
+++ b/test/cp.test
|
||||
@@ -9,7 +9,7 @@ The cp utility should only copy ACLs if `-p' is given.
|
||||
> -rw-rw-r--+
|
||||
From cfd9ba83811189d9e12c86d32b06b5fd15b5f358 Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Mon, 20 May 2013 13:49:34 +0200
|
||||
Subject: [PATCH] make the tests ready for SELinux
|
||||
|
||||
$ cp f g
|
||||
- $ ls -l g | awk -- '{ print $1 }'
|
||||
+ $ ls -l g | awk -- '{ print $1 }' | sed 's/\\.$//'
|
||||
> -rw-r--r--
|
||||
---
|
||||
test/root/permissions.test | 8 ++++----
|
||||
test/root/restore.test | 2 +-
|
||||
test/root/setfacl.test | 2 +-
|
||||
3 files changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
$ rm g
|
||||
diff --git a/test/getfacl-recursive.test b/test/getfacl-recursive.test
|
||||
index b88c211..a72192e 100644
|
||||
--- a/test/getfacl-recursive.test
|
||||
+++ b/test/getfacl-recursive.test
|
||||
@@ -1,5 +1,6 @@
|
||||
Tests for proper path recursion
|
||||
|
||||
+ $ umask 022
|
||||
$ mkdir -p 1/2/3
|
||||
$ mkdir 1/link
|
||||
$ touch 1/link/file
|
||||
diff --git a/test/misc.test b/test/misc.test
|
||||
index 7c62c64..e6140da 100644
|
||||
--- a/test/misc.test
|
||||
+++ b/test/misc.test
|
||||
@@ -254,7 +254,7 @@ Add some users and groups
|
||||
Symlink in directory with default ACL?
|
||||
|
||||
$ ln -s d d/l
|
||||
- $ ls -dl d/l | awk '{print $1}'
|
||||
+ $ ls -dl d/l | awk '{print $1}' | sed 's/\\.$//'
|
||||
> lrwxrwxrwx
|
||||
|
||||
$ ls -dl -L d/l | awk '{print $1}'
|
||||
@@ -343,7 +343,7 @@ Remove the default ACL
|
||||
Reset to base entries
|
||||
|
||||
$ setfacl -b d
|
||||
- $ ls -dl d | awk '{print $1}'
|
||||
+ $ ls -dl d | awk '{print $1}' | sed 's/\\.$//'
|
||||
> drwxr-x---
|
||||
|
||||
$ getfacl --omit-header d
|
||||
@@ -355,7 +355,7 @@ Reset to base entries
|
||||
Now, chmod should change the group_obj entry
|
||||
|
||||
$ chmod 775 d
|
||||
- $ ls -dl d | awk '{print $1}'
|
||||
+ $ ls -dl d | awk '{print $1}' | sed 's/\\.$//'
|
||||
> drwxrwxr-x
|
||||
|
||||
$ getfacl --omit-header d
|
||||
diff --git a/test/root/permissions.test b/test/root/permissions.test
|
||||
index afaf5f0..4880bd2 100644
|
||||
--- a/test/root/permissions.test
|
||||
@ -116,21 +72,6 @@ index 630e9fb..dd7fe08 100644
|
||||
> -rw-r-----
|
||||
|
||||
$ setfacl -m m:- g
|
||||
diff --git a/test/sbits-restore.test b/test/sbits-restore.test
|
||||
index e5e4fb2..abdb58a 100644
|
||||
--- a/test/sbits-restore.test
|
||||
+++ b/test/sbits-restore.test
|
||||
@@ -13,10 +13,10 @@ Ensure setting of SUID/SGID/sticky via --restore works
|
||||
$ touch d/g
|
||||
$ touch d/u
|
||||
$ setfacl --restore d.acl
|
||||
- $ ls -dl d | awk '{print $1}'
|
||||
+ $ ls -dl d | awk '{print $1}' | sed 's/\\.$//'
|
||||
> drwxr-xr-t
|
||||
- $ ls -dl d/u | awk '{print $1}'
|
||||
+ $ ls -dl d/u | awk '{print $1}' | sed 's/\\.$//'
|
||||
> -rwSr--r--
|
||||
- $ ls -dl d/g | awk '{print $1}'
|
||||
+ $ ls -dl d/g | awk '{print $1}' | sed 's/\\.$//'
|
||||
> -rw-r-Sr--
|
||||
$ rm -Rf d
|
||||
--
|
||||
1.7.1
|
||||
|
28
0004-acl-2.2.52-libdir.patch
Normal file
28
0004-acl-2.2.52-libdir.patch
Normal file
@ -0,0 +1,28 @@
|
||||
From 3dee229914dc17beef900d16175a877697119911 Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Rytarowski <n54@gmx.com>
|
||||
Date: Sat, 27 Apr 2013 22:43:31 +0200
|
||||
Subject: [PATCH] Install the libraries to the appropriate directory
|
||||
|
||||
[upstream commit 2971df45020e39516c9b3d6217195b4029026f7a]
|
||||
|
||||
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
|
||||
---
|
||||
include/builddefs.in | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/include/builddefs.in b/include/builddefs.in
|
||||
index 2ef6173..876a735 100644
|
||||
--- a/include/builddefs.in
|
||||
+++ b/include/builddefs.in
|
||||
@@ -31,7 +31,7 @@ PKG_DISTRIBUTION= @pkg_distribution@
|
||||
PKG_BIN_DIR = @bindir@
|
||||
PKG_SBIN_DIR = @sbindir@
|
||||
PKG_LIB_DIR = @libdir@@libdirsuffix@
|
||||
-PKG_DEVLIB_DIR = @libexecdir@@libdirsuffix@
|
||||
+PKG_DEVLIB_DIR = @libdir@@libdirsuffix@
|
||||
PKG_INC_DIR = @includedir@
|
||||
PKG_MAN_DIR = @mandir@
|
||||
PKG_DOC_DIR = @datadir@/doc/@pkg_name@-@pkg_version@
|
||||
--
|
||||
1.7.1
|
||||
|
@ -1,40 +0,0 @@
|
||||
diff --git a/include/builddefs.in b/include/builddefs.in
|
||||
index d054a56..10b0cd4 100644
|
||||
--- a/include/builddefs.in
|
||||
+++ b/include/builddefs.in
|
||||
@@ -28,14 +28,14 @@ PKG_RELEASE = @pkg_release@
|
||||
PKG_VERSION = @pkg_version@
|
||||
PKG_PLATFORM = @pkg_platform@
|
||||
PKG_DISTRIBUTION= @pkg_distribution@
|
||||
-PKG_BIN_DIR = @bindir@
|
||||
-PKG_SBIN_DIR = @sbindir@
|
||||
-PKG_LIB_DIR = @libdir@@libdirsuffix@
|
||||
-PKG_DEVLIB_DIR = @libexecdir@@libdirsuffix@
|
||||
-PKG_INC_DIR = @includedir@
|
||||
-PKG_MAN_DIR = @mandir@
|
||||
-PKG_DOC_DIR = @datadir@/doc/@pkg_name@
|
||||
-PKG_LOCALE_DIR = @datadir@/locale
|
||||
+PKG_BIN_DIR = $(DESTDIR)@bindir@
|
||||
+PKG_SBIN_DIR = $(DESTDIR)@sbindir@
|
||||
+PKG_LIB_DIR = $(DESTDIR)@libdir@@libdirsuffix@
|
||||
+PKG_DEVLIB_DIR = $(DESTDIR)@libexecdir@@libdirsuffix@
|
||||
+PKG_INC_DIR = $(DESTDIR)@includedir@
|
||||
+PKG_MAN_DIR = $(DESTDIR)@mandir@
|
||||
+PKG_DOC_DIR = $(DESTDIR)@datadir@/doc/@pkg_name@-@pkg_version@
|
||||
+PKG_LOCALE_DIR = $(DESTDIR)@datadir@/locale
|
||||
|
||||
CC = @cc@
|
||||
AWK = @awk@
|
||||
diff --git a/include/buildmacros b/include/buildmacros
|
||||
index 17423c0..3118a17 100644
|
||||
--- a/include/buildmacros
|
||||
+++ b/include/buildmacros
|
||||
@@ -40,7 +40,7 @@ OBJECTS = $(ASFILES:.s=.o) \
|
||||
$(LFILES:.l=.o) \
|
||||
$(YFILES:%.y=%.tab.o)
|
||||
|
||||
-INSTALL = $(TOPDIR)/include/install-sh -o $(PKG_USER) -g $(PKG_GROUP)
|
||||
+INSTALL = $(TOPDIR)/include/install-sh
|
||||
|
||||
SHELL = /bin/sh
|
||||
IMAGES_DIR = $(TOPDIR)/all-images
|
Binary file not shown.
BIN
acl-2.2.52.src.tar.gz.sig
Normal file
BIN
acl-2.2.52.src.tar.gz.sig
Normal file
Binary file not shown.
30
acl.spec
30
acl.spec
@ -1,7 +1,7 @@
|
||||
Summary: Access control list utilities
|
||||
Name: acl
|
||||
Version: 2.2.51
|
||||
Release: 9%{?dist}
|
||||
Version: 2.2.52
|
||||
Release: 1%{?dist}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: gawk
|
||||
BuildRequires: gettext
|
||||
@ -9,13 +9,18 @@ BuildRequires: libattr-devel
|
||||
BuildRequires: libtool
|
||||
Requires: libacl = %{version}-%{release}
|
||||
Source: http://download.savannah.gnu.org/releases-noredirect/acl/acl-%{version}.src.tar.gz
|
||||
Patch1: acl-2.2.39-build.patch
|
||||
|
||||
# fix a typo in setfacl(1) man page (#675451)
|
||||
Patch1: 0001-acl-2.2.49-bz675451.patch
|
||||
|
||||
# use pkg version in $(PKG_DOC_DIR)
|
||||
Patch2: 0002-acl-2.2.52-docdir.patch
|
||||
|
||||
# prepare the test-suite for SELinux and arbitrary umask
|
||||
Patch4: acl-2.2.49-tests.patch
|
||||
Patch3: 0003-acl-2.2.52-tests.patch
|
||||
|
||||
# fix typos in setfacl(1) man page (#675451)
|
||||
Patch6: acl-2.2.49-bz675451.patch
|
||||
# Install the libraries to the appropriate directory
|
||||
Patch4: 0004-acl-2.2.52-libdir.patch
|
||||
|
||||
License: GPLv2+
|
||||
Group: System Environment/Base
|
||||
@ -52,13 +57,12 @@ defined in POSIX 1003.1e draft standard 17.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch6 -p1
|
||||
|
||||
%build
|
||||
touch .census
|
||||
# acl abuses libexecdir
|
||||
%configure --libexecdir=%{_libdir}
|
||||
%configure
|
||||
|
||||
# uncomment to turn on optimizations
|
||||
# sed -i 's/-O2/-O0/' libtool include/builddefs
|
||||
@ -85,8 +89,6 @@ make install-lib DESTDIR=$RPM_BUILD_ROOT
|
||||
# get rid of libacl.a and libacl.la
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/libacl.a
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/libacl.la
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/libacl.a
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/libacl.la
|
||||
|
||||
chmod 0755 $RPM_BUILD_ROOT/%{_libdir}/libacl.so.*.*.*
|
||||
|
||||
@ -116,6 +118,10 @@ chmod 0755 $RPM_BUILD_ROOT/%{_libdir}/libacl.so.*.*.*
|
||||
%{_libdir}/libacl.so.*
|
||||
|
||||
%changelog
|
||||
* Mon May 20 2013 Kamil Dudka <kdudka@redhat.com> 2.2.52-1
|
||||
- new upstream release, drop applied patches
|
||||
- drop workarounds that are no longer necessary
|
||||
|
||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.51-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user