[tw]
- new version 2.2.39 - fixed usage of long UTF-8 filenames (#183181) Thanks to Andrey for the initial patch.
This commit is contained in:
parent
a6dffdba00
commit
b6b9a647f5
@ -2,3 +2,4 @@ acl-2.2.23.src.tar.gz
|
||||
acl-2.2.31.src.tar.gz
|
||||
acl-2.2.32.src.tar.gz
|
||||
acl-2.2.34.src.tar.gz
|
||||
acl_2.2.39-1.tar.gz
|
||||
|
36
acl-2.2.39-build.patch
Normal file
36
acl-2.2.39-build.patch
Normal file
@ -0,0 +1,36 @@
|
||||
--- acl-2.2.39/include/builddefs.in.build 2006-06-20 02:51:25.000000000 -0400
|
||||
+++ acl-2.2.39/include/builddefs.in 2006-07-05 12:34:05.000000000 -0400
|
||||
@@ -26,14 +26,14 @@
|
||||
PKG_VERSION = @pkg_version@
|
||||
PKG_PLATFORM = @pkg_platform@
|
||||
PKG_DISTRIBUTION= @pkg_distribution@
|
||||
-PKG_BIN_DIR = @bindir@
|
||||
-PKG_SBIN_DIR = @sbindir@
|
||||
-PKG_LIB_DIR = @libdir@@libdirsuffix@
|
||||
-PKG_DEVLIB_DIR = @libexecdir@@libdirsuffix@
|
||||
-PKG_INC_DIR = @includedir@
|
||||
-PKG_MAN_DIR = @mandir@
|
||||
-PKG_DOC_DIR = @datadir@/doc/@pkg_name@
|
||||
-PKG_LOCALE_DIR = @datadir@/locale
|
||||
+PKG_BIN_DIR = $(DESTDIR)@bindir@
|
||||
+PKG_SBIN_DIR = $(DESTDIR)@sbindir@
|
||||
+PKG_LIB_DIR = $(DESTDIR)@libdir@@libdirsuffix@
|
||||
+PKG_DEVLIB_DIR = $(DESTDIR)@libexecdir@@libdirsuffix@
|
||||
+PKG_INC_DIR = $(DESTDIR)@includedir@
|
||||
+PKG_MAN_DIR = $(DESTDIR)@mandir@
|
||||
+PKG_DOC_DIR = $(DESTDIR)@datadir@/doc/@pkg_name@-@pkg_version@
|
||||
+PKG_LOCALE_DIR = $(DESTDIR)@datadir@/locale
|
||||
|
||||
CC = @cc@
|
||||
AWK = @awk@
|
||||
--- acl-2.2.39/include/buildmacros.build 2006-07-05 12:32:07.000000000 -0400
|
||||
+++ acl-2.2.39/include/buildmacros 2006-07-05 12:32:07.000000000 -0400
|
||||
@@ -26,7 +26,7 @@
|
||||
$(LFILES:.l=.o) \
|
||||
$(YFILES:%.y=%.tab.o)
|
||||
|
||||
-INSTALL = $(TOPDIR)/install-sh -o $(PKG_USER) -g $(PKG_GROUP)
|
||||
+INSTALL = $(TOPDIR)/install-sh
|
||||
|
||||
SHELL = /bin/sh
|
||||
IMAGES_DIR = $(TOPDIR)/all-images
|
24
acl-2.2.39-path_max.patch
Normal file
24
acl-2.2.39-path_max.patch
Normal file
@ -0,0 +1,24 @@
|
||||
--- acl-2.2.39/setfacl/parse.c.path_max 2006-06-20 02:51:25.000000000 -0400
|
||||
+++ acl-2.2.39/setfacl/parse.c 2006-07-05 15:27:21.000000000 -0400
|
||||
@@ -24,6 +24,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <errno.h>
|
||||
+#include <limits.h>
|
||||
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
@@ -412,7 +413,12 @@
|
||||
gid_t *gid_p)
|
||||
{
|
||||
int c;
|
||||
- char linebuf[1024];
|
||||
+ /*
|
||||
+ Max PATH_MAX bytes even for UTF-8 path names and additional 6
|
||||
+ bytes for "#file:". Not a good solution but for now it is the
|
||||
+ best I can do without too much impact on the code. [tw]
|
||||
+ */
|
||||
+ char linebuf[PATH_MAX+6];
|
||||
char *cp;
|
||||
char *p;
|
||||
int comments_read = 0;
|
15
acl.spec
15
acl.spec
@ -1,12 +1,13 @@
|
||||
Summary: Access control list utilities.
|
||||
Name: acl
|
||||
Version: 2.2.34
|
||||
Release: 2
|
||||
Version: 2.2.39
|
||||
Release: 1
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
BuildRequires: libattr-devel >= 2.4.1
|
||||
Source: ftp://oss.sgi.com/projects/xfs/cmd_tars/acl-%{version}.src.tar.gz
|
||||
Source: ftp://oss.sgi.com/projects/xfs/cmd_tars/acl_%{version}-1.tar.gz
|
||||
Patch0: acl-2.2.3-multilib.patch
|
||||
Patch1: acl-2.2.32-build.patch
|
||||
Patch1: acl-2.2.39-build.patch
|
||||
Patch2: acl-2.2.39-path_max.patch
|
||||
BuildRequires: autoconf, libtool >= 1.5, gettext
|
||||
License: GPL
|
||||
Group: System Environment/Base
|
||||
@ -42,6 +43,7 @@ defined in POSIX 1003.1e draft standard 17.
|
||||
%setup -q
|
||||
%patch0 -p1 -b .multilib
|
||||
%patch1 -p1 -b .build
|
||||
%patch2 -p1 -b .path_max
|
||||
autoconf
|
||||
|
||||
%build
|
||||
@ -97,6 +99,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
/%{_lib}/libacl.so.*
|
||||
|
||||
%changelog
|
||||
* Wed Jul 5 2006 Thomas Woerner <twoerner@redhat.com> 2.2.39-1
|
||||
- new version 2.2.39
|
||||
- fixed usage of long UTF-8 filenames (#183181)
|
||||
Thanks to Andrey for the initial patch.
|
||||
|
||||
* Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 2.2.34-2
|
||||
- rebuild for -devel deps
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user