upstream release - 2.3.0
This commit is contained in:
parent
d5c22707ba
commit
3b266dc344
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
/acl-2.2.*.tar.gz
|
||||
/acl-2.[23].*.tar.gz
|
||||
|
@ -1,29 +0,0 @@
|
||||
From c03773259fbe6d3f3355efc8e66990718d5cab54 Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Mon, 31 Aug 2020 17:16:34 +0200
|
||||
Subject: [PATCH] __acl_create_entry_obj: do not break strict aliasing rules
|
||||
|
||||
... to avoid SIGSEGV with link-time optimisation enabled
|
||||
|
||||
Bug: https://bugzilla.redhat.com/1873975
|
||||
Upstream-report: https://lists.nongnu.org/archive/html/acl-devel/2020-08/msg00000.html
|
||||
---
|
||||
libacl/acl_create_entry.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/libacl/acl_create_entry.c b/libacl/acl_create_entry.c
|
||||
index 2214c1a..8ee72a3 100644
|
||||
--- a/libacl/acl_create_entry.c
|
||||
+++ b/libacl/acl_create_entry.c
|
||||
@@ -42,7 +42,7 @@ __acl_create_entry_obj(acl_obj *acl_obj_p)
|
||||
entry_obj_p->eprev = acl_obj_p->aprev;
|
||||
entry_obj_p->enext = (acl_entry_obj *)acl_obj_p;
|
||||
entry_obj_p->eprev->enext = entry_obj_p;
|
||||
- entry_obj_p->enext->eprev = entry_obj_p;
|
||||
+ acl_obj_p->aprev = entry_obj_p;
|
||||
|
||||
entry_obj_p->econtainer = acl_obj_p;
|
||||
init_acl_entry_obj(*entry_obj_p);
|
||||
--
|
||||
2.25.4
|
||||
|
Binary file not shown.
BIN
acl-2.3.0.tar.gz.sig
Normal file
BIN
acl-2.3.0.tar.gz.sig
Normal file
Binary file not shown.
10
acl.spec
10
acl.spec
@ -1,7 +1,7 @@
|
||||
Summary: Access control list utilities
|
||||
Name: acl
|
||||
Version: 2.2.53
|
||||
Release: 10%{?dist}
|
||||
Version: 2.3.0
|
||||
Release: 1%{?dist}
|
||||
BuildRequires: gawk
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gettext
|
||||
@ -15,9 +15,6 @@ Source: https://download-mirror.savannah.gnu.org/releases/acl/acl-%{version}.tar
|
||||
# avoid permission denied problem with LD_PRELOAD in the test-suite
|
||||
Patch1: 0001-acl-2.2.53-test-runwrapper.patch
|
||||
|
||||
# make __acl_create_entry_obj() work with LTO enabled (#1873975)
|
||||
Patch2: 0002-acl-2.2.53-setattr-segv.patch
|
||||
|
||||
License: GPLv2+
|
||||
URL: https://savannah.nongnu.org/projects/acl
|
||||
|
||||
@ -122,6 +119,9 @@ rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}*
|
||||
%{_libdir}/libacl.so.*
|
||||
|
||||
%changelog
|
||||
* Fri Mar 12 2021 Kamil Dudka <kdudka@redhat.com> - 2.3.0-1
|
||||
- new upstream release
|
||||
|
||||
* Mon Jan 25 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.53-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (acl-2.2.53.tar.gz) = 176b7957fe0e7618e0b7bf2ac5071f7fa29417df718cce977661a576fa184e4af9d303b591c9d556b6ba8923e799457343afa401f5a9f7ecd9022185a4e06716
|
||||
SHA512 (acl-2.3.0.tar.gz) = 77c0f387955d98ee086020943ea5d50ddcf5a36981cb28d2e90c74c20c3893c13c3fa9bc5bc47f79957987ec19afd00ad0b144a1387562b887c1f5fb5e6850cc
|
||||
|
Loading…
Reference in New Issue
Block a user