- tweaked setfacl tree walk flags (#488674)
This commit is contained in:
parent
2f25943749
commit
2354d23ec1
30
acl-2.2.49-setfacl-walk.patch
Normal file
30
acl-2.2.49-setfacl-walk.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
diff --git a/setfacl/setfacl.c b/setfacl/setfacl.c
|
||||||
|
index 091b9cc..be34e69 100644
|
||||||
|
--- a/setfacl/setfacl.c
|
||||||
|
+++ b/setfacl/setfacl.c
|
||||||
|
@@ -76,7 +76,7 @@ struct option long_options[] = {
|
||||||
|
const char *progname;
|
||||||
|
const char *cmd_line_options, *cmd_line_spec;
|
||||||
|
|
||||||
|
-int walk_flags = WALK_TREE_DEREFERENCE;
|
||||||
|
+int walk_flags = WALK_TREE_DEREFERENCE_TOPLEVEL;
|
||||||
|
int opt_recalculate; /* recalculate mask entry (0=default, 1=yes, -1=no) */
|
||||||
|
int opt_promote; /* promote access ACL to default ACL */
|
||||||
|
int opt_test; /* do not write to the file system.
|
||||||
|
@@ -580,13 +580,14 @@ int main(int argc, char *argv[])
|
||||||
|
break;
|
||||||
|
|
||||||
|
case 'L': /* follow symlinks */
|
||||||
|
- walk_flags |= WALK_TREE_LOGICAL;
|
||||||
|
+ walk_flags |= WALK_TREE_LOGICAL | WALK_TREE_DEREFERENCE;
|
||||||
|
walk_flags &= ~WALK_TREE_PHYSICAL;
|
||||||
|
break;
|
||||||
|
|
||||||
|
case 'P': /* do not follow symlinks */
|
||||||
|
walk_flags |= WALK_TREE_PHYSICAL;
|
||||||
|
- walk_flags &= ~WALK_TREE_LOGICAL;
|
||||||
|
+ walk_flags &= ~(WALK_TREE_LOGICAL | WALK_TREE_DEREFERENCE |
|
||||||
|
+ WALK_TREE_DEREFERENCE_TOPLEVEL);
|
||||||
|
break;
|
||||||
|
|
||||||
|
case 't': /* test mode */
|
7
acl.spec
7
acl.spec
@ -1,13 +1,14 @@
|
|||||||
Summary: Access control list utilities
|
Summary: Access control list utilities
|
||||||
Name: acl
|
Name: acl
|
||||||
Version: 2.2.49
|
Version: 2.2.49
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: libattr-devel >= 2.4.1
|
BuildRequires: libattr-devel >= 2.4.1
|
||||||
BuildRequires: autoconf, libtool >= 1.5, gettext, gawk
|
BuildRequires: autoconf, libtool >= 1.5, gettext, gawk
|
||||||
Source: http://download.savannah.gnu.org/releases-noredirect/acl/acl-%{version}.src.tar.gz
|
Source: http://download.savannah.gnu.org/releases-noredirect/acl/acl-%{version}.src.tar.gz
|
||||||
Patch0: acl-2.2.3-multilib.patch
|
Patch0: acl-2.2.3-multilib.patch
|
||||||
Patch1: acl-2.2.39-build.patch
|
Patch1: acl-2.2.39-build.patch
|
||||||
|
Patch2: acl-2.2.49-setfacl-walk.patch
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
URL: http://oss.sgi.com/projects/xfs/
|
URL: http://oss.sgi.com/projects/xfs/
|
||||||
@ -44,6 +45,7 @@ defined in POSIX 1003.1e draft standard 17.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
autoconf
|
autoconf
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -99,6 +101,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
/%{_lib}/libacl.so.*
|
/%{_lib}/libacl.so.*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Dec 26 2009 Kamil Dudka <kdudka@redhat.com> 2.2.49-2
|
||||||
|
- tweaked setfacl tree walk flags (#488674), thanks to Markus Steinborn
|
||||||
|
|
||||||
* Sun Dec 20 2009 Kamil Dudka <kdudka@redhat.com> 2.2.49-1
|
* Sun Dec 20 2009 Kamil Dudka <kdudka@redhat.com> 2.2.49-1
|
||||||
- new upstream bugfix release
|
- new upstream bugfix release
|
||||||
- big cleanup in patches
|
- big cleanup in patches
|
||||||
|
Loading…
Reference in New Issue
Block a user