[tw]
- spec file cleanup - mark po files as lang specific
This commit is contained in:
parent
e420ee0d0c
commit
1074a79012
36
acl-2.2.32-build.patch
Normal file
36
acl-2.2.32-build.patch
Normal file
@ -0,0 +1,36 @@
|
|||||||
|
--- acl-2.2.32/include/buildmacros.build 2005-12-06 15:33:03.000000000 +0100
|
||||||
|
+++ acl-2.2.32/include/buildmacros 2005-12-06 15:33:06.000000000 +0100
|
||||||
|
@@ -54,7 +54,7 @@
|
||||||
|
$(LFILES:.l=.o) \
|
||||||
|
$(YFILES:%.y=%.tab.o)
|
||||||
|
|
||||||
|
-INSTALL = $(TOPDIR)/install-sh -o $(PKG_USER) -g $(PKG_GROUP)
|
||||||
|
+INSTALL = $(TOPDIR)/install-sh
|
||||||
|
|
||||||
|
SHELL = /bin/sh
|
||||||
|
IMAGES_DIR = $(TOPDIR)/all-images
|
||||||
|
--- acl-2.2.32/include/builddefs.in.build 2005-10-07 18:51:14.000000000 +0200
|
||||||
|
+++ acl-2.2.32/include/builddefs.in 2005-12-06 15:34:20.000000000 +0100
|
||||||
|
@@ -53,14 +53,14 @@
|
||||||
|
PKG_VERSION = @pkg_version@
|
||||||
|
PKG_PLATFORM = @pkg_platform@
|
||||||
|
PKG_DISTRIBUTION= @pkg_distribution@
|
||||||
|
-PKG_BIN_DIR = @bindir@
|
||||||
|
-PKG_SBIN_DIR = @sbindir@
|
||||||
|
-PKG_LIB_DIR = @libdir@
|
||||||
|
-PKG_DEVLIB_DIR = @libexecdir@
|
||||||
|
-PKG_INC_DIR = @includedir@
|
||||||
|
-PKG_MAN_DIR = @mandir@
|
||||||
|
-PKG_DOC_DIR = @datadir@/doc/@pkg_name@
|
||||||
|
-PKG_LOCALE_DIR = @datadir@/locale
|
||||||
|
+PKG_BIN_DIR = $(DESTDIR)@bindir@
|
||||||
|
+PKG_SBIN_DIR = $(DESTDIR)@sbindir@
|
||||||
|
+PKG_LIB_DIR = $(DESTDIR)@libdir@
|
||||||
|
+PKG_DEVLIB_DIR = $(DESTDIR)@libexecdir@
|
||||||
|
+PKG_INC_DIR = $(DESTDIR)@includedir@
|
||||||
|
+PKG_MAN_DIR = $(DESTDIR)@mandir@
|
||||||
|
+PKG_DOC_DIR = $(DESTDIR)@datadir@/doc/@pkg_name@-@pkg_version@
|
||||||
|
+PKG_LOCALE_DIR = $(DESTDIR)@datadir@/locale
|
||||||
|
|
||||||
|
CC = @cc@
|
||||||
|
AWK = @awk@
|
76
acl.spec
76
acl.spec
@ -1,11 +1,12 @@
|
|||||||
Summary: Access control list utilities.
|
Summary: Access control list utilities.
|
||||||
Name: acl
|
Name: acl
|
||||||
Version: 2.2.32
|
Version: 2.2.32
|
||||||
Release: 1
|
Release: 2
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
BuildRequires: libattr-devel >= 2.4.1
|
BuildRequires: libattr-devel >= 2.4.1
|
||||||
Source: ftp://oss.sgi.com/projects/xfs/cmd_tars/acl-%{version}.src.tar.gz
|
Source: ftp://oss.sgi.com/projects/xfs/cmd_tars/acl-%{version}.src.tar.gz
|
||||||
Patch0: acl-2.2.3-multilib.patch
|
Patch0: acl-2.2.3-multilib.patch
|
||||||
|
Patch1: acl-2.2.32-build.patch
|
||||||
BuildRequires: autoconf, libtool >= 1.5, gettext
|
BuildRequires: autoconf, libtool >= 1.5, gettext
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -40,6 +41,7 @@ defined in POSIX 1003.1e draft standard 17.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .multilib
|
%patch0 -p1 -b .multilib
|
||||||
|
%patch1 -p1 -b .build
|
||||||
autoconf
|
autoconf
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -50,46 +52,18 @@ make LIBTOOL="libtool --tag=CC"
|
|||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
DIST_ROOT="$RPM_BUILD_ROOT"
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
DIST_INSTALL=`pwd`/install.manifest
|
make install-dev DESTDIR=$RPM_BUILD_ROOT
|
||||||
DIST_INSTALL_DEV=`pwd`/install-dev.manifest
|
make install-lib DESTDIR=$RPM_BUILD_ROOT
|
||||||
DIST_INSTALL_LIB=`pwd`/install-lib.manifest
|
|
||||||
export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
|
|
||||||
make install DIST_MANIFEST="$DIST_INSTALL" PKG_DOC_DIR=%{_docdir}/acl-%{version}
|
|
||||||
make install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
|
|
||||||
make install-lib DIST_MANIFEST="$DIST_INSTALL_LIB"
|
|
||||||
|
|
||||||
# Buahhh, ugly hack, but it works.
|
# get rid of libacl.la
|
||||||
perl -pi -e 's|^f 644|f 755|' $DIST_INSTALL_LIB
|
rm -f $RPM_BUILD_ROOT/%{_libdir}/libacl.la
|
||||||
chmod 755 $RPM_BUILD_ROOT/%{_lib}/*
|
|
||||||
|
|
||||||
# get rid of *.la files
|
# create
|
||||||
rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
|
rm -f $RPM_BUILD_ROOT/%{_libdir}/libacl.so
|
||||||
|
ln -s /%{_lib}/libacl.so $RPM_BUILD_ROOT/%{_libdir}/libacl.so
|
||||||
|
|
||||||
files()
|
%find_lang %{name}
|
||||||
{
|
|
||||||
sort | uniq | awk '
|
|
||||||
$1 == "d" {
|
|
||||||
if (match ($6, "/usr/include/acl"))
|
|
||||||
printf ("%%%%dir %%%%attr(%s,%s,%s) %s\n", $2, $3, $4, $5); }
|
|
||||||
$1 == "f" { if (match ($6, "/usr/share/man") || match ($6, "/usr/share/doc/acl"))
|
|
||||||
printf ("%%%%doc ");
|
|
||||||
if (match ($6, "/usr/share/man"))
|
|
||||||
printf ("%%%%attr(%s,%s,%s) %s*\n", $2, $3, $4, $6);
|
|
||||||
else
|
|
||||||
printf ("%%%%attr(%s,%s,%s) %s\n", $2, $3, $4, $6); }
|
|
||||||
$1 == "l" { if (match ($3, "/usr/share/man") || match ($3, "/usr/share/doc/acl"))
|
|
||||||
printf ("%%%%doc ");
|
|
||||||
if (match ($3, "/usr/share/man"))
|
|
||||||
printf ("%%%%attr(0777,root,root) %s*\n", $3);
|
|
||||||
else
|
|
||||||
printf ("%%%%attr(0777,root,root) %s\n", $3); }'
|
|
||||||
}
|
|
||||||
set +x
|
|
||||||
files < "$DIST_INSTALL" > files.rpm
|
|
||||||
files < "$DIST_INSTALL_DEV" | grep -v libacl.la > filesdevel.rpm
|
|
||||||
files < "$DIST_INSTALL_LIB" > fileslib.rpm
|
|
||||||
set -x
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
@ -98,16 +72,34 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
%postun -n libacl -p /sbin/ldconfig
|
%postun -n libacl -p /sbin/ldconfig
|
||||||
|
|
||||||
%files -f files.rpm
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/chacl
|
||||||
|
%{_bindir}/getfacl
|
||||||
|
%{_bindir}/setfacl
|
||||||
|
%{_datadir}/doc/acl-%{version}
|
||||||
|
%{_mandir}/man1/chacl.1*
|
||||||
|
%{_mandir}/man1/getfacl.1*
|
||||||
|
%{_mandir}/man1/setfacl.1*
|
||||||
|
%{_mandir}/man5/acl.5*
|
||||||
|
|
||||||
%files -n libacl-devel -f filesdevel.rpm
|
%files -n libacl-devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
/usr/include/acl
|
/%{_lib}/libacl.so
|
||||||
|
%{_includedir}/acl
|
||||||
|
%{_includedir}/sys/acl.h
|
||||||
|
%{_libdir}/libacl.*
|
||||||
|
%{_mandir}/man3/acl_*
|
||||||
|
|
||||||
%files -n libacl -f fileslib.rpm
|
%files -n libacl
|
||||||
|
%defattr(-,root,root)
|
||||||
|
/%{_lib}/libacl.so.*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Dec 6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2
|
||||||
|
- spec file cleanup
|
||||||
|
- mark po files as lang specific
|
||||||
|
|
||||||
* Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
|
* Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
|
||||||
- 2.2.32
|
- 2.2.32
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user