import accountsservice-0.6.50-8.el8

This commit is contained in:
CentOS Sources 2020-04-28 05:44:34 -04:00 committed by Andrew Lukoshko
parent 8eb6902ca5
commit 01272aa841
3 changed files with 1920 additions and 6 deletions

File diff suppressed because it is too large Load Diff

View File

@ -1,4 +1,4 @@
From 4ff9bc526fec4be51f42739b4258529d7e4695a1 Mon Sep 17 00:00:00 2001
From 51d5c9e9baec33aa74a60a4ac11f1de8f71acb2a Mon Sep 17 00:00:00 2001
From: Ray Strode <rstrode@redhat.com>
Date: Fri, 12 Oct 2018 15:53:52 -0400
Subject: [PATCH] lib: save os when creating user
@ -17,10 +17,10 @@ extension to accountsservice.
create mode 100644 data/com.redhat.AccountsServiceUser.System.xml
diff --git a/data/Makefile.am b/data/Makefile.am
index 521c6c2..a441452 100644
index 6cf5e30..648774c 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -1,44 +1,56 @@
@@ -1,45 +1,57 @@
dbusifdir = $(datadir)/dbus-1/interfaces
dbusif_DATA = \
@ -61,6 +61,7 @@ index 521c6c2..a441452 100644
$(dbusconf_DATA) \
$(service_in_files) \
$(policy_in_files) \
org.freedesktop.realmd.xml \
accounts-daemon.service.in
DISTCLEANFILES = \
@ -180,7 +181,7 @@ index 408d91f..d711d65 100644
libaccountsservice_la_sources = \
diff --git a/src/libaccountsservice/act-user-manager.c b/src/libaccountsservice/act-user-manager.c
index 325421b..091b46a 100644
index e7e26b1..9f3d6e5 100644
--- a/src/libaccountsservice/act-user-manager.c
+++ b/src/libaccountsservice/act-user-manager.c
@@ -27,60 +27,61 @@
@ -840,5 +841,5 @@ index 325421b..091b46a 100644
{
GError *local_error = NULL;
--
2.17.1
2.21.0

View File

@ -2,7 +2,7 @@
Name: accountsservice
Version: 0.6.50
Release: 7%{?dist}
Release: 8%{?dist}
Summary: D-Bus interfaces for querying and manipulating user account information
License: GPLv3+
URL: https://www.freedesktop.org/wiki/Software/AccountsService/
@ -28,6 +28,8 @@ Patch20: 0001-lib-don-t-set-loaded-state-until-seat-is-fetched.patch
Patch30: 0001-data-don-t-send-change-updates-for-login-history.patch
Patch40: 0001-daemon-if-no-local-users-check-if-machine-is-enrolle.patch
Patch90: 0001-lib-save-os-when-creating-user.patch
Requires: polkit
@ -113,6 +115,10 @@ rm $RPM_BUILD_ROOT%{_libdir}/*.a
%{_datadir}/gtk-doc/html/libaccountsservice/*
%changelog
* Sun Dec 15 2019 Ray Strode <rstrode@redhat.com> - 0.6.50-8
- Don't set HasNoUsers=true if realmd has providers
Related: #1750516
* Mon Jun 17 2019 Ray Strode <rstrode@redhat.com> - 0.6.50-7
- Don't send change updates for login history changes
Resolves: #1713080