AlmaLinux changes

This commit is contained in:
eabdullin 2021-11-17 14:07:05 +03:00
commit a49539fafa
5 changed files with 100 additions and 179 deletions

View File

@ -1,116 +0,0 @@
From 16b6963ef5e37805d2587684f90d2c6d5dd4ffdc Mon Sep 17 00:00:00 2001
From: Jakub Filak <jfilak@redhat.com>
Date: Thu, 6 Dec 2018 17:57:59 +0100
Subject: [PATCH] cli list: show a hint about creating a case in RHTS
Adds "Run 'abrt-cli report ...' for creating a case in Red Hat Customer Portal" to
abrt-cli list output.
Resolves: #1649753
(cherry-picked from 7966e5737e8d3af43b1ecdd6a823234b8d25931d)
Signed-off-by: Jakub Filak <jfilak@redhat.com>
---
configure.ac | 2 ++
src/cli/Makefile.am | 3 ++-
src/cli/list.c | 49 +++++++++++++++++++++++++++++++++++++++++++++
3 files changed, 53 insertions(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 76e0f274b..5d70bb9a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -246,6 +246,7 @@ DEFAULT_PLUGINS_CONF_DIR='${datadir}/${PACKAGE_NAME}/conf.d/plugins'
EVENTS_DIR='${datadir}/libreport/events'
EVENTS_CONF_DIR='${sysconfdir}/libreport/events.d'
JOURNAL_CATALOG_DIR='$(prefix)/lib/systemd/catalog'
+WORKFLOWS_DIR='${datadir}/libreport/workflows'
ENABLE_SOCKET_OR_DBUS='-DENABLE_DBUS=1'
DEFAULT_DUMP_LOCATION_MODE=0751
DEFAULT_DUMP_DIR_MODE=$($PKG_CONFIG --variable=dd_mode libreport)
@@ -389,6 +390,7 @@ AC_SUBST(PLUGINS_CONF_DIR)
AC_SUBST(DEFAULT_PLUGINS_CONF_DIR)
AC_SUBST(EVENTS_CONF_DIR)
AC_SUBST(JOURNAL_CATALOG_DIR)
+AC_SUBST(WORKFLOWS_DIR)
AC_SUBST(EVENTS_DIR)
AC_SUBST(DEFAULT_DUMP_LOCATION)
AC_SUBST(DEFAULT_DUMP_LOCATION_MODE)
diff --git a/src/cli/Makefile.am b/src/cli/Makefile.am
index 92dc20ab4..a7c76efa3 100644
--- a/src/cli/Makefile.am
+++ b/src/cli/Makefile.am
@@ -17,7 +17,8 @@ abrt_cli_CFLAGS = \
-I$(srcdir)/../include \
-I$(srcdir)/../lib \
$(LIBREPORT_CFLAGS) \
- $(POLKIT_AGENT_CFLAGS)
+ $(POLKIT_AGENT_CFLAGS) \
+ -DWORKFLOWS_DIR=\"${WORKFLOWS_DIR}\"
if SUGGEST_AUTOREPORTING
abrt_cli_CFLAGS += -DSUGGEST_AUTOREPORTING=1
diff --git a/src/cli/list.c b/src/cli/list.c
index d069695c6..2c140cb38 100644
--- a/src/cli/list.c
+++ b/src/cli/list.c
@@ -77,6 +77,55 @@ static void print_crash(problem_data_t *problem_data, int detailed, int text_siz
/*names_to_skip:*/ NULL,
/*max_text_size:*/ text_size,
MAKEDESC_SHOW_ONLY_LIST | MAKEDESC_SHOW_URLS);
+
+ /*
+ * If the problem is reportable and has not yet been reported into RHTS
+ * and there is at least one applicable Workflow which contains
+ * 'report_RHTSupport' event, then append a short message informing
+ * user that he can create a new case in Red Hat Customer Portal.
+ */
+ const char *const not_reportable = problem_data_get_content_or_NULL(problem_data, FILENAME_NOT_REPORTABLE);
+ const char *const reported_to = not_reportable ? NULL : problem_data_get_content_or_NULL(problem_data, FILENAME_REPORTED_TO);
+ report_result_t *const report = !reported_to ? NULL : find_in_reported_to_data(reported_to, "RHTSupport");
+
+ if (!not_reportable && !report)
+ {
+ /* The lines below should be replaced by something simpler, I'd
+ * like to see:
+ * GHashTable *possible_worfklows = load_applicable_workflows_for_dump();
+ *
+ * However, this feature (rhbz#1055565) is intended for RHEL only
+ * and I'm not sure whether it's worth to file another bug against
+ * libreport and try to improve libreport public API.
+ */
+ const char *const dump_dir_name = problem_data_get_content_or_NULL(problem_data, CD_DUMPDIR);
+ GList *const wf_names = list_possible_events_glist(dump_dir_name, "workflow");
+ GHashTable *const possible_workflows = load_workflow_config_data_from_list(wf_names, WORKFLOWS_DIR);
+ g_list_free_full(wf_names, free);
+
+ int event_found = 0;
+
+ GHashTableIter iter;
+ gpointer key = NULL;
+ gpointer value = NULL;
+
+ g_hash_table_iter_init(&iter, possible_workflows);
+ while (!event_found && g_hash_table_iter_next(&iter, &key, &value))
+ {
+ GList *const event_names = wf_get_event_names((workflow_t *)value);
+ event_found = !!g_list_find_custom(event_names, "report_RHTSupport", (GCompareFunc)g_strcmp0);
+ g_list_free_full(event_names, free);
+ }
+
+ g_hash_table_destroy(possible_workflows);
+
+ if (event_found)
+ {
+ char *tmp = xasprintf("%sRun 'abrt-cli report %s' for creating a case in Red Hat Customer Portal\n", desc, dump_dir_name);
+ free(desc);
+ desc = tmp;
+ }
+ }
}
fputs(desc, stdout);
free(desc);
--
2.17.2

View File

@ -1,28 +0,0 @@
From c0aa44a93bfdc701839d2c70568224521a6d5c5b Mon Sep 17 00:00:00 2001
From: Jakub Filak <jfilak@redhat.com>
Date: Thu, 6 Dec 2018 18:00:45 +0100
Subject: [PATCH] cli: mark the suggestion text for translation
(cherry-picked from 187530c4df6971927d1e099584be5b418ab2725b)
Signed-off-by: Jakub Filak <jfilak@redhat.com>
---
src/cli/list.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/cli/list.c b/src/cli/list.c
index 2c140cb38..f16ce8c0d 100644
--- a/src/cli/list.c
+++ b/src/cli/list.c
@@ -121,7 +121,7 @@ static void print_crash(problem_data_t *problem_data, int detailed, int text_siz
if (event_found)
{
- char *tmp = xasprintf("%sRun 'abrt-cli report %s' for creating a case in Red Hat Customer Portal\n", desc, dump_dir_name);
+ char *tmp = xasprintf(_("%sRun 'abrt-cli report %s' for creating a case in Red Hat Customer Portal\n"), desc, dump_dir_name);
free(desc);
desc = tmp;
}
--
2.17.2

View File

@ -1,31 +0,0 @@
From 58dcdd2f2780263e79a82ecebb27b000b0583979 Mon Sep 17 00:00:00 2001
From: Jakub Filak <jfilak@redhat.com>
Date: Thu, 6 Dec 2018 18:01:13 +0100
Subject: [PATCH] cli: get list of possible workflows for problem_data_t
File system access is not possible, so we have to rely on the data
transfered via D-Bus.
(cherry-picked from f2055f8c6469b590172d94e9ea530243af89f028)
Signed-off-by: Jakub Filak <jfilak@redhat.com>
---
src/cli/list.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/cli/list.c b/src/cli/list.c
index f16ce8c0d..e688d2f49 100644
--- a/src/cli/list.c
+++ b/src/cli/list.c
@@ -99,7 +99,7 @@ static void print_crash(problem_data_t *problem_data, int detailed, int text_siz
* libreport and try to improve libreport public API.
*/
const char *const dump_dir_name = problem_data_get_content_or_NULL(problem_data, CD_DUMPDIR);
- GList *const wf_names = list_possible_events_glist(dump_dir_name, "workflow");
+ GList *const wf_names = list_possible_events_problem_data_glist(problem_data, dump_dir_name, "workflow");
GHashTable *const possible_workflows = load_workflow_config_data_from_list(wf_names, WORKFLOWS_DIR);
g_list_free_full(wf_names, free);
--
2.17.2

View File

@ -0,0 +1,94 @@
From 3d54b451282246ff8dfdff12e809b64c446b48d2 Mon Sep 17 00:00:00 2001
From: Michal Srb <michal@redhat.com>
Date: Wed, 31 Mar 2021 13:28:57 +0200
Subject: [PATCH] Do not report to journal
We do not ship the journal reporter in RHEL 8.
---
src/plugins/ccpp_event.conf | 8 --------
src/plugins/koops_event.conf | 4 ----
src/plugins/python3_event.conf | 4 ----
src/plugins/python_event.conf | 4 ----
src/plugins/vmcore_event.conf | 4 ----
src/plugins/xorg_event.conf | 4 ----
6 files changed, 28 deletions(-)
diff --git a/src/plugins/ccpp_event.conf b/src/plugins/ccpp_event.conf
index 9883861..f8338d2 100644
--- a/src/plugins/ccpp_event.conf
+++ b/src/plugins/ccpp_event.conf
@@ -111,11 +111,3 @@ EVENT=report-gui type=CCpp
EVENT=report-cli type=CCpp
report-cli -- "$DUMP_DIR"
-
-EVENT=report_systemd-journal type=CCpp analyzer=abrt-ccpp
- reporter-systemd-journal --message-id 5ab0271ecf1941a2b89299716e880661 \
- -F /etc/libreport/plugins/catalog_ccpp_format.conf
-
-EVENT=report_systemd-journal type=CCpp analyzer=abrt-journal-core
- reporter-systemd-journal --message-id 5ab0271ecf1941a2b89299716e880661 \
- -F /etc/libreport/plugins/catalog_journal_ccpp_format.conf
diff --git a/src/plugins/koops_event.conf b/src/plugins/koops_event.conf
index f4a3ba2..5e53723 100644
--- a/src/plugins/koops_event.conf
+++ b/src/plugins/koops_event.conf
@@ -52,7 +52,3 @@ EVENT=report-gui type=Kerneloops mce!=non-fatal
EVENT=report-cli type=Kerneloops
report-cli -- "$DUMP_DIR"
-
-EVENT=report_systemd-journal type=Kerneloops
- reporter-systemd-journal --message-id 8ed36508c5a24d0ab2d633f330899e5f \
- -F /etc/libreport/plugins/catalog_koops_format.conf
diff --git a/src/plugins/python3_event.conf b/src/plugins/python3_event.conf
index 8c5b279..481a1c4 100644
--- a/src/plugins/python3_event.conf
+++ b/src/plugins/python3_event.conf
@@ -34,7 +34,3 @@ EVENT=report-gui type=Python3 component!=anaconda
EVENT=report-cli type=Python3 component!=anaconda
report-cli -- "$DUMP_DIR"
-
-EVENT=report_systemd-journal type=Python3
- reporter-systemd-journal --message-id 4d6f95dd9ff54eb7bd1f32a387f327c3 \
- -F /etc/libreport/plugins/catalog_python3_format.conf
diff --git a/src/plugins/python_event.conf b/src/plugins/python_event.conf
index 4e5d39c..1824364 100644
--- a/src/plugins/python_event.conf
+++ b/src/plugins/python_event.conf
@@ -34,7 +34,3 @@ EVENT=report-gui type=Python component!=anaconda
EVENT=report-cli type=Python component!=anaconda
report-cli -- "$DUMP_DIR"
-
-EVENT=report_systemd-journal type=Python
- reporter-systemd-journal --message-id b25955d7738d4db9a498a734620194ef \
- -F /etc/libreport/plugins/catalog_python_format.conf
diff --git a/src/plugins/vmcore_event.conf b/src/plugins/vmcore_event.conf
index bf97b39..61bc9d1 100644
--- a/src/plugins/vmcore_event.conf
+++ b/src/plugins/vmcore_event.conf
@@ -64,7 +64,3 @@ EVENT=report-gui type=vmcore
EVENT=report-cli type=vmcore
report-cli -- "$DUMP_DIR"
-
-EVENT=report_systemd-journal type=vmcore
- reporter-systemd-journal --message-id ebde29430d524b5fb043138098fd7e89 \
- -F /etc/libreport/plugins/catalog_vmcore_format.conf
diff --git a/src/plugins/xorg_event.conf b/src/plugins/xorg_event.conf
index 5ffe4bf..8d0d585 100644
--- a/src/plugins/xorg_event.conf
+++ b/src/plugins/xorg_event.conf
@@ -26,7 +26,3 @@ EVENT=report-gui type=xorg
EVENT=report-cli type=xorg
report-cli -- "$DUMP_DIR"
-
-EVENT=report_systemd-journal type=xorg
- reporter-systemd-journal --message-id 6a9a2826cc074934bff0dd0a45a10453 \
- -F /etc/libreport/plugins/catalog_xorg_format.conf
--
2.30.2

View File

@ -55,7 +55,7 @@
Summary: Automatic bug detection and reporting tool
Name: abrt
Version: 2.10.9
Release: 20%{?dist}.alma.1
Release: 21%{?dist}.alma
License: GPLv2+
URL: https://abrt.readthedocs.org/
Source: https://github.com/abrt/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
@ -157,6 +157,7 @@ Patch0085: 0085-abrt-action-install-debuginfo-Fix-variable-reference.patch
Patch0086: 0086-plugins-sosreport_event-Rename-nfsserver-plugin.patch
# git format-patch 2.10.9-19.el8 --no-numbered --start-number=87 --topo-order
Patch0087: 0087-plugins-abrt-action-install-debuginfo-Fix-reference.patch
Patch0090: 0090-skip-journal-reporting.patch
# autogen.sh is need to regenerate all the Makefile files
Patch1000: 1000-Add-autogen.sh.patch
@ -1368,11 +1369,12 @@ killall abrt-dbus >/dev/null 2>&1 || :
%config(noreplace) %{_sysconfdir}/profile.d/abrt-console-notification.sh
%changelog
* Tue Feb 09 2021 - Andrei Lukoshko <alukoshko@cloudlinux.com> - 2.10.9-20.alma.1
* Fri Oct 08 2021 Andrei Lukoshko <alukoshko@almalinux.org> - 2.10.9-21.alma
- Add support for GPG subkeys
* Wed Jan 27 2021 - Anatholy Scryabin <ascryabin@cloudlinux.com> - 2.10.9-20.alma
- Disable rhtsupport
* Wed Mar 31 2021 Michal Srb <michal@redhat.com> - 2.10.9-21
- Do not report problems to journal as we don't ship the journal reporter
- Resolves: rhbz#1844739
* Wed Aug 19 2020 - Ernestas Kulik <ekulik@redhat.com> - 2.10.9-20
- Something something patch for rhbz#1835388