import abrt-2.10.9-11.el8

This commit is contained in:
CentOS Sources 2019-11-05 14:47:16 -05:00 committed by Stepan Oksanichenko
parent 5c4e77a87d
commit 847c8a8f66
2 changed files with 91 additions and 1 deletions

View File

@ -0,0 +1,57 @@
From f6e07167e8769219471b10a3c20fa64ada8ce61f Mon Sep 17 00:00:00 2001
From: Martin Kutlak <mkutlak@redhat.com>
Date: Fri, 12 Jul 2019 17:46:48 +0200
Subject: [PATCH] a-a-list-dsos: Fix decoding of strings from rpm
rpm used to return bytes but that was changed to return strings in recent release.
Related: rhbz#1693751
Resolves: rhbz#1694970
Signed-off-by: Martin Kutlak <mkutlak@redhat.com>
---
abrt.spec.in | 1 +
src/plugins/abrt-action-list-dsos | 13 ++++++-------
2 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/abrt.spec.in b/abrt.spec.in
index 03f1a67d..b9c9d5f1 100644
--- a/abrt.spec.in
+++ b/abrt.spec.in
@@ -233,6 +233,7 @@ Requires: python2-libreport
%if %{with python3}
Requires: python3-libreport
%endif # with python3
+Requires: rpm >= 4.14.2-11
%description addon-ccpp
This package contains %{name}'s C/C++ analyzer plugin.
diff --git a/src/plugins/abrt-action-list-dsos b/src/plugins/abrt-action-list-dsos
index adb228a4..8bf5415e 100644
--- a/src/plugins/abrt-action-list-dsos
+++ b/src/plugins/abrt-action-list-dsos
@@ -84,15 +84,14 @@ if __name__ == "__main__":
outname = None
vendor = h[rpm.RPMTAG_VENDOR]
- if vendor != None:
- vendor = vendor.decode('utf-8')
+ rpmtag_nevra = h[rpm.RPMTAG_NEVRA]
outfile.write("%s %s (%s) %s\n" %
- (path,
- h[rpm.RPMTAG_NEVRA].decode('utf-8'),
- vendor,
- h[rpm.RPMTAG_INSTALLTIME])
- )
+ (path,
+ rpmtag_nevra,
+ vendor,
+ h[rpm.RPMTAG_INSTALLTIME])
+ )
except Exception as ex:
error_msg_and_die("Can't get the DSO list: %s" % ex)
--
2.21.0

View File

@ -55,7 +55,7 @@
Summary: Automatic bug detection and reporting tool
Name: abrt
Version: 2.10.9
Release: 10%{?dist}
Release: 11%{?dist}
License: GPLv2+
URL: https://abrt.readthedocs.org/
Source: https://github.com/abrt/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
@ -93,6 +93,34 @@ Patch0027: 0027-cli-mark-the-suggestion-text-for-translation.patch
Patch0028: 0028-cli-get-list-of-possible-workflows-for-problem_data_.patch
#Patch0029: 0029-spec-Add-explicit-package-version-requirement-of-abr.patch
#git format-patch 2.10.9-10.el8 -N --start-number 30 --topo-order
#Patch030: 0030-testsuite-dbus-element-handling-Use-external-script.patch
#Patch031: 0031-testsuite-reporter-upload-ssh-keys-Don-t-test-curl-o.patch
#Patch032: 0032-testsuite-abrt-action-ureport-Port-fakefaf-to-Python.patch
#Patch033: 0033-testsuite-bugzilla-private-reports-Port-pyserve-to-P.patch
#Patch034: 0034-testsuite-ureport-attachments-Port-pyserve-to-Python.patch
#Patch035: 0035-testsuite-upload-ftp-Drop-in-tree-copy-of-pyftpdlib.patch
#Patch036: 0036-testsuite-rhts-test-Port-pyserve-to-Python-3.patch
#Patch037: 0037-testsuite-dumpdir_completeness-Batch-import-keys.patch
#Patch038: 0038-testsuite-Add-initial-test-order-for-RHEL-8.patch
#Patch039: 0039-testsuite-bugzilla-bt-reattach-Port-pyserve-to-Pytho.patch
#Patch040: 0040-testsuite-reporter-mantisbt-Port-pyserve-to-Python3.patch
#Patch041: 0041-testsuite-reporter-mantisbt-Fix-query-header.patch
#Patch042: 0042-testsuite-abrt-action-ureport-Fix-fakefaf.py.patch
#Patch043: 0043-testsuite-aux-Remove-Python-3-related-packages.patch
#Patch044: 0044-aux-lib.sh-add-generate_python3_segfault.patch
#Patch045: 0045-dont-blame-interpret-switch-to-generate_python3_segf.patch
#Patch046: 0046-duptest-core_backtrace-use-python3-on-rhel8.patch
#Patch047: 0047-ureport-auth-modify-a-pattern-to-match-error-message.patch
#Patch048: 0048-testsuite-Add-abrt-auto-reporting-sanity-authenticat.patch
#Patch049: 0049-runtests-new-test-for-PrivateReports.patch
#Patch050: 0050-dumpoops-make-sure-hostname-matches-in-oops_full_hos.patch
#Patch051: 0051-oops-processing-fixed-oops1.test-handling.-reworked-.patch
#Patch052: 0052-meaningful-logs-check-relative-counts-of-lines-inste.patch
#Patch053: 0053-non-fatal-mce-prepare-oops1.test-from-template-befor.patch
#Patch054: 0054-oops-processing-fix-for-rhel-8.patch
#Patch055: 0055-dumpoops-remove-sed-of-file-not-existing-and-not-nee.patch
Patch056: 0056-a-a-list-dsos-Fix-decoding-of-strings-from-rpm.patch
#git format-patch 2.10.9-11.el8 -N --start-number 57 --topo-order
# autogen.sh is need to regenerate all the Makefile files
Patch1000: 1000-Add-autogen.sh.patch
@ -272,6 +300,7 @@ Requires: python2-libreport
%if %{with python3}
Requires: python3-libreport
%endif # with python3
Requires: rpm >= 4.14.2-11
%description addon-ccpp
This package contains %{name}'s C/C++ analyzer plugin.
@ -1308,6 +1337,10 @@ killall abrt-dbus >/dev/null 2>&1 || :
%config(noreplace) %{_sysconfdir}/profile.d/abrt-console-notification.sh
%changelog
* Tue Jul 16 2019 Michal Fabik <mfabik@redhat.com> - 2.10.9-11
- a-a-list-dsos: Fix decoding of strings from rpm
Resolves: rhbz#1694970
* Fri Dec 7 2018 Martin Kutlak <mkutlak@redhat.com> - 2.10.9-10
- spec: Add-explicit-package-version-requirement-of-abrt-libs
- cli: get list of possible workflows for problem_data_t