import abrt-2.10.9-19.el8
This commit is contained in:
parent
73f28f3c4f
commit
2a5c8bbfaa
@ -0,0 +1,118 @@
|
||||
From caf03304c98dc84086b2f4f60be4b41fc76f31e6 Mon Sep 17 00:00:00 2001
|
||||
From: Martin Kutlak <mkutlak@redhat.com>
|
||||
Date: Wed, 4 Mar 2020 16:41:28 +0100
|
||||
Subject: [PATCH] a-a-save-package-data: Use regexps to match interpreters
|
||||
|
||||
Instead of adding more and more interpreters to the list which
|
||||
gets outdated after a while, we can utilize regular expressions.
|
||||
|
||||
User will still have an option to set Interpreters in config file to
|
||||
match any other interpreters.
|
||||
|
||||
The regexes should cover interpreters:
|
||||
|
||||
Python:
|
||||
* python
|
||||
* python2
|
||||
* python2.7
|
||||
* python3
|
||||
* python3.8
|
||||
* platform-python
|
||||
* platform-python3
|
||||
* platform-python3.8
|
||||
|
||||
Perl:
|
||||
* perl
|
||||
* perl5.30.1
|
||||
|
||||
PHP:
|
||||
* php
|
||||
* php-cgi
|
||||
|
||||
R
|
||||
retrace.fedoraproject.org/faf/reports/2832480
|
||||
tcl
|
||||
retrace.fedoraproject.org/faf/reports/2555398
|
||||
|
||||
The regexes should cover interpreters:
|
||||
R:
|
||||
* R
|
||||
|
||||
tcl:
|
||||
* tclsh
|
||||
* tclsh8.6
|
||||
|
||||
Tests require will-crash and perl-interpreter installed.
|
||||
|
||||
Resolves: rhbz#1798494
|
||||
|
||||
Signed-off-by: Martin Kutlak <mkutlak@redhat.com>
|
||||
---
|
||||
src/daemon/abrt-action-save-package-data.c | 39 ++++++++-
|
||||
1 files change, 38 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/src/daemon/abrt-action-save-package-data.c b/src/daemon/abrt-action-save-package-data.c
|
||||
index 21b4c97d..6ced7971 100644
|
||||
--- a/src/daemon/abrt-action-save-package-data.c
|
||||
+++ b/src/daemon/abrt-action-save-package-data.c
|
||||
@@ -17,11 +17,47 @@
|
||||
51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
|
||||
*/
|
||||
#include <fnmatch.h>
|
||||
+#include <glib.h>
|
||||
#include "libabrt.h"
|
||||
#include "rpm.h"
|
||||
|
||||
#define GPG_CONF "gpg_keys.conf"
|
||||
|
||||
+/**
|
||||
+ "python3.4, python3.5, python3.6, python3.7, perl, perl5.16.2"
|
||||
+ * The regexes should cover interpreters with basename:
|
||||
+ * Python:
|
||||
+ * python
|
||||
+ * python2
|
||||
+ * python3
|
||||
+ * python2.7
|
||||
+ * python3.8
|
||||
+ * platform-python
|
||||
+ * platform-python3
|
||||
+ * platform-python3.8
|
||||
+ *
|
||||
+ * Perl:
|
||||
+ * perl
|
||||
+ * perl5.30.1
|
||||
+ *
|
||||
+ * PHP:
|
||||
+ * php
|
||||
+ * php-cgi
|
||||
+ *
|
||||
+ * R:
|
||||
+ * R
|
||||
+ *
|
||||
+ * tcl:
|
||||
+ * tclsh
|
||||
+ * tclsh8.6
|
||||
+ **/
|
||||
+#define DEFAULT_INTERPRETERS_REGEX \
|
||||
+ "^(perl ([[:digit:]][.][[:digit:]]+[.][[:digit:]])? |" \
|
||||
+ "php (-cgi)? |" \
|
||||
+ "(platform-)? python ([[:digit:]]([.][[:digit:]])?)? |" \
|
||||
+ "R |" \
|
||||
+ "tclsh ([[:digit:]][.][[:digit:]])?)$"
|
||||
+
|
||||
static bool settings_bOpenGPGCheck = false;
|
||||
static GList *settings_setOpenGPGPublicKeys = NULL;
|
||||
static GList *settings_setBlackListedPkgs = NULL;
|
||||
@@ -304,7 +340,8 @@ static int SavePackageDescriptionToDebugDump(const char *dump_dir_name, const ch
|
||||
/* if basename is known interpreter, we want to blame the running script
|
||||
* not the interpreter
|
||||
*/
|
||||
- if (g_list_find_custom(settings_Interpreters, basename, (GCompareFunc)g_strcmp0))
|
||||
+ if (g_regex_match_simple(DEFAULT_INTERPRETERS_REGEX, basename, G_REGEX_EXTENDED, /*MatchFlags*/0) ||
|
||||
+ g_list_find_custom(settings_Interpreters, basename, (GCompareFunc)g_strcmp0))
|
||||
{
|
||||
struct pkg_envra *script_pkg = get_script_name(cmdline, &executable, chroot);
|
||||
/* executable may have changed, check it again */
|
||||
--
|
||||
2.25.1
|
||||
|
@ -0,0 +1,42 @@
|
||||
From 11869ec9290a32c028d9d2741a7466206b635f59 Mon Sep 17 00:00:00 2001
|
||||
From: Jake Daryll Obina <jake.obina@gmail.com>
|
||||
Date: Mon, 25 Jun 2018 11:52:11 +0800
|
||||
Subject: [PATCH] harvest_vmcore: Fix missing argument error during
|
||||
delete_and_close()
|
||||
|
||||
delete_and_close() requires a directory name argument and it is being called
|
||||
without one. This argument is really not necessary though since the directory
|
||||
name is already saved in the directory object (can be queried via the directory
|
||||
object's name attribute), and it is the saved directory that is always deleted
|
||||
regardless of the argument passed in.
|
||||
|
||||
Signed-off-by: Jake Daryll Obina <jake.obina@gmail.com>
|
||||
---
|
||||
src/hooks/abrt_harvest_vmcore.py.in | 6 ++++--
|
||||
1 file changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/hooks/abrt_harvest_vmcore.py.in b/src/hooks/abrt_harvest_vmcore.py.in
|
||||
index 7d4bba52..66c3ad37 100644
|
||||
--- a/src/hooks/abrt_harvest_vmcore.py.in
|
||||
+++ b/src/hooks/abrt_harvest_vmcore.py.in
|
||||
@@ -128,13 +128,15 @@ def create_abrtd_info(dest, uuid):
|
||||
return dd
|
||||
|
||||
|
||||
-def delete_and_close(dd, dd_dirname):
|
||||
+def delete_and_close(dd):
|
||||
"""
|
||||
Deletes the given dump directory and closes it.
|
||||
|
||||
dd - dump directory object
|
||||
- dd_dirname - full path to dump directory
|
||||
"""
|
||||
+ # Save the directory name as the directory object could be destroyed during
|
||||
+ # delete().
|
||||
+ dd_dirname = dd.name
|
||||
if not dd.delete() == 0:
|
||||
sys.stderr.write("Unable to delete '%s'\n" % (dd_dirname))
|
||||
return
|
||||
--
|
||||
2.25.1
|
||||
|
26
SOURCES/0066-cli-Add-a-shebang.patch
Normal file
26
SOURCES/0066-cli-Add-a-shebang.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From 445e68861693be83023e93de072cf04caf833e57 Mon Sep 17 00:00:00 2001
|
||||
From: Martin Kutlak <mkutlak@redhat.com>
|
||||
Date: Wed, 12 Dec 2018 16:07:33 +0100
|
||||
Subject: [PATCH] cli: Add a shebang
|
||||
|
||||
Fixes a ShellCheck warning SC2148.
|
||||
|
||||
error: Tips depend on target shell and yours is unknown. Add a shebang.
|
||||
|
||||
Signed-off-by: Martin Kutlak <mkutlak@redhat.com>
|
||||
---
|
||||
src/cli/abrt-console-notification.sh | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/cli/abrt-console-notification.sh b/src/cli/abrt-console-notification.sh
|
||||
index f1a79ffb..cd69eb38 100755
|
||||
--- a/src/cli/abrt-console-notification.sh
|
||||
+++ b/src/cli/abrt-console-notification.sh
|
||||
@@ -1,3 +1,4 @@
|
||||
+#!/bin/sh
|
||||
# If shell is not connect to a terminal, return immediately, because this script
|
||||
# should print out ABRT's status and it is senseless to continue without
|
||||
# terminal.
|
||||
--
|
||||
2.26.2
|
||||
|
@ -0,0 +1,47 @@
|
||||
From 9edffdf1a4be9a2983cb69f1ebff81c805cde72f Mon Sep 17 00:00:00 2001
|
||||
From: Martin Kutlak <mkutlak@redhat.com>
|
||||
Date: Wed, 12 Dec 2018 16:09:59 +0100
|
||||
Subject: [PATCH] shellcheck: Use $(...) instead of legacy backticked
|
||||
|
||||
Fixes ShellCheck warning SC2006.
|
||||
|
||||
Signed-off-by: Martin Kutlak <mkutlak@redhat.com>
|
||||
---
|
||||
src/cli/abrt-console-notification.sh | 4 ++--
|
||||
src/plugins/abrt-action-analyze-ccpp-local.in | 2 +-
|
||||
2 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/cli/abrt-console-notification.sh b/src/cli/abrt-console-notification.sh
|
||||
index cd69eb38..c245677b 100755
|
||||
--- a/src/cli/abrt-console-notification.sh
|
||||
+++ b/src/cli/abrt-console-notification.sh
|
||||
@@ -26,11 +26,11 @@ if [ ! -f "$LPATHDIR" ]; then
|
||||
mkdir -p "$LPATHDIR" >"$ABRT_DEBUG_LOG" 2>&1 || return 0
|
||||
fi
|
||||
|
||||
-TMPPATH=`mktemp --tmpdir="$LPATHDIR" lastnotification.XXXXXXXX 2> "$ABRT_DEBUG_LOG"`
|
||||
+TMPPATH=$(mktemp --tmpdir="$LPATHDIR" lastnotification.XXXXXXXX 2> "$ABRT_DEBUG_LOG")
|
||||
|
||||
SINCE=0
|
||||
if [ -f "$SINCEFILE" ]; then
|
||||
- SINCE=`cat $SINCEFILE 2>"$ABRT_DEBUG_LOG"`
|
||||
+ SINCE=$(cat "$SINCEFILE" 2>"$ABRT_DEBUG_LOG")
|
||||
fi
|
||||
|
||||
# always update the lastnotification
|
||||
diff --git a/src/plugins/abrt-action-analyze-ccpp-local.in b/src/plugins/abrt-action-analyze-ccpp-local.in
|
||||
index 6691c59b..92593437 100644
|
||||
--- a/src/plugins/abrt-action-analyze-ccpp-local.in
|
||||
+++ b/src/plugins/abrt-action-analyze-ccpp-local.in
|
||||
@@ -15,7 +15,7 @@ if $INSTALL_DI; then
|
||||
# debuginfo install fail even for root.
|
||||
# Therefore, if we are root, we don't use the wrapper.
|
||||
EXECUTABLE=@LIBEXEC_DIR@/abrt-action-install-debuginfo-to-abrt-cache
|
||||
- if [ x"`id -u`" = x"0" ]; then
|
||||
+ if [ x"$(id -u)" = x"0" ]; then
|
||||
EXECUTABLE=abrt-action-install-debuginfo
|
||||
fi
|
||||
|
||||
--
|
||||
2.26.2
|
||||
|
@ -0,0 +1,35 @@
|
||||
From dad230792b046c711f4e491cfdbabda58862ee78 Mon Sep 17 00:00:00 2001
|
||||
From: Martin Kutlak <mkutlak@redhat.com>
|
||||
Date: Wed, 12 Dec 2018 16:12:23 +0100
|
||||
Subject: [PATCH] shellcheck: Suppress shellcheck warning SC1090
|
||||
|
||||
ShellCheck is not able to include sourced files from paths that are determined at runtime.
|
||||
The file will not be read, potentially resulting in warnings about unassigned variables and similar.
|
||||
|
||||
If you don't care that ShellCheck is unable to account for the file, specify
|
||||
"# shellcheck source=/dev/null".
|
||||
|
||||
Signed-off-by: Martin Kutlak <mkutlak@redhat.com>
|
||||
---
|
||||
src/plugins/abrt-action-analyze-ccpp-local.in | 5 +++--
|
||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/plugins/abrt-action-analyze-ccpp-local.in b/src/plugins/abrt-action-analyze-ccpp-local.in
|
||||
index 92593437..9144c0e6 100644
|
||||
--- a/src/plugins/abrt-action-analyze-ccpp-local.in
|
||||
+++ b/src/plugins/abrt-action-analyze-ccpp-local.in
|
||||
@@ -26,8 +26,9 @@ if $INSTALL_DI; then
|
||||
EXTRA_ARGS=
|
||||
for osrel in "${DUMP_DIR:-.}/os_info_in_rootdir" "${DUMP_DIR:-.}/os_info"
|
||||
do
|
||||
- if [ -e $osrel ]; then
|
||||
- . $osrel
|
||||
+ if [ -e "$osrel" ]; then
|
||||
+ # shellcheck source=/dev/null
|
||||
+ . "$osrel"
|
||||
if [ -n "$VERSION_ID" ]; then
|
||||
EXTRA_ARGS="--releasever=$VERSION_ID"
|
||||
break
|
||||
--
|
||||
2.26.2
|
||||
|
@ -0,0 +1,34 @@
|
||||
From 58d1e4fa0a0f6fc2fc3ee773665de70a073ae759 Mon Sep 17 00:00:00 2001
|
||||
From: Martin Kutlak <mkutlak@redhat.com>
|
||||
Date: Wed, 12 Dec 2018 16:16:55 +0100
|
||||
Subject: [PATCH] shellcheck: Check exit code directly with if mycmd
|
||||
|
||||
Running a command and then checking its exit status $? against 0 is redundant.
|
||||
|
||||
Fixes ShellCheck warning SC2181.
|
||||
|
||||
Signed-off-by: Martin Kutlak <mkutlak@redhat.com>
|
||||
---
|
||||
src/plugins/abrt-action-analyze-ccpp-local.in | 8 +++-----
|
||||
1 file changed, 3 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/src/plugins/abrt-action-analyze-ccpp-local.in b/src/plugins/abrt-action-analyze-ccpp-local.in
|
||||
index 9144c0e6..d2453c19 100644
|
||||
--- a/src/plugins/abrt-action-analyze-ccpp-local.in
|
||||
+++ b/src/plugins/abrt-action-analyze-ccpp-local.in
|
||||
@@ -36,9 +36,7 @@ if $INSTALL_DI; then
|
||||
fi
|
||||
done
|
||||
|
||||
- ${EXECUTABLE} ${EXTRA_ARGS} --size_mb=4096
|
||||
-fi
|
||||
-
|
||||
-if [ $? = 0 ]; then
|
||||
- abrt-action-generate-backtrace && abrt-action-analyze-backtrace
|
||||
+ if ${EXECUTABLE} "${EXTRA_ARGS}" --size_mb=4096; then
|
||||
+ abrt-action-generate-backtrace && abrt-action-analyze-backtrace
|
||||
+ fi
|
||||
fi
|
||||
--
|
||||
2.26.2
|
||||
|
33
SOURCES/0070-shellcheck-Use-command-instead-of-type.patch
Normal file
33
SOURCES/0070-shellcheck-Use-command-instead-of-type.patch
Normal file
@ -0,0 +1,33 @@
|
||||
From cbc15ea4a2be99a980a0f762c45b09055ab78527 Mon Sep 17 00:00:00 2001
|
||||
From: Martin Kutlak <mkutlak@redhat.com>
|
||||
Date: Wed, 12 Dec 2018 16:20:09 +0100
|
||||
Subject: [PATCH] shellcheck: Use command instead of type
|
||||
|
||||
type undefined in POSIX sh.
|
||||
Replacing 'command -v' is similar to the builtin 'type' and is defined in POSIX.
|
||||
|
||||
Fixes ShellCheck warning SC2039.
|
||||
|
||||
Signed-off-by: Martin Kutlak <mkutlak@redhat.com>
|
||||
---
|
||||
src/plugins/abrt-action-analyze-vulnerability.in | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/plugins/abrt-action-analyze-vulnerability.in b/src/plugins/abrt-action-analyze-vulnerability.in
|
||||
index 7532b72c..4cae52e6 100755
|
||||
--- a/src/plugins/abrt-action-analyze-vulnerability.in
|
||||
+++ b/src/plugins/abrt-action-analyze-vulnerability.in
|
||||
@@ -2,8 +2,8 @@
|
||||
|
||||
# Do we have the tools we need?
|
||||
# If no, exit silently.
|
||||
-type @GDB@ >/dev/null 2>&1 || exit 0
|
||||
-type eu-readelf >/dev/null 2>&1 || exit 0
|
||||
+command -v @GDB@ >/dev/null 2>&1 || exit 0
|
||||
+command -v eu-readelf >/dev/null 2>&1 || exit 0
|
||||
|
||||
# Do we have coredump?
|
||||
test -r coredump || {
|
||||
--
|
||||
2.26.2
|
||||
|
@ -0,0 +1,39 @@
|
||||
From 8394acb416a48cdac9a8000aa8a63736814ac71b Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Miroslav=20Such=C3=BD?= <msuchy@redhat.com>
|
||||
Date: Fri, 17 Aug 2018 16:18:21 +0200
|
||||
Subject: [PATCH] plugin "general" from sos has been split into two new plugins
|
||||
|
||||
This resolves BZ 1608444
|
||||
---
|
||||
abrt.spec.in | 1 +
|
||||
src/plugins/sosreport_event.conf | 2 +-
|
||||
2 files changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/abrt.spec.in b/abrt.spec.in
|
||||
index de54f121..65d55510 100644
|
||||
--- a/abrt.spec.in
|
||||
+++ b/abrt.spec.in
|
||||
@@ -96,6 +96,7 @@ BuildRequires: python3-humanize
|
||||
|
||||
Requires: libreport >= %{libreport_ver}
|
||||
Requires: satyr >= %{satyr_ver}
|
||||
+Requires: sos >= 3.6
|
||||
# these only exist on suse
|
||||
%if 0%{?suse_version}
|
||||
BuildRequires: dbus-1-glib-devel
|
||||
diff --git a/src/plugins/sosreport_event.conf b/src/plugins/sosreport_event.conf
|
||||
index 88ca26fe..5e366ec6 100644
|
||||
--- a/src/plugins/sosreport_event.conf
|
||||
+++ b/src/plugins/sosreport_event.conf
|
||||
@@ -7,7 +7,7 @@ EVENT=post-create remote!=1
|
||||
--only=filesys --only=hardware --only=kernel --only=libraries \
|
||||
--only=memory --only=networking --only=nfsserver --only=pam \
|
||||
--only=process --only=rpm -k rpm.rpmva=off --only=ssh \
|
||||
- --only=startup --only=yum --only=general --only=x11 \
|
||||
+ --only=startup --only=yum --only=date --only=host --only=x11 \
|
||||
--only=cups --only=logs --only=grub2 --only=cron --only=pci \
|
||||
--only=auditd --only=selinux --only=lvm2 --only=sar \
|
||||
--only=processor \
|
||||
--
|
||||
2.26.2
|
||||
|
30
SOURCES/0072-sos-use-services-instead-of-startup.patch
Normal file
30
SOURCES/0072-sos-use-services-instead-of-startup.patch
Normal file
@ -0,0 +1,30 @@
|
||||
From 0a3ea24b2158f19342fce8523aeb2e26204bbcad Mon Sep 17 00:00:00 2001
|
||||
From: Jakub Filak <jfilak@redhat.com>
|
||||
Date: Fri, 16 Oct 2015 11:39:00 +0200
|
||||
Subject: [PATCH] sos: use 'services' instead of 'startup'
|
||||
|
||||
The plugin has been renamed to 'services'.
|
||||
|
||||
Resolves: #1272005
|
||||
|
||||
Signed-off-by: Jakub Filak <jfilak@redhat.com>
|
||||
---
|
||||
src/plugins/sosreport_event.conf | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/plugins/sosreport_event.conf b/src/plugins/sosreport_event.conf
|
||||
index 5e366ec6..57eb6bcb 100644
|
||||
--- a/src/plugins/sosreport_event.conf
|
||||
+++ b/src/plugins/sosreport_event.conf
|
||||
@@ -7,7 +7,7 @@ EVENT=post-create remote!=1
|
||||
--only=filesys --only=hardware --only=kernel --only=libraries \
|
||||
--only=memory --only=networking --only=nfsserver --only=pam \
|
||||
--only=process --only=rpm -k rpm.rpmva=off --only=ssh \
|
||||
- --only=startup --only=yum --only=date --only=host --only=x11 \
|
||||
+ --only=services --only=yum --only=date --only=host --only=x11 \
|
||||
--only=cups --only=logs --only=grub2 --only=cron --only=pci \
|
||||
--only=auditd --only=selinux --only=lvm2 --only=sar \
|
||||
--only=processor \
|
||||
--
|
||||
2.26.2
|
||||
|
@ -0,0 +1,99 @@
|
||||
From 0966d7fd6e3d51fc99088de94343212c5f09e74d Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Miroslav=20Such=C3=BD?= <msuchy@redhat.com>
|
||||
Date: Tue, 5 May 2020 18:28:50 +0200
|
||||
Subject: [PATCH] setgid instead of setuid the
|
||||
abrt-action-install-debuginfo-to-abrt-cache [RHBZ 1796245]
|
||||
|
||||
OpenSCAP does not like setuid files, we can be setgid instead.
|
||||
|
||||
We need to g+w the directories so other run under a different user can be able to write there too.
|
||||
|
||||
Resolves:
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1796245
|
||||
---
|
||||
abrt.spec.in | 4 ++--
|
||||
.../abrt-action-install-debuginfo-to-abrt-cache.c | 15 +++------------
|
||||
src/plugins/abrt-action-install-debuginfo.in | 6 ++++++
|
||||
3 files changed, 11 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/abrt.spec.in b/abrt.spec.in
|
||||
index 326294008..4c01fffe6 100644
|
||||
--- a/abrt.spec.in
|
||||
+++ b/abrt.spec.in
|
||||
@@ -1015,8 +1015,8 @@ killall abrt-dbus >/dev/null 2>&1 || :
|
||||
|
||||
%dir %{_localstatedir}/lib/abrt
|
||||
|
||||
-# attr(6755) ~= SETUID|SETGID
|
||||
-%attr(6755, abrt, abrt) %{_libexecdir}/abrt-action-install-debuginfo-to-abrt-cache
|
||||
+# attr(2755) ~= SETGID
|
||||
+%attr(2755, abrt, abrt) %{_libexecdir}/abrt-action-install-debuginfo-to-abrt-cache
|
||||
|
||||
%{_bindir}/abrt-action-analyze-c
|
||||
%{_bindir}/abrt-action-trim-files
|
||||
diff --git a/src/plugins/abrt-action-install-debuginfo-to-abrt-cache.c b/src/plugins/abrt-action-install-debuginfo-to-abrt-cache.c
|
||||
index 71967f77a..0f843512e 100644
|
||||
--- a/src/plugins/abrt-action-install-debuginfo-to-abrt-cache.c
|
||||
+++ b/src/plugins/abrt-action-install-debuginfo-to-abrt-cache.c
|
||||
@@ -78,7 +78,6 @@ int main(int argc, char **argv)
|
||||
const gid_t egid = getegid();
|
||||
const gid_t rgid = getgid();
|
||||
const uid_t euid = geteuid();
|
||||
- const gid_t ruid = getuid();
|
||||
|
||||
/* We need to open the build ids file under the caller's UID/GID to avoid
|
||||
* information disclosures when reading files with changed UID.
|
||||
@@ -93,17 +92,11 @@ int main(int argc, char **argv)
|
||||
if (setregid(egid, rgid) < 0)
|
||||
perror_msg_and_die("setregid(egid, rgid)");
|
||||
|
||||
- if (setreuid(euid, ruid) < 0)
|
||||
- perror_msg_and_die("setreuid(euid, ruid)");
|
||||
-
|
||||
const int build_ids_fd = open(build_ids, O_RDONLY);
|
||||
|
||||
if (setregid(rgid, egid) < 0)
|
||||
perror_msg_and_die("setregid(rgid, egid)");
|
||||
|
||||
- if (setreuid(ruid, euid) < 0 )
|
||||
- perror_msg_and_die("setreuid(ruid, euid)");
|
||||
-
|
||||
if (build_ids_fd < 0)
|
||||
perror_msg_and_die("Failed to open file '%s'", build_ids);
|
||||
|
||||
@@ -155,12 +148,10 @@ int main(int argc, char **argv)
|
||||
*/
|
||||
/* do setregid only if we have to, to not upset selinux needlessly */
|
||||
if (egid != rgid)
|
||||
- IGNORE_RESULT(setregid(egid, egid));
|
||||
- if (euid != ruid)
|
||||
{
|
||||
- IGNORE_RESULT(setreuid(euid, euid));
|
||||
- /* We are suid'ed! */
|
||||
- /* Prevent malicious user from messing up with suid'ed process: */
|
||||
+ IGNORE_RESULT(setregid(egid, egid));
|
||||
+ /* We are sgid'ed! */
|
||||
+ /* Prevent malicious user from messing up with sgid'ed process: */
|
||||
#if 1
|
||||
// We forgot to sanitize PYTHONPATH. And who knows what else we forgot
|
||||
// (especially considering *future* new variables of this kind).
|
||||
diff --git a/src/plugins/abrt-action-install-debuginfo.in b/src/plugins/abrt-action-install-debuginfo.in
|
||||
index 6269c221e..659a9aa84 100644
|
||||
--- a/src/plugins/abrt-action-install-debuginfo.in
|
||||
+++ b/src/plugins/abrt-action-install-debuginfo.in
|
||||
@@ -248,6 +248,12 @@ if __name__ == "__main__":
|
||||
repo_pattern=repo_pattern,
|
||||
releasever=releasever)
|
||||
result = downloader.download(missing, download_exact_files=exact_fls)
|
||||
+
|
||||
+ # make sure that all downloaded directories are writeable by abrt group
|
||||
+ for root, dirs, files in os.walk(self.cachedirs[0]):
|
||||
+ for walked_dir in dirs:
|
||||
+ os.chmod(os.path.join(root, walked_dir), 0o775)
|
||||
+
|
||||
except OSError as ex:
|
||||
if ex.errno == errno.EPIPE:
|
||||
clean_up(TMPDIR, silent=True)
|
||||
--
|
||||
2.21.3
|
||||
|
28
SOURCES/0083-remove-old-transition-postscriptlet.patch
Normal file
28
SOURCES/0083-remove-old-transition-postscriptlet.patch
Normal file
@ -0,0 +1,28 @@
|
||||
From 755fef17815bf130f6b092b23a99d77bcf3963a1 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Miroslav=20Such=C3=BD?= <msuchy@redhat.com>
|
||||
Date: Wed, 13 May 2020 09:33:29 +0200
|
||||
Subject: [PATCH] remove old transition postscriptlet
|
||||
|
||||
I think that after nine years, we can safely assume everyone done this migration.
|
||||
---
|
||||
abrt.spec.in | 4 ----
|
||||
1 file changed, 4 deletions(-)
|
||||
|
||||
diff --git a/abrt.spec.in b/abrt.spec.in
|
||||
index 4c01fffe6..f8cebffe3 100644
|
||||
--- a/abrt.spec.in
|
||||
+++ b/abrt.spec.in
|
||||
@@ -694,10 +694,6 @@ exit 0
|
||||
%systemd_post abrtd.service
|
||||
|
||||
%post addon-ccpp
|
||||
-# this is required for transition from 1.1.x to 2.x
|
||||
-# because /cache/abrt-di/* was created under root with root:root
|
||||
-# so 2.x fails when it tries to extract debuginfo there..
|
||||
-chown -R abrt:abrt %{_localstatedir}/cache/abrt-di
|
||||
%systemd_post abrt-ccpp.service
|
||||
%systemd_post abrt-journal-core.service
|
||||
%journal_catalog_update
|
||||
--
|
||||
2.21.3
|
||||
|
@ -0,0 +1,33 @@
|
||||
From 62b5e536cf965843ffcd7f9db3cc2d8176c901a2 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Miroslav=20Such=C3=BD?= <msuchy@redhat.com>
|
||||
Date: Wed, 13 May 2020 09:36:32 +0200
|
||||
Subject: [PATCH] make sure that former caches are group writable
|
||||
|
||||
The files previously can be just 755. We need to be sure they are group writable.
|
||||
|
||||
Resolves:
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1796245
|
||||
---
|
||||
abrt.spec.in | 6 ++++++
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
diff --git a/abrt.spec.in b/abrt.spec.in
|
||||
index f8cebffe3..41b72071a 100644
|
||||
--- a/abrt.spec.in
|
||||
+++ b/abrt.spec.in
|
||||
@@ -695,6 +695,12 @@ exit 0
|
||||
|
||||
%post addon-ccpp
|
||||
%systemd_post abrt-ccpp.service
|
||||
+# migration from 2.14.1.18
|
||||
+if [ ! -e "%{_localstatedir}/cache/abrt-di/.migration-group-add" ]; then
|
||||
+ chmod -R g+w %{_localstatedir}/cache/abrt-di
|
||||
+ touch "%{_localstatedir}/cache/abrt-di/.migration-group-add"
|
||||
+fi
|
||||
+
|
||||
%systemd_post abrt-journal-core.service
|
||||
%journal_catalog_update
|
||||
|
||||
--
|
||||
2.21.3
|
||||
|
@ -0,0 +1,28 @@
|
||||
From 39faa81497c9b7e1b443c6aed8ddaa0f2516dc66 Mon Sep 17 00:00:00 2001
|
||||
From: Ernestas Kulik <ekulik@redhat.com>
|
||||
Date: Thu, 4 Jun 2020 12:53:13 +0200
|
||||
Subject: [PATCH] abrt-action-install-debuginfo: Fix variable reference
|
||||
|
||||
The code in cc79333dcd3fea7701ebbf97fb0919fbad90f3f0 was initially
|
||||
intended for libreport, but a thinko was introduced when it was moved
|
||||
over.
|
||||
---
|
||||
src/plugins/abrt-action-install-debuginfo.in | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/plugins/abrt-action-install-debuginfo.in b/src/plugins/abrt-action-install-debuginfo.in
|
||||
index 659a9aa84..3a46233b7 100644
|
||||
--- a/src/plugins/abrt-action-install-debuginfo.in
|
||||
+++ b/src/plugins/abrt-action-install-debuginfo.in
|
||||
@@ -250,7 +250,7 @@ if __name__ == "__main__":
|
||||
result = downloader.download(missing, download_exact_files=exact_fls)
|
||||
|
||||
# make sure that all downloaded directories are writeable by abrt group
|
||||
- for root, dirs, files in os.walk(self.cachedirs[0]):
|
||||
+ for root, dirs, files in os.walk(config.cachedirs[0]):
|
||||
for walked_dir in dirs:
|
||||
os.chmod(os.path.join(root, walked_dir), 0o775)
|
||||
|
||||
--
|
||||
2.21.3
|
||||
|
@ -0,0 +1,33 @@
|
||||
From 077bd3543fc233defb7018ea7d8bcf9aea7fa955 Mon Sep 17 00:00:00 2001
|
||||
From: Ernestas Kulik <ekulik@redhat.com>
|
||||
Date: Tue, 30 Jun 2020 14:19:07 +0200
|
||||
Subject: [PATCH] plugins: sosreport_event: Rename nfsserver plugin
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
See
|
||||
https://github.com/sosreport/sos/commit/fad72dbacc7e5c3c2721e452823750974ea31550.
|
||||
|
||||
The sosreport devs don’t give a shit about anything, so here we are,
|
||||
cleaning up their messes at the last minute.
|
||||
---
|
||||
src/plugins/sosreport_event.conf | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/plugins/sosreport_event.conf b/src/plugins/sosreport_event.conf
|
||||
index 57eb6bcb..4a4a29cd 100644
|
||||
--- a/src/plugins/sosreport_event.conf
|
||||
+++ b/src/plugins/sosreport_event.conf
|
||||
@@ -5,7 +5,7 @@ EVENT=post-create remote!=1
|
||||
nice sosreport --tmp-dir "$DUMP_DIR" --batch \
|
||||
--only=anaconda --only=boot --only=devicemapper \
|
||||
--only=filesys --only=hardware --only=kernel --only=libraries \
|
||||
- --only=memory --only=networking --only=nfsserver --only=pam \
|
||||
+ --only=memory --only=networking --only=nfs --only=pam \
|
||||
--only=process --only=rpm -k rpm.rpmva=off --only=ssh \
|
||||
--only=services --only=yum --only=date --only=host --only=x11 \
|
||||
--only=cups --only=logs --only=grub2 --only=cron --only=pci \
|
||||
--
|
||||
2.26.2
|
||||
|
@ -55,7 +55,7 @@
|
||||
Summary: Automatic bug detection and reporting tool
|
||||
Name: abrt
|
||||
Version: 2.10.9
|
||||
Release: 11%{?dist}
|
||||
Release: 19%{?dist}
|
||||
License: GPLv2+
|
||||
URL: https://abrt.readthedocs.org/
|
||||
Source: https://github.com/abrt/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||
@ -121,6 +121,40 @@ Patch0028: 0028-cli-get-list-of-possible-workflows-for-problem_data_.patch
|
||||
#Patch055: 0055-dumpoops-remove-sed-of-file-not-existing-and-not-nee.patch
|
||||
Patch056: 0056-a-a-list-dsos-Fix-decoding-of-strings-from-rpm.patch
|
||||
#git format-patch 2.10.9-11.el8 -N --start-number 57 --topo-order
|
||||
Patch057: 0057-a-a-save-package-data-Use-regexps-to-match-interpret.patch
|
||||
Patch058: 0058-harvest_vmcore-Fix-missing-argument-error-during-del.patch
|
||||
#git format-patch 2.10.9-12.el8 -N --start-number 59 --topo-order
|
||||
#Patch059: 0059-abrtd-infinite-event-loop-remove-unnecesary-from-REs.patch
|
||||
#Patch060: 0060-spec-Revert-libreport-dependency-change.patch
|
||||
#Patch061: 0061-Revert-spec-Revert-libreport-dependency-change.patch
|
||||
#Patch062: 0062-spec-Revert-libreport-dependency-change.patch
|
||||
#Patch063: 0063-spec-Don-t-build-with-RHTS-bits-on-CentOS.patch
|
||||
#Patch064: 0064-dont-blame-interpret-Rename-and-redo.patch
|
||||
#Patch065: 0065-tests-aux-lib-Add-remove_problem_directory.patch
|
||||
Patch066: 0066-cli-Add-a-shebang.patch
|
||||
Patch067: 0067-shellcheck-Use-.-instead-of-legacy-backticked.patch
|
||||
Patch068: 0068-shellcheck-Suppress-shellcheck-warning-SC1090.patch
|
||||
Patch069: 0069-shellcheck-Check-exit-code-directly-with-if-mycmd.patch
|
||||
Patch070: 0070-shellcheck-Use-command-instead-of-type.patch
|
||||
#git format-patch 2.10.9-13.el8 --no-numbered --start-number=71 --topo-order
|
||||
Patch071: 0071-plugin-general-from-sos-has-been-split-into-two-new-.patch
|
||||
#git format-patch 2.10.9-14.el8 --no-numbered --start-number=72 --topo-order
|
||||
Patch072: 0072-sos-use-services-instead-of-startup.patch
|
||||
#git format-patch 2.10.9-16.el8 --no-numbered --start-number=73 --topo-order
|
||||
#Patch0073: 0073-setgid-instead-of-setuid-the-abrt-action-install-deb.patch
|
||||
#Patch0074: 0074-remove-old-transition-postscriptlet.patch
|
||||
#Patch0075: 0075-make-sure-that-former-caches-are-group-writable.patch
|
||||
#Patch0076: 0076-abrt-action-install-debuginfo-Fix-variable-reference.patch
|
||||
#Patch0077: 0077-Revert-abrt-action-install-debuginfo-Fix-variable-re.patch
|
||||
#Patch0078: 0078-Revert-make-sure-that-former-caches-are-group-writab.patch
|
||||
#Patch0079: 0079-Revert-remove-old-transition-postscriptlet.patch
|
||||
#Patch0080: 0080-Revert-setgid-instead-of-setuid-the-abrt-action-inst.patch
|
||||
#Patch0081: 0081-Revert-a-a-install-debuginfo-Clean-cache-if-we-need-.patch
|
||||
Patch0082: 0082-setgid-instead-of-setuid-the-abrt-action-install-deb.patch
|
||||
Patch0083: 0083-remove-old-transition-postscriptlet.patch
|
||||
Patch0084: 0084-make-sure-that-former-caches-are-group-writable.patch
|
||||
Patch0085: 0085-abrt-action-install-debuginfo-Fix-variable-reference.patch
|
||||
Patch0086: 0086-plugins-sosreport_event-Rename-nfsserver-plugin.patch
|
||||
|
||||
# autogen.sh is need to regenerate all the Makefile files
|
||||
Patch1000: 1000-Add-autogen.sh.patch
|
||||
@ -779,11 +813,13 @@ exit 0
|
||||
%systemd_post abrtd.service
|
||||
|
||||
%post addon-ccpp
|
||||
# this is required for transition from 1.1.x to 2.x
|
||||
# because /cache/abrt-di/* was created under root with root:root
|
||||
# so 2.x fails when it tries to extract debuginfo there..
|
||||
chown -R abrt:abrt %{_localstatedir}/cache/abrt-di
|
||||
%systemd_post abrt-ccpp.service
|
||||
# migration from 2.14.1.18
|
||||
if [ ! -e "%{_localstatedir}/cache/abrt-di/.migration-group-add" ]; then
|
||||
chmod -R g+w %{_localstatedir}/cache/abrt-di
|
||||
touch "%{_localstatedir}/cache/abrt-di/.migration-group-add"
|
||||
fi
|
||||
|
||||
%systemd_post abrt-journal-core.service
|
||||
%journal_catalog_update
|
||||
|
||||
@ -1011,7 +1047,7 @@ killall abrt-dbus >/dev/null 2>&1 || :
|
||||
%dir %attr(0751, root, abrt) %{_localstatedir}/%{var_base_dir}/%{name}
|
||||
%dir %attr(0700, abrt, abrt) %{_localstatedir}/spool/%{name}-upload
|
||||
# abrtd runs as root
|
||||
%dir %attr(0755, root, root) %{_localstatedir}/run/%{name}
|
||||
%ghost %dir %attr(0755, root, root) %{_localstatedir}/run/%{name}
|
||||
%ghost %attr(0666, -, -) %{_localstatedir}/run/%{name}/abrt.socket
|
||||
%ghost %attr(0644, -, -) %{_localstatedir}/run/%{name}/abrtd.pid
|
||||
|
||||
@ -1092,8 +1128,8 @@ killall abrt-dbus >/dev/null 2>&1 || :
|
||||
|
||||
%dir %{_localstatedir}/lib/abrt
|
||||
|
||||
# attr(6755) ~= SETUID|SETGID
|
||||
%attr(6755, abrt, abrt) %{_libexecdir}/abrt-action-install-debuginfo-to-abrt-cache
|
||||
# attr(2755) ~= SETGID
|
||||
%attr(2755, abrt, abrt) %{_libexecdir}/abrt-action-install-debuginfo-to-abrt-cache
|
||||
|
||||
%{_bindir}/abrt-action-analyze-c
|
||||
%{_bindir}/abrt-action-trim-files
|
||||
@ -1337,6 +1373,37 @@ killall abrt-dbus >/dev/null 2>&1 || :
|
||||
%config(noreplace) %{_sysconfdir}/profile.d/abrt-console-notification.sh
|
||||
|
||||
%changelog
|
||||
* Tue Jun 30 2020 - Ernestas Kulik <ekulik@redhat.com> - 2.10.9-19
|
||||
- Add another patch for #1846272
|
||||
|
||||
* Mon Jun 29 2020 - Michal Židek <mzidek@redhat.com> - 2.10.9-18
|
||||
- Resolves: rhbz#1835388
|
||||
- This is seccond commit to fix som mess with one missing patch and synchronize
|
||||
the internal gitlab patch numbers with this spec file
|
||||
|
||||
* Wed Jun 24 2020 - Michal Židek <mzidek@redhat.com> - 2.10.9-17
|
||||
- Resolves: rhbz#1835388
|
||||
|
||||
* Mon Jun 22 2020 - Ernestas Kulik <ekulik@redhat.com> - 2.10.9-16
|
||||
- Add another patch for #1846272
|
||||
|
||||
* Thu Jun 11 2020 Ernestas Kulik <ekulik@redhat.com> - 2.10.9-15
|
||||
- Remove unintended line change in abrt_event.conf
|
||||
|
||||
* Thu Jun 11 2020 Ernestas Kulik <ekulik@redhat.com> - 2.10.9-14
|
||||
- Add patch for #1846272
|
||||
|
||||
* Wed Jun 10 2020 Michal Židek <mzidek@redhat.com> - 2.10.9-13
|
||||
- Resolves: rhbz#1658685
|
||||
- shellcheck: Use command instead of type
|
||||
- shellcheck: Check exit code directly with if mycmd
|
||||
- shellcheck: Suppress shellcheck warning SC1090
|
||||
- shellcheck: Use $(...) instead of legacy backticked
|
||||
- cli: Add a shebang
|
||||
|
||||
* Wed Mar 11 2020 Ernestas Kulik <ekulik@redhat.com> - 2.10.9-12
|
||||
- Fix #1798494, #1805728, #1809949
|
||||
|
||||
* Tue Jul 16 2019 Michal Fabik <mfabik@redhat.com> - 2.10.9-11
|
||||
- a-a-list-dsos: Fix decoding of strings from rpm
|
||||
Resolves: rhbz#1694970
|
||||
|
Loading…
Reference in New Issue
Block a user