Update to 0.0.3
This commit is contained in:
parent
88a9062eb8
commit
e47057d788
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
/cantarell-fonts-0.0.1.tar.bz2
|
||||
/cantarell-fonts-0.0.3.tar.bz2
|
||||
|
@ -7,8 +7,8 @@
|
||||
%global archivename2 Cantarell-Regular
|
||||
|
||||
Name: %{fontname}-fonts
|
||||
Version: 0.0.1
|
||||
Release: 4%{?dist}
|
||||
Version: 0.0.3
|
||||
Release: 1%{?dist}
|
||||
Summary: Cantarell, a Humanist sans-serif font family
|
||||
|
||||
Group: User Interface/X
|
||||
@ -20,11 +20,8 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildArch: noarch
|
||||
BuildRequires: fontpackages-devel
|
||||
BuildRequires: fontforge
|
||||
BuildRequires: autoconf automake libtool
|
||||
Requires: fontpackages-filesystem
|
||||
|
||||
Patch1: cantarell-fontconfig.patch
|
||||
|
||||
%description
|
||||
Cantarell is a set of fonts designed by Dave Crossland. It is a
|
||||
sans-serif humanist typeface family.
|
||||
@ -32,12 +29,8 @@ sans-serif humanist typeface family.
|
||||
%prep
|
||||
%setup -q -n %{actualname}-fonts-%{version}
|
||||
|
||||
%patch1 -p1 -b .fontconfig
|
||||
|
||||
%build
|
||||
|
||||
autoreconf -f -i
|
||||
|
||||
%configure
|
||||
make %{?_smp_mflags}
|
||||
fontforge -lang=ff -c 'Open($1); Generate($2);' ./src/%{archivename1}.sfd %{archivename1}.otf
|
||||
@ -61,6 +54,9 @@ ln -s %{_fontconfig_templatedir}/%{fontconf} \
|
||||
rm -rf %{buildroot}
|
||||
|
||||
%changelog
|
||||
* Mon Feb 21 2011 Cosimo Cecchi <cosimoc@redhat.com> - 0.0.3-1
|
||||
- Update to 0.0.3
|
||||
|
||||
* Fri Feb 18 2011 Cosimo Cecchi <cosimoc@redhat.com> - 0.0.1-4
|
||||
- Include upstream patch for the fontconfig snippet
|
||||
|
||||
|
@ -1,65 +0,0 @@
|
||||
diff --git a/fontconfig/31-cantarell.conf b/fontconfig/31-cantarell.conf
|
||||
new file mode 100644
|
||||
index 0000000..2b3ab09
|
||||
--- /dev/null
|
||||
+++ b/fontconfig/31-cantarell.conf
|
||||
@@ -0,0 +1,18 @@
|
||||
+<?xml version="1.0" encoding="UTF-8"?>
|
||||
+<!DOCTYPE fontconfig SYSTEM "../fonts.dtd">
|
||||
+<!--
|
||||
+
|
||||
+ Define aliasing and other fontconfig settings for Cantarell.
|
||||
+
|
||||
+-->
|
||||
+<fontconfig>
|
||||
+ <!-- Generic name assignment -->
|
||||
+ <match target="pattern">
|
||||
+ <test qual="any" name="family">
|
||||
+ <string>Cantarell</string>
|
||||
+ </test>
|
||||
+ <edit name="family" mode="assign" binding="weak">
|
||||
+ <string>Cantarell</string>
|
||||
+ </edit>
|
||||
+ </match>
|
||||
+</fontconfig>
|
||||
diff --git a/fontconfig/57-cantarell.conf b/fontconfig/57-cantarell.conf
|
||||
deleted file mode 100644
|
||||
index 03efec1..0000000
|
||||
--- a/fontconfig/57-cantarell.conf
|
||||
+++ /dev/null
|
||||
@@ -1,23 +0,0 @@
|
||||
-<?xml version="1.0" encoding="UTF-8"?>
|
||||
-<!DOCTYPE fontconfig SYSTEM "../fonts.dtd">
|
||||
-<!--
|
||||
-
|
||||
- Define aliasing and other fontconfig settings for Cantarell.
|
||||
-
|
||||
--->
|
||||
-<fontconfig>
|
||||
- <!-- Generic name assignment -->
|
||||
- <alias>
|
||||
- <family>Cantarell</family>
|
||||
- <default>
|
||||
- <family>sans-serif</family>
|
||||
- </default>
|
||||
- </alias>
|
||||
- <!-- Generic name aliasing -->
|
||||
- <alias>
|
||||
- <family>sans-serif</family>
|
||||
- <prefer>
|
||||
- <family>Cantarell</family>
|
||||
- </prefer>
|
||||
- </alias>
|
||||
-</fontconfig>
|
||||
diff --git a/fontconfig/Makefile.am b/fontconfig/Makefile.am
|
||||
index 335a682..a6fb360 100644
|
||||
--- a/fontconfig/Makefile.am
|
||||
+++ b/fontconfig/Makefile.am
|
||||
@@ -1,6 +1,6 @@
|
||||
configdir = $(datadir)/fontconfig/conf.avail/
|
||||
config_DATA = \
|
||||
- 57-cantarell.conf
|
||||
+ 31-cantarell.conf
|
||||
|
||||
EXTRA_DIST = $(config_DATA)
|
||||
|
Loading…
Reference in New Issue
Block a user