Upstream patch for using the right fontconfig rules
This commit is contained in:
parent
ee0dee171f
commit
cafc08a7f1
@ -1,14 +1,14 @@
|
|||||||
%global actualname cantarell
|
%global actualname cantarell
|
||||||
|
|
||||||
%global fontname abattis-%{actualname}
|
%global fontname abattis-%{actualname}
|
||||||
%global fontconf 57-cantarell.conf
|
%global fontconf 31-cantarell.conf
|
||||||
|
|
||||||
%global archivename1 Cantarell-Bold
|
%global archivename1 Cantarell-Bold
|
||||||
%global archivename2 Cantarell-Regular
|
%global archivename2 Cantarell-Regular
|
||||||
|
|
||||||
Name: %{fontname}-fonts
|
Name: %{fontname}-fonts
|
||||||
Version: 0.0.1
|
Version: 0.0.1
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: Cantarell, a Humanist sans-serif font family
|
Summary: Cantarell, a Humanist sans-serif font family
|
||||||
|
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
@ -22,6 +22,8 @@ BuildRequires: fontpackages-devel
|
|||||||
BuildRequires: fontforge
|
BuildRequires: fontforge
|
||||||
Requires: fontpackages-filesystem
|
Requires: fontpackages-filesystem
|
||||||
|
|
||||||
|
Patch1: cantarell-fontconfig.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Cantarell is a set of fonts designed by Dave Crossland. It is a
|
Cantarell is a set of fonts designed by Dave Crossland. It is a
|
||||||
sans-serif humanist typeface family.
|
sans-serif humanist typeface family.
|
||||||
@ -29,6 +31,8 @@ sans-serif humanist typeface family.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n %{actualname}-fonts-%{version}
|
%setup -q -n %{actualname}-fonts-%{version}
|
||||||
|
|
||||||
|
%patch1 -p1 -b .fontconfig
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
@ -53,6 +57,9 @@ ln -s %{_fontconfig_templatedir}/%{fontconf} \
|
|||||||
rm -rf %{buildroot}
|
rm -rf %{buildroot}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 18 2011 Cosimo Cecchi <cosimoc@redhat.com> - 0.0.1-4
|
||||||
|
- Include upstream patch for the fontconfig snippet
|
||||||
|
|
||||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.1-3
|
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.1-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
65
cantarell-fontconfig.patch
Normal file
65
cantarell-fontconfig.patch
Normal file
@ -0,0 +1,65 @@
|
|||||||
|
diff --git a/fontconfig/31-cantarell.conf b/fontconfig/31-cantarell.conf
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..2b3ab09
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/fontconfig/31-cantarell.conf
|
||||||
|
@@ -0,0 +1,18 @@
|
||||||
|
+<?xml version="1.0" encoding="UTF-8"?>
|
||||||
|
+<!DOCTYPE fontconfig SYSTEM "../fonts.dtd">
|
||||||
|
+<!--
|
||||||
|
+
|
||||||
|
+ Define aliasing and other fontconfig settings for Cantarell.
|
||||||
|
+
|
||||||
|
+-->
|
||||||
|
+<fontconfig>
|
||||||
|
+ <!-- Generic name assignment -->
|
||||||
|
+ <match target="pattern">
|
||||||
|
+ <test qual="any" name="family">
|
||||||
|
+ <string>Cantarell</string>
|
||||||
|
+ </test>
|
||||||
|
+ <edit name="family" mode="assign" binding="weak">
|
||||||
|
+ <string>Cantarell</string>
|
||||||
|
+ </edit>
|
||||||
|
+ </match>
|
||||||
|
+</fontconfig>
|
||||||
|
diff --git a/fontconfig/57-cantarell.conf b/fontconfig/57-cantarell.conf
|
||||||
|
deleted file mode 100644
|
||||||
|
index 03efec1..0000000
|
||||||
|
--- a/fontconfig/57-cantarell.conf
|
||||||
|
+++ /dev/null
|
||||||
|
@@ -1,23 +0,0 @@
|
||||||
|
-<?xml version="1.0" encoding="UTF-8"?>
|
||||||
|
-<!DOCTYPE fontconfig SYSTEM "../fonts.dtd">
|
||||||
|
-<!--
|
||||||
|
-
|
||||||
|
- Define aliasing and other fontconfig settings for Cantarell.
|
||||||
|
-
|
||||||
|
--->
|
||||||
|
-<fontconfig>
|
||||||
|
- <!-- Generic name assignment -->
|
||||||
|
- <alias>
|
||||||
|
- <family>Cantarell</family>
|
||||||
|
- <default>
|
||||||
|
- <family>sans-serif</family>
|
||||||
|
- </default>
|
||||||
|
- </alias>
|
||||||
|
- <!-- Generic name aliasing -->
|
||||||
|
- <alias>
|
||||||
|
- <family>sans-serif</family>
|
||||||
|
- <prefer>
|
||||||
|
- <family>Cantarell</family>
|
||||||
|
- </prefer>
|
||||||
|
- </alias>
|
||||||
|
-</fontconfig>
|
||||||
|
diff --git a/fontconfig/Makefile.am b/fontconfig/Makefile.am
|
||||||
|
index 335a682..a6fb360 100644
|
||||||
|
--- a/fontconfig/Makefile.am
|
||||||
|
+++ b/fontconfig/Makefile.am
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
configdir = $(datadir)/fontconfig/conf.avail/
|
||||||
|
config_DATA = \
|
||||||
|
- 57-cantarell.conf
|
||||||
|
+ 31-cantarell.conf
|
||||||
|
|
||||||
|
EXTRA_DIST = $(config_DATA)
|
||||||
|
|
Loading…
Reference in New Issue
Block a user