import aardvark-dns-1.1.0-4.el8

This commit is contained in:
CentOS Sources 2022-09-27 06:57:24 -04:00 committed by Stepan Oksanichenko
commit fa2720ff29
4 changed files with 95 additions and 0 deletions

2
.aardvark-dns.metadata Normal file
View File

@ -0,0 +1,2 @@
bb8ff7cbd83800f0043d7320a70f20d1cbde8a1a SOURCES/aardvark-dns-v1.1.0-vendor.tar.gz
9971b328f307ecf11ba8a42c0988219565aa135a SOURCES/v1.1.0.tar.gz

2
.gitignore vendored Normal file
View File

@ -0,0 +1,2 @@
SOURCES/aardvark-dns-v1.1.0-vendor.tar.gz
SOURCES/v1.1.0.tar.gz

26
SOURCES/201.patch Normal file
View File

@ -0,0 +1,26 @@
From a34a32a9faea832f378f67d5121f430d0b96a925 Mon Sep 17 00:00:00 2001
From: Aditya R <arajan@redhat.com>
Date: Tue, 23 Aug 2022 22:23:48 +0530
Subject: [PATCH] makefile: remove windows specific libaries from vendor
Modify `vendor-rm-windows` to remove windows specific libaries from
vendor directory
Signed-off-by: Aditya R <arajan@redhat.com>
---
Makefile | 2 ++
1 file changed, 2 insertions(+)
diff --git a/Makefile b/Makefile
index 411203a..75ba52d 100644
--- a/Makefile
+++ b/Makefile
@@ -109,6 +109,8 @@ vendor: ## vendor everything into vendor/
vendor-rm-windows:
if [ -d "vendor/winapi" ]; then \
rm -fr vendor/winapi*gnu*/lib/*.a; \
+ rm -fr vendor/windows*/lib/*.a; \
+ rm -fr vendor/windows*/lib/*.lib; \
fi
.PHONY: vendor-tarball

65
SPECS/aardvark-dns.spec Normal file
View File

@ -0,0 +1,65 @@
# debuginfo doesn't work yet
%global debug_package %{nil}
Epoch: 2
Name: aardvark-dns
Version: 1.1.0
License: ASL 2.0 and BSD and MIT
Release: 4%{?dist}
ExclusiveArch: %{rust_arches}
Summary: Authoritative DNS server for A/AAAA container records
URL: https://github.com/containers/aardvark-dns
Patch0: https://patch-diff.githubusercontent.com/raw/containers/aardvark-dns/pull/201.patch
Source0: %{url}/archive/v%{version}.tar.gz
Source1: %{url}/releases/download/v%{version}/%{name}-v%{version}-vendor.tar.gz
BuildRequires: cargo
BuildRequires: git-core
BuildRequires: make
BuildRequires: rust-srpm-macros
%description
%{summary}
Forwards other request to configured resolvers.
Read more about configuration in `src/backend/mod.rs`.
%prep
%autosetup -Sgit
tar fx %{SOURCE1}
mkdir -p .cargo
cat >.cargo/config << EOF
[source.crates-io]
replace-with = "vendored-sources"
[source.vendored-sources]
directory = "vendor"
EOF
%build
%{__make} build
%install
%{__make} DESTDIR=%{buildroot} PREFIX=%{_prefix} install
%files
%license LICENSE
%dir %{_libexecdir}/podman
%{_libexecdir}/podman/%{name}
%changelog
* Wed Aug 24 2022 Jindrich Novy <jnovy@redhat.com> - 2:1.1.0-4
- remove windows binaries and regenerate vendor tarball
- Related: #2061390
* Tue Aug 09 2022 Jindrich Novy <jnovy@redhat.com> - 2:1.1.0-3
- add gating.yaml
- Related: #2061390
* Thu Aug 04 2022 Jindrich Novy <jnovy@redhat.com> - 2:1.1.0-2
- bump Epoch to preserve upgrade path
- Related: #2061390
* Wed Aug 3 2022 Jindrich Novy <jnovy@redhat.com> 1.1.0-1
- initial import
- Related: #2061390