import WALinuxAgent-2.3.0.2-3.el9
This commit is contained in:
commit
ff541f0453
1
.WALinuxAgent.metadata
Normal file
1
.WALinuxAgent.metadata
Normal file
@ -0,0 +1 @@
|
||||
de1d5307a1fc937038536b27d1e32f7ee851d0dd SOURCES/v2.3.0.2.tar.gz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/v2.3.0.2.tar.gz
|
48
SOURCES/0002-Fix-distro-resolution-for-RedHat-2083.patch
Normal file
48
SOURCES/0002-Fix-distro-resolution-for-RedHat-2083.patch
Normal file
@ -0,0 +1,48 @@
|
||||
From 7289e616a836fe0f1c97388f40e5d4916804ae91 Mon Sep 17 00:00:00 2001
|
||||
From: Paula Gombar <gombarica@gmail.com>
|
||||
Date: Wed, 2 Dec 2020 21:36:41 -0800
|
||||
Subject: Fix distro resolution for RedHat (#2083)
|
||||
|
||||
vkuznets: cherry-picking the primary change of the commit (adding 'rhel')
|
||||
only, pylint changes require additional commits.
|
||||
|
||||
Signed-off-by: Vitaly Kuznetsov <vkuznets@redhat.com>
|
||||
---
|
||||
tests/common/osutil/test_factory.py | 14 ++++++++++++++
|
||||
1 file changed, 14 insertions(+)
|
||||
|
||||
diff --git a/tests/common/osutil/test_factory.py b/tests/common/osutil/test_factory.py
|
||||
index f7d46b21..c48dd17f 100644
|
||||
--- a/tests/common/osutil/test_factory.py
|
||||
+++ b/tests/common/osutil/test_factory.py
|
||||
@@ -195,6 +195,13 @@ class TestOsUtilFactory(AgentTestCase):
|
||||
self.assertTrue(isinstance(ret, Redhat6xOSUtil))
|
||||
self.assertEqual(ret.get_service_name(), "waagent")
|
||||
|
||||
+ ret = _get_osutil(distro_name="rhel",
|
||||
+ distro_code_name="",
|
||||
+ distro_full_name="",
|
||||
+ distro_version="6")
|
||||
+ self.assertTrue(type(ret) == Redhat6xOSUtil)
|
||||
+ self.assertEquals(ret.get_service_name(), "waagent")
|
||||
+
|
||||
ret = _get_osutil(distro_name="centos",
|
||||
distro_code_name="",
|
||||
distro_full_name="",
|
||||
@@ -223,6 +230,13 @@ class TestOsUtilFactory(AgentTestCase):
|
||||
self.assertTrue(isinstance(ret, RedhatOSUtil))
|
||||
self.assertEqual(ret.get_service_name(), "waagent")
|
||||
|
||||
+ ret = _get_osutil(distro_name="rhel",
|
||||
+ distro_code_name="",
|
||||
+ distro_full_name="",
|
||||
+ distro_version="7")
|
||||
+ self.assertTrue(type(ret) == RedhatOSUtil)
|
||||
+ self.assertEquals(ret.get_service_name(), "waagent")
|
||||
+
|
||||
ret = _get_osutil(distro_name="centos",
|
||||
distro_code_name="",
|
||||
distro_full_name="",
|
||||
--
|
||||
2.27.0
|
||||
|
16
SOURCES/module-setup.sh
Normal file
16
SOURCES/module-setup.sh
Normal file
@ -0,0 +1,16 @@
|
||||
#!/usr/bin/bash
|
||||
|
||||
# called by dracut
|
||||
check() {
|
||||
return 0
|
||||
}
|
||||
|
||||
# called by dracut
|
||||
depends() {
|
||||
return 0
|
||||
}
|
||||
|
||||
# called by dracut
|
||||
install() {
|
||||
inst_rules 66-azure-storage.rules 99-azure-product-uuid.rules
|
||||
}
|
256
SPECS/WALinuxAgent.spec
Normal file
256
SPECS/WALinuxAgent.spec
Normal file
@ -0,0 +1,256 @@
|
||||
%global with_legacy 0
|
||||
%global dracut_modname 97walinuxagent
|
||||
|
||||
Name: WALinuxAgent
|
||||
Version: 2.3.0.2
|
||||
Release: 3%{?dist}
|
||||
Summary: The Microsoft Azure Linux Agent
|
||||
|
||||
License: ASL 2.0
|
||||
URL: https://github.com/Azure/%{name}
|
||||
Source0: https://github.com/Azure/%{name}/archive/v%{version}.tar.gz
|
||||
Source1: module-setup.sh
|
||||
|
||||
# Python3.9 fixes
|
||||
Patch0002: 0002-Fix-distro-resolution-for-RedHat-2083.patch
|
||||
# Source-git patches
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: python3-setuptools
|
||||
BuildRequires: python3-distro
|
||||
Requires: %name-udev = %version-%release
|
||||
%if 0%{?fedora}
|
||||
Requires: ntfsprogs
|
||||
%endif
|
||||
Requires: openssh
|
||||
Requires: openssh-server
|
||||
Requires: openssl
|
||||
Requires: parted
|
||||
Requires: python3-pyasn1
|
||||
Requires: iptables
|
||||
|
||||
BuildRequires: systemd
|
||||
Requires(post): systemd
|
||||
Requires(preun): systemd
|
||||
Requires(postun): systemd
|
||||
|
||||
%description
|
||||
The Microsoft Azure Linux Agent supports the provisioning and running of Linux
|
||||
VMs in the Microsoft Azure cloud. This package should be installed on Linux disk
|
||||
images that are built to run in the Microsoft Azure environment.
|
||||
|
||||
%if 0%{?with_legacy}
|
||||
%package legacy
|
||||
Summary: The Microsoft Azure Linux Agent (legacy)
|
||||
Requires: %name = %version-%release
|
||||
Requires: python2
|
||||
Requires: net-tools
|
||||
|
||||
%description legacy
|
||||
The Microsoft Azure Linux Agent supporting old version of extensions.
|
||||
%endif
|
||||
|
||||
%package udev
|
||||
Summary: Udev rules for Microsoft Azure
|
||||
|
||||
%description udev
|
||||
Udev rules specific to Microsoft Azure Virtual Machines.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0002 -p1
|
||||
# Apply source-git patches
|
||||
|
||||
%build
|
||||
%py3_build
|
||||
|
||||
%install
|
||||
%{__python3} setup.py install -O1 --skip-build --root %{buildroot} --lnx-distro redhat
|
||||
|
||||
mkdir -p -m 0700 %{buildroot}%{_sharedstatedir}/waagent
|
||||
mkdir -p %{buildroot}%{_localstatedir}/log
|
||||
touch %{buildroot}%{_localstatedir}/log/waagent.log
|
||||
|
||||
mkdir -p %{buildroot}%{_udevrulesdir}
|
||||
mv %{buildroot}%{_sysconfdir}/udev/rules.d/*.rules %{buildroot}%{_udevrulesdir}/
|
||||
|
||||
rm -rf %{buildroot}/%{python3_sitelib}/tests
|
||||
rm -rf %{buildroot}/%{python3_sitelib}/__main__.py
|
||||
rm -rf %{buildroot}/%{python3_sitelib}/__pycache__/__main__*.py*
|
||||
|
||||
sed -i 's,#!/usr/bin/env python,#!/usr/bin/python3,' %{buildroot}%{_sbindir}/waagent
|
||||
%if 0%{?with_legacy}
|
||||
sed -i 's,#!/usr/bin/env python,#!/usr/bin/python2,' %{buildroot}%{_sbindir}/waagent2.0
|
||||
%else
|
||||
rm -f %{buildroot}%{_sbindir}/waagent2.0
|
||||
%endif
|
||||
sed -i 's,/usr/bin/python ,/usr/bin/python3 ,' %{buildroot}%{_unitdir}/waagent.service
|
||||
|
||||
mv %{buildroot}%{_sysconfdir}/logrotate.d/waagent.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
|
||||
|
||||
install -m0755 -D -t %{buildroot}%{_prefix}/lib/dracut/modules.d/%{dracut_modname}/ %{SOURCE1}
|
||||
|
||||
%post
|
||||
%systemd_post waagent.service
|
||||
|
||||
%preun
|
||||
%systemd_preun waagent.service
|
||||
|
||||
%postun
|
||||
%systemd_postun_with_restart waagent.service
|
||||
|
||||
%files
|
||||
%doc LICENSE.txt NOTICE README.md
|
||||
%ghost %{_localstatedir}/log/waagent.log
|
||||
%dir %attr(0700, root, root) %{_sharedstatedir}/waagent
|
||||
%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
|
||||
%{_sbindir}/waagent
|
||||
%config(noreplace) %{_sysconfdir}/waagent.conf
|
||||
%{_unitdir}/waagent.service
|
||||
%{python3_sitelib}/azurelinuxagent
|
||||
%{python3_sitelib}/*.egg-info
|
||||
|
||||
%files udev
|
||||
%{_udevrulesdir}/*.rules
|
||||
%{_prefix}/lib/dracut/modules.d/%{dracut_modname}/*.sh
|
||||
|
||||
%if 0%{?with_legacy}
|
||||
%files legacy
|
||||
%{_sbindir}/waagent2.0
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 2.3.0.2-3
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Sun Jul 25 2021 Miroslav Rezanina <mrezanin@redhat.com> - 2.3.0.2-2
|
||||
- wala-Require-iptables-package.patch [bz#1978572]
|
||||
- Resolves: bz#1978572
|
||||
([Azure][WALA][RHEL-9] WALA needs iptables package)
|
||||
|
||||
* Thu Jun 24 2021 Miroslav Rezanina <mrezanin@redhat.com> - 2.3.0.2-1
|
||||
- Rebase to 2.3.0.2 [bz#1972101]
|
||||
- Resolves: bz#1972101
|
||||
([Azure][RHEL-9]Rebase WALinuxAgent to 2.3.0.2)
|
||||
|
||||
* Thu Apr 15 2021 Mohan Boddu <mboddu@redhat.com> - 2.2.52-6
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Fri Feb 19 2021 Vitaly Kuznetsov <vkuznets@redhat.com> - 2.2.52-5
|
||||
- Require ntfsprogs on Fedora only
|
||||
|
||||
* Tue Jan 26 2021 Vitaly Kuznetsov <vkuznets@redhat.com> - 2.2.52-4
|
||||
- Fix distro resolution for RedHat
|
||||
|
||||
* Mon Jan 25 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.52-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Fri Jan 15 2021 Vitaly Kuznetsov <vkuznets@redhat.com> - 2.2.52-2
|
||||
- Add udev rules to initramfs (#1909287)
|
||||
|
||||
* Wed Dec 09 2020 Vitaly Kuznetsov <vkuznets@redhat.com> - 2.2.52-1
|
||||
- Update to 2.2.52 (#1849923)
|
||||
- Add not yet upstream patches supporting Python3.9 changes
|
||||
|
||||
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.48.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Tue Jun 09 2020 Vitaly Kuznetsov <vkuznets@redhat.com> - 2.2.48.1-1
|
||||
- Update to 2.2.48.1 (#1641605)
|
||||
- Split udev rules to a separate subpackage (#1748432)
|
||||
|
||||
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 2.2.46-2
|
||||
- Rebuilt for Python 3.9
|
||||
|
||||
* Wed Apr 15 2020 Vitaly Kuznetsov <vkuznets@redhat.com> - 2.2.46-1
|
||||
- Update to 2.2.46
|
||||
|
||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.40-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 2.2.40-6
|
||||
- Rebuilt for Python 3.8.0rc1 (#1748018)
|
||||
|
||||
* Wed Aug 21 2019 Miro Hrončok <mhroncok@redhat.com> - 2.2.40-5
|
||||
- Rebuilt for Python 3.8
|
||||
|
||||
* Wed Aug 21 2019 Vitaly Kuznetsov <vkuznets@redhat.com> - 2.2.40-4
|
||||
- Disable Python2 dependent 'legacy' subpackage (#1741029)
|
||||
|
||||
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 2.2.40-3
|
||||
- Rebuilt for Python 3.8
|
||||
|
||||
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.40-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Mon Jun 03 2019 Vitaly Kuznetsov <vkuznets@redhat.com> - 2.2.40-1
|
||||
- Update to 2.2.40
|
||||
- Fix FTBFS in the preparation for Python3.8 (#1705219)
|
||||
|
||||
* Thu Mar 14 2019 Vitaly Kuznetsov <vkuznets@redhat.com> - 2.2.38-1
|
||||
- Update to 2.2.38 (CVE-2019-0804)
|
||||
|
||||
* Thu Mar 14 2019 Vitaly Kuznetsov <vkuznets@redhat.com> - 2.2.37-1
|
||||
- Update to 2.2.37
|
||||
|
||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.32-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Thu Sep 20 2018 Vitaly Kuznetsov <vkuznets@redhat.com> - 2.2.32-1
|
||||
- Update to 2.2.32.2
|
||||
|
||||
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.25-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 2.2.25-3
|
||||
- Rebuilt for Python 3.7
|
||||
|
||||
* Wed Apr 25 2018 Vitaly Kuznetsov <vkuznets@redhat.com> - 2.2.25-2
|
||||
- Move net-tools dependency to WALinuxAgent-legacy (#1106781)
|
||||
|
||||
* Mon Apr 16 2018 Vitaly Kuznetsov <vkuznets@redhat.com> - 2.2.25-1
|
||||
- Update to 2.2.25
|
||||
- Switch to Python3
|
||||
- Legacy subpackage with waagent2.0 supporting old extensions
|
||||
|
||||
* Wed Feb 28 2018 Iryna Shcherbina <ishcherb@redhat.com> - 2.0.18-5
|
||||
- Update Python 2 dependency declarations to new packaging standards
|
||||
(See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.18-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.18-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.18-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Sat Apr 02 2016 Scott K Logan <logans@cottsay.net> - 2.0.18-1
|
||||
- Update to 2.0.18
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.14-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Thu Jul 02 2015 Scott K Logan <logans@cottsay.net> - 2.0.14-1
|
||||
- Update to 2.0.14
|
||||
|
||||
* Tue Jun 16 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.13-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Mon Jun 01 2015 Scott K Logan <logans@cottsay.net> - 2.0.13-1
|
||||
- Update to 2.0.13
|
||||
|
||||
* Thu Apr 02 2015 Scott K Logan <logans@cottsay.net> - 2.0.12-1
|
||||
- Update to 2.0.12-Oracle
|
||||
|
||||
* Sat Jan 10 2015 Scott K Logan <logans@cottsay.net> - 2.0.11-2
|
||||
- Use systemd for rhel7
|
||||
- Own logrotate.d
|
||||
- Fix python2-devel dep
|
||||
|
||||
* Sat Dec 20 2014 Scott K Logan <logans@cottsay.net> - 2.0.11-1
|
||||
- Initial package
|
Loading…
Reference in New Issue
Block a user