import WALinuxAgent-2.2.46-7.el8
This commit is contained in:
parent
d95574a683
commit
fb6d49fca2
@ -1 +1 @@
|
||||
45d136023c003b28a9b49fd89e6c9570b38fb397 SOURCES/WALinuxAgent-2.2.38.tar.gz
|
||||
6a636c47aea02063bde8282a5bc2bb61d4afe640 SOURCES/WALinuxAgent-2.2.46.tar.gz
|
||||
|
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/WALinuxAgent-2.2.38.tar.gz
|
||||
SOURCES/WALinuxAgent-2.2.46.tar.gz
|
||||
|
@ -1,9 +1,9 @@
|
||||
From 6b4aa78bf155631ee2d4b594a80e68e07b85b586 Mon Sep 17 00:00:00 2001
|
||||
From 63f8528699e608ef46d256fd8105b338049336e3 Mon Sep 17 00:00:00 2001
|
||||
From: Miroslav Rezanina <mrezanin@redhat.com>
|
||||
Date: Thu, 6 Oct 2016 12:25:35 +0200
|
||||
Subject: Add inital redhat build support
|
||||
|
||||
Rebase notes (2.2.38):
|
||||
Rebase notes (2.2.32):
|
||||
- Fix license text
|
||||
|
||||
Rebase notes (2.2.26):
|
||||
@ -14,7 +14,10 @@ Rebase notes (2.2.10):
|
||||
- switched to sha256
|
||||
- added .gitpublish profile
|
||||
|
||||
Merged patches (2.2.38):
|
||||
Rebase notes (2.2.46):
|
||||
- added waagent-extn.logrotate
|
||||
|
||||
Merged patches (2.2.45):
|
||||
- df29beb Switch from platform-python to python36
|
||||
- 6749108 Stop packaging legacy waagent2.0
|
||||
|
||||
@ -28,15 +31,11 @@ Merged patches (2.2.32):
|
||||
|
||||
(cherry picked from commit 19d4f82cd5345fdc52b357afcf3b5aa4bc4ce4d9)
|
||||
(cherry picked from commit 1676db295321adbd571f04773782eed5b0817d64)
|
||||
|
||||
Conflicts:
|
||||
config/waagent.conf
|
||||
---
|
||||
.gitpublish | 8 +
|
||||
azurelinuxagent/ga/update.py | 12 +-
|
||||
bin/waagent | 2 +-
|
||||
bin/waagent2.0 | 2 +-
|
||||
config/waagent.conf | 3 -
|
||||
init/arch/waagent.service | 2 +-
|
||||
init/clearlinux/waagent.service | 2 +-
|
||||
init/suse/waagent | 2 +-
|
||||
@ -45,7 +44,7 @@ Conflicts:
|
||||
redhat/.gitignore | 1 +
|
||||
redhat/Makefile | 72 +++++++
|
||||
redhat/Makefile.common | 37 ++++
|
||||
redhat/WALinuxAgent.spec.template | 190 +++++++++++++++++
|
||||
redhat/WALinuxAgent.spec.template | 186 +++++++++++++++++
|
||||
redhat/rpmbuild/BUILD/.gitignore | 2 +
|
||||
redhat/rpmbuild/RPMS/.gitignore | 2 +
|
||||
redhat/rpmbuild/SOURCES/.gitignore | 2 +
|
||||
@ -58,7 +57,7 @@ Conflicts:
|
||||
redhat/scripts/tarball_checksum.sh | 3 +
|
||||
setup.py | 2 +-
|
||||
tests/data/ext/sample_ext-1.3.0/sample.py | 2 +-
|
||||
26 files changed, 985 insertions(+), 17 deletions(-)
|
||||
25 files changed, 981 insertions(+), 14 deletions(-)
|
||||
create mode 100644 .gitpublish
|
||||
create mode 100644 redhat/.gitignore
|
||||
create mode 100644 redhat/Makefile
|
||||
@ -76,10 +75,10 @@ Conflicts:
|
||||
create mode 100755 redhat/scripts/tarball_checksum.sh
|
||||
|
||||
diff --git a/azurelinuxagent/ga/update.py b/azurelinuxagent/ga/update.py
|
||||
index bb66614..f77fbee 100644
|
||||
index c882bc1..8367274 100644
|
||||
--- a/azurelinuxagent/ga/update.py
|
||||
+++ b/azurelinuxagent/ga/update.py
|
||||
@@ -92,8 +92,11 @@ def get_update_handler():
|
||||
@@ -93,8 +93,11 @@ def get_update_handler():
|
||||
|
||||
|
||||
def get_python_cmd():
|
||||
@ -93,7 +92,7 @@ index bb66614..f77fbee 100644
|
||||
|
||||
|
||||
class UpdateHandler(object):
|
||||
@@ -150,9 +153,8 @@ class UpdateHandler(object):
|
||||
@@ -151,9 +154,8 @@ class UpdateHandler(object):
|
||||
|
||||
# Launch the correct Python version for python-based agents
|
||||
cmds = textutil.safe_shlex_split(agent_cmd)
|
||||
@ -125,20 +124,6 @@ index 25aa0ce..a868211 100644
|
||||
#
|
||||
# Azure Linux Agent
|
||||
#
|
||||
diff --git a/config/waagent.conf b/config/waagent.conf
|
||||
index 62a9441..4754029 100644
|
||||
--- a/config/waagent.conf
|
||||
+++ b/config/waagent.conf
|
||||
@@ -65,9 +65,6 @@ Logs.Verbose=n
|
||||
# Enable Console logging, default is y
|
||||
# Logs.Console=y
|
||||
|
||||
-# Is FIPS enabled
|
||||
-OS.EnableFIPS=n
|
||||
-
|
||||
# Root device timeout in seconds.
|
||||
OS.RootDeviceScsiTimeout=300
|
||||
|
||||
diff --git a/init/arch/waagent.service b/init/arch/waagent.service
|
||||
index d426eb2..ff1ebab 100644
|
||||
--- a/init/arch/waagent.service
|
||||
@ -202,7 +187,7 @@ index 52e0eae..51c263c 100755
|
||||
import glob
|
||||
import os
|
||||
diff --git a/setup.py b/setup.py
|
||||
index ee0d839..da19bf1 100755
|
||||
index 372807f..f0798ff 100755
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -1,4 +1,4 @@
|
||||
|
26
SOURCES/0003-Fix-fips.patch
Normal file
26
SOURCES/0003-Fix-fips.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From c990d90bf1cfaf728d094f5e4157ebd70515a228 Mon Sep 17 00:00:00 2001
|
||||
From: Miroslav Rezanina <mrezanin@redhat.com>
|
||||
Date: Mon, 13 Apr 2020 05:27:49 +0200
|
||||
Subject: Fix fips
|
||||
|
||||
---
|
||||
config/waagent.conf | 3 ---
|
||||
1 file changed, 3 deletions(-)
|
||||
|
||||
diff --git a/config/waagent.conf b/config/waagent.conf
|
||||
index 62a9441..4754029 100644
|
||||
--- a/config/waagent.conf
|
||||
+++ b/config/waagent.conf
|
||||
@@ -65,9 +65,6 @@ Logs.Verbose=n
|
||||
# Enable Console logging, default is y
|
||||
# Logs.Console=y
|
||||
|
||||
-# Is FIPS enabled
|
||||
-OS.EnableFIPS=n
|
||||
-
|
||||
# Root device timeout in seconds.
|
||||
OS.RootDeviceScsiTimeout=300
|
||||
|
||||
--
|
||||
1.8.3.1
|
||||
|
355
SOURCES/wala-Update-Provisioning-options-1853.patch
Normal file
355
SOURCES/wala-Update-Provisioning-options-1853.patch
Normal file
@ -0,0 +1,355 @@
|
||||
From 51dcc3b2ba972db7b30c75097919b3e4ab396a89 Mon Sep 17 00:00:00 2001
|
||||
From: Vitaly Kuznetsov <vkuznets@redhat.com>
|
||||
Date: Tue, 28 Apr 2020 10:00:11 +0200
|
||||
Subject: [PATCH] Update 'Provisioning' options (#1853)
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
RH-Author: Vitaly Kuznetsov <vkuznets@redhat.com>
|
||||
Message-id: <20200427083047.1269733-1-vkuznets@redhat.com>
|
||||
Patchwork-id: 96138
|
||||
O-Subject: [RHEL-8.2.1 WALinuxAgent PATCH] Update 'Provisioning' options (#1853)
|
||||
Bugzilla: 1822882
|
||||
RH-Acked-by: Philippe Mathieu-Daudé <philmd@redhat.com>
|
||||
RH-Acked-by: Cathy Avery <cavery@redhat.com>
|
||||
RH-Acked-by: Mohammed Gamal <mgamal@redhat.com>
|
||||
|
||||
commit 92b652e031dd01027113702df7ee93c816bfd1aa
|
||||
Author: Vitaly Kuznetsov <vitty@redhat.com>
|
||||
Date: Tue Apr 21 02:01:03 2020 +0200
|
||||
|
||||
Update 'Provisioning' options (#1853)
|
||||
|
||||
'Provisioning.Enabled' and 'Provisioning.UseCloudInit' parameters are
|
||||
removed since v2.2.45 and replaced with 'Provisioning.Agent'. Update
|
||||
distro specific configs accordingly.
|
||||
|
||||
Signed-off-by: Vitaly Kuznetsov <vkuznets@redhat.com>
|
||||
|
||||
Co-authored-by: Vitaly Kuznetsov <vkuznets@redhat.com>
|
||||
|
||||
Signed-off-by: Vitaly Kuznetsov <vkuznets@redhat.com>
|
||||
Signed-off-by: Miroslav Rezanina <mrezanin@redhat.com>
|
||||
---
|
||||
config/alpine/waagent.conf | 8 +++-----
|
||||
config/arch/waagent.conf | 8 +++-----
|
||||
config/bigip/waagent.conf | 8 +++-----
|
||||
config/clearlinux/waagent.conf | 8 +++-----
|
||||
config/coreos/waagent.conf | 8 +++-----
|
||||
config/debian/waagent.conf | 8 +++-----
|
||||
config/freebsd/waagent.conf | 8 +++-----
|
||||
config/gaia/waagent.conf | 8 +++-----
|
||||
config/iosxe/waagent.conf | 8 +++-----
|
||||
config/nsbsd/waagent.conf | 8 +++-----
|
||||
config/openbsd/waagent.conf | 8 +++-----
|
||||
config/suse/waagent.conf | 8 +++-----
|
||||
config/ubuntu/waagent.conf | 8 +++-----
|
||||
config/waagent.conf | 8 +++-----
|
||||
14 files changed, 42 insertions(+), 70 deletions(-)
|
||||
|
||||
diff --git a/config/alpine/waagent.conf b/config/alpine/waagent.conf
|
||||
index ac9466e..2a010cf 100644
|
||||
--- a/config/alpine/waagent.conf
|
||||
+++ b/config/alpine/waagent.conf
|
||||
@@ -2,15 +2,13 @@
|
||||
# Windows Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
# Enable extension handling. Do not disable this unless you do not need password reset,
|
||||
# backup, monitoring, or any extension handling whatsoever.
|
||||
Extensions.Enabled=y
|
||||
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=y
|
||||
diff --git a/config/arch/waagent.conf b/config/arch/waagent.conf
|
||||
index 8d509cf..f999359 100644
|
||||
--- a/config/arch/waagent.conf
|
||||
+++ b/config/arch/waagent.conf
|
||||
@@ -2,11 +2,9 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=n
|
||||
diff --git a/config/bigip/waagent.conf b/config/bigip/waagent.conf
|
||||
index 7446bcb..49acf9d 100644
|
||||
--- a/config/bigip/waagent.conf
|
||||
+++ b/config/bigip/waagent.conf
|
||||
@@ -13,15 +13,13 @@ Role.ConfigurationConsumer=None
|
||||
# Specified program is invoked with XML file argument specifying role topology.
|
||||
Role.TopologyConsumer=None
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
# Enable extension handling. Do not disable this unless you do not need password reset,
|
||||
# backup, monitoring, or any extension handling whatsoever.
|
||||
Extensions.Enabled=y
|
||||
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=y
|
||||
diff --git a/config/clearlinux/waagent.conf b/config/clearlinux/waagent.conf
|
||||
index 10567cc..0b70d26 100644
|
||||
--- a/config/clearlinux/waagent.conf
|
||||
+++ b/config/clearlinux/waagent.conf
|
||||
@@ -13,11 +13,9 @@ Role.ConfigurationConsumer=None
|
||||
# Specified program is invoked with XML file argument specifying role topology.
|
||||
Role.TopologyConsumer=None
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=y
|
||||
diff --git a/config/coreos/waagent.conf b/config/coreos/waagent.conf
|
||||
index 8d3312c..0ce7b27 100644
|
||||
--- a/config/coreos/waagent.conf
|
||||
+++ b/config/coreos/waagent.conf
|
||||
@@ -2,15 +2,13 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
# Enable extension handling. Do not disable this unless you do not need password reset,
|
||||
# backup, monitoring, or any extension handling whatsoever.
|
||||
Extensions.Enabled=y
|
||||
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=n
|
||||
diff --git a/config/debian/waagent.conf b/config/debian/waagent.conf
|
||||
index 28e496e..4c1880e 100644
|
||||
--- a/config/debian/waagent.conf
|
||||
+++ b/config/debian/waagent.conf
|
||||
@@ -2,15 +2,13 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
# Enable extension handling. Do not disable this unless you do not need password reset,
|
||||
# backup, monitoring, or any extension handling whatsoever.
|
||||
Extensions.Enabled=y
|
||||
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=y
|
||||
diff --git a/config/freebsd/waagent.conf b/config/freebsd/waagent.conf
|
||||
index 83988ae..1d1710b 100644
|
||||
--- a/config/freebsd/waagent.conf
|
||||
+++ b/config/freebsd/waagent.conf
|
||||
@@ -2,15 +2,13 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
# Enable extension handling. Do not disable this unless you do not need password reset,
|
||||
# backup, monitoring, or any extension handling whatsoever.
|
||||
Extensions.Enabled=y
|
||||
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=y
|
||||
diff --git a/config/gaia/waagent.conf b/config/gaia/waagent.conf
|
||||
index 6992ff2..b1dc764 100644
|
||||
--- a/config/gaia/waagent.conf
|
||||
+++ b/config/gaia/waagent.conf
|
||||
@@ -2,15 +2,13 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
# Enable extension handling. Do not disable this unless you do not need password reset,
|
||||
# backup, monitoring, or any extension handling whatsoever.
|
||||
Extensions.Enabled=y
|
||||
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=n
|
||||
diff --git a/config/iosxe/waagent.conf b/config/iosxe/waagent.conf
|
||||
index 6787d30..533a234 100644
|
||||
--- a/config/iosxe/waagent.conf
|
||||
+++ b/config/iosxe/waagent.conf
|
||||
@@ -2,11 +2,9 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=n
|
||||
-
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=y
|
||||
diff --git a/config/nsbsd/waagent.conf b/config/nsbsd/waagent.conf
|
||||
index 178f9a2..b859fd5 100644
|
||||
--- a/config/nsbsd/waagent.conf
|
||||
+++ b/config/nsbsd/waagent.conf
|
||||
@@ -2,11 +2,9 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=n
|
||||
diff --git a/config/openbsd/waagent.conf b/config/openbsd/waagent.conf
|
||||
index 54f2e11..697f129 100644
|
||||
--- a/config/openbsd/waagent.conf
|
||||
+++ b/config/openbsd/waagent.conf
|
||||
@@ -2,11 +2,9 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=y
|
||||
diff --git a/config/suse/waagent.conf b/config/suse/waagent.conf
|
||||
index 5e601e6..dc99b12 100644
|
||||
--- a/config/suse/waagent.conf
|
||||
+++ b/config/suse/waagent.conf
|
||||
@@ -2,15 +2,13 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
# Enable extension handling. Do not disable this unless you do not need password reset,
|
||||
# backup, monitoring, or any extension handling whatsoever.
|
||||
Extensions.Enabled=y
|
||||
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=y
|
||||
diff --git a/config/ubuntu/waagent.conf b/config/ubuntu/waagent.conf
|
||||
index 759db70..8c2c512 100644
|
||||
--- a/config/ubuntu/waagent.conf
|
||||
+++ b/config/ubuntu/waagent.conf
|
||||
@@ -2,15 +2,13 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=n
|
||||
-
|
||||
# Enable extension handling. Do not disable this unless you do not need password reset,
|
||||
# backup, monitoring, or any extension handling whatsoever.
|
||||
Extensions.Enabled=y
|
||||
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=y
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=y
|
||||
diff --git a/config/waagent.conf b/config/waagent.conf
|
||||
index 62a9441..b558bb4 100644
|
||||
--- a/config/waagent.conf
|
||||
+++ b/config/waagent.conf
|
||||
@@ -2,15 +2,13 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
# Enable extension handling. Do not disable this unless you do not need password reset,
|
||||
# backup, monitoring, or any extension handling whatsoever.
|
||||
Extensions.Enabled=y
|
||||
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=y
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -1,15 +1,18 @@
|
||||
Summary: Microsoft Azure Linux Agent
|
||||
Name: WALinuxAgent
|
||||
Version: 2.2.38
|
||||
Release: 1%{?dist}
|
||||
Version: 2.2.46
|
||||
Release: 7%{?dist}
|
||||
|
||||
License: ASL 2.0
|
||||
Group: Development/Libraries
|
||||
Url: https://github.com/Azure/WALinuxAgent
|
||||
Source0: WALinuxAgent-2.2.38.tar.gz
|
||||
Source0: WALinuxAgent-2.2.46.tar.gz
|
||||
|
||||
BuildArch: noarch
|
||||
Patch0001: 0001-Add-inital-redhat-build-support.patch
|
||||
Patch0002: 0003-Fix-fips.patch
|
||||
# For bz#1822882 - [Azure][RHEL-8]Some parameter changes are not in waagent.conf
|
||||
Patch3: wala-Update-Provisioning-options-1853.patch
|
||||
|
||||
# rhel requirements
|
||||
BuildRequires: python3-devel
|
||||
@ -36,6 +39,8 @@ images that are built to run in the Azure environment.
|
||||
%setup -q
|
||||
|
||||
%patch0001 -p1
|
||||
%patch0002 -p1
|
||||
%patch3 -p1
|
||||
|
||||
%build
|
||||
%py3_build
|
||||
@ -60,13 +65,29 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%defattr(-,root,root)
|
||||
%{python3_sitelib}/*
|
||||
%config(noreplace) %{_sysconfdir}/waagent.conf
|
||||
%{_sysconfdir}/logrotate.d/waagent.logrotate
|
||||
%config(noreplace) %{_sysconfdir}/logrotate.d/waagent.logrotate
|
||||
%config(noreplace) %{_sysconfdir}/logrotate.d/waagent-extn.logrotate
|
||||
%{_sbindir}/waagent
|
||||
%{_unitdir}/waagent.service
|
||||
/etc/udev/rules.d/66-azure-storage.rules
|
||||
/etc/udev/rules.d/99-azure-product-uuid.rules
|
||||
|
||||
%changelog
|
||||
* Wed Jun 10 2020 Miroslav Rezanina <mrezanin@redhat.com> - 2.2.46-7.el8
|
||||
- wla-Mark-logrotate-configs-with-config-noreplace.patch [bz#1838254]
|
||||
- Resolves: bz#1838254
|
||||
([Azure]WALinuxAgent RPM update clobbers waagent.logrotate log rotation changes)
|
||||
|
||||
* Tue May 26 2020 Miroslav Rezanina <mrezanin@redhat.com> - 2.2.46-6.el8
|
||||
- wala-Update-Provisioning-options-1853.patch [bz#1827792]
|
||||
- Resolves: bz#1822882
|
||||
([Azure][RHEL-8]Some parameter changes are not in waagent.conf)
|
||||
|
||||
* Wed Apr 15 2020 Miroslav Rezanina <mrezanin@redhat.com> - 2.2.46-5.el8
|
||||
- Rebase to 2.2.46 [bz#1791069]
|
||||
- Resolves: bz#1791069
|
||||
([Azure][RHEL-8.3]Ask to increase the WALA version available for RHEL 8.0 to 2.2.46)
|
||||
|
||||
* Wed Jul 24 2019 Miroslav Rezanina <mrezanin@redhat.com> - 2.2.38-1
|
||||
- Rebase to 2.2.38 [bz#1722848]
|
||||
- Resolves: bz#1722848
|
||||
|
Loading…
Reference in New Issue
Block a user