* Mon Jan 13 2025 Miroslav Rezanina <mrezanin@redhat.com> - 2.9.1.1-9

- wla-redhat-Add-a-udev-rule-to-avoid-managing-slave-NICs-.patch [RHEL-68796]
- Resolves: RHEL-68796
  (Please add `mana` to 99-azure-unmanaged-devices.conf of Azure image)
This commit is contained in:
Miroslav Rezanina 2025-01-13 03:13:53 -05:00
parent 7278f3ba4f
commit f9de8a962a
2 changed files with 63 additions and 1 deletions

View File

@ -3,7 +3,7 @@
Name: WALinuxAgent
Version: 2.9.1.1
Release: 8%{?dist}
Release: 9%{?dist}
Summary: The Microsoft Azure Linux Agent
License: Apache-2.0
@ -18,6 +18,8 @@ Patch2: wla-Disable-automatic-log-collector.patch
Patch3: wla-redhat-Use-NetworkManager-to-set-DHCP-hostnames-on-r.patch
# For RHEL-46713 - [Azure][RHEL-10][WALA] waagent -collect-logs doesn't work and the log is confusing
Patch4: wla-skip-cgorup-monitor-2939.patch
# For RHEL-68796 - Please add `mana` to 99-azure-unmanaged-devices.conf of Azure image
Patch5: wla-redhat-Add-a-udev-rule-to-avoid-managing-slave-NICs-.patch
BuildArch: noarch
@ -129,6 +131,11 @@ rm -rf %{_unitdir}/waagent.service.d/
%endif
%changelog
* Mon Jan 13 2025 Miroslav Rezanina <mrezanin@redhat.com> - 2.9.1.1-9
- wla-redhat-Add-a-udev-rule-to-avoid-managing-slave-NICs-.patch [RHEL-68796]
- Resolves: RHEL-68796
(Please add `mana` to 99-azure-unmanaged-devices.conf of Azure image)
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 2.9.1.1-8
- Bump release for October 2024 mass rebuild:
Resolves: RHEL-64018

View File

@ -0,0 +1,55 @@
From dd3a8f78ef32aed2f1267dd7dd495c65edd259a1 Mon Sep 17 00:00:00 2001
From: Vitaly Kuznetsov <vkuznets@redhat.com>
Date: Mon, 6 Jan 2025 17:13:11 +0100
Subject: [PATCH] redhat: Add a udev rule to avoid managing slave NICs with
NetworkManager
RH-Author: Vitaly Kuznetsov <vkuznets@redhat.com>
RH-MergeRequest: 15: redhat: Add a udev rule to avoid managing slave NICs with NetworkManager
RH-Jira: RHEL-68796
RH-Acked-by: Ani Sinha <anisinha@redhat.com>
RH-Acked-by: Emanuele Giuseppe Esposito <eesposit@redhat.com>
RH-Acked-by: Cathy Avery <cavery@redhat.com>
RH-Commit: [1/1] f6a5ab0e22831b67fc48afc8e80b724fcb9c8503 (vkuznets/WALinuxAgentCentOS)
This is borrowed from https://github.com/Azure/azure-vm-utils/pull/41 and
the long term plan is to get azure-vm-utils packaged for RHEL
eventually. For the time being, just put the required udev rule into
WALinuxAgent package.
Signed-off-by: Vitaly Kuznetsov <vkuznets@redhat.com>
---
config/10-azure-unmanaged-sriov.rules | 6 ++++++
setup.py | 3 ++-
2 files changed, 8 insertions(+), 1 deletion(-)
create mode 100644 config/10-azure-unmanaged-sriov.rules
diff --git a/config/10-azure-unmanaged-sriov.rules b/config/10-azure-unmanaged-sriov.rules
new file mode 100644
index 00000000..7eefcb26
--- /dev/null
+++ b/config/10-azure-unmanaged-sriov.rules
@@ -0,0 +1,6 @@
+# Azure VMs with accelerated networking may have MANA, mlx4, or mlx5 SR-IOV devices which are transparently bonded to a synthetic
+# hv_netvsc device. Mark devices with the IFF_SLAVE bit set as unmanaged devices:
+# AZURE_UNMANAGED_SRIOV=1 for 10-azure-unmanaged-sriov.network
+# ID_NET_MANAGED_BY=unmanaged for systemd-networkd >= 255
+# NM_UNMANAGED=1 for NetworkManager
+SUBSYSTEM=="net", ACTION!="remove", DRIVERS=="mana|mlx4_core|mlx5_core", ATTR{flags}=="0x?[89ABCDEF]??", ENV{AZURE_UNMANAGED_SRIOV}="1", ENV{ID_NET_MANAGED_BY}="unmanaged", ENV{NM_UNMANAGED}="1"
diff --git a/setup.py b/setup.py
index 8f5d92b4..f76aff30 100755
--- a/setup.py
+++ b/setup.py
@@ -82,7 +82,8 @@ def set_openbsd_rc_files(data_files, dest="/etc/rc.d/", src=None):
def set_udev_files(data_files, dest="/etc/udev/rules.d/", src=None):
if src is None:
- src = ["config/66-azure-storage.rules",
+ src = ["config/10-azure-unmanaged-sriov.rules",
+ "config/66-azure-storage.rules",
"config/99-azure-product-uuid.rules"]
data_files.append((dest, src))
--
2.39.3