Update to 2.0.12-Oracle
This commit is contained in:
parent
196a46b878
commit
d3958f71e6
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
/WALinuxAgent-b3f2619a854455675ae5f2ee14726659e0398af7.tar.gz
|
/WALinuxAgent-b3f2619a854455675ae5f2ee14726659e0398af7.tar.gz
|
||||||
|
/WALinuxAgent-26785b64279913d416767a6288a3b3f970ed4522.tar.gz
|
||||||
|
34
WALinuxAgent-2.0.12-oracle-linux-name.patch
Normal file
34
WALinuxAgent-2.0.12-oracle-linux-name.patch
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
From 95d1985deca1bc2561031ef08cc300b29558269c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Yue Zhang <yuezha@microsoft.com>
|
||||||
|
Date: Thu, 26 Mar 2015 21:51:15 +0800
|
||||||
|
Subject: [PATCH] Merge distro name fix on oracle linux
|
||||||
|
|
||||||
|
---
|
||||||
|
waagent | 7 +++++++
|
||||||
|
1 file changed, 7 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/waagent b/waagent
|
||||||
|
index cbd005b..68d3c64 100644
|
||||||
|
--- a/waagent
|
||||||
|
+++ b/waagent
|
||||||
|
@@ -5619,6 +5619,7 @@ def DistInfo(fullname=0):
|
||||||
|
release = re.sub('\-.*\Z', '', str(platform.release()))
|
||||||
|
distinfo = ['FreeBSD', release]
|
||||||
|
return distinfo
|
||||||
|
+
|
||||||
|
if 'linux_distribution' in dir(platform):
|
||||||
|
distinfo = list(platform.linux_distribution(full_distribution_name=fullname))
|
||||||
|
distinfo[0] = distinfo[0].strip() # remove trailing whitespace in distro name
|
||||||
|
@@ -5747,6 +5748,12 @@ def main():
|
||||||
|
LoggerInit('/var/log/waagent.log','/dev/console')
|
||||||
|
global LinuxDistro
|
||||||
|
LinuxDistro=DistInfo()[0]
|
||||||
|
+
|
||||||
|
+ #The platform.py lib has issue with detecting oracle linux distribution.
|
||||||
|
+ #Merge the following patch provided by oracle as a temparory fix.
|
||||||
|
+ if os.path.exists("/etc/oracle-release"):
|
||||||
|
+ LinuxDistro="Oracle Linux"
|
||||||
|
+
|
||||||
|
global MyDistro
|
||||||
|
MyDistro=GetMyDistro()
|
||||||
|
if MyDistro == None :
|
@ -1,4 +1,4 @@
|
|||||||
%global commit b3f2619a854455675ae5f2ee14726659e0398af7
|
%global commit 26785b64279913d416767a6288a3b3f970ed4522
|
||||||
|
|
||||||
%if 0%{?fedora}
|
%if 0%{?fedora}
|
||||||
%global distro fedora
|
%global distro fedora
|
||||||
@ -17,8 +17,8 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: WALinuxAgent
|
Name: WALinuxAgent
|
||||||
Version: 2.0.11
|
Version: 2.0.12
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The Microsoft Azure Linux Agent
|
Summary: The Microsoft Azure Linux Agent
|
||||||
|
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -27,6 +27,8 @@ URL: https://github.com/Azure/%{name}
|
|||||||
Source0: https://github.com/Azure/%{name}/archive/%{commit}/%{name}-%{commit}.tar.gz
|
Source0: https://github.com/Azure/%{name}/archive/%{commit}/%{name}-%{commit}.tar.gz
|
||||||
# Redhat-specific patch (not submitted upstream)
|
# Redhat-specific patch (not submitted upstream)
|
||||||
Patch0: %{name}-2.0.8-logrotate-name.patch
|
Patch0: %{name}-2.0.8-logrotate-name.patch
|
||||||
|
# Pulled from upstream
|
||||||
|
Patch1: %{name}-2.0.12-oracle-linux-name.patch
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
@ -66,6 +68,7 @@ images that are built to run in the Microsoft Azure environment.
|
|||||||
%prep
|
%prep
|
||||||
%setup -qn %{name}-%{commit}
|
%setup -qn %{name}-%{commit}
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
chmod 0755 distro/redhat/waagent.sysV
|
chmod 0755 distro/redhat/waagent.sysV
|
||||||
|
|
||||||
@ -126,6 +129,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 02 2015 Scott K Logan <logans@cottsay.net> - 2.0.12-1
|
||||||
|
- Update to 2.0.12-Oracle
|
||||||
|
|
||||||
* Sat Jan 10 2015 Scott K Logan <logans@cottsay.net> - 2.0.11-2
|
* Sat Jan 10 2015 Scott K Logan <logans@cottsay.net> - 2.0.11-2
|
||||||
- Use systemd for rhel7
|
- Use systemd for rhel7
|
||||||
- Own logrotate.d
|
- Own logrotate.d
|
||||||
|
Loading…
Reference in New Issue
Block a user