diff --git a/WALinuxAgent.spec b/WALinuxAgent.spec
index b663a4c..8d183b2 100644
--- a/WALinuxAgent.spec
+++ b/WALinuxAgent.spec
@@ -1,7 +1,7 @@
 Summary: Microsoft Azure Linux Agent
 Name: WALinuxAgent
 Version: 2.7.0.6
-Release: 2%{?dist}
+Release: 3%{?dist}
 
 License: ASL 2.0
 Group: Development/Libraries
@@ -13,6 +13,10 @@ Patch0001: 0001-Add-inital-redhat-build-support.patch
 Patch0002: 0002-Implement-restart_if-for-RedHat-OS.patch
 # For bz#2080826 - [Azure][WALA][RHEL-8] [8.7] walinuxagent kills network during boot
 Patch0003: wla-redhat-Fix-command-sequence-for-restarting-net-inter.patch
+# For bz#2092002 - [Azure][WALA][RHEL-8.7] Provisioning failed if no ifcfg-eth0
+Patch4: wla-redhat-Use-NetworkManager-to-set-DHCP-hostnames-on-r.patch
+# For bz#2114824 - [Azure][WALA][RHEL-8.7] The description of "Logs.Collect" is incorrect
+Patch5: wla-Update-Log-Collector-default-in-Comments-and-Readme-.patch
 
 # rhel requirements
 BuildRequires:  python3-devel
@@ -48,6 +52,8 @@ Udev rules specific to Microsoft Azure Virtual Machines.
 %patch0001 -p1
 %patch0002 -p1
 %patch0003 -p1
+%patch4 -p1
+%patch5 -p1
 
 %build
 %py3_build
@@ -86,6 +92,14 @@ rm -rf $RPM_BUILD_ROOT
 %{_udevrulesdir}/*.rules
 
 %changelog
+* Tue Aug 09 2022 Miroslav Rezanina <mrezanin@redhat.com> - 2.7.0.6-3
+- wla-redhat-Use-NetworkManager-to-set-DHCP-hostnames-on-r.patch [bz#2092002]
+- wla-Update-Log-Collector-default-in-Comments-and-Readme-.patch [bz#2114824]
+- Resolves: bz#2092002
+  ([Azure][WALA][RHEL-8.7] Provisioning failed if no ifcfg-eth0)
+- Resolves: bz#2114824
+  ([Azure][WALA][RHEL-8.7] The description of "Logs.Collect" is incorrect)
+
 * Tue Jul 12 2022 Camilla Conte <cconte@redhat.com> - 2.7.0.6-2
 - wla-redhat-Fix-command-sequence-for-restarting-net-inter.patch [bz#2080826]
 - Resolves: bz#2080826
diff --git a/wla-Update-Log-Collector-default-in-Comments-and-Readme-.patch b/wla-Update-Log-Collector-default-in-Comments-and-Readme-.patch
new file mode 100644
index 0000000..0410399
--- /dev/null
+++ b/wla-Update-Log-Collector-default-in-Comments-and-Readme-.patch
@@ -0,0 +1,108 @@
+From 97728b1371d39f5ddd31004db0ba87b268308c5d Mon Sep 17 00:00:00 2001
+From: Mohammed Gamal <mgamal@redhat.com>
+Date: Wed, 3 Aug 2022 13:39:56 +0200
+Subject: [PATCH 2/2] Update Log Collector default in Comments and Readme
+ (#2608)
+
+RH-Author: Mohamed Gamal Morsy <mmorsy@redhat.com>
+RH-MergeRequest: 9: Update Log Collector default in Comments and Readme
+RH-Commit: [1/1] ff82c0e933649ccd06d3cc48753324cddef2c56a
+RH-Bugzilla: 2114824
+RH-Acked-by: Vitaly Kuznetsov <vkuznets@redhat.com>
+RH-Acked-by: Miroslav Rezanina <mrezanin@redhat.com>
+
+Bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=2114824
+
+(cherry picked from commit a560872bec103523e73ddcb5fb5705896545ffce)
+
+Signed-off-by: Mohammed Gamal <mgamal@redhat.com>
+---
+ README.md                    | 2 +-
+ config/debian/waagent.conf   | 2 +-
+ config/suse/waagent.conf     | 2 +-
+ config/ubuntu/waagent.conf   | 2 +-
+ config/waagent.conf          | 2 +-
+ tests/data/test_waagent.conf | 2 +-
+ 6 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/README.md b/README.md
+index c69f43e6..f2f3db46 100644
+--- a/README.md
++++ b/README.md
+@@ -465,7 +465,7 @@ _Default: y_
+ 
+ If set, agent logs will be periodically collected and uploaded to a secure location for improved supportability.
+ 
+-NOTE: This feature is only supported ubuntu 16.04+; this flag will not take effect on any other distro.
++NOTE: This feature relies on the agent's resource usage features (cgroups); this flag will not take effect on any distro not supported.
+ 
+ #### __Logs.CollectPeriod__
+ 
+diff --git a/config/debian/waagent.conf b/config/debian/waagent.conf
+index 6bc36604..dfd7afcd 100644
+--- a/config/debian/waagent.conf
++++ b/config/debian/waagent.conf
+@@ -63,7 +63,7 @@ Logs.Verbose=n
+ # Enable Console logging, default is y
+ # Logs.Console=y
+ 
+-# Enable periodic log collection, default is n
++# Enable periodic log collection, default is y
+ Logs.Collect=y
+ 
+ # How frequently to collect logs, default is each hour
+diff --git a/config/suse/waagent.conf b/config/suse/waagent.conf
+index ac9f11a2..c617f9af 100644
+--- a/config/suse/waagent.conf
++++ b/config/suse/waagent.conf
+@@ -66,7 +66,7 @@ Logs.Verbose=n
+ # Enable Console logging, default is y
+ # Logs.Console=y
+ 
+-# Enable periodic log collection, default is n
++# Enable periodic log collection, default is y
+ Logs.Collect=y
+ 
+ # How frequently to collect logs, default is each hour
+diff --git a/config/ubuntu/waagent.conf b/config/ubuntu/waagent.conf
+index 63635a81..19b56bae 100644
+--- a/config/ubuntu/waagent.conf
++++ b/config/ubuntu/waagent.conf
+@@ -66,7 +66,7 @@ Logs.Verbose=n
+ # Enable Console logging, default is y
+ # Logs.Console=y
+ 
+-# Enable periodic log collection, default is n
++# Enable periodic log collection, default is y
+ Logs.Collect=y
+ 
+ # How frequently to collect logs, default is each hour
+diff --git a/config/waagent.conf b/config/waagent.conf
+index c7d10e2f..14cd01c8 100644
+--- a/config/waagent.conf
++++ b/config/waagent.conf
+@@ -72,7 +72,7 @@ Logs.Verbose=n
+ # Enable Console logging, default is y
+ # Logs.Console=y
+ 
+-# Enable periodic log collection, default is n
++# Enable periodic log collection, default is y
+ Logs.Collect=y
+ 
+ # How frequently to collect logs, default is each hour
+diff --git a/tests/data/test_waagent.conf b/tests/data/test_waagent.conf
+index a386228a..cc60886e 100644
+--- a/tests/data/test_waagent.conf
++++ b/tests/data/test_waagent.conf
+@@ -67,7 +67,7 @@ ResourceDisk.MountOptions=None
+ # Enable verbose logging (y|n)
+ Logs.Verbose=n
+ 
+-# Enable periodic log collection, default is n
++# Enable periodic log collection, default is y
+ Logs.Collect=y
+ 
+ # How frequently to collect logs, default is each hour
+-- 
+2.31.1
+
diff --git a/wla-redhat-Use-NetworkManager-to-set-DHCP-hostnames-on-r.patch b/wla-redhat-Use-NetworkManager-to-set-DHCP-hostnames-on-r.patch
new file mode 100644
index 0000000..7a5a934
--- /dev/null
+++ b/wla-redhat-Use-NetworkManager-to-set-DHCP-hostnames-on-r.patch
@@ -0,0 +1,49 @@
+From f45dc73365999334e680d64c90d36f710a0c7831 Mon Sep 17 00:00:00 2001
+From: Mohammed Gamal <mgamal@redhat.com>
+Date: Fri, 29 Jul 2022 13:07:13 +0200
+Subject: [PATCH 1/2] redhat: Use NetworkManager to set DHCP hostnames on
+ recent RHEL distros
+
+RH-Author: Mohamed Gamal Morsy <mmorsy@redhat.com>
+RH-MergeRequest: 8: redhat: Use NetworkManager to set DHCP hostnames on recent RHEL distros
+RH-Commit: [1/1] b83612e9d88bac7117541d7f7832f65ef268bbe3
+RH-Bugzilla: 2092002
+RH-Acked-by: Vitaly Kuznetsov <vkuznets@redhat.com>
+RH-Acked-by: Miroslav Rezanina <mrezanin@redhat.com>
+
+Bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=2092002
+
+Recent versions of RHEL 8 and RHEL 9 started using NetworkManager to configure
+network intefaces instead of sysconfig files. Configurations are no longer
+stored in /etc/sysconfig/ifcfg-{interface}.
+
+Fix this for setting DHCP hostnames in those RHEL versions.
+
+Signed-off-by: Mohammed Gamal <mgamal@redhat.com>
+---
+ azurelinuxagent/common/osutil/redhat.py | 12 ++++++++++++
+ 1 file changed, 12 insertions(+)
+
+diff --git a/azurelinuxagent/common/osutil/redhat.py b/azurelinuxagent/common/osutil/redhat.py
+index 5c397ae8..7dd36add 100644
+--- a/azurelinuxagent/common/osutil/redhat.py
++++ b/azurelinuxagent/common/osutil/redhat.py
+@@ -158,3 +158,15 @@ class RedhatOSUtil(Redhat6xOSUtil):
+                 time.sleep(wait)
+             else:
+                 logger.warn("exceeded restart retries")
++
++    def set_dhcp_hostname(self, hostname):
++        """
++        Recent RHEL distributions use network manager instead of sysconfig files
++        to configure network interfaces
++        """
++        ifname = self.get_if_name()
++
++        return_code = shellutil.run("nmcli device modify {0} ipv4.dhcp-hostname {1} ipv6.dhcp-hostname {1}".format(ifname, hostname))
++
++        if return_code != 0:
++            logger.error("failed to set DHCP hostname for interface {0}: return code {1}".format(ifname, return_code))
+-- 
+2.31.1
+