import WALinuxAgent-2.2.49.2-3.el8
This commit is contained in:
parent
013f7b6e7b
commit
631cf90677
@ -1 +1 @@
|
||||
6a636c47aea02063bde8282a5bc2bb61d4afe640 SOURCES/WALinuxAgent-2.2.46.tar.gz
|
||||
3c11701ed7b3d9dc76f521eb9519c3f1ce8a24b8 SOURCES/WALinuxAgent-2.2.49.2.tar.gz
|
||||
|
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/WALinuxAgent-2.2.46.tar.gz
|
||||
SOURCES/WALinuxAgent-2.2.49.2.tar.gz
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 63f8528699e608ef46d256fd8105b338049336e3 Mon Sep 17 00:00:00 2001
|
||||
From 18257d0baf1acde7522c1bf7d10e0a588d974431 Mon Sep 17 00:00:00 2001
|
||||
From: Miroslav Rezanina <mrezanin@redhat.com>
|
||||
Date: Thu, 6 Oct 2016 12:25:35 +0200
|
||||
Subject: Add inital redhat build support
|
||||
@ -29,9 +29,10 @@ Merged patches (2.2.32):
|
||||
- 1b15ada Switch to platform-python in systemd unit file
|
||||
- 59f682b Use sys.executable to find system python
|
||||
|
||||
(cherry picked from commit 19d4f82cd5345fdc52b357afcf3b5aa4bc4ce4d9)
|
||||
(cherry picked from commit 1676db295321adbd571f04773782eed5b0817d64)
|
||||
Merged patches (2.2.49):
|
||||
- 3a23336 Mark logrotate configs with %config(noreplace)
|
||||
---
|
||||
.gitignore | 1 +
|
||||
.gitpublish | 8 +
|
||||
azurelinuxagent/ga/update.py | 12 +-
|
||||
bin/waagent | 2 +-
|
||||
@ -44,7 +45,7 @@ Merged patches (2.2.32):
|
||||
redhat/.gitignore | 1 +
|
||||
redhat/Makefile | 72 +++++++
|
||||
redhat/Makefile.common | 37 ++++
|
||||
redhat/WALinuxAgent.spec.template | 186 +++++++++++++++++
|
||||
redhat/WALinuxAgent.spec.template | 206 +++++++++++++++++++
|
||||
redhat/rpmbuild/BUILD/.gitignore | 2 +
|
||||
redhat/rpmbuild/RPMS/.gitignore | 2 +
|
||||
redhat/rpmbuild/SOURCES/.gitignore | 2 +
|
||||
@ -57,7 +58,7 @@ Merged patches (2.2.32):
|
||||
redhat/scripts/tarball_checksum.sh | 3 +
|
||||
setup.py | 2 +-
|
||||
tests/data/ext/sample_ext-1.3.0/sample.py | 2 +-
|
||||
25 files changed, 981 insertions(+), 14 deletions(-)
|
||||
26 files changed, 1002 insertions(+), 14 deletions(-)
|
||||
create mode 100644 .gitpublish
|
||||
create mode 100644 redhat/.gitignore
|
||||
create mode 100644 redhat/Makefile
|
||||
@ -75,10 +76,10 @@ Merged patches (2.2.32):
|
||||
create mode 100755 redhat/scripts/tarball_checksum.sh
|
||||
|
||||
diff --git a/azurelinuxagent/ga/update.py b/azurelinuxagent/ga/update.py
|
||||
index c882bc1..8367274 100644
|
||||
index 6fec60e..d2a80ab 100644
|
||||
--- a/azurelinuxagent/ga/update.py
|
||||
+++ b/azurelinuxagent/ga/update.py
|
||||
@@ -93,8 +93,11 @@ def get_update_handler():
|
||||
@@ -87,8 +87,11 @@ def get_update_handler():
|
||||
|
||||
|
||||
def get_python_cmd():
|
||||
@ -92,7 +93,7 @@ index c882bc1..8367274 100644
|
||||
|
||||
|
||||
class UpdateHandler(object):
|
||||
@@ -151,9 +154,8 @@ class UpdateHandler(object):
|
||||
@@ -152,9 +155,8 @@ class UpdateHandler(object):
|
||||
|
||||
# Launch the correct Python version for python-based agents
|
||||
cmds = textutil.safe_shlex_split(agent_cmd)
|
||||
@ -105,7 +106,7 @@ index c882bc1..8367274 100644
|
||||
self._evaluate_agent_health(latest_agent)
|
||||
|
||||
diff --git a/bin/waagent b/bin/waagent
|
||||
index 4039e03..13d8d37 100755
|
||||
index 60cdf56..0443ecb 100755
|
||||
--- a/bin/waagent
|
||||
+++ b/bin/waagent
|
||||
@@ -1,4 +1,4 @@
|
||||
@ -115,7 +116,7 @@ index 4039e03..13d8d37 100755
|
||||
# Azure Linux Agent
|
||||
#
|
||||
diff --git a/bin/waagent2.0 b/bin/waagent2.0
|
||||
index 25aa0ce..a868211 100644
|
||||
index 3473267..762d211 100644
|
||||
--- a/bin/waagent2.0
|
||||
+++ b/bin/waagent2.0
|
||||
@@ -1,4 +1,4 @@
|
||||
|
@ -1,7 +1,7 @@
|
||||
From f5ae5815bce7a1e10188bdbbb0277d0ae79cafe2 Mon Sep 17 00:00:00 2001
|
||||
From a5af5690f0df9cb12fc46f8f14e4beba7c3aeae8 Mon Sep 17 00:00:00 2001
|
||||
From: Vitaly Kuznetsov <vkuznets@redhat.com>
|
||||
Date: Thu, 13 Aug 2020 08:43:58 +0200
|
||||
Subject: [PATCH] Fix handling of gen2 disks with udev rules (#1954)
|
||||
Subject: Fix handling of gen2 disks with udev rules (#1954)
|
||||
|
||||
RH-Author: Vitaly Kuznetsov <vkuznets@redhat.com>
|
||||
Message-id: <20200810082500.479999-1-vkuznets@redhat.com>
|
@ -1,26 +0,0 @@
|
||||
From c990d90bf1cfaf728d094f5e4157ebd70515a228 Mon Sep 17 00:00:00 2001
|
||||
From: Miroslav Rezanina <mrezanin@redhat.com>
|
||||
Date: Mon, 13 Apr 2020 05:27:49 +0200
|
||||
Subject: Fix fips
|
||||
|
||||
---
|
||||
config/waagent.conf | 3 ---
|
||||
1 file changed, 3 deletions(-)
|
||||
|
||||
diff --git a/config/waagent.conf b/config/waagent.conf
|
||||
index 62a9441..4754029 100644
|
||||
--- a/config/waagent.conf
|
||||
+++ b/config/waagent.conf
|
||||
@@ -65,9 +65,6 @@ Logs.Verbose=n
|
||||
# Enable Console logging, default is y
|
||||
# Logs.Console=y
|
||||
|
||||
-# Is FIPS enabled
|
||||
-OS.EnableFIPS=n
|
||||
-
|
||||
# Root device timeout in seconds.
|
||||
OS.RootDeviceScsiTimeout=300
|
||||
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -1,355 +0,0 @@
|
||||
From 51dcc3b2ba972db7b30c75097919b3e4ab396a89 Mon Sep 17 00:00:00 2001
|
||||
From: Vitaly Kuznetsov <vkuznets@redhat.com>
|
||||
Date: Tue, 28 Apr 2020 10:00:11 +0200
|
||||
Subject: [PATCH] Update 'Provisioning' options (#1853)
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
RH-Author: Vitaly Kuznetsov <vkuznets@redhat.com>
|
||||
Message-id: <20200427083047.1269733-1-vkuznets@redhat.com>
|
||||
Patchwork-id: 96138
|
||||
O-Subject: [RHEL-8.2.1 WALinuxAgent PATCH] Update 'Provisioning' options (#1853)
|
||||
Bugzilla: 1822882
|
||||
RH-Acked-by: Philippe Mathieu-Daudé <philmd@redhat.com>
|
||||
RH-Acked-by: Cathy Avery <cavery@redhat.com>
|
||||
RH-Acked-by: Mohammed Gamal <mgamal@redhat.com>
|
||||
|
||||
commit 92b652e031dd01027113702df7ee93c816bfd1aa
|
||||
Author: Vitaly Kuznetsov <vitty@redhat.com>
|
||||
Date: Tue Apr 21 02:01:03 2020 +0200
|
||||
|
||||
Update 'Provisioning' options (#1853)
|
||||
|
||||
'Provisioning.Enabled' and 'Provisioning.UseCloudInit' parameters are
|
||||
removed since v2.2.45 and replaced with 'Provisioning.Agent'. Update
|
||||
distro specific configs accordingly.
|
||||
|
||||
Signed-off-by: Vitaly Kuznetsov <vkuznets@redhat.com>
|
||||
|
||||
Co-authored-by: Vitaly Kuznetsov <vkuznets@redhat.com>
|
||||
|
||||
Signed-off-by: Vitaly Kuznetsov <vkuznets@redhat.com>
|
||||
Signed-off-by: Miroslav Rezanina <mrezanin@redhat.com>
|
||||
---
|
||||
config/alpine/waagent.conf | 8 +++-----
|
||||
config/arch/waagent.conf | 8 +++-----
|
||||
config/bigip/waagent.conf | 8 +++-----
|
||||
config/clearlinux/waagent.conf | 8 +++-----
|
||||
config/coreos/waagent.conf | 8 +++-----
|
||||
config/debian/waagent.conf | 8 +++-----
|
||||
config/freebsd/waagent.conf | 8 +++-----
|
||||
config/gaia/waagent.conf | 8 +++-----
|
||||
config/iosxe/waagent.conf | 8 +++-----
|
||||
config/nsbsd/waagent.conf | 8 +++-----
|
||||
config/openbsd/waagent.conf | 8 +++-----
|
||||
config/suse/waagent.conf | 8 +++-----
|
||||
config/ubuntu/waagent.conf | 8 +++-----
|
||||
config/waagent.conf | 8 +++-----
|
||||
14 files changed, 42 insertions(+), 70 deletions(-)
|
||||
|
||||
diff --git a/config/alpine/waagent.conf b/config/alpine/waagent.conf
|
||||
index ac9466e..2a010cf 100644
|
||||
--- a/config/alpine/waagent.conf
|
||||
+++ b/config/alpine/waagent.conf
|
||||
@@ -2,15 +2,13 @@
|
||||
# Windows Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
# Enable extension handling. Do not disable this unless you do not need password reset,
|
||||
# backup, monitoring, or any extension handling whatsoever.
|
||||
Extensions.Enabled=y
|
||||
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=y
|
||||
diff --git a/config/arch/waagent.conf b/config/arch/waagent.conf
|
||||
index 8d509cf..f999359 100644
|
||||
--- a/config/arch/waagent.conf
|
||||
+++ b/config/arch/waagent.conf
|
||||
@@ -2,11 +2,9 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=n
|
||||
diff --git a/config/bigip/waagent.conf b/config/bigip/waagent.conf
|
||||
index 7446bcb..49acf9d 100644
|
||||
--- a/config/bigip/waagent.conf
|
||||
+++ b/config/bigip/waagent.conf
|
||||
@@ -13,15 +13,13 @@ Role.ConfigurationConsumer=None
|
||||
# Specified program is invoked with XML file argument specifying role topology.
|
||||
Role.TopologyConsumer=None
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
# Enable extension handling. Do not disable this unless you do not need password reset,
|
||||
# backup, monitoring, or any extension handling whatsoever.
|
||||
Extensions.Enabled=y
|
||||
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=y
|
||||
diff --git a/config/clearlinux/waagent.conf b/config/clearlinux/waagent.conf
|
||||
index 10567cc..0b70d26 100644
|
||||
--- a/config/clearlinux/waagent.conf
|
||||
+++ b/config/clearlinux/waagent.conf
|
||||
@@ -13,11 +13,9 @@ Role.ConfigurationConsumer=None
|
||||
# Specified program is invoked with XML file argument specifying role topology.
|
||||
Role.TopologyConsumer=None
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=y
|
||||
diff --git a/config/coreos/waagent.conf b/config/coreos/waagent.conf
|
||||
index 8d3312c..0ce7b27 100644
|
||||
--- a/config/coreos/waagent.conf
|
||||
+++ b/config/coreos/waagent.conf
|
||||
@@ -2,15 +2,13 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
# Enable extension handling. Do not disable this unless you do not need password reset,
|
||||
# backup, monitoring, or any extension handling whatsoever.
|
||||
Extensions.Enabled=y
|
||||
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=n
|
||||
diff --git a/config/debian/waagent.conf b/config/debian/waagent.conf
|
||||
index 28e496e..4c1880e 100644
|
||||
--- a/config/debian/waagent.conf
|
||||
+++ b/config/debian/waagent.conf
|
||||
@@ -2,15 +2,13 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
# Enable extension handling. Do not disable this unless you do not need password reset,
|
||||
# backup, monitoring, or any extension handling whatsoever.
|
||||
Extensions.Enabled=y
|
||||
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=y
|
||||
diff --git a/config/freebsd/waagent.conf b/config/freebsd/waagent.conf
|
||||
index 83988ae..1d1710b 100644
|
||||
--- a/config/freebsd/waagent.conf
|
||||
+++ b/config/freebsd/waagent.conf
|
||||
@@ -2,15 +2,13 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
# Enable extension handling. Do not disable this unless you do not need password reset,
|
||||
# backup, monitoring, or any extension handling whatsoever.
|
||||
Extensions.Enabled=y
|
||||
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=y
|
||||
diff --git a/config/gaia/waagent.conf b/config/gaia/waagent.conf
|
||||
index 6992ff2..b1dc764 100644
|
||||
--- a/config/gaia/waagent.conf
|
||||
+++ b/config/gaia/waagent.conf
|
||||
@@ -2,15 +2,13 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
# Enable extension handling. Do not disable this unless you do not need password reset,
|
||||
# backup, monitoring, or any extension handling whatsoever.
|
||||
Extensions.Enabled=y
|
||||
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=n
|
||||
diff --git a/config/iosxe/waagent.conf b/config/iosxe/waagent.conf
|
||||
index 6787d30..533a234 100644
|
||||
--- a/config/iosxe/waagent.conf
|
||||
+++ b/config/iosxe/waagent.conf
|
||||
@@ -2,11 +2,9 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=n
|
||||
-
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=y
|
||||
diff --git a/config/nsbsd/waagent.conf b/config/nsbsd/waagent.conf
|
||||
index 178f9a2..b859fd5 100644
|
||||
--- a/config/nsbsd/waagent.conf
|
||||
+++ b/config/nsbsd/waagent.conf
|
||||
@@ -2,11 +2,9 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=n
|
||||
diff --git a/config/openbsd/waagent.conf b/config/openbsd/waagent.conf
|
||||
index 54f2e11..697f129 100644
|
||||
--- a/config/openbsd/waagent.conf
|
||||
+++ b/config/openbsd/waagent.conf
|
||||
@@ -2,11 +2,9 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=y
|
||||
diff --git a/config/suse/waagent.conf b/config/suse/waagent.conf
|
||||
index 5e601e6..dc99b12 100644
|
||||
--- a/config/suse/waagent.conf
|
||||
+++ b/config/suse/waagent.conf
|
||||
@@ -2,15 +2,13 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
# Enable extension handling. Do not disable this unless you do not need password reset,
|
||||
# backup, monitoring, or any extension handling whatsoever.
|
||||
Extensions.Enabled=y
|
||||
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=y
|
||||
diff --git a/config/ubuntu/waagent.conf b/config/ubuntu/waagent.conf
|
||||
index 759db70..8c2c512 100644
|
||||
--- a/config/ubuntu/waagent.conf
|
||||
+++ b/config/ubuntu/waagent.conf
|
||||
@@ -2,15 +2,13 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=n
|
||||
-
|
||||
# Enable extension handling. Do not disable this unless you do not need password reset,
|
||||
# backup, monitoring, or any extension handling whatsoever.
|
||||
Extensions.Enabled=y
|
||||
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=y
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=y
|
||||
diff --git a/config/waagent.conf b/config/waagent.conf
|
||||
index 62a9441..b558bb4 100644
|
||||
--- a/config/waagent.conf
|
||||
+++ b/config/waagent.conf
|
||||
@@ -2,15 +2,13 @@
|
||||
# Microsoft Azure Linux Agent Configuration
|
||||
#
|
||||
|
||||
-# Enable instance creation
|
||||
-Provisioning.Enabled=y
|
||||
-
|
||||
# Enable extension handling. Do not disable this unless you do not need password reset,
|
||||
# backup, monitoring, or any extension handling whatsoever.
|
||||
Extensions.Enabled=y
|
||||
|
||||
-# Rely on cloud-init to provision
|
||||
-Provisioning.UseCloudInit=n
|
||||
+# Which provisioning agent to use. Supported values are "auto" (default), "waagent",
|
||||
+# "cloud-init", or "disabled".
|
||||
+Provisioning.Agent=auto
|
||||
|
||||
# Password authentication for root account will be unavailable.
|
||||
Provisioning.DeleteRootPassword=y
|
||||
--
|
||||
1.8.3.1
|
||||
|
63
SOURCES/wla-Fixed-faulty-check-for-run_command-2093.patch
Normal file
63
SOURCES/wla-Fixed-faulty-check-for-run_command-2093.patch
Normal file
@ -0,0 +1,63 @@
|
||||
From 51ff3dc6705217f52e4b4810fa9b6eac406ca84e Mon Sep 17 00:00:00 2001
|
||||
From: Vitaly Kuznetsov <vkuznets@redhat.com>
|
||||
Date: Thu, 17 Dec 2020 06:50:11 +0100
|
||||
Subject: [PATCH] Fixed faulty check for run_command (#2093)
|
||||
|
||||
RH-Author: Vitaly Kuznetsov <vkuznets@redhat.com>
|
||||
Message-id: <20201209101549.2667108-1-vkuznets@redhat.com>
|
||||
Patchwork-id: 100366
|
||||
O-Subject: [RHEL8 WALinuxAgent PATCH] Fixed faulty check for run_command (#2093)
|
||||
Bugzilla: 1903074
|
||||
RH-Acked-by: Cathy Avery <cavery@redhat.com>
|
||||
RH-Acked-by: Mohammed Gamal <mgamal@redhat.com>
|
||||
|
||||
Bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=1903074
|
||||
Brew: https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=33563215
|
||||
Tested: by QE
|
||||
Branch: rhel840/master-2.2.49
|
||||
|
||||
commit b1799aef33f1213ef8828d5ba1838582026d5030
|
||||
Author: Laveesh Rohra <larohra@microsoft.com>
|
||||
Date: Tue Dec 1 16:13:03 2020 -0800
|
||||
|
||||
Fixed faulty check for run_command (#2093)
|
||||
|
||||
Signed-off-by: Vitaly Kuznetsov <vkuznets@redhat.com>
|
||||
Signed-off-by: Miroslav Rezanina <mrezanin@redhat.com>
|
||||
---
|
||||
azurelinuxagent/common/osutil/redhat.py | 5 ++++-
|
||||
azurelinuxagent/common/osutil/suse.py | 2 +-
|
||||
2 files changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/azurelinuxagent/common/osutil/redhat.py b/azurelinuxagent/common/osutil/redhat.py
|
||||
index 8974ecc..1b3ae0e 100644
|
||||
--- a/azurelinuxagent/common/osutil/redhat.py
|
||||
+++ b/azurelinuxagent/common/osutil/redhat.py
|
||||
@@ -106,7 +106,10 @@ class RedhatOSUtil(Redhat6xOSUtil):
|
||||
to hostname.
|
||||
"""
|
||||
hostnamectl_cmd = ['hostnamectl', 'set-hostname', hostname, '--static']
|
||||
- if self._run_command_without_raising(hostnamectl_cmd, log_error=False) != 0:
|
||||
+
|
||||
+ try:
|
||||
+ shellutil.run_command(hostnamectl_cmd, log_error=False)
|
||||
+ except shellutil.CommandError:
|
||||
logger.warn("[{0}] failed, attempting fallback".format(' '.join(hostnamectl_cmd)))
|
||||
DefaultOSUtil.set_hostname(self, hostname)
|
||||
|
||||
diff --git a/azurelinuxagent/common/osutil/suse.py b/azurelinuxagent/common/osutil/suse.py
|
||||
index 2192c67..0b5fc8d 100644
|
||||
--- a/azurelinuxagent/common/osutil/suse.py
|
||||
+++ b/azurelinuxagent/common/osutil/suse.py
|
||||
@@ -80,7 +80,7 @@ class SUSEOSUtil(SUSE11OSUtil):
|
||||
self._run_command_without_raising(["systemctl", "start", "{}.service".format(self.dhclient_name)],
|
||||
log_error=False)
|
||||
|
||||
- def start_network(self) :
|
||||
+ def start_network(self):
|
||||
self._run_command_without_raising(["systemctl", "start", "network.service"], log_error=False)
|
||||
|
||||
def restart_ssh_service(self):
|
||||
--
|
||||
2.18.4
|
||||
|
@ -1,24 +1,23 @@
|
||||
Summary: Microsoft Azure Linux Agent
|
||||
Name: WALinuxAgent
|
||||
Version: 2.2.46
|
||||
Release: 8%{?dist}
|
||||
Version: 2.2.49.2
|
||||
Release: 3%{?dist}
|
||||
|
||||
License: ASL 2.0
|
||||
Group: Development/Libraries
|
||||
Url: https://github.com/Azure/WALinuxAgent
|
||||
Source0: WALinuxAgent-2.2.46.tar.gz
|
||||
Source0: WALinuxAgent-2.2.49.2.tar.gz
|
||||
|
||||
BuildArch: noarch
|
||||
Patch0001: 0001-Add-inital-redhat-build-support.patch
|
||||
Patch0002: 0003-Fix-fips.patch
|
||||
# For bz#1822882 - [Azure][RHEL-8]Some parameter changes are not in waagent.conf
|
||||
Patch3: wala-Update-Provisioning-options-1853.patch
|
||||
# For bz#1859037 - [Azure][WALA]Cannot create /dev/disk/azure/resource softlinks in Gen2 VM
|
||||
Patch4: wla-Fix-handling-of-gen2-disks-with-udev-rules-1954.patch
|
||||
Patch0002: 0002-Fix-handling-of-gen2-disks-with-udev-rules-1954.patch
|
||||
# For bz#1903074 - [Azure][WALA] Miss report "hostnamectl set-hostname --static] failed, attempting fallback"
|
||||
Patch3: wla-Fixed-faulty-check-for-run_command-2093.patch
|
||||
|
||||
# rhel requirements
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: python3-setuptools
|
||||
Requires: %name-udev = %version-%release
|
||||
Requires: openssh
|
||||
Requires: openssh-server
|
||||
Requires: openssl
|
||||
@ -36,6 +35,11 @@ The Azure Linux Agent supports the provisioning and running of Linux
|
||||
VMs in the Azure cloud. This package should be installed on Linux disk
|
||||
images that are built to run in the Azure environment.
|
||||
|
||||
%package udev
|
||||
Summary: Udev rules for Microsoft Azure
|
||||
|
||||
%description udev
|
||||
Udev rules specific to Microsoft Azure Virtual Machines.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
@ -43,7 +47,6 @@ images that are built to run in the Azure environment.
|
||||
%patch0001 -p1
|
||||
%patch0002 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
|
||||
%build
|
||||
%py3_build
|
||||
@ -52,6 +55,9 @@ images that are built to run in the Azure environment.
|
||||
%{__python3} setup.py install --single-version-externally-managed -O1 --root=$RPM_BUILD_ROOT --record=INSTALLED_FILES
|
||||
rm -f %{buildroot}%{_sbindir}/waagent2.0
|
||||
|
||||
mkdir -p %{buildroot}%{_udevrulesdir}
|
||||
mv %{buildroot}%{_sysconfdir}/udev/rules.d/*.rules %{buildroot}%{_udevrulesdir}/
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
@ -72,10 +78,26 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%config(noreplace) %{_sysconfdir}/logrotate.d/waagent-extn.logrotate
|
||||
%{_sbindir}/waagent
|
||||
%{_unitdir}/waagent.service
|
||||
/etc/udev/rules.d/66-azure-storage.rules
|
||||
/etc/udev/rules.d/99-azure-product-uuid.rules
|
||||
|
||||
%files udev
|
||||
%{_udevrulesdir}/*.rules
|
||||
|
||||
%changelog
|
||||
* Tue Jan 12 2021 Miroslav Rezanina <mrezanin@redhat.com> - 2.2.49.2-3.el8
|
||||
- wla-Provide-udev-rules-as-a-separate-subpackage.patch [bz#1913074]
|
||||
- Resolves: bz#1913074
|
||||
([Azure][RFE] please provide the WALinuxAgent-udev subpackage)
|
||||
|
||||
* Thu Dec 17 2020 Miroslav Rezanina <mrezanin@redhat.com> - 2.2.49.2-2.el8
|
||||
- wla-Fixed-faulty-check-for-run_command-2093.patch [bz#1903074]
|
||||
- Resolves: bz#1903074
|
||||
([Azure][WALA] Miss report "hostnamectl set-hostname --static] failed, attempting fallback")
|
||||
|
||||
* Wed Nov 18 2020 Miroslav Rezanina <mrezanin@redhat.com> - 2.2.49.2-1.el8
|
||||
- Rebase to 2.2.49.2 [bz#1896907]
|
||||
- Resolves: bz#1896907
|
||||
([Azure] Rebase WALinuxAgent to 2.2.49)
|
||||
|
||||
* Thu Aug 13 2020 Miroslav Rezanina <mrezanin@redhat.com> - 2.2.46-8.el8
|
||||
- wla-Fix-handling-of-gen2-disks-with-udev-rules-1954.patch [bz#1859037]
|
||||
- Resolves: bz#1859037
|
||||
@ -91,16 +113,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
- Resolves: bz#1822882
|
||||
([Azure][RHEL-8]Some parameter changes are not in waagent.conf)
|
||||
|
||||
* Wed Apr 15 2020 Miroslav Rezanina <mrezanin@redhat.com> - 2.2.46-5.el8
|
||||
* Thu Apr 09 2020 Miroslav Rezanina <mrezanin@redhat.com> - 2.2.46-5.el8
|
||||
- Rebase to 2.2.46 [bz#1791069]
|
||||
- Resolves: bz#1791069
|
||||
([Azure][RHEL-8.3]Ask to increase the WALA version available for RHEL 8.0 to 2.2.46)
|
||||
|
||||
* Wed Jul 24 2019 Miroslav Rezanina <mrezanin@redhat.com> - 2.2.38-1
|
||||
- Rebase to 2.2.38 [bz#1722848]
|
||||
- Resolves: bz#1722848
|
||||
([Azure]walinuxagent 2.2.38 rebase [8.1.0])
|
||||
|
||||
* Wed Jun 26 2019 Miroslav Rezanina <mrezanin@redhat.com> - 2.2.32-3.el8
|
||||
- wla-Switch-from-platform-python-to-python36.patch [bz#1720373]
|
||||
- wla-Stop-packaging-legacy-waagent2.0.patch [bz#1720373]
|
||||
|
Loading…
Reference in New Issue
Block a user