Update to 2.0.13
This commit is contained in:
parent
d3958f71e6
commit
5f84b1b501
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
/WALinuxAgent-b3f2619a854455675ae5f2ee14726659e0398af7.tar.gz
|
||||
/WALinuxAgent-26785b64279913d416767a6288a3b3f970ed4522.tar.gz
|
||||
/WALinuxAgent-30019ae2c10a5c78f55d4ec342db07366abcc602.tar.gz
|
||||
|
@ -1,34 +0,0 @@
|
||||
From 95d1985deca1bc2561031ef08cc300b29558269c Mon Sep 17 00:00:00 2001
|
||||
From: Yue Zhang <yuezha@microsoft.com>
|
||||
Date: Thu, 26 Mar 2015 21:51:15 +0800
|
||||
Subject: [PATCH] Merge distro name fix on oracle linux
|
||||
|
||||
---
|
||||
waagent | 7 +++++++
|
||||
1 file changed, 7 insertions(+)
|
||||
|
||||
diff --git a/waagent b/waagent
|
||||
index cbd005b..68d3c64 100644
|
||||
--- a/waagent
|
||||
+++ b/waagent
|
||||
@@ -5619,6 +5619,7 @@ def DistInfo(fullname=0):
|
||||
release = re.sub('\-.*\Z', '', str(platform.release()))
|
||||
distinfo = ['FreeBSD', release]
|
||||
return distinfo
|
||||
+
|
||||
if 'linux_distribution' in dir(platform):
|
||||
distinfo = list(platform.linux_distribution(full_distribution_name=fullname))
|
||||
distinfo[0] = distinfo[0].strip() # remove trailing whitespace in distro name
|
||||
@@ -5747,6 +5748,12 @@ def main():
|
||||
LoggerInit('/var/log/waagent.log','/dev/console')
|
||||
global LinuxDistro
|
||||
LinuxDistro=DistInfo()[0]
|
||||
+
|
||||
+ #The platform.py lib has issue with detecting oracle linux distribution.
|
||||
+ #Merge the following patch provided by oracle as a temparory fix.
|
||||
+ if os.path.exists("/etc/oracle-release"):
|
||||
+ LinuxDistro="Oracle Linux"
|
||||
+
|
||||
global MyDistro
|
||||
MyDistro=GetMyDistro()
|
||||
if MyDistro == None :
|
@ -1,4 +1,4 @@
|
||||
%global commit 26785b64279913d416767a6288a3b3f970ed4522
|
||||
%global commit 30019ae2c10a5c78f55d4ec342db07366abcc602
|
||||
|
||||
%if 0%{?fedora}
|
||||
%global distro fedora
|
||||
@ -8,6 +8,7 @@
|
||||
%global distro redhat
|
||||
%if 0%{?rhel} < 7
|
||||
%global initsys sysV
|
||||
%{!?_udevrulesdir: %global _udevrulesdir /lib/udev/rules.d}
|
||||
%else
|
||||
%global initsys systemd
|
||||
%endif
|
||||
@ -17,7 +18,7 @@
|
||||
%endif
|
||||
|
||||
Name: WALinuxAgent
|
||||
Version: 2.0.12
|
||||
Version: 2.0.13
|
||||
Release: 1%{?dist}
|
||||
Summary: The Microsoft Azure Linux Agent
|
||||
|
||||
@ -27,8 +28,6 @@ URL: https://github.com/Azure/%{name}
|
||||
Source0: https://github.com/Azure/%{name}/archive/%{commit}/%{name}-%{commit}.tar.gz
|
||||
# Redhat-specific patch (not submitted upstream)
|
||||
Patch0: %{name}-2.0.8-logrotate-name.patch
|
||||
# Pulled from upstream
|
||||
Patch1: %{name}-2.0.12-oracle-linux-name.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
@ -68,7 +67,6 @@ images that are built to run in the Microsoft Azure environment.
|
||||
%prep
|
||||
%setup -qn %{name}-%{commit}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
chmod 0755 distro/redhat/waagent.sysV
|
||||
|
||||
@ -82,6 +80,9 @@ mkdir -p -m 0700 %{buildroot}%{_sharedstatedir}/waagent
|
||||
mkdir -p %{buildroot}%{_localstatedir}/log
|
||||
touch %{buildroot}%{_localstatedir}/log/waagent.log
|
||||
|
||||
mkdir -p %{buildroot}%{_udevrulesdir}
|
||||
mv %{buildroot}%{_sysconfdir}/udev/rules.d/99-azure-product-uuid.rules %{buildroot}%{_udevrulesdir}/99-azure-product-uuid.rules
|
||||
|
||||
%post
|
||||
%if %{initsys} == systemd
|
||||
%systemd_post waagent.service
|
||||
@ -121,6 +122,7 @@ fi
|
||||
%config(noreplace) %{_sysconfdir}/logrotate.d
|
||||
%{_sbindir}/waagent
|
||||
%config(noreplace) %{_sysconfdir}/waagent.conf
|
||||
%{_udevrulesdir}/99-azure-product-uuid.rules
|
||||
|
||||
%if %{initsys} == systemd
|
||||
%{_unitdir}/waagent.service
|
||||
@ -129,6 +131,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jun 01 2015 Scott K Logan <logans@cottsay.net> - 2.0.13-1
|
||||
- Update to 2.0.13
|
||||
|
||||
* Thu Apr 02 2015 Scott K Logan <logans@cottsay.net> - 2.0.12-1
|
||||
- Update to 2.0.12-Oracle
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user