Drop logrotate rename patch
Signed-off-by: Vitaly Kuznetsov <vkuznets@redhat.com>
This commit is contained in:
parent
2e0f70375b
commit
35ed182848
@ -1,11 +0,0 @@
|
||||
--- a/setup.py 2014-10-05 03:39:26.477801917 -0500
|
||||
+++ b/setup.py 2014-10-05 03:39:51.749922806 -0500
|
||||
@@ -155,7 +155,7 @@
|
||||
sys.exit(1)
|
||||
try:
|
||||
self.copy_file('config/waagent.logrotate',
|
||||
- tgtDir + 'etc/logrotate.d/waagent')
|
||||
+ tgtDir + 'etc/logrotate.d/WALinuxAgent')
|
||||
except:
|
||||
msg = 'Could not install logrotate file in '
|
||||
msg += tgtDir + 'etc/logrotate.d'
|
@ -12,8 +12,6 @@ Group: System Environment/Daemons
|
||||
License: ASL 2.0
|
||||
URL: https://github.com/Azure/%{name}
|
||||
Source0: https://github.com/Azure/%{name}/archive/%{commit}/%{name}-%{commit}.tar.gz
|
||||
# Redhat-specific patch (not submitted upstream)
|
||||
Patch0: %{name}-2.0.8-logrotate-name.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
@ -39,7 +37,6 @@ images that are built to run in the Microsoft Azure environment.
|
||||
|
||||
%prep
|
||||
%setup -qn %{name}-%{commit}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%{__python3} setup.py build
|
||||
@ -54,6 +51,8 @@ touch %{buildroot}%{_localstatedir}/log/waagent.log
|
||||
mkdir -p %{buildroot}%{_udevrulesdir}
|
||||
mv %{buildroot}%{_sysconfdir}/udev/rules.d/99-azure-product-uuid.rules %{buildroot}%{_udevrulesdir}/99-azure-product-uuid.rules
|
||||
|
||||
mv %{buildroot}%{_sysconfdir}/logrotate.d/waagent %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
|
||||
|
||||
%post
|
||||
%systemd_post waagent.service
|
||||
|
||||
@ -67,7 +66,7 @@ mv %{buildroot}%{_sysconfdir}/udev/rules.d/99-azure-product-uuid.rules %{buildro
|
||||
%doc Changelog LICENSE-2.0.txt NOTICE README
|
||||
%ghost %{_localstatedir}/log/waagent.log
|
||||
%dir %attr(0700, root, root) %{_sharedstatedir}/waagent
|
||||
%config(noreplace) %{_sysconfdir}/logrotate.d
|
||||
%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
|
||||
%{_sbindir}/waagent
|
||||
%config(noreplace) %{_sysconfdir}/waagent.conf
|
||||
%{_udevrulesdir}/99-azure-product-uuid.rules
|
||||
|
Loading…
Reference in New Issue
Block a user